eingebettete Weiterleitug ist nicht mehr möglich

  • Hallo zusammen!


    Seit der letzten (automatischen) Aktualisierung vor ein paar Tagen auf die Version 3.1.2 funktioniert in meiner Firma die "eingebettete" Weiterleitung nicht mehr.
    Es wurden keine Einstellungen verändert (Konten sind alle IMAP) - d.h. die E-Mails sollen regulär mit eingebettetem Text weitergeleitet werden.
    Der Fehler tritt bei mind. 3 Windows-XP-Rechnern auf.
    Die Weiterleitung im Anhang funktioniert nach wie vor, aber anders muss es natürlich auch funktionieren.


    Wurde beim letzten Update aus Versehen ein solcher Hammer-Bug eingebaut oder wurden nur irgendwelche Konfigurationen geändert, die mir nicht bekannt sind?
    Bisher habe ich im Internet nur ähnliche Fehlermeldungen von vor 5 Jahren gefunden ...


    Gruß
    Iris

  • guten Abend und willkommen im Thunderbirdforum!


    Ichhab das jetzt grad ausprobiert, Thunderbird 3.1.2, Win 7, 64 Bit geht ohne Probleme dass die Mail eingebunden und nicht als Anhang weitergeleitet wurde.
    Hast Du bzw. habt Ihr unter Extras Einstellungen Verfassen Allgemein eingestellt, dass eingebunden wietergeleitet werden soll?
    Wie sieht die Sache aus, wenn Thunderbird im abgesicherten Modus gestartet wurde?

  • Guten Morgen!


    Zumindest auf meinem Rechner ist der Thunderbird so eingestellt, dass bei einer Weiterleitung der Text der E-Mail in die neue Nachricht eingebettet werden soll. (das meinte ich mit "keine Einstellungen wurden verändert")
    Testhalber habe ich diesen Wert auch mal umgesetzt (dann wurde der Text automatisch angehängt - das funktionierte) und dann wieder zurückgesetzt, aber das zeigte keine Wirkung.


    Nachdem mein Kollege heute das Problem ebenfalls noch einmal getestet hatte, haben wir festgestellt, dass dieses Problem nur bei den E-Mails auftritt, die von unserem firmeninternen Online-System automatisch verschickt wurden.
    Eine genauere Überprüfung ergab, dass der Header der E-Mail zu gewöhnlich verschickten E-Mails einen Unterschied im Content-Type enthielt.
    Bisher hatten wir immer "multipart/mixed" angegeben - eine Änderung auf "multipart/alternative" löste das Problem.
    ... zumindestens für's erste ...


    Die Frage ist, ob das so gewollt ist. ;-)


    Gruß
    Iris



    P.S.: Auch im abgesicherten Modus blieb das Problem bestehen. (nur im die Informationen komplett zu machen)

  • Hallo Iris,
    das Problem wird wohl nicht bestehen, wenn die Mails in Rein-Text versendet bzw. weitergeleitet würden, aber das ist ja wohl nicht gewünscht.
    Das Dumme ist: es gibt keinen Standard für HTML in Mails und mit einem solchen Verhalten muss daher immer gerechnet werden. Nur bei Mails von TB zu TB kann man diese Fehler ausschließen.
    Oft haben MS-Produkte dieses Problem weniger, weil sie sich nicht an die strengen HTML-Normen halten.
    TB tut das im Allgemeinen aber und kann mit den erweiterten oder mit Skripten verfassten HTML-Mails nicht korrekt umgehen.
    Wie du schon erkannt hast, ist dabei u.a. die interne Deklarierung der Mail verantwortlich.
    Man müsste also bei Problemen überprüfen, welche Deklarierung TB vornehmen würde, bei gleichem Inhalt.
    Dazu bracht man ja nur eine Mail über "Später senden" in den Postausgang bringen und dort den Quelltext (Strg+U) überprüfen.
    Vielleicht ist für eine kommerzielle Verwendung ein anderer Mailklient besser geeignet.
    TB erhebt diesen Anspruch nämlich nicht, zumal TB auch nicht voll netzwerkfähig ist.


    Wenn es ein "Hammer-Bug" wäre, müsste er vielleicht bei https://bugzilla.mozilla.org zu finden sein.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    Jo das mit den Standards ist immer so ne Sache ... Freud und Leid. Ich kann ein Lied davon singen ...
    Prinzipiell ist das ja auch so in Ordnung.
    Wie du sagst: TB hält sich an HTML-Normen und das finde ich auch gut. Desto mehr Normen - desto mehr kann ich mich darauf verlassen, dass etwas so "kommt", wie ich es mir vorstelle. (Ich bin selber Programmiererin.)
    Ich weiß nur, dass es vorher funktioniert hat.
    Das heißt von der Version 3.1.1 zu 3.1.2 wurde irgendetwas verändert, dass es nicht mehr funktioniert.
    Wenn das so gewollt war, dann gut!
    Wenn nicht, dann hat diese Änderung vielleicht noch mehr unliebsame Überraschungen parat...


    Mehr wollte ich nicht gesagt haben. ;)


    Wir werden die automatische Mail-Generierung bei uns ohnehin noch einmal überarbeiten und dann noch mehr Rücksicht auf solche Unwägbarkeiten legen.
    Vielen Dank soweit!
    Gruß aus Aachen
    Iris

  • Hallo,
    zur Überprüfung des Verhaltens, könntest du mir ja mal eine solche Mail als *.eml zusenden.
    Falls du das tun möchtest, schreibe mir eine PN und ich sende dir meine Mailadresse für solche Zwecke..


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw