Filter arbeitet nicht

  • Thundervird 3.14 unter WinXP Pro
    POP-Konto - d.h. die Mails sind alle lokal auf dem Rechner.


    Bisher hatte ich noch nicht viele Filterregeln eingestellt.
    Nun hab ich mich bei ein paar Mailinglisten eingetragen und hab nun eher Verwendung für sinnvolle Filter.
    Also hab ich einige eingestellt - das lieb auch ganz gut.
    Vorhin hab ich noch ein paar andere dazugenommen - und obwohl sie alle genau so eingetragen sind, wie die Regeln zuvor, geht nun nichts mehr.
    Nicht nur, daß die neuen Regeln nicht ziehen - die alten gehen auch nicht mehr!
    Ich hab das gerade gecheckt, inden ich eine Mail, die schonmal korrekt weggefiltert wurde, erneut in den Posteingang stellte - wen ich auf den Button "Jetzt ausführen" clicke, passiert einfach nichts.
    Auch dann, wen ich den Aktivierungshaken aus der neuen Filterregel rausnehme, passiert nichts.
    Langsam hab ich den Verdacht, daß hier ein Programmierfehler vorliegt.


    In diesem Zusammenhang bin ich natürlich auch auf das "Filterprotokoll" gestoßen - besser gesagt: auf den Button der entsprechend beschriftet ist.
    Denn da ich so ein Protokoll zuvor nicht gebraucht hatte (es lief ja alles), hab ich da bislang nicht reingeschaut.
    Nun kann ich zwar das Protokoll aktivieren oder deaktivieren und sogar leeren - aber ich sehe nicht, daß dabei irgendetwas passiert, den angezeigt wird das Protokol nicht. lediglich der Text steht da, wonach das Protokoll eine Datei sei - von diesem Text fühle ich mich ziemlich verarscht, denn der hat ungefähr ebensoviel Sinn wie eine Fehlermeldung á la "Es ist ein Fehler aufgetreten". Was ich bräuchte, wäre nicht die Angabe, DASS es sich um eine Datei handelt, sondern die Angabe, UM WELCHE Datei es sich handelt - sinnvoll wäre hier beispielsweise ein Link, der einen Editor öffnet mit der Datei.
    Ich halte es für einen groben Designfehler, daß beim Filter keine Anzeige sagt, daß er gerade läuft.
    Während der Eingabe der Filterregeln hatte ich eine Stelle, da kam kurz eine Fehlermeldung, wonach änderungen nicht möglich seien, da etwas mit den Regeln nicht stimmen würde - diese Meldung kam jedoch nur einmal und dann nie wieder - ohne, daß ich etwas geändert hätte - und es wurde auch nicht angezeigt, wo der Fehler liegt - da frag ich mich doch, wie dämlich eine Fehlermeldung ist, die nach einer Analyse einen Fehler meldet, ohne den Grund für diese Meldung auszuweisen?


    Zudem finde ich es irritierend, daß ich Filterregeln zwar importieren, nicht aber exportieren kann - jedenfalls hab ich hierzu keinen Menüe-Eintrag gefunden.


    Kann mir bitte jemand diese Defizite erklären?


    Andreas


    Ergänzung:
    Die Fehlermeldung beim Ändern der Filtereinträge ist wieder aufgetaucht: Der Text lautet:
    "Dieser Filter kann nicht gespeichert werden, da die Suchbedingungen im aktuellen Kontext teilweise ungültig sind".
    Das ist für mich nichts weiter als sinnloses BlaBla, da ich zum einen damit nicht gesagt bekomme, was angeblich falsch sein soll, zum anderen alle Einträge nochmals durchgegangen bin - wie sollte es in einer vernünftigen Eingabemaske möglich sein, einen ungültigen Eintrag vorzunehmen?
    Und was kann daran falsch sein, wenn ich einfach etliche Mailadressen eintrage, von denen ich die Nachrichten in einem Unterordner haben will?

  • guten Morgen und willkommen im Thunderbirdforum!


    wir hier haben doch noch - trotz vielleicht manchmal Frustration - Zeit, für einen Gruß und eine Verabschiedung.
    Hast Du Schonmal thunderbird im abgesicherten Modus gestartet, treten da da die Probleme auch auf?
    Das Filterprotokoll kann durch ein Kontrollkästchen aktiviert werden, und erst dann, wenn danach eine Aktion erfolgt, wird sie protokolliert und man sieht die Einträge im Fenster der Filterregeln, und wenn Du dann in Deinem Kontoordner nachschaust, also c:\dokumente und Einstellungen\username\anwendungsdaten\thunderbird\profiles\mail\kontoname, findest Du eine Datei filterlogs.html, die Du anschauenkannst.
    ein Programmierfehler liegt bestimmt nicht vor, weil ich habe für alle meine mailinglisten Filter erstellt, und das sind nicht wenige, und die laufen alle korrekt.

  • Danke für die Antwort,


    aber leider hilft mir das nicht weiter.
    Um das Problem zu analysieren, hab ich den zuletzt erzeugten Filter wieder rausgenommen (deaktivieren reichte nicht aus) und danach liefen die Filter wieder.
    Dann habe ich ihn neu aufgebaut und jede Mailadresse einzeln dort eingestellt, und dan gleich getestet.
    Das Verhalten wurde hierbei immer seltsamer, denn manche Adressen erzeugten beim Eintragen genau den oben angegebenen Fehler, sonach der Filter als ganzes nicht arbeiten wollte.
    Nahm ich die Adresse wieder raus, lief er wieder - ich habe das mehrfach nachgeprüft.
    Wenn ich dann genau dieselbe Adresse statt auf dieser Zeile unter einer anderen Zeile eingetragen habe, wurde mir kein Fehler angezeigt und der Filter arbeitete.


    Ich programmiere seit mehr als 20 Jahren - und niemand kann mir erzählen, daß so ein Verhalten NICHT auf einen Programmierfehler zurückzuführen ist.


    Gibt es irgendwo eine Doku, die speziell die Plausibilitätsprüfungen beschreibt, welche beim Anlegen der Filterregeln durchlaufen werden?
    Ich habe den Verdacht, daß hier unsauber mit der Speicherverwaltung umgegangen wird - nur das könnte erklären, daß exact derselbe Parameter einmal abgewiesen und ein anderes mal problemlos akzeptiert wird.


    Natürlich wäre es auch möglich, daß das Problem bei Windows zu suchen ist - jedoch nur dann, wenn Mozilla den (unverzeihlichen) Fehler begangen hätte, in derart relevante interne Steuerungsfunktionen Systemaufrufe einzubauen.


    Da der Fehler momentan nicht mehr auftritt, kann ich dieses Verhalten auch im Abgesicherten Modus nicht mehr testen. Dennoch scheint es mit ein Fehler zu sein, wenn ein Filter, nachdem eine Plausi-Prüfung einmal schiefgelaufen ist, deaktiviert wird, ohne, daß man dies angezeigt bekommt!


    Wenn Du derart viele Filter verwendest, kannst Du vielleicht auch nachempfinden, daß ich das standardmäßige Handling der Filterverwaltung sehr unhandlich finde.
    Gibt es keine Möglichkeit, diese Einträge auf ander Weise zu bearbeiten, bei der man einen besseren Überblick über die gesamte Regel hat?


    A.S.

  • Da Du ein Hallo noch immer nicht für nötig hältst, lass ichs heute auch bleiben.
    1. kannst Du, wenn Du wirklich so überzeugt bist, dass es sich um einen Bug handeln, einen bei Bugzilla einstellen.
    Und Du bist selber Programmierer? Ok, Thunderbird ist open Source.

  • Zitat von "Rothaut"

    guten Morgen und willkommen im Thunderbirdforum!


    wir hier haben doch noch - trotz vielleicht manchmal Frustration - Zeit, für einen Gruß und eine Verabschiedung.


    Hallo Rothaut,


    da gebe ich dir völlig recht. Ein Minimum an Höflichkeit sollte man selbst hier zeigen.


    Wir beide hatten diese Woche in einem anderen Thread hier einen fruchtbaren Dialog. Nun zu meinem Problem mit dem Message-Filter, was ein bisschen dem Problem des OP ähnelt – deshalb schreibe ich es nach einer Google-Suche hier. Ich habe seit einigen Tagen folgendes Phänomen:


    In einem neu eingerichteten Konto verwende ich einen Filter, der ziemlich viele Bedingungen hat. Nun kommt es immer mal wieder dazu, dass bei Änderungen des Filters (Bearbeiten) beim Abspeichern folgende Fehlermeldung erscheint:

    Zitat

    Dieser Filter kann nicht gespeichert werden, da die Suchbedingungen im aktuellen Kontext teilweise ungültig sind.


    Wenn ich dann einfach ein bisschen planlos im Bearbeiten-Fenster herumklicke und dann wieder auf OK klicke, lässt sich die Änderung problemlos abspeichern. Und der Filter funktioniert auch einwandfrei. Dass da irgend etwas "ungültig" wäre, konnte ich bisher nicht erkennen.


    Das passiert immer wieder – mindestens bei jedem zweiten oder dritten Bearbeitungsvorgang. Woher kann das kommen?


    Gruß
    Karl


    TB: 3.1.9, POP, Win XP

  • Guten Abend!!


    Ich könnte mir vorstellen, dass der Filter zum Abarbeiten der vielen Bedingungen eben eine Zeit braucht, und vielleicht durcheinander kommt, wenns zu viele werden, ich weiß es nicht, ich hatte das noch nie.
    Ich mach dann meistens mehrere Filter, wenn die Bedingungen für einen über den Kopf zu wachsen drohen.