"Simultaner" Zugriff per IMAP beschert Probleme [erl.]

  • Hallo,


    Folgendes Szenario: Ich habe Thunderbird 3.1.9 auf meinem Desktop-Rechner (Windows 7 Ultimate 32 Bit) und Thunderbird 3.1.8 auf meinem Notebook (Ubuntu 10.10 64 bit) installiert. Mein Notebook nutze ich eigentlich fast nur an der Uni. Heute ist mir allerdings ein etwas merkwürdiges aber villeicht doch interessantes Problem aufgefallen.


    Wenn mein Desktop-Rechner und mein Notebook gleichzeitig laufen und auf beiden Thunderbird aktiv ist, kommt es zu Komplikationen mit meiner Uni-Mail-Adresse, welche per IMAP läuft. Wenn ich an einem Rechner eine Mail sende, wird sie nicht in den Ordner "Gesendet" verschoben, am anderen Rechner geschieht dies allerdings. Oder ich kann "irgendwie" an einem Rechner keine Mail löschen, dafür erscheint sie im Thunderbird auf dem anderen Rechner im Papierkorb, starte ich den Client neu ist sie allerdings wieder da usw... Kurz gesagt: Die "Synchronisation" geht flöten, sobald beide Clients simultan auf beiden Rechnern laufen. Läuft allerdings nur ein Client (unabhängig davon auf welchem OS/Rechner) funktioniert alles einwandfrei. Woran kann das liegen? Ich denke es liegt nicht am Betriebssystem oder an den unterschiedlichen Thunderbird-Versionen, da das simultane Laufen von Thunderbird beispielsweise bei meinem T-Online Konto überhaupt kein Problem darstellt. Kann es sein, dass manche Mail-Adressen einfach nicht für einen derartigen Gebrauch gemacht sind?


    Das Problem ist eigentlich halb so wild, da es wirklich nur sehr selten vorkommt, dass mein Desktop-Rechner und mein Notebook gleichzeitig genutzt werden. Ich frage mehr aus rein technischem Interesse :mrgreen:.


    Viele Grüße,


    STaRDoGGCHaMP

  • Hallo,


    es kann durchaus sein, dass es auf dem Mailserver bei solchen Aktionen zu Verzögerungen bei der Synchronisation kommt.

    Zitat


    kann "irgendwie" an einem Rechner keine Mail löschen, dafür erscheint sie im Thunderbird auf dem anderen Rechner im Papierkorb, starte ich den Client neu ist sie allerdings wieder da usw..

    wo ist sie dann, auch im Papierkorb des ersten Rechners oder wieder am Ursprung?

  • Hallo rum,


    Vielen Dank für deine Antwort. Es gibt kein immer gleiches Verhalten bei der Problematik, es mangelt einfach an der Synchronisation. Die Aktionen die ich durchführe werden serverseitig auch fast immer durchgeführt, allerdings im Client falsch dargestellt. Ich hab eben mal die Administration vom Rechenzentrum angeschrieben und die haben mir gesagt, dass das Verhalten normal ist und ich dafür sorgen sollte, dass nur ein Client gleichzeitig auf meine Mail-Adresse zugreift. Trotzdem vielen Dank.


    Viele Grüße,


    STaRDoGGCHaMP

  • Hallo STaRDoGGCHaMP,


    also normaler weise ... .
    Aber was/wer ist schon normal ... .


    Zum einen kann man auch einen IMAP-Server so konfigurieren, dass pro Konto nur ein einziger gleichzeitiger Zugriff möglich ist. Jeder Zugriff belastet die Prozessoren des Servers, und da müssen sich die IT-Verantwortlichen im Gezerre mit ihren Geldgebern manchmal eben was einfallen lassen. KANN eine Begründung sein.


    Zum zweiten heißt ja IMAP nicht zwingend, dass durch "idelen" immer alle Konten auf dem Server automatisch synchronisiert werden. Manche (kräftigen!) Server lassen viele dauerhafte Verbindungen stehen - andere unterstützen dieses Kommando überhaupt nicht und es wird immer nur manuell synchronisiert. Oder eben beim Neustart des Clients.


    Der Fachmann kann durch Beobachtung des Traffics mit einem Sniffer derartige Sachen eingrenzen. Aber mitunter hilft es auch, andere Nutzer zu befragen, ob es bei denen mit Ausgugg usw. funktioniert, oder du fragst einen aus dem IT-Team. In der Regel haben diese Kollegen nichts gegen einen fachlichen Disput.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!