TB 5+6: zitierter Text nicht mehr editierbar(schon wieder!))

  • Hallo,
    ich bin neu hier im Forum, habe alles abgesucht, aber noch keine Antwort auf mein Problem gefunden.


    Vorgeschichte: Bis zu meinem update von der letzt-aktuellen Version von TB (4.x) auf TB 5.0 konnte ich aus beliebigen (sogar in anderen TB-Fenstern aufgerufenen) e-mails den Text zitieren (z.B.. "Antworten", dann "Optionen->Nachricht zitieren". Dieser Text stellte sich mit einer blauen senkrechten Linie am linken Rand dar. Ich konnte nach irgendeinem Satz darin hineinklicken, die RETURN-Taste drücken und meine direkte Antwort auf diesen Textteil darunter tippen (die blaue Linie wurde dafür unterbrochen); Und so weiter bis ich alle Antworten zu den jeweiligen Zitat-Teilen gegeben hatte.


    Aktuelles Problem: Jetzt löscht sich der gesamte zitierte Text, sobald ich innerhalb des "Abschnittes der blauen Linie" eine Stelle anklicke und dann auf RETURN-Taste drücke. Ein Einfügen einzelner Antworten auf Zitat-Abschnitte ist damit nicht mehr möglich. Schade!


    Frage: Habe ich nur übersehen, irgendwelche neuen Einstellungen umzuschalten? Was muss ich ändern um die alte Funktionalität wieder zu bekommen?


    Beste Grüße!

    4 Mal editiert, zuletzt von InselEnte ()

  • Ich nutze unter Windows XP diese Funktionalität ebenfalls recht stark.


    Beim Update von 3.1.11 auf 5.0 gab es damit keine Probleme, ich habe auch nichts neu eingestellt.
    TB 4.0 gab es außerdem nicht, muß also 3.x.x gewesen sein.

  • Danke für den Hinweis, HaasUwe,



    jetzt weiss ich wenigstens, dass es ein lokales Problem auf meinem PC sein muss.


    Deshalb habe ich nun mal das Setup von TB5.0 heruntergeladen und manuell über die bestehende Version drüber installiert - leider besteht das Problem weiter.


    Erweiterungen (AddOns): Ich habe nur 2 Wörterbücher (deutsch und spanisch) installiert.
    Ich nutze auch Win-XP, SP3.


    (Sorry, meine Vorversion wird natürlich 3.1.11 gewesen sein, da ich "automatische Updates" aktiviert habe konnte ich das nicht mehr nachvollziehen)



    Grüße!

  • So,


    ich habe jetzt erst mal wieder von TB 5.0 auf TB 3.1.11 herabgestuft (manuell überinstalliert).
    Mit der alten Version funktioniert meine Text-in-zitierten-Text-Einfügen - Funktion wieder klaglos.


    Da ich diese Funktion nicht missen möchte, lasse ich erst einmal den "alten" TB drauf.


    Oder hat jemand noch eine Idee, woran mein Problem im TB 5.0 liegen könnte?


    Grüße!

  • Verflixt, auch mit dem neuen TB 6.0 habe nun ich diesen Fehler !! ??
    Sogar wenn ich TB 6.0 im abgesicherten Modus starte.


    Auch hier wieder: Beim Downgrade auf die neueste 3er Version, 3.1.12, nicht mehr - liegt wohl doch an der Version >3 und seiner Einstellung?
    Ist vielleicht irgendein geheimer "Schalter", z.B: in der config, hinzu gekommen, der sich bei mir nicht "umlegt"?



    Ich wäre euch echt dankbar um einen Hinweis.



    Grüße!
    InselEnte


    (TB: s.o.), POP, Win XP SP3,

  • Hallo,
    möglich ist auch, dass es sich bei dir um einen Fehler im TB-Profil handelt und dieses wird ja bei einem Update nicht verändert.
    Also würde ich die neueste TB-Version installieren und ein neues Profil anlegen zunächst testweise mit einem Konto, das alte Profil kann ja jederzeit mit dem TB-Profilmanager wieder aufgerufen werden.
    Dort teste das Verhalten noch einmal!


    Profile verwalten (Anleitungen)


    Getestet in TB 6.0 (ist glaube ich eine Beta) und zwar mit der Voreinstellung "Original-Nachricht beim Antworten zitieren" und ohne diese, in diesem Fall das von dir erwähnte Menü "Optionen, Zitieren" benutzt.
    Klappt einwandfrei.
    Ich glaube nicht, dass es an der Version 5.0 liegt, so ein Fehler wäre bekannt.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    vielen Dank für deinen guten Lösungsweg-Vorschlag!
    Ich habe nun alle möglichen Varianten durchgespielt.
    Erst mal mein Profil gesichert, dann 3 verschiedene TB-versionen (3.1.12, 5.0, 6.0) installiert, sowohl drüber als auch komplett neu (zwischenzeitlich auch mehrmals alle Folder und die Registry gelöscht), etc.


    Es ist tatsächlich so, dass meine gewünschte Funktion in einem neuen Profil (mit demselben TB 6.0 (=final V.)) klaglos funktioniert. Immerhin! Wenn ich per ProfileManager wieder umschalte auf mein Originalprofil funktioniert es aber wieder nicht mehr :pale:


    Also nochmal, genauer, meine Fehlerbeschreibung:
    · Bei "Antworten"->"Optionen"->"Nachricht zitieren" einer empfangenen Mail passiert bei mir ab TB 5.0 folgendes:
    Ich kann Buchstaben etc. (auch reine Zeilenumbrüche, "Shift-Return"!!) im zitiertenText hinter der blauen Linie ergänzen, aber sobald ich die Return-Taste drücke ist der gesamte zitierte Text weg, und nur "Am (...) schrieb (...):" steht noch und hinter dem Doppelpunkt blinkt der Cursor.
    · Es tritt der Fehler AUCH auf, wenn ich nur einen TextAUSSCHNITT zitiert habe (den ich vor dem Anklicken von "Nachricht zitieren" mit dem Cursor grau markiert habe)
    · ABER: Es tritt der Fehler NICHT auf, wenn ich in der Konten-Einstellung das "automatische Zitieren" aktiviert habe, da kann ich problemlos "returns" einfügen!


    Leider verwalte ich in meinem TB 3 Mail-Accounts, habe in jedem einiges an Archiven und kann daher nicht problemlos mein neues Profile benutzen - oder doch?? Wie könnte ich denn den Inhalt meines "alten"(defekten?) Profils evtl. in das neue kopieren, ohne den Fehler mitzukompieren? :nixweiss:


    Ich habe nun auch die prefs.js (bzw "about:config") der beiden Profiles durchsucht / versucht zu vergleichen, aber in meiner TB-Unerfahrenheit nichts eindeutiges gefunden.
    (Ich bin ja immer noch der Meinung, es läge einfach nur an einem einzigen bestimmten falsch gestellten Software-Schalter in einer der Konfigurationsdateien meines bisherigen Profils und ein "true" oder "false" an der richtigen Stelle korrigiere das Problem....?)


    Grüße

  • Zitat

    Leider verwalte ich in meinem TB 3 Mail-Accounts, habe in jedem einiges an Archiven und kann daher nicht problemlos mein neues Profile benutzen - oder doch??


    Doch natürlich, ist nur mit ein bisschen Arbeit verbunden.
    Installiere im neuen Profil das Add-on ImportExportTools.
    Damit kannst du jeden Ordner oder auch alle im Profil importieren. Schaue dir unter Extras, ImportExportTools die vielen Optionen des Tools an bes. MBox Dateien importieren.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Mit diesem PlugIn kann ich leider in meinem neuen TB6.0-Profil nicht gut arbeiten, es bricht mit einem Skriptfehler den Import ab (ist auch lt. Website nur bis TB 3.1 getestet), danach habe ich nur eine lange Liste teils gleichlautender Ordner, die meist nicht, teilweise unvollständig gefüllt sind, ungeordnet im neuen Profil. Außerdem übernimmt es , wie ich es sehe, wohl leider nicht die Ordner (Server-) einstellungen, u.v.m...
    (Ich habe den Ordner (sozusagen "x1y2z3.default") meines alten Profiles unter dem von dir empfohlenen "MBox Dateien importieren" angegeben)


    Du empfiehlst mir also, bildlich gesprochen, wegen einer defekten Schraube mein Auto um eine intakte Schraube herum komplett neu aufbauen? :eek: Würde viel lieber die defekte Schraube wechseln! - Bloß: Welche ist es?!!!


    Grüße

  • Re: TB 5.0 + TB 6.0: zitierter Text nicht mehr editierbar


    Zitat

    ist auch lt. Website nur bis TB 3.1 getestet


    Welche Webseite?
    Du hast es von meinem Link heruntergeladen?
    Wenn ich dir hier einen Tipp gebe, dann muss das Add-on in meiner 6.0 Version laufen und das tut es auch, egal, was auf der Webseite steht.


    Zitat

    es bricht mit einem Skriptfehler den Import ab


    Welcher Fehler wird denn angezeigt? Und welche Option genau hast du genommen?

    Zitat

    übernimmt es , wie ich es sehe, wohl leider nicht die Ordner (Server-) einstellungen, u.v.m...


    Nein, die Konten werden nicht übernommen, aber davon war ja keine Rede.
    Wie viele Konten hast du denn? Meine 10 Konten habe ich in weniger als 10 Minuten erstellt. Mit dem Kontenassistenten geht das ruckzuck.

    Zitat

    Du empfiehlst mir also, bildlich gesprochen, wegen einer defekten Schraube mein Auto um eine intakte Schraube herum komplett neu aufbauen?


    Ja, genau das tue ich, weil es der einzige sinnvolle Weg ist, denn ich bin nicht vor deinem Computer und wir machen hier keine Fernwartung mit Therapie.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    2 Mal editiert, zuletzt von mrb ()

  • Ja graba , das tut es und ohne Patch und ohne Spezial Add-on zum Kompatibelmachen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"


    Welche Webseite?
    Du hast es von meinem Link heruntergeladen?


    Richtig, unter "known issues" steht "The extension is compatible with Thunderbird 1.0 - 3.1 and has the autoupdate enabled."


    Zitat von "mrb"


    Welcher Fehler wird denn angezeigt?


    Ist heute nicht mehr reproduzierbar, hieß ähnlich wie "ein Script auf dieser Seite ist eventuell beschädigt.... wollen Sie es stoppen oder ....."(?)


    Zitat von "mrb"

    Und welche Option genau hast du genommen?


    Hab' ich oben schon geschrieben:

    Zitat von "InselEnte"

    (Ich habe den Ordner (sozusagen "x1y2z3.default") meines alten Profiles unter dem von dir empfohlenen "MBox Dateien importieren" angegeben)


    Ich ware dankbar um eine hilfreichere Angabe, falls ich den falschen Ordner gegriffen hätte. Die vielen Optionen sind nichts für TB-Anfänger wie mich...
    Ich habe es gerade nochmals durchgespielt: Jetzt habe ich von meinen 3 Mailkonten 7 "drafts"-Ordner, 5 "inbox"-Ordner, 1 "gesendet"-Ordner, 5 "Sent"-Ordner, 7 "Trash"-Ordnerund noch ein paar mit ".sqlite"- oder ".rc"-Endung. Alle in einem Konto - das ist, was mich ziemlich verzweifeln lässt


    Zitat von "mrb"


    Nein, die Konten werden nicht übernommen, aber davon war ja keine Rede.


    Ja, aber ich habe schon davon geredet, dass ich gerne auch die Konten hätte...


    Zitat von "mrb"

    Wie viele Konten hast du denn? Meine 10 Konten habe ich in weniger als 10 Minuten erstellt. Mit dem Kontenassistenten geht das ruckzuck.


    ...welchem Kontenassistenten, bitte? (edit: ach so, dem eingebauten, kein Add-On, okay.)


    Zitat von "mrb"

    ...weil es der einzige sinnvolle Weg ist, denn ich bin nicht vor deinem Computer und wir machen hier keine Fernwartung mit Therapie.


    Verstehe schon. Ich bin halt kein so'n Crack wie du, deshalb suche ich ja Hilfe im Forum, sonst bräuchte ich sie ja nicht. Aber in groben Schritten hilft sie mir auch nicht, wenn ich die Zwischenschritte nicht kenne oder verstehe, die für dich ein Klacks sind.


    Grüße

  • Hallo,

    Zitat von "InselEnte"


    Richtig, unter "known issues" steht "The extension is compatible with Thunderbird 1.0 - 3.1 and has the autoupdate enabled."


    wenn du auf der Website des Autors weiter nach unten scrollst, findest du den Hinweis: "Go to the page at Addons Mozilla Org". Dort findest du ganz unten "Informazioni sulla versione". Rechts davon auf die Doppelpfeile klicken und du siehst, dass diese Add-on-Version bis einschl. TB 6.* kompatibel ist.

  • Nun zu deinem Problem.
    Wenn du kleine Schritte möchtest, gehen wir dann auch so vor und zwar zunächst mit einem einzigen Ordner.
    Ich gehe davon aus, dass du den Pfad zu deinem alten Profil inzwischen kennst.
    Im neuen Profil markierst du links im Ordnerfenster einen Ordner, in den die alten Mails haben willst.
    Dann gehst du auf Extras, ImportExportTools, Mboxdateien importieren, und lässt den oberen Button markiert so wie er ist und hakst unten das Kästchen an.
    Du klickst dort auf den alten Profilordner.
    Dann auf den Ordner Mail. und überprüfe, ob dort oder in einem weiteren Unterordner eine MBox-datei ( das sind die Dateien ohne Endung z.B.B. inbox) eine Größe über sagen wir 5 KB hat.
    Diese klickst du doppelt an oder einfach und gehst dann auf "open".
    Jetzt findest du links im Ordnerfenster in dem von dir vorher markierten Ordner einen neuen Ordner mit Namen Inbox.
    Und dieser müsste Mails enthalten.
    Kannst du das bitte mal so machen?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Also:


    Ich habe nun doch "das Auto um die Schraube herum neu aufgebaut", um bei der Empfehlung von "mrb" und meiner Metapher zu bleiben.



    Hier nochmal Schritt-für-Schritt, falls es jemand brauchen sollte :verweis: :


    · Mittels ImportExportTools-AddOn habe ich erst einmal die Ordner(hierarchisch) aus meinem alten Profil exportiert (das hatte ich nicht gewusst).
    · Genauso das Adressbuch mit dessen eigener Exportfunktion (ein .LDIF-file).
    · Alles obige in einen vorher neu erstellten Ordner "TB-Umzug" geladen.


    · Dann per "ausführen"-> "Thunderbird.exe -P" den Profilmanager aufgerufen,
    · Neues Profil erstellt und
    · die Konten dort wieder neu eingerichtet.
    · Das AddOn "ImportExportTools" auch hier installiert und
    · einzeln die Ordner aus meinem TB-Umzugsordner (dabei war markiert die jeweils zugehörige neue Kontentitelzeile) per "Extras"->"ImportExportTools"->"MBox-Dateien importieren"->"Bestimmte MBoxdateien zum Importieren auswählen" EINZELN Ordner für Ordner im zugehörigen Konto eingelesen.
    · In jedem Konto eine Mail an mich geschickt, damit auch der jeweils zum Konto gehörige Ordner "gesendet" erstellt wird (der ist gleich nach der Geburt des Kontos noch nicht vorhanden), dann
    · In den importierten Ordnern alle Mails markiert und per "rechterMausklick"->"verschieben in" in den zugehörigen Ordner verschoben.
    · Anschließend die leeren Ordner aus dem Umzug gelöscht
    · Das "Adressbuch" aufgerufen und unter "Extras"->"Importieren"->"Adressbücher" den Pfad zum .LDIF-File in meiner Umzugskiste angegeben. Im Adressbuch steht jetzt ein eigenes unter demselben Namen wie der LDIF-File hatte.



    Ich weiss nicht, was ich alles vergessen habe:
    · Filter? -> manuell neu eingestellt
    · Junk-Datenbank? -> ist die alte verloren, oder kann ich sie irgendwie in das neue Profil retten (kopieren von "training.dat" oder welcher anderen Datei?))
    · ... nochwas?? na ja, notfalls kann ich ja noch im alten Profil vorbeischauen, falls was fehlen sollte..


    Danke dir, "mrb"! :zustimm:
    Bin dadurch etwas weiter in das Thema "Thunderbird" eingedrungen - wieder was gelernt!
    Der Lösungsweg behob zwar nicht die (unbekannte) Usache des Problems, war aber eine Umgehungslösung mit dem gleichen Effekt - "was heilt hilft"!


    Grüße

  • Zitat

    Mittels ImportExportTools-AddOn habe ich erst einmal die Ordner(hierarchisch) aus meinem alten Profil exportiert


    Warum? Die Ordner sind doch schon da.
    Dieser Schritt war absolut unnötig und ich hatte ihn auch nicht genannt.

    Zitat

    Genauso das Adressbuch mit dessen eigener Exportfunktion (ein .LDIF-file).


    Auch das ist nicht unbedingt nötig, denn die Adressbuchdateien liegen ja als abook.mab vor, aber es ist zumindest eine Sicherheit und geht auch schnell.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • :wall: Es ist wie verhext:


    Jetzt hat sich "alles" wieder "verstellt" und ich habe den gleichen Fehler schon wieder, wie zuvor!!

    Das einzige was ich mir vorstellen kann ist, dass ich CCleaner inzwischen mal drüberlaufen lassen habe (auch für die Registry). Gibt es vielleicht dort Einträge, die mir CCleaner herausgelöscht hat und nötig für diese Funktion sind? Weiß jemand etwas über die Registry-Einträge bei TB5.0 + 6.0 ? (habe XP SP3)



    Grüße!
    InselElnte



    P.S.: zum vorigen Beitrag: Es war ja gerade meine Absicht, NICHT die Originalfiles im Profil, also auch abook.mab, nicht original zu übernehmen, da ich den Fehler dort vermutet hatte, weil gerade ja die Originalfiles auch genauso bei der Versionsumstellung beibehalten worden sind. Aber anscheinend liegt es in einer neuen Regstry-Einstellung, die ich (wir) noch nicht kennen....??

  • Hallo,


    warum verwendest du nicht die Undo-Funktion von CC? Oder sollte die nicht wirklich tun, was sie verspricht?


    Merke: Es gibt in der Registry nichts zu "cleanen". Das ist eine Datenbank und kein verstaubter Schrank, wo man putzen könnte. In einer Datenbank kann man Daten verändern (= verfälschen, falls man nicht gezielt editiert) oder löschen (= vernichten). Im wirklichen Leben erwartet allerdings auch kein vernünftiger Mensch, daß man ein Haus, das mit der Abrißbirne zerstört worden ist, wieder "reparieren" kann, mit der Software-Abrißbirne verhält sich das im Wesentlichen ebenso.


    Solltest du allerdings ein vollständiges Image deines Systems haben ...


    P.S. Es geht im übrigen um Registry-Einträge des Systems, TB verwendet (von ein paar hier nicht relevanten Ausnahmen abgesehen) diese Datenbank nicht, sondern sein Profil. Aber CC macht ja auch keineswegs bei der Registry Halt.

  • Okay, wenn ich nun von den unverlangten aber obligatorischen.de Belehrungen zum Thema Registry absehe, habe ich gelernt, dass mein Problem NICHT in der Registry zu suchen ist. Immerhin.


    Demnach richtet sich meine Aufmerksamkeit wieder auf einer der der Profil-Dateien, jedoch in welcher steckt die gefragte Anweisung?
    Welche der Einstellungen in den Profil-Dateien bezieht sich auf die von mir unerwünschte Funktionsänderung und ist "verstellt"? (Und warum bei mir immer wieder?)


    Kennt sich denn niemand wirklich in den Tiefen des TB aus? Mit meiner Metapher gesagt: "Wo ist die Schraube?"


    Danke und hoffnungsvolle Grüße!
    InselEnte