Thunderbird wandelt JPEGs beim reinziehen in BMP um

  • Hallo,


    in TB 2 konnte ich ohne Probleme JPEGs vom Browser per drag&drop in Thunderbird ziehen und als E-Mail Anhang einfügen.


    Seit dem Update auf Version3 jedoch werden die JPEGS als wesentlich größere BMPs eingefügt. Ich konnte das Problem bis heute (Version 5 / Windows XP / alles IMAP-Konten) nicht beheben. Auch der Test ein neues Profil zu erstellen brachte keine Besserung.


    Gibt es für dieses Problem inzw. eine Lösung? Damals konnte mir niemand wirklich helfen.


    vg
    eli

    3 Mal editiert, zuletzt von Eli ()

  • Hallo eli,


    ich will das so recht nicht glauben ... .
    Wohin genau schiebst du deine Bilder? (In den Mailtext oder so wie es richtig ist, in die Adresszeile?)
    Werden die Anhänge in dem kleinen Fenster neben der Adresszeile dann bereits als .bmp angezeigt?
    Was passiert, wenn du (ordentlich ...) die Anhänge per Klick auf den Anhang-Button hinzufügst, und nicht auf Mausschubserart?
    Versendest du deine Mails als Reintextmail oder Klickibunti (Verzeihung: html ...)
    Werden in deinem (warum auch immer) geheim gehaltenen Betriebssystem die Dateianhänge mit angezeigt oder unvernünftigerweise ausgeblendet?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hi Peter,


    Betriebssystem (XP), Kontoart ist IMAP.


    Ich schiebe die Bilder in die Adresszeile, direkt nach dem 'loslassen' werden sie dann bereits als .bmp angezeigt und auch der dateiname wird verändert (zb aus logo.jpg wird pm98kx2l.bmp).


    Beim 'ordentlichen' einfügen passiert das nicht. Die Bilder werden korrekt eingefügt.


    Ich versende Reintext-Mails, kein HTML. Angefügte Bilder werden direkt angezeigt.


    VG
    Eli

  • Danke.
    Ich - purer Linuxnutzer - habe mich jetzt extra einmal an eine WinDOSe (7) gesetzt und getestet.
    Wie bei mit seit vielen Jahren unter Linux hat er auch hier das .jpg exakt übernommen, gesendet und auch als solches wieder empfangen.
    Demzufolge gehe ich weiterhin davon aus, dass der TB das nicht von sich aus macht.


    Mehr kann ich aber dazu nicht sagen - und hoffe mal, dass ein erfahrener Liebhaber des Programms mit den Fenstern hier weiterhilft.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Ich kann auf meinem Fensterprogramme das Verhalten auch nicht bestätigen.
    vielleicht ist ein entsprechendes AddOn installiert

  • vermutet ihr eher ein addon oder ein plugin?


    sind die bei einem neuen profil automatisch auch drin? denn wiegesagt: auch bei erstellen eines neuen profils tritt das problem auf

  • Liste doch mal AddOns und PlugIns auf (inkl. Version)
    Vielleicht kann man daraus etwas ersehen

  • Ist es nicht einfacher, den TB mal testweise im Safe-Mode zu starten?

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Vielleicht springt uns bei den PlugIns und AddOns was ins Auge, wenn nicht, können wir danach immer noch auf Fehlersuche gehen.

  • im safe-mode kam das problem leider auch.


    add-ons habe ich mal viele (quote/header-addons etc) entfernt, die ich eh nichtmehr brauchte, übrig ist nur noch 'sort folders'.
    unter plugins (die offenbar auch der safe-mod nicht abschaltet) sind sehr sehr viele:


    - adobe acrobat
    - google earth
    - google update
    - java development toolkit
    - java platform se 6
    - ms office 2010
    - ms office 2010
    - ms drm
    - ms drm
    - quicktime plug-in
    - realplayer version
    - realplayer gm live-connect
    - shockwave flash
    - windows live photogallery
    - windws media player
    - windows presentation foundation


    und übrigens:


    jetzt ist es sogar so, dass er das erzeugte bmp nicht mehr findet. eine entsprechende fehlermeldung kommt beim abshcicken der nachricht. wie lange das problem schon so besteht kann ich nicht genau sagen, da ichs mir inzw. abgewöhnt hab bilder vom browser reinzuziehen. wenn man ein bild vom dekstop reinzieht gehts übrigens

  • Die Grafik vom Browser sollte man immer zwischenspeichern (zum Beispiel in das Temp-Verzeichnis)


    In welchem Format speichert er die Grafiken aus dem Browser (welcher?) heraus?
    In welchem Format speichert er die Grafiken dann im TB heraus?

  • Das mit dem Reinziehen aus dem Browser habe ich erst jetzt so richtig "verstanden". Bin immer vom Dateimanager ausgegangen.
    ich kann mir einfach nicht vorstellen, dass ein in html eingebettetes jpg dann auch einfach so nach Mausschubserart übernommen werden kann. Denke mal, dass das die Ursache ist.
    Was passiert denn, wenn du ein Bild auf den Desktop ziehst. Ist es dann wirklich ein .jpg?

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hi,


    ok also ums nochmal klar zu machen:


    Es geht um das ziehen von Jpeg oder Gif-Bildern vom Browser (Firefox) direkt in die Mail hinhein (ohne vorheriges manuelles abspeichern).


    Das hat bei mir früher (TB 2) ohne Probleme funktioniert. Nach dem Update auf TB3 wurde das Bild immer als .bmp umgewandelt. Und beim aktuellen test wurde es als .bmp umgewandelt aber offenbar fehlerhaft, denn die datei wird beim verschicken nicht gefunden.


    Vom Browser auf den Desktop ziehen habe ich noch nie versucht, glaube das geht gar nicht, da man ja erst Firefox minimieren müsste um den Desktop zu sehen.

  • Anderfalls werden die Cachedaten genommen, und die sind immer BMP weils schneller geht.

  • aber früher ging das bei mir ohne probleme mit deim firefox->thunderbird


    das kann doch nich sein, dass das ohne grund nicht mehr geht?

  • sprich es liegt an firefox und gar nicht an thunderbird?
    gibts da irgendwo eine dokumentation, dass das geändert wurde?


    und: wieso findet er die 'reingezogene' umgewandelte bmp nicht mehr? zumindest das ding ja noch ...

  • Die Änderung des FF findest Du in den Entwicklerinfos


    Wenn sich in der Zwischenzeit auf den geöffneten Tabs im FF etwas ändert, ändert sich auch der Cache.
    deswegen: Grafiken immer selber Zwischenspeichern (Kann man ja nach dem Versenden manuell löschen, ich habe dafür X:\Downloads)