Problem bei Migration Vista auf Win7 [Erledigt]

  • Thunderbird-Version: 8.0
    Betriebssystem + Version: Win7 Pro 64bit / Vista Business 64bit


    Guten Tag zusammen,


    ich stehe vor einem nervenden Problem bei der Migration von Vista auf 7. Zunächst: ich habe das schon einige Male ohne Probleme gemacht, und natürlich die FAQs etc. genau angeschaut, aber dieses spezielle Problem scheint niemand anderes bislang gehabt zu haben.


    Ich habe ein Backup der Profile-Ordners (bzw. des gesamten Thunderbird-Ordners mit dem Pfad Appdata\Roaming\Thunderbird) unter Vista gemacht und wollte diesen, wie gewohnt, in der Thunderbird-Installation unter Win7 an selber Stelle einfügen. Das Einfügen klappt auch, jedoch ignoriert Thunderbird die Profile. Egal, was ich mache (auch wenn ich über den Profilemanager den Backup-Ordner angebe oder den alten Thunderbird-Ordner einsetze) - beim Start von Thunderbird erscheint lediglich das Begrüßungsfenster zur Konteneinrichtung.


    Kann mir jemand helfen?


    Vielen Dank!
    C.

  • Hallo


    und willkommen im Thunderbird-Forum!


    Eigentlich hört sich das schon richtig an.. :gruebel:


    Lösche den Win 7er Profilordner Appdata\Roaming\Thunderbird komplett und starte TB neu, dann sollte es einen neuen Ordner mit einem neuen Profil [der Ordner mit den 8_wilden_Buchstaben.default, wobei auch default sonstwie heißen kann, z.B. ghw63k9g.test oder ghw63k9g.MeineMails...
    geben, kontrolliere das anhand Datum/Uhrzeit. Lösche den Inhalt des Profils und kopiere den Inhalt des anderen rein.

  • Erstmal vielen Dank für die Begrüßung und dass Du Dir die Zeit nimmst, mir zu antworten.


    Ich habe Deinen Vorschlag haarklein befolgt, aber es tut sich leider nichts. TB ignoriert einfach das eingefügte neue Profil (bzw. die in den neuen Ordner eingefügten alten Daten).

  • Dann fügst du das scheinbar nicht im richtigen Ort ein.
    Erstelle ein Pseudo-Konto und dann schau in Hilfe>Informationen zur Fehlerbehebung nach, welchen Pfad dir TB dort zeigt.
    Ich bin für Heute nun off, viel Erfolg!

  • Dank auch für diesen Tipp, rum.


    Jedoch: Auch das (funktionierende) und von mir gerade neu eingerichtete Konto ist genau dort gespeichert, wo ich die migrierten Daten eingefügt habe. Der Pfad ist der der selbe. Das neue Konto richtet es sich inmitten der migrierten Daten ein und ignoriert meine migrierten Konten, Mails, etc.


    Übrigens habe ich verschiedene Varianten auch auf dem virtuellen XP versucht, aber auch hier werden die migrierten Daten ignoriert.


    Gibt es noch weitere Hinweise oder Tipps? Ich bin für alles dankbar!


    Grüße
    C.

  • Hallo,


    mach mal einen Screenshot deines Profilordners im Windows Explorer mit aufgeklapptem Verzeichnisbaum links (!) und poste den Inhalt der Datei profiles.ini in dem Profil.

  • Hallo,


    damit wir uns nicht lange dabei aufhalten, was du eventuelle noch brauchst und was nicht: Mache eine Sicherung des gesamten Ordners Thunderbird (direkt unter Roaming).


    Was bei dir nicht stimmt ist der Umstand, daß es bei dir 2 Profilordner gibt, die hinter dem Punkt den Namen default haben; das darf nicht sein. Die Frage lautet jetzt, in welchem sind die für dich wichtigen Daten und ist der anderer Profilordner eventuell nur Spielmaterial bei den Versuchen, die Migration abzuschließen und ohne jegliche Nutzdaten. (Die Frage, wie das entstanden ist, wäre zwar interessant, aber nicht zielführend, lassen wir das bis zu den Feiertagen. :mrgreen: )


    Wir machen es folgendermaßen - alles bei beendetem TB:


    Benenne den Ordner der beginnt mit 2ad... um, indem du den Namen default durch etwas anderes ersetzt, zum Beispiel unbekannt


    Ändere die Datei profiles.ini in der Zeile StartWithLastProfile=1 die 1 gegen 0.


    Starte TB, es wird der Profilmanager sichtbar; dort sollte der Haken bei "automatisch mit letztem Profil starten" (oder so ähnlich) entfernt werden (solange, bis alle Unklarheiten beseitigt sind), dadurch wird der Manager bei jedem Aufruf automatisch erscheinen. Erreichst du jetzt das Profil 8ka... ? Ist der Inhalt relevant?


    Starte TB erneut. Im Profilmanager klicke auf "neues Profil" und navigiere zu dem gerade umbenannten Ordner, der mit 2ad... beginnt. Der Manager wird den Namen unbekannt als Profilnamen übernehmen. Starte nun nach Auswahl dieses Proflls und prüfe dieses.

  • Hallo,


    vielen Dank für die Hinweise und die Anleitung, leider war auch dies erfolglos.


    Zu dem zweiten Default-Ordner: Auf meinem alten System lief TB mit beiden Ordnern, der zweite ist nicht erst mit der Migration/Rumprobieren entstanden (auch in einem älteren Backup sind beide Ordner enthalten). Der Ordner mit 2.... ist nicht groß beinhaltet nichts Wichtiges, die letzte Änderung darin ist von 2008, der Ordner mit 8.... ist der wirklich wichtige. Bei den bisherigen Versuchen hatte ich deshalb auch stets nur den 8...-Ordner berücksichtigt. (So habe ich z.B. nur den Inhalt des 8...-Ordners in den von TB neu erstellten Profileordner kopiert, also nur einen default-Ordner mit korrektem Pfad im Profilorder gehabt, aber ohne Ergebnis.)


    Ich habe aber das gemacht, was Du vorgeschlagen hast. Dabei hatte sich, nachdem ich in der profile.ini "StartWithLastProfile=0" gespeichert hatte, aber nichts geändert - nach dem Start von TB erschien nicht der Profilemanager, sondern ganz normal die Aufforderung von TB zur Konteneinrichtung. Ich habe trotzdem aus der 2...-Ordnerbezeichnung das "default" rausgenommen und den 8...-Ordner im Profilmanger angewählt. Wieder erscheint nur die Aufforderung zur Konteneinrichtung.


    Es ist zum Verrücktwerden.


    Trotzdem Danke,
    C.

  • Hallo Ungarn,


    so wie es rum oben beschrieben hat, funktioniert es. Etwas merkwürdig erscheint mir

    "Ungarn" schrieb:

    ... Auf meinem alten System lief TB mit beiden Ordnern, der zweite ist nicht erst mit der Migration/Rumprobieren entstanden (auch in einem älteren Backup sind beide Ordner enthalten).


    bzw. dass der Screenshot ebenfalls noch beide Profile zeigt. Denn wenn Du die Anleitung von rum befolgt hast, dürfte nach dem Löschen des gesamten Profilordners und anschließendem Start des TB nur ein Profi vorhanden sein. Und zwar ein ganz neues, dessen Bezeichnung im Filesystem auch anders lauten sollte, also nicht 8ka ... . In diesen neuen Ordner hinein solltest Du den Inhalt Deines 8ka... Ordners kopieren. Nur den Inhalt, nicht den 8ka... selbst.


    Eine Frage zum Backup. Hast Du das Backup vielleicht auf CD/DVD gemacht? Dann kann es ein, dass die Dateien beim Restore einen Schreibschutz bekommen und der TB darüber stolpert.


    Gruß


    AlexisS

  • Hallo AlexisS,


    Du hast natürlich völlig recht. Ich habe unnötig Verwirrung gestiftet, indem ich nicht einen Screenshot der von rum vorgeschlagenen Konfiguration gemacht habe. Dieser Screenshot zeigt die Ordnerstruktur, nachdem ich den TB-Ordner aus dem Backup in der Neuinstallation eingefügt hatte.


    Ich habe aber natürlich diese verkorkste Struktur auch wieder gelöscht, um mit dem von TB neu generierten default-Ordner weiterzuarbeiten. Dort habe ich dann den Inhalt (nicht den Ordner selbst) des relevanten Backup-Profilordners einfügt. Aber, wie gesagt, ohne Erfolg.


    Das Backup habe ich übrigens auf einer externen Festplatte gemacht; die Sache mit Schreibschutz/Berechtigungen kam mir auch in den Sinn, das hatte ich schon geprüft.


    Grüße
    C.

  • Hallo zusammen,


    ich habe jetzt beschlossen, die ganze Sache ohne weiteres Rumpobieren auf die umständliche Art und Weise zu lösen. Ich habe meine Konten neu angelegt und in die jeweiligen Ordner dann den Inhalt der Kontenordner aus dem Backup kopiert, sowie das Adressbuch. Das hat - bis auf eine Kleinigkeit im Adressbuch (ein kleineres Adressbuch kam trotz Kopierens aller Adressbuch-Dateien abhanden) - auch geklappt.


    Ich danke Euch allen für Eure Hilfe und Tipps und ganz generell für die tolle Auflistung/Erklärung, was die jeweiligen Dateien in TB bedeuten (http://www.thunderbird-mail.de…_Profil_kurz_erkl%C3%A4rt), so konnte ich auch ohne tiefere TB-Kenntnisse dies nun über die Bühne bekommen.


    Grüße
    C.

  • Hallo,


    "Ungarn" schrieb:

    is auf eine Kleinigkeit im Adressbuch (ein kleineres Adressbuch kam trotz Kopierens aller Adressbuch-Dateien abhanden)

    bei den Adressbüchern stellt sich TB gerne etwas quer, man kann ein Adressbuch nicht einfach ins Profil kopieren, dann erkennt der Vogel das nicht.
    Erstelle in TB ein neues Adressbuch, das ergibt eine neue Datei abook-x.mab (x=Zahl) im Profil und dann beende TB und kopiere das abook-1.mab aus dem alten in das neue Profil, übernehme aber den neuen Namen. Nach dem Start von TB sollte dann das Adressbuch wieder da sein.

  • Hallo,


    schön daß das Kind jetzt in trockenen Tüchern ist. Was ich allerdings merkwürdig finde ist, daß genau das rum in seiner ersten Antwort vorgeschlagen hatte und du darauf geschrieben hattest, daß das "haarklein befolgt" nicht funktioniert habe. :gruebel:

  • Hallo,


    @ rum: Danke für den Adressbuch-Tipp (auf den ich nach all dem selber hätte kommen können)! Nun ist es wieder da.


    @ Cosmo: Da muss ich Dich leider korrigieren, rum hatte zu Beginn nur von den gesamten Profilordnern gesprochen (bzw. dem gesamten Inhalt), nicht von einzelnen Dateien innerhalb der Konten/Ordner, wie Inbox. Erst jetzt habe ich "handverlesen" einzelne Dateien rüberkopiert.


    Trotzdem, vielen Dank Euch allen für die Hilfe. Endlich kann ich wieder normal e-mailen!


    Grüße,
    C.