Quoted-Printables werden nicht dekodiert

  • .
    Guten Tag, TB-Freunde,


    mit meinem Thunderbird habe ich keine Probleme - alles läuft, wie es soll - insbesondere werden alle eingehenden Mails korrekt angezeigt. Jetzt habe ich aber eine eMail mit nicht dekodierten "quoted printables" erhalten, bei der Sender und ich rätseln, was hier falsch gelaufen ist. Ich habe keine Ahnung...


    Kann bitte einer von Euch uns helfen, auf die richtige Spur (und zur Abstellung) zu kommen? (Vielleicht war es ja auch nur ein einmaliger Fehler im System...)


    Danke für jeden Tipp!
    Peter



    Thunderbird-Version 11.0:
    Betriebssystem Win7 SP1:
    Kontenart IMAP:
    Postfachanbieter GMAIL:

    Einmal editiert, zuletzt von graba () aus folgendem Grund: Code-Tags gesetzt

  • Hallo,
    kann ich mir noch keinen Reim daraus machen.
    Kannst du im Quelltext den Absender-Mailklienten erkennen?
    Z.B.

    Code
    1. User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20120312 Thunderbird/11.0
    2. MIME-Version: 1.0


    Achtung: die MIME-Version muss dort stehen. Ist das bei dir der Fall?


    Bei mir sieht der Quelltext so aus:



    Wie du vielleicht erkennen kannst, wird die Reintextversion mit korrekten Umlauten dargestellt. Die Deklaration:
    8-bit (also unkodiert mit erweitertem Zeichensatz wegen der Umlaute), der charset ISO-8859-1 enthält alle Umlaute.
    In der HTML-Version muss "quoted printable" genommen werden, weil der charset us-ascii keine Umlaute enthält, dem entsprechend wird 7-bit genommen (unkodiert, keine Umlaute).
    Die Aufgabe die Umlaute richtig darzustellen übernimmt also "quoted printable".
    Diese Mail wurde mit einem englischen Thunderbird versendet.


    Die Deklaration in der deutschen Version ist anders:



    Hier wird bei gleichem Text "quoted printable" nicht verwendet, weil auch im HTML-Teil 8-bit deklariert ist (unkodiert mit allen Umlauten).


    Außerdem erkenne ich in deinem Quelltext nicht die Deklaration Content-Type: multipart/alternative;
    Bitte überprüfe, ob die bei dir vorhanden ist, falls nicht, brauchen wir gar nicht weiter nach den Ursachen zu suchen.
    Resümee: es sind vermutlich falsche oder fehlende Deklarationen die Ursache und somit
    Schuld des Mailklienten des Versenders, der bestimmt nicht Thunderbird verwendet hat.


    Ach ja, da der Betreff bei vorhandenen Sonderzeichen immer "quoted printable" verlangt, siehst du auch im Quelltext die kodierten Zeichen, das ist völlig normal.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für Eure Mühe!


    Jetzt kann ich aber leider (?) gar nichts mehr nachvollziehen oder testen:


    Die ursprüngliche Mail hatte laut Anzeige einen Umfang von 6,4 MegaByte - jetzt, nach ein paar Tagen wieder geöffnet, hat sie nur 4,2 kByte Umfang und - oh Wunder - alle Zeichen werden korrekt angezeigt.


    Wir können also das Problem nicht mehr klären. Ob ich darüber ärgerlich bin? :lol:


    LG, Peter

  • Hallo,
    und der Quelltext sieht genauso aus, wie dein schon geposteter?


    Und du hast mal als Reintext und als HTML anzeigen lassen?


    Zitat

    Ob ich darüber ärgerlich bin?


    Würde ich nicht sein, so etwas passiert, und vielleicht bekommst du ja noch so etwas.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw