Profil wiederhergest. - alle Emails und Unterordner weg[erl]

  • Thunderbird-Version: 11.0.1
    Betriebssystem + Version: Windows 7 Home
    Kontenart (POP / IMAP): POP3
    Postfachanbieter (z.B. GMX):


    Hallo,


    ich beschreibe mal kurz, was ich schon getan habe. Habe echt viel gelesen im Forum und schon etliche Stunden damit verbracht Dinge auszuprobieren, frage mich nun ob ich noch was übersehen habe. Vielleicht reicht schon ein Stichwort als Hilfe.


    1.Profilordner "Thunderbird" gesichert auf alter Festplatte: Benutzer\%Benutzername%\AppData\Roaming\Thunderbird
    2.Profilordner "Thunderbird" richtig abgelegt in neuer Festplatte: Benutzer\%Benutzername%\AppData\Roaming\Thunderbird
    3.TB 11.0.1. neu installiert -> alle 4 Konten wurden wieder angelegt inkl. Konteneinstellungen der Server (nur ohne PW) -> jetzt fehlen nur alle Emails, Unterordner und Unterunterordner, auch "gesendet","Entwürfe","Vorlagen" sind nicht angezeigt. Es ist nur "Posteingang" und "Papierkorb" zu sehen ohne Inhalte.


    Habe ich wirklich nur die Wahl alle Unterordner mit den ImportExportTools wieder zu importieren?


    Vielen Dank für Eure Mühe schon im voraus!


    Gruß
    surfer

  • Moin;


    imho war die Reihenfolge falsch:
    zu erst die Installation machen und TB einmal aufrufen;
    dann das alte Profil passend reinkopieren. Entscheidend ist der "kryptische Ordner aus den 8 Buchstaben" und dieser wird jedesmal anders zusammen gesetzt. ;) -> Profildateien


    xxxxxx -> gestrichen wegen falscher Angabe. ;)


    Greetz

    2 Mal editiert, zuletzt von DerCrabbe ()

  • Moin,

    "DerCrabbe" schrieb:

    Außerdem meine ich das in Roaming nicht der "richtige" Profilordern abgelegt wird, sondern vielmehr eine Kopie davon. Aber ich habe kein Win7.


    Wie kommst du darauf?
    Den_Profilordner_finden
    Die Vorgehensweise war schon richtig (deine funktioniert aber auch), ich würde jetzt noch überprüfen, ob auch die Datei Profiles.ini mitkopiert wurde und deren Inhalt auf das Profil verweist. Falls irgendwann der Profilordner oder gar der Speicherort der einzelnen Konten manuell geändert wurde, kann das die Ursache für die Probleme sein. Andere Möglichkeit: das Profil wurde als Administrator gesichert und zurückkopiert und "gehört" jetzt diesem - der aktuelle Benutzer sollte aber Vollzugriff haben.
    Gruß, muzel

  • ... habe Obiges ausprobiert. TB installiert, einmal gestartet. Dann Profilordner an die richtige Stelle kopiert.


    gleiche Problem!


    ... auch die Rechte für den Profilordner stimmen. (also nicht nur Adminrechte)
    Die .ini habe ich auch angepasst, indem auf das richtige Profil gezeigt wird. Dann ist TB leer ohne irgendwelche Dateninhalte.


    any more ideas? ;)


    Gruß
    surfer

  • "surfer" schrieb:


    Die .ini habe ich auch angepasst, indem auf das richtige Profil gezeigt wird. Dann ist TB leer ohne irgendwelche Dateninhalte.
    surfer


    Was steht in der profiles.ini?

  • Inhalt der .ini :



    [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=1
    Path=Profiles/xx5u9217.default

  • Hallo,


    wenn der komplette Ordner ..\thunderbird\.. kopiert wurde und alles da ist, außer die Inhalte der Kontenordner , dann denke ich, muzel liegt hiermit

    "muzel" schrieb:

    Falls irgendwann der Profilordner oder gar der Speicherort der einzelnen Konten manuell geändert wurde, kann das die Ursache für die Probleme sein.

    richtig.

  • ...also die Profile wurden nicht geändert auch nicht umbenannt.


    Ich habe ganz normal nach der Anleitung den Thunderbird - Ordner raus und reinkopiert. ;)

  • Zitat

    Ich habe ganz normal nach der Anleitung den Thunderbird - Ordner raus und reinkopiert.

    Und auch nie vorher in den Konteneinstellungen den Pfad geändert? Was steht in den Kontoeinstellungen jeweils unter Konten-Einstellungen - Server-Einstellungen - Lokaler Ordner?

  • ... wenn ich den Pfad geändert hatte ging nichts mehr. Dann waren die 4 Konten auch weg im Thunderbirdemailprogramm.


    Ich habe 4Profile in meinem Thunderbirdordner. (Keine Ahnung wann die alle angelegt worden sind in ca 7 Jahren) Nach der Installation nimmt TB sich immer ein bestimmtes Profil, wo eben keine Ordner & Emails drin sind aber die Konteneinstellungen der Server drin sind.
    Habe schon raufgefunden, dass in einem bestimmten alle Daten drin sind. Wenn ich aber nachträglich auf dieses Profil ändere funktionierts auch nicht.
    Nun habe ich nochmal folgendes probiert: Alle anderen Profile aus dem Ordner Thunderbird rausgelöscht und nur das drin gelassen wo alles drin ist.


    Dann ist gar nichts im Thunderbird zu sehen, keine Konten auch keine Servereinträge. Alles jungfräulich sozusagen, als wenn alles neu installiert wurde.
    Dann kann ich ja auch keine Profileinstellungen vornehmen, da keine Server und nichts eingetragen sind.


    Ich kann immer wieder meinen Thunderbirdordner ( mit allen 4 Profilen) nehmen und an den Platz kopieren: Benutzer\%Benutzername%\AppData\Roaming\Thunderbird
    und Thunderbird neu installieren. Oder umgedreht erst installieren und dann Order reinkopieren kommt das gleiche raus wie anfangs beschrieben.

  • Aha, 4 Profile, so langsam kommt die ganze Wahrheit ans Licht. Wenn du aber einen funktionierenden Zustand 1:1 kopiert hättest (alle Profile und die profiles.ini), hätte es trotzdem wie vorher funktioniert.

    Zitat

    Nach der Installation nimmt TB sich immer ein bestimmtes Profil, wo eben keine Ordner & Emails drin sind aber die Konteneinstellungen der Server drin sind.

    Nicht irgendeins, sondern das Standardprofil aus der Profiles.ini.
    Und vermutlich sind in den Konteneinstellungen (gespeichert in der prefs.js), Verweise auf ein anderes Profil (mit absolutem Pfad irgendwohin...?).
    Du weißt nicht, wo 4 Profile herkommen, bist dir aber sicher, nie die Pfade in den Konteneinstellungen geändert zu haben?
    Ich glaube nicht, daß sich das Chaos noch auflösen läßt, denn ich vermute, daß schon bei Datensicherung/Wiederherstellung etwas schiefgegangen ist.
    Also: Konten neueinrichten und entweder mit den ImportExportTools die Mails importieren oder, wenn du genau weißt was du tust ;) - nach dem Neuanlegen einfach die neu entstandenen Dateien (bei beendetem TB) durch die alten ersetzen (also INBOX, SENT usw.). Keine Ahnung, ob das bei (noch) nicht vorhandenen funktioniert, vermutlich muß man die erst im TB anlegen.
    Gruß, muzel

  • Vielen Dank!


    das hat schon geholfen. Habe mich für die letztere Variante von muzel entschieden, ohne ImportExportTool einfach die Dateien (INBOX,SENT;DRAFTS,ARCHIEVES, usw. inkl. Unterordner & Unterunterordner) in das von TB angelegte Standardprofil reinkopiert bzw. überschrieben. Das hat wunderbar geklappt, ich konnte wirklich alle Email, selbst gelöschte wiederherstellen. Somit habe ich gleich aufgeräumt und die anderen verwirrenden 3 Profile (oben erwähnt) gelöscht.
    So sauber war mein TB noch nie installiert jetzt. ;) Damit hat mir das Thunderbird-mail-Forum einen großen Dienst erwiesen und ich bedanke mich respektvoll für die Hilfe.


    Alles Gute und vielleicht hilft es anderen auch nochmal. :les:


    Gruß
    surfer

  • Klingt gut - ich würde dann recht bald (wenn du es nicht sowieso vorhattest), ein Backup machen, und auch später regelmäßig.
    - m.

  • ...auf jeden Fall mache ich ab jetzt häufiger Backups. Mit Mozbackup und den Thunderbird Ordner. ( zum Glück gehen ja beide Varianten)


    nochmal vielen Dank. :zustimm:

  • Guten Morgen,


    wenn du die Suche mit der ersten Variante fütterst, dann weißt du, warum wir die nicht empfehlen, sondern lieber die Zweite nehmen.
    Komfortable Backups lassen sich mit dem (für Privatanwender?) kostenlosen Personal Backup von Rathlev automatisieren.