TB 13 löscht IMAP Mails, weil er nicht ONLINE gehen darf

  • Thunderbird-Version: 13.01 - (vorher unter XP: 11 oder 12.0.1 )
    Betriebssystem + Version: XP => jetzt Windows 7 HPrem
    Kontenart (POP / IMAP): IMAP [macht Probleme], pop3
    Postfachanbieter (z.B. GMX): GMX, UNI,yahoo


    Hallo,


    ich überlege gerade, wie ich das Problem am besten schildern kann.
    Um es kurz zu machen: Ich hab bis Ende Mai mit Thunderbird (11 oder 12 … eher 12) unter XP gearbeitet.


    2 POP3 und 2 IMAP Konten. Ein IMAP Konto hat ca. 8.000 Emails, das andere 400. Das Pop3 Konto hat 1400.


    So jetzt hab ich damals am 29.5. unter XP den funktionierenden Thunderbird beendet und dann den Ordner Anwendungsdaten\Thunderbird (mit dem Standardprofilordner) mit 7z gepackt.
    Dann hab ich Win 7 draufgespielt.


    Damit ich zwischenzeitlich die Emails von meinem Arbeitgeber verarbeiten konnte, hab ich in TB 13 schnell ein [neues] Profil und ein IMAP und 1 Pop3-Konto darin angelegt.
    Ich hab seit Win7 jetzt Thunderbird 13 (die vorherigen TB11/12erVersionen hab ich nicht gesichert, da ich davon ausging daß die neuesten Thunderbirdversionen ohne Problem damit klarkommen).


    Jetzt hab ich etwas mehr Zeit, um das Backup zurückzuspielen.


    Da ich schon mal Thunderbird portable ausprobiert hab, und der einfach nen Profilordner "dabei hat", dem es egal ist von welchem Rechner die darin liegenden Dateien kommen - hab ich jetzt einfach unter meinem installierten normalen TB 13 ein zweites, neues Profil erstellt, alle Dateien in dem Ordner
    „C:\Users\BENUTZER\AppData\Roaming\Thunderbird\Profiles\udckdxte.Universität“
    gelöscht und aus dem Backup-ZipArchiv.7z die Dateien samt Unterordnern 1:1 da reinkopiert.


    Sollte eigentlich alles funktionieren. (hab ja quasi nur die Dateien "ausgetauscht")



    1) Also hab ich Thunderbird wieder mit dem Parameter –p gestartet, damit ich das Profil auswählen und OFFLINE starten konnte. (wollte online nicht, wegen für später geplanten Abgleich der Mails - erstmal gucken, ob überhaupt alles geht)


    Thunderbird aber wollte natürlich sogleich ONLINE gehen um zu überprüfen, ob die drinsteckenden Addons aktuell sind oder seine Arbeit gleich verweigern und sich wieder beenden.
    Also hab ich ganz kurz auf „ONLINE gehen“ und WEITER geklickt.


    Thunderbird hatte dann auch normal gestartet. Sogar schon ein paar neue Emails aus dem IMAPkonto dazugeladen, bevor ich unten links OFFLINE klicken konnte.
    Allerdings röddelte er weiter rum (hat wahrscheinlich die Mails neuindiziert) – der grüne Balken unten rechts lief andauernd.
    Also hab ich TB normal beendet.


    Zu meinem Erstaunen waren nach erneutem TB-Start (als OFFLINE) beide IMAP Konten leer. D.h. die IINBOX enthielt jeweils 0 Emails und sämtliche andere Ordner wie (Entwurf, Gesendet, Archiv ) waren auch verschwunden.
    Dies betraf nur die IMAP Konten. Die pop3 Konten schienen in Ordnung.
    Aber ich hab dann mit dem TotalCommander im IMAP Ordner unter dem Konto nachgeschaut. Da waren eine 16 kB INBOX-Datei und noch weitere. (von zuvor 1200 MB INBOX-Datei) – also nicht nur unsichtbar, sondern auch psyikalisch gelöscht.


    2) Also hab ich das Profil wieder komplett aus dem Backup drüberkopiert und TB diesmal komplett mit gekappter WLAN verbindung gestartet. Erster Start – vollkommen OK. TB Beenden und neu starten endete in leeren IMAP –Konten. Wie vorher.



    3) Also, Profil wieder rüberkopiert – diesmal TB im abgesicherten Mode Thunderbird.exe –safemode gestaratet – um fehlerhafte Addons (ImportExportTools, SendToTray, PasswortExporter) auszuschließen. Erst alles OK dann selbes Resultat nach TB Neustart.



    4) Dann kam mir ne Idee: OK, probier’s hier mit dem alten Thunderbird 11 – also TB 11 runtergeladen, Setup entpackt, TB11 Mit –p gestartet.
    Selbes Problem.


    Dann sagte mir jemand (f*x™) im Chat, daß Thunderbird ja evtl. Pfade absolut und nicht relativ in seinen Dateien im Profilordner abspeichert.
    OK, da dämmerte mir was.
    Ich bin ja von XP nach Windows 7 und da sind die Pfade jetzt total anders.
    „C:\Users\BENUTZER\AppData\Roaming\Thunderbird\Profiles\udckdxte.Universität“ war unter XP ja
    „C:\Dokumente und Eigene Dateien\BENUTZER\Anwendungsdaten\Thunderbird\Profiles\afektrg.BLABLA“


    Aber ob es daran liegt???
    Jetzt hab ich folgenden Thread gefunden und nehme an, daß es daran nicht liegen kann:
    http://www.thunderbird-mail.de…iewtopic.php?f=27&t=58861


    Und jetzt hab ich zum 5.ten Mal das 1,9 GB-PROFIL zurückkopiert und TB im -Safemode gestartet. Aber wenn ich den gleich zumache, hab ich bestimmt wieder die Emails weg.


    Macht TB das nur, weil ich ihm OFFLINE vorschreibe und nicht erlaube, sich gleich online zu verbinden? Löscht er deshalb meine o.g. komplett geladenen (header+Text) Mails aus den IMAPkonten beim weiteren Start?


    Ich hoffe, ich hab alles verständlich beschrieben? (zwar etwas sehr ausführlich...)



    Aber was kann ich denn machen, um mein bisheriges Profil hier unter TB 13 und Windows 7 weiter nutzen zu können?



    Vielen Dank schon mal.

    Einmal editiert, zuletzt von Elite ()

  • Hallo Elite,


    ich hoffe, dass ich die Infos alle richtig mitbekommen habe. Hast Du mal auf dem Server nachgesehen, ob dort die Mails noch vorhanden sind. Wenn nicht, synchronisiert TB mit dem Server und löscht sie logischer Weise auch aus dem eigenen Profil. Ist kein Bug, sondern ein Feature und IMAP-immanent.


    Wenn Du offline bist, kannst Du die Mails mal in den Lokalen Ordner kopieren, dann hast Du sie auch noch nach der Synchronisation.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 64 Bit | Firefox 64 Bit | Avira Free Security Suite | Fritzbox 7490

  • Tag,
    Danke.


    Ja, glücklicherweise sind alle Emails noch jeweils auf den Servern der IMAP-Konten.


    Da hatte ich sofort nach dem ersten Test nachgeschaut.


    Die Emails verbleiben uneingeschränkt auf dem Server und werden komplett heruntergeladen und verlbleiben normal auch so lange in dem Ordner, bis eine Internetverbindung die Synchronisation ermöglicht.


    Und darum hab ich erst Recht für die Folgeversuche immer gleich die WLANverbindung gekappt. Daher konnte ich sicher sein, daß kein Abgleich stattfinden konnte.


    Also, warum komplett alle Ordner aus dem IMAP-Konto [nennen wir es mal "ChuckNoris@uni-Konstanze.de"oder so] wie Entwurf, Gesendet, Papierkorb von TB selbständig gelöscht werden und nur ein leerer INBOX-Ordner drinbleibt - ist mir ein Rätsel.
    Ich hab ja nicht meinen ganzen Uni-Account geslöscht. :D
    Und das macht er bei dem andern IMAPkonto (yahoo) auch. Nur die pop3 Konten sind anscheinend normal.


    Zitat

    Wenn Du offline bist, kannst Du die Mails mal in den Lokalen Ordner kopieren, dann hast Du sie auch noch nach der Synchronisation.


    Ich versteh schon - aber warum duldet TB nicht, daß ich ihn mehrmals ohne Verbindung zum WLAN/internet starte und löscht daher alle meine bisherigen Mails?
    Ich müßte den doch ungestört auch komplett OFFline verwenden können.


    Nach dem ersten Start nach dem Zurückkopieren läuft ja alles ganz normal.Nur wenn ich TB schließe und wieder starte, sind die Mails weg.

  • Hallo,


    ich bin wahrlich kein IMAP-Experte, schon gar nicht im Offline-Modus, aber könnte mir vorstellen, dass Du in TB nicht eingestellt hast, dass die Mails offline vorgehalten werden sollen. Dann sind die Mails eben offline nicht sichtbar. Es spricht doch einiges dafür. Überprüfe diese Einstellung.


    Dass die Mails noch auf dem Server sind, beweist aber, dass TB nichts löscht. Denn sonst wären sie dort auch weg (nach Deinem kurzen Online-Abenteuer).


    Sollte alles nichts helfen, lösche das IMAP-Konto und lege es neu an. Dann braucht TB etwas, um alle Mails neu herunter zu laden, aber danach hast Du dann alles was nötig ist.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 64 Bit | Firefox 64 Bit | Avira Free Security Suite | Fritzbox 7490

  • Hallo,


    Zitat von "Elite"

    Aber deshalb darf er doch nicht gleich alle löschen, nur weil er den Server nicht erreicht (WLAN aus)


    doch, TB muss dann sogar alle löschen, denn sonst würdest Du die Mails ja offline vorhalten und das hast Du ja gemäß Einstellungen ausdrücklich nicht gewünscht. Jetzt stell Dir mal vor, dass Du genau das willst und TB täte das nicht. Dann würden wir jetzt einen ähnlichen Thread führen, nur mit umgekehrten Vorzeichen. :D


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 64 Bit | Firefox 64 Bit | Avira Free Security Suite | Fritzbox 7490

  • also, weil ich jetzt so getan hab, als wäre meine Internetverbindung kaputt und TB offline gestartet hab und weil dieser Haken da oben gesetzt ist (letzter Screenshot; " [x] Nachrichten auf diesem Rechenr vorhalten")


    löscht der beim Neustart alle?


    Also muß ich den beim ersten Start dann in den Kontoeinstellungen für 1x rausnehmen, bevor ich TB wieder beende?

  • Hallo,


    nein, wenn das Häkchen gesetzt ist, dürfte TB keine Nachrichten mehr löschen. Allerdings kann es sein, dass TB einige Zeit braucht, bis wirklich alle Nachrichten herunter geladen wurden und auf dem Rechner vorgehalten werden.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 64 Bit | Firefox 64 Bit | Avira Free Security Suite | Fritzbox 7490