Konten-Einstell. nicht mehr änderbar nach UpDate 15,0[erl.]

  • Thunderbird-Version: 15,0
    Betriebssystem + Version: Windows XP Professional SP3
    Kontenart (POP / IMAP): POP + IMAP (insg 11 Konten)
    Postfachanbieter (z.B. GMX): WEB + Freenet + GMX + WebVision + 1und1


    Ein "Hallo" an alle die regelmäßig updaten ... und jetzt vielleicht das gleiche Problem haben wie ich.
    Denn nach meinem UpDate von einer funktionierenden Version 14,x auf die neueste Version 15,0 habe ich Probleme, die es wohl schon mit Version 2,0,0,9 gab. Leider funktioniert bei TB 15,0 der dort beschriebene Lösungsweg nicht.


    Aufgefallen war es mir, weil die Verwaltung der JUNK-Mails nicht mehr stimmte.
    Eingestellt war in den "Einstellungen" und den "Konteneinstellungen": automatisches verschieben in den Ordner "Junk". Junk-Filter war für alle Konten aktiviert. Verschoben werden sollte nach "Lokale Ordner".
    Tatsächlich wurde aber nach dem UpDate JUNK im Posteingang abgelegt und nach dem markieren als JUNK sofort gelöscht (nicht erst in den Papierkorb, sondern sofort vollständig).


    Also "Einstellungen" geprüft, AUS und dann wieder EIN geschaltet. Lässt sich speichern, hat aber keine Auswirkung.
    Dann "Konten-Einstellungen" geprüft. Auch hier AUS und EIN schalten. Speichern (= Klick auf OK) klappt nicht. Alles wiederholt, Programm neu gestartet, PC neu gestartet, ... jedes mir bekannte Prozedere durchgezogen ... der Fehler bleibt. [
    b]Ich kann seit dem UpDate die Konten-Einstellungen nicht mehr verändern!!![/b]
    :aerger:


    Erneut alles durchgesehen, weitere (vermutlich vom UpDate vorgenommene) Änderungen entdeckt:
    Bei "Konten-Einstellungen" konnte man vorher auswählen, welchen "Absendern der gewählten Adressbücher vertrauen" zutreffend ist. Das Feld ist leer.
    Bei Junk-Kopfzeilen dieses externen Filters vertrauen war "SpamAssasin" markiert. Das Feld ist ebenfalls leer.
    Neue Nachrichten sollten verschoben werden nach "Junk in Lokale Ordner". Hier wird der Name eines Mailkontos angezeigt ... welches angezeigt wird hängt davon ab, welche Einstellung ich zuletzt ändern wollte (mehr als "wollen" klappt ja nicht).
    Ausserdem festgestellt: bei "Einstellungen" sollten in der UpDate-Chronik Einträge vorhanden sein. Die Liste ist leer.


    Nervig, aber erst heute aufgefallen (weil ich TB ca 20x geöffnet + geschlossen habe) und vermutlich nicht auf TB 15 zurückzuführen: eigene Spalteneinstellungen kann man einrichten und dann für alle lokalen Ordner und Unterordner übernehmen. TB merkt es sich aber nicht (oder nicht lange ...)!


    -
    Hintergrund-Infos: TB 12,0,1 am 19.05.2012 installiert > UpDates 13,0,1 + 14,0 + 15,0 (letztes am 29.08.2012 installiert)
    Virenscanner Kaspersky-Internet-Security (das Thunderbird-Verzeichnis ist aus der Überwachung ausgenommen)
    Problem tritt auf, wenn ich TB im abgesicherten Modus ohne Add-Ons nutze.
    Problem tritt ebenfalls auf, wenn ich Kasperskys Mail-Überwachung ausschalte.
    -


    So, das wars mit meinem Status Quo.


    Da das mein erster Beitrag hier im Forum ist (seit dem Ende meiner "Lern-Phase" bin ich mit TB immer sehr zufrieden gewesen), weiss ich nicht, ob das ergänzen eines alten Betrags passend ist - oder - ich ein neues Thema anfangen sollte.


    Meine Bitte an den Admin dieses Forums: bitte umhängen, wenn nötig. Danke.


    Eine gute Nacht ... bzw einen Guten Tag Euch allen
    VG Lothar

  • Hallo Lothar


    und willkommen im Thunderbird-Forum!


    Deaktiviere mal den Start von Kaspersky mit dem BS und dann starte den PC neu und teste.
    Hast du deine POP Konten separat oder global geführt?


    Zitat

    Da das mein erster Beitrag hier im Forum ist (seit dem Ende meiner "Lern-Phase" bin ich mit TB immer sehr zufrieden gewesen), weiss ich nicht, ob das ergänzen eines alten Betrags passend ist - oder - ich ein neues Thema anfangen sollte.

    dazu sagen die Forenregeln (Link auf der linken Seite)

    Zitat

    Dein neuer Thread ist also absolut ok!

  • Hallo rum.


    Kaspersky kann ich über "Schutz anhalten" de-aktivieren ohne dafür den PC neu booten zu müssen.
    Getestet, Ergebnis: keine Änderung.


    Hat mich aber auf eine Idee gebracht: auch das Programmverzeichnis von TB aus der Überwachung rauszunehmen, nicht nur das Datenverzeichnis.
    Getestet, Ergebnis: keine Änderung.


    POP Konten "separat" oder "global" geführt? Die Frage verstehe ich nicht.
    Könntest Du bitte erklären was Du meinst. Danke.


    -
    Meine Vermutung: irgendein Schalter in der "prefs.js" ist verstellt.
    Aufgefallen ist mir zum Beispiel, dass dort wo ursprünglich "true" stand jetzt "false" eingetragen ist
    user_pref("mail.identity.id12.fcc_reply_follows_parent", true);
    user_pref("mail.identity.id12.fcc_reply_follows_parent", false);


    Gibt es irgendwo die Möglichkeit nachzulesen, welcher Schalter welche Bedeutung hat?
    Wenn es nämlich nicht übers Programm klappen sollte, dass man die "prefs.js" mit einem Editor korrigiert?


    -
    Andere Idee: ich habe in TB15 ein GMail-Konto neu eingerichtet. Die von TB15 angelegte Ordnerstruktur vereinzelte alles. [nachträgliche Anmerkung: "separate Anlage", alle anderen Konten sind "global" angelegt // lb ] Das wollte ich so nicht, also habe ich das GMail-Konto wieder de-installiert.
    Vielleicht hat TB was dagegen, wenn man Konten wieder löscht?


    -
    Ich werd das GMail-Konto testweise eben wieder einrichten ... Morgen!


    Gute Nacht dann und Danke.

    Einmal editiert, zuletzt von bsbecker ()

  • Guten Morgen,


    "bsbecker" schrieb:

    Kaspersky kann ich über "Schutz anhalten" de-aktivieren ohne dafür den PC neu booten zu müssen.

    sorry, vergiss das! Du kannst so eine Sicherheitssoftware nicht einfach abschalten, das wäre ja auch fatal, denn dann könnte Malware ja einfach die Sicherheitssoftware im lfd. Betrieb deaktivieren, nein, die Regeln greifen viel zu tief in das BS ein.
    Da geht nur das oben genannte einfache Procedere, das Mitstarten zu unterbinden, besser noch> Konfigurieren von Windows XP auf die Durchführung eines "sauberen Neustarts"


    Das Programmverzeichnis kann und soll eingeschlossen bleiben, nur das Profil nicht.
    Die prefs.js manuell editieren, kann, muss aber nicht gut gehen. Ich lasse da lieber die Finger von... :rolleyes: 

    "bsbecker" schrieb:

    POP Konten "separat" oder "global" geführt? Die Frage verstehe ich nicht.

    da hilft ein Blick in die Anleitung, Konten einrichten


    "bsbecker" schrieb:

    Die von TB15 angelegte Ordnerstruktur vereinzelte alles

    was meinst du damit? Hattest du das Konto als POP oder IMAP eingerichtet?

  • Hallo rum.
    Danke für Deine Hinweise. Ehrlich. Danke. Allerdings habe ich andere Erfahrungen.


    Man kann KIS2012 sehr wohl "pausieren" lassen oder auch abschalten. Und ich muss auch nicht über MSCONFIG die Systemeinstellung verändern, wenn ich nur den Programmstart von KIS2012 testweise aussetzen möchte. Da reicht 1 Schalter in den Einstellungen und es startet nicht mehr.
    Außerdem: wenn es am KIS2012 liegen würde, dann hätte es das Problem doch schon bei TB12 + 13 + 14 geben müssen. Denn am KIS2012 hat sich nichts geändert. Am TB schon. Und bis TB 14 gab es kein Problem. Logische Schlussfolgerung: es gab nur eine Änderung bei TB, also wird es wohl auch an TB liegen ...


    Wie auch immer, ich habe es getestet: auch ohne Virenscanner besteht das Problem mit TB15 unverändert weiter.


    -
    Der Blick in Anleitung+Forum ist bei mir immer das erste. Ich kann lesen. Tue es auch. "RTFM" ... erledigt.
    Doch wenn man (so wie ich) 12 Mailkonten bei 5 verschiendenen Anbietern hat, dann erledigt sich der Hinweis "... die SMTP-Server separat von den E-Mail-Konten eingerichtet ..." von selber. Es kann keine für alle Konten gültige "Standard-Einstellung" geben (das meinstens Du doch mit "global", oder?).


    -
    Ich hatte GMail als POP-Konto eingerichtet. ... und bis jetzt noch nicht wieder neu eingerichtet ... das teste ich ... später.
    Vorher geprüft: ich habe 11 Konten eingerichtet für POP+IMAP, aber 12 Konten stehen bei Ausgang (SMTP) und 14 Konten werden mir im Verzeichnis "*\tb\Mail\" angezeigt. Also gibt es einen Fehler beim löschen von nicht mehr benötigten Konten?


    Ich werde die inzwischen unbenötigten Verzeichnisse manuell löschen (nachdem ich vorher eine komplette Sicherung angelegt habe). Dann sehen wir weiter ...


    -
    Noch was: da Du sehr gut informiert bist: welche Dateien darf man sonst noch so in TB löschen, die dann beim nächsten Start von TB "sauber" neu angelegt werden? Gibt es dazu evtl. eine komplette Liste? Was ich beim suchen im Forum finde, sind immer nur Bruchstücke, die zum jeweiligen Problem passen.
    Danach darf/kann man löschen: panacea.dat + alle *.msf. Was sonst noch? Wo kann man nachlesen?


    -
    Vorab schon mal Danke für Deine Unterstützung.
    Deine Antworten bringen mich auch auf neue Ideen! :top:

  • Es bleibt spannend ... denn plötzlich läuft etwas anders als gestern noch ... ohne dass ich etwas geändert habe ...


    "Konten-Einstellungen" - "Junk-Filter" (eines beliebigen Kontos) - beliebige Einstellung ändern - Klick auf "OK" - klappt nicht > man kann nur "Abbrechen".


    "Konten-Einstellungen" - "Junk-Filter" (eines beliebigen Kontos) - beliebige Einstellung ändern - Klick auf einen beliebigen anderen Ordner, nur eben nicht "Junk-Filter" - Klick auf "OK" klappt ... aber die geänderte Einstellung wurde NICHT gespeichert!


    Damit ist mein aktueller Stand: das Problem gibt es nur beim JUNK-Filter.
    Die Konten-Einstellungen lassen sich (zumindest auf meinem PC) seit dem UpDate auf TB15 nicht mehr ändern.
    Zumindest auf meinem PC.


    In welcher Datei wird diese Information gespeichert?
    Was sollte dort stehen?
    ... mal sehen, ob/was ich dazu finde ...

  • Hallo "Mod. graba".
    Ich habe gerade Deinen Kommentar zu einem jetzt gesperrten Thread gelesen: Edit: Es ist nicht sinnvoll, einen uralten Thread auszugraben, nur um mitzuteilen, dass man ein ähnliches Problem habe und ein Beitrag dazu geschrieben wurde. Mod. graba


    Ich hatte im Forum gesucht, nur einen "uralten Thread" (Update auf: 2.0.0.9 Kontoeinstellungen nicht mehr änderbar) gefunden, meine Frage dort gepostet. Dann später einen eigenen Beitrag erstellt, das ganze umgehängt und auf die Änderung hingewiesen, damit jemand der heute sucht und nur den alten Thread findet weiss, dass es einen aktuelleren Beitrag dazu gibt.
    Wenn Du das nicht sinnvoll findest - ok.
    Mir hilft es, wenn jemand sagt: das gleiche Problem gibt es jetzt auch in der neuen Version. Denn wenn irgendwer eine Lösung gefunden, aber nie gepostet hatte, dann käme man vielleicht etwas schneller ans Ziel. Ist zumindest meine Meinung!


    Schönen Tag noch, VG Lothar

  • Hallo,


    deine Schlussfolgerung

    "bsbecker" schrieb:

    wenn es am KIS2012 liegen würde, dann hätte es das Problem doch schon bei TB12 + 13 + 14 geben müssen. Denn am KIS2012 hat sich nichts geändert. Am TB schon. Und bis TB 14 gab es kein Problem. Logische Schlussfolgerung: es gab nur eine Änderung bei TB, also wird es wohl auch an TB liegen ...

    ist nicht schlüssig.
    Zum einen kann ein "Feature" in KIS enthalten sein, das erst mit der neuen Version von TB Probleme macht. Zum anderen ist der im Zitat fett markierte Bereich hoffentlich nicht wahr, denn ein Schutzsystem, welches nicht ständig, bestenfalls mehrfach täglich aktualisiert wird, taugt nichts. Und ab und an geht da mal was schief, ist mir selber hier passiert=> Fehlalarm durch neue Virendefinition
    Und last, but not least spricht das Forum eine andere Sprache, wir haben hier zig Probleme mit KIS und allesamt sagen zuerst, dass das nicht sein kann.

    "bsbecker" schrieb:

    Man kann KIS2012 sehr wohl "pausieren" lassen oder auch abschalten.

    sorry, ganz klares nein. Es werden Regeln & Steuerdateien etc. eingebunden und die kann man im lfd. Betrieb nicht ersetzen. Es mag sein, dass dann kein Dienst mehr sichtbar ist, aber die Änderungen sind trotzdem da.


    "bsbecker" schrieb:

    Der Blick in Anleitung+Forum ist bei mir immer das erste. Ich kann lesen. Tue es auch. "RTFM" ... erledigt.

    du schiebst mir mehr oder weniger direkt ein RTFM unter? :evil: Das würde ich nie loslassen, meist noch nicht mal Ansatzweise.
    In dem von mir empfohlenen Abschnitt der Anleitung steht übrigens ein Artikel, der den Unterschied von separater/globaler Kontoführung erklärt. Das hat absolut nichts mit deiner Vermutung

    "bsbecker" schrieb:

    dann erledigt sich der Hinweis "... die SMTP-Server separat von den E-Mail-Konten eingerichtet ..." von selber. Es kann keine für alle Konten gültige "Standard-Einstellung" geben (das meinstens Du doch mit "global", oder?).

    zu tun.
    Warum du 12 Postausgangs-Server hast? Es kann, muss aber keine Relation der Anzahl der Eingangs-Server<>Ausgangs-Server geben. Du kannst mit einem Postausgans-S. zig Konten bedienen, so es der Provider akzeptiert, und du kannst evtl für Aliase andere, zusätzliche Postausgans-S. anlegen.
    Beim Löschen eines Kontos wird von TB das Verzeichnis nicht gelöscht und das ist auch gut so, so manch einer hat sich damit "den Hals gerettet".

    "bsbecker" schrieb:

    Gibt es dazu evtl. eine komplette Liste?

    ist das nun eine Art RTFM wenn ich sage, das findest du in der Anleitung unter dem Punkt "Profile erstellen und benutzen - Sicherheitskopien anlegen und wiederherstellen>Die Dateien im Profil kurz erklärt" :gruebel:

  • Hallo,

    "bsbecker" schrieb:

    damit jemand der heute sucht und nur den alten Thread findet weiss, dass es einen aktuelleren Beitrag dazu gibt.


    nur eine kleine Anmerkung, um nicht von einer Problemlösung abzulenken: Wer mit der Suche den alten Thread findet, dürfte zwangsläufig auch den neuen finden, ohne dass der alte Thread mit anderen Ausgangsbedingungen wieder aufgewärmt wird.
    BTW: Unsere Art des Moderierens wird diesbezüglich auch im englischspr. Forum so gepflegt, ist also nicht ungewöhnlich.

  • Zweiter Versuch ...
    Die ganze Nachricht war komplett fertig ... doch plötzlich war ich ausgeloggt ... alles weg ...
    Der Tag fängt damit nicht ganz so gut an. Also alles zurück auf Anfang.


    graba
    Gegen die Art des moderierens ist nichts einzuwenden. Doch ich hatte wie gesagt meine Gründe, im alten Thread zu schreiben.
    Meine persönliche, ganz aktuelle Erfahrung ist, dass man nicht zwangsläufig findet (siehe unten) und ohne Verweis leicht zu früh aufgeben könnte.


    rum
    Vorab: da alles schon geschrieben war, werde ich etwas knapper antworten als im ersten Durchgang.
    Bevor es falsch verstanden wird: keine Unhöflichkeit, nur genervt weil ich doch alles schon mal fertig hatte ...


    1/ KIS wird automatisch aktualisiert. Doch das sind die Virendefinitionsdateien, nicht die Search-Engine. Schutz wird damit laufend aktualisiert = verändert, Programm nur 1x jährlich, beim UpDate.
    Fehlalarme bei KIS sind bekannt (1 Kunde hat das bei JEDEM Update seines Hauptprogramms), die Ursachen aber auch (der Compiler dieses Programms wird von KIS "gemobbt").
    Problemmeldungen zu KIS findet man in jedem Forum. Doch wenn man alles zusammenfasst, ist KIS ein guter Schutz der einfach nur schwer einzustellen ist (was nicht heissen soll, dass ich es kann, doch meine Probleme mit KIS werden kleiner).


    2/ Was wird eingebunden? Was ist zu ersetzen? Was wurde verändert?
    Ich habe da gänzlich andere Erfahrungen. Wenn KIS pausiert, tut es nichts mehr. Wenn man das Programm beendet oder gar den Autostart verhindert, ist da nichts mehr aktiv.
    Und jeder dieser Vorgänge ist nur manuell, vom Anwender, lokal durchführbar, da der Selbstschutz von KIS alles andere verhindert.
    Und ja, ich weiss dass ich bei jedem abschalten Risiken eingehe. Doch manche Programminstallationen erfordern genau das, da sie sonst gar nicht installiert werden könnten ... Also kann man nachweislich DOCH Sicherheitssoftware im laufenden Betrieb "abschalten".
    Solltest Du Dich aber auf konkrete, Dir bekannte Änderungen beziehen, die speziell vom Programm "Kaspersky Internet Security 2012" vorgenommen werden und vielleicht nicht mal durch eine De-Installation zu beseitigen wären, dann wäre ich an dieser Information sehr interessiert.
    Doch im konkreten Fall, dem Problem mit dem JUNK-Filter von TB, spricht dagegen, dass KIS überhaupt nichts meldet. Keine Störung, keinen Verdacht, kein Hinweis. Und sonst meckert KIS einen sofort an, wenn sich da irgendetwas, auch nur annähernd verdächtiges, bewegt.


    3/ SORRY! MISSVERSTÄNDNIS!
    Ich schiebe Dir nichts unter! Ich mache nichts bei anderen, was ich bei selber auch nicht mag.
    Nur ich hatte gelesen, nichts gefunden und wollte nur klarstellen: ich habe gesucht und gelesen, aber nicht das worauf Du Dich beziehst.
    Doch ich hatte in der "Thunderbird-Hilfe" gesucht und Du hattest an die "Anleitungen" = "Dokumentation" gedacht (ich nutze TB wie gesagt erst seit 3 Monaten).
    Jetzt kann ich antworten: alle Konten sind "global" eingerichtet.


    4/ NEIN. Es ist keine Art von "Read The Fucking Manual" sondern "You Do It Right".
    Wenn die gesuchte Antwort irgendwo steht und man bekommt keinen Tip, keinen Hinweis, keinen Link, dann kann es leicht zur endlosen Suche werden.
    Du hast also genau das richtige getan. Danke dafür.


    Doch lesen führt auch zu Nachfragen.
    Bei history.mab steht "Kann gelöscht werden", das ist eindeutig. Doch z.B. bei compatibility.ini steht "Die Datei wird automatisch erzeugt". Das ist nicht eindeutig.
    Heisst das jetzt, man könnte diese Datei löschen, sie würde beim nächsten Start von TB automatisch neu erstellt? Oder wird sie nur bei der Installation erstellt?


    So, das wars für heute. Ich bin müde ...
    Gute Nacht bzw. oder Guten Morgen dann.
    VG Lothar

  • Da ich inzwischen sowohl die Problemursache als auch die Lösung gefunden habe, hier mein zusammenfassender "Abschlussbericht:"


    Problem:
    jegliche Änderungen der JUNK-Filter waren nicht mehr speicherbar. Wenn man änderte, funktionierte der "OK"-Button nicht mehr. Wenn man auf einen anderen Abschnitt wechselte funktionierte der "OK"-Button wieder, doch die Einstellung/Änderung war nicht gespeichert.


    Was war passiert:
    am 31.08.2012 wurde das automatische UpDate auf Version 15.0 installiert. Darum hatte ich die Problemursache erst mal beim UpDate vermutet.
    Doch am gleichen Tag hatte ich zuerst das 13. Mailkonto erfasst (GoogleMail.com) und dann wieder gelöscht, weil eine "separate" Anlage nicht gewünscht war (alle anderen 12 Konten waren vor Monaten "global" angelegt worden) und ich davon ausging, bei der Erfassung die Stelle übersehen zu haben, wo man "globale" Anlage wählen kann. [Anmerkung dazu: die Ersteinrichtung ist immer "separat". Erst über "Konten-Einstellungen" - "Servereinstellungen" - "Erweitert ..." kann man einstellen, ob der Posteingang weiter "separat" oder "global" gespeichert werden soll. Doch das hatte ich vergessen ...] Dieses löschen des separat geführten Mailkontos hat dann sehr wahrscheinlich dazu geführt, dass alle JUNK-Filter-Einstellungen danach "defekt" waren. (Im Thunderbird-Forum finden sich einige Beiträge zu ähnlichen Problemen, wenn man gezielt nach "Einstellungen JUNK-Filter" sucht.)



    Lösungsweg:
    Datensicherung von Programm- und Profilordner
    Thunderbird starten - "Extras" - "Einstellungen" - "Erweitert" - "Konfiguration bearbeiten" - "Ja, ich werde vorsichtig sein" - es öffnet sich ein Fenster, welches den Inhalt der Datei "prefs.js" anzeigt.
    In der leeren Kopfzeile ist einzugeben:
    [ mail.server.server*.spamActionTargetAccount ], wobei das * sicherstellt, dass wirklich alle Konten (Accounts) angezeigt werden.
    [ mail.server.server*.spamActionTargetFolder ], wobei das * sicherstellt, dass wirklich alle Ordner (Folder) angezeigt werden.
    Mit Rechts-Klick auf die Zeilen und Links-Klick auf "zurückzusetzen" ist jeder einzelne Eintrag in den Ursprungszustand zurückzusetzen.
    Sobald alle Einträge zurückgesetzt wurden: Fenster schliessen - Programm beenden - Datensicherung des Profilordners (nur zur Sicherheit und zur Kontrolle, wo was geändert wurde).
    Thunderbird starten - "Extras" - "Konten-Einstellungen" - JUNK-Filter für alle Konten einstellen auf "Junk in Lokale Ordner".



    Anmerkung:
    Der Fehler, der keinen Zusammenhang zu irgendeiner Programmversion oder einem UpDate erkennen lässt, tritt wohl seit Version 2,x immer wieder auf. Egal welches Betriebssystem, welche Hardware, welcher Virenscanner eingesetzt wird. Hier nach der Fehlerursache zu suchen ist Zeitverschwendung (es ist eben nicht immer der böse Virenscanner, der die Probleme macht).
    Ebenso unnötig ist es (zumindest bei diesem Fehler), ein neues Profil anzulegen oder das komplette Programm oder gar das Betriebssystem (wegen Viren-Verdacht) neu zu installieren.


    Das hier war und ist ganz einfach ein Bug von Thunderbird, der bis heute nicht beseitigt wurde.