Anzeige von Grafikdateien

Am 24.09.2018, werden in der Zeit zwischen 21:00 Uhr und 09:00 Uhr des folgenden Tages Wartungsarbeiten am Server durchgeführt. Daher wird die Webseite in dieser Zeit nur eingeschränkt erreichbar sein.
  • Thunderbird-Version: 16.0.1
    Betriebssystem + Version: WIN 7 / WIN XP
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): Intern


    Hallo miteinander,
    das Thema Grafiken wurde zwar schon des öfteren hier im Forum behandelt, doch war für meine Problematik leider nicht die richtige Hilfe dabei, oder ich habe sie nicht gefunden.


    Folgender Zustand: Ich möchte bei uns in der Firma auf Thunderbird umsteigen und habe das Prog auf 4 Rechner installiert. Wir verwenden bis jetzt OE und Outlook.
    Für die User wurden HTML-Dateien erstellt, die das Firmenlogo und Absenderdaten enthalten. Diese HTML-Dateien kann ich auch mit TB öffnen oder als Vorlage verwenden.
    Doch das große Logo wird nicht angezeigt. Nur ein Platzhalter.
    Ich habe schon alle möglichen Addons installiert, sämtliche Einstellungen getestet und auch die permmission... und mailnews.... -Werte geändert.
    Das paradoxe an der Sache ist, wenn ich aus TB Mails verschicke (bis auf einen Rechner), kommen diese richtig an, wenn sie mit OE oder Outlook oder Incredmail empfangen werden, doch nicht wenn sie mit TB empfangen werden.
    Ich stehe momentan total "auf dem Schlauch".
    Vielleicht weiss jemand weiter, denn so kann ich das Prog. nicht in der Firma installieren.
    Anbei würde ich 2 Bilder hier einstellen, wenn ich wüsste, wie´s geht :redface: , eines wie es eigentlich aussehen soll und eines wie es in TB aussieht. (liegen bei mir auf dem Rechner)


    Danke einstweilen und viele Grüße aus Regensburg


    Detlev

  • Hallo und willkommen im Forum!


    Zitat

    Doch das große Logo wird nicht angezeigt. Nur ein Platzhalter.


    Wo wurde die ursprünglich Signatur erzeugt, in einem externen Programm oder in Thunderbird selbst?


    Die sicherste Methode, ist es, die Signatur in einem Verfassenfenster zu erstellen und sie dann unter Datei > Speichern als > Datei > *.html abzuspeichern. Dann in den Konteneinstellungen > Signaturtext, dort HTML anhaken und den Pfad zur Datei suchen.


    Hintergrund: es gibt keinen Standard für HTML in Mails, so dass TB Probleme den Code aus externen Programmen wie Word, Outlook u.a. zu verstehen. Manchmal kann die Signatur noch in TB selbst dargestellt werden, aber niczht mehr beim Empfänger. Dasselbe kann auch passieren, wenn TB solche HTML-Mails von Empfängern erhält, die nicht Thunderbird benutzen.
    Konsequenz:
    entweder den oben beschriebenen Weg gehen oder auf Thunderbird verzichten.
    Übrigens kommen bei vielen Empfängern, die nur Reintext verwenden, diese Mails verkrüppelt an, denn aus Sicherheitsgründen ist HTML in Mails oft abgeschaltet (z.B. bei mir) und die (verantwortungsbewussten) Netzwerkadministratoren von Firmen verhindern deren Empfang und wandeln die Mails in Reintext um.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo und guten Morgen mrb,


    danke für die Antwort; hier einige Erklärungen.


    Die HTML-Datei habe ich erstellt in Word 2007 - Outlook - Microsoft Expression Web 4 und Incredimail. Also 4 verschiedene Programme.
    Nach Deiner Vorgehensweise habe ich auch schon eine Signatur- oder Vorlagendatei erstellt.
    Aber das Grundproblem ist, selbst im Verfassenfenster wird die Grafik/das Logo schon mit Platzhalter angezeigt. Das heißt, selbst auf dem eigenen Rechner ist die Grafik nicht sichtbar.
    Ich habe es mit jpg und png getestet. Braucht man vielleicht ein ganz anderes Grafikformat ?
    Das mit Reintext funktioniert bei uns nicht, wir brauchen schon fast zwingend HTML.
    Stört aber nicht, da ich 1 Firewallrechner und einen Mail-Server installiert habe, die jeweils mit den entsprechenden Programmen zum Schutz laufen.
    Wir bekommen am Tag auch über 200 Mails (insgesamt über 1000) von Kommunen und Baufirmen, die alle ihr Logo/Wappen als Briefkopf eingebunden haben.
    Und diese ganzen Bilder sehen wir auch.
    Nur unsere eigenen nicht :cry: Als Beispiel 2 Bilder



    Das mit der Signatur ist generell kein schönes Erscheinungsbild, da die Grafik hier ja am Ende der Mail angezeigt wird. Und sie sollte eigentlich ja die Kopfzeile bilden.
    Aber abgesehen davon, wird die Grafik auch bei der Signatur nicht angezeigt, nicht mal im Verfassenfenster.
    Vielleicht gibt es doch noch einen Weg / Trick ?? Würde mich freuen.


    Viele Grüße aus Regensburg
    Detlev

  • Hallo,
    poste mir mal wie du genau vorgegangen bist, als du im Verfassenfenster die Signatur eingefügt hast.

    Zitat

    Aber das Grundproblem ist, selbst im Verfassenfenster wird die Grafik/das Logo schon mit Platzhalter angezeigt. Das heißt, selbst auf dem eigenen Rechner ist die Grafik nicht sichtbar.


    Das darf nicht sein.
    Ist das bei anderen Grafiken auch so?
    Der Dateityp ist egal.
    Enthält der Dateiname Umlaute oder andere Zeichen?


    Zitat

    Das mit der Signatur ist generell kein schönes Erscheinungsbild, da die Grafik hier ja am Ende der Mail angezeigt wird. Und sie sollte eigentlich ja die Kopfzeile bilden.


    Warum legst du nicht eine Vorlage an und benutzt diese immer wieder.


    Könntest du mir mal Folgendes per Mail zuschicken (wenn es dir Recht ist):


    - eine Vorlage (oder als empfangene Mail) der Mail (am Besten als *.eml)
    - die *.html Datei der Signatur
    - die Grafikdatei


    Ich poste dir per PN eine Mailadresse
    Bin aber erst spät am Abend wieder zu Hause.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    ich bin dabei deine Mail an mich zu überprüfen.


    Eins ist aber klar, die *.html Datei als Signatur kann nur dann mit dem Bild nur angezeigt werden, wenn sich das Bild auf dem gleichen Computer im angegebenen Pfad befindet. Es wird nämlich nicht in der Datei gespeichert, das ist auch z.B. in Windows Live Mail der Fall.


    Die Mail von dir ist bei mir korrekt angekommen auch mit Bild.


    Ich habe dann deine Mail hier "nachgebaut", heißt, die Signatur einkopiert und das Bild (png) oben eingefügt. Dabei ist im Hauptfenster bei mir unter Ansicht, "Anhänge eingebunden anzeigen" angehakt. Das ist wohl zwingend notwendig und wird der Grund sein, warum es bei dir nicht klappt.
    Dann speichere ich die Mail als Entwurf oder Vorlage ab.
    Jetzt öffne ich den Quelltext (Strg+U) des Entwurfes und siehe da, man erkennt sofort: der Anhang befindet sich in Form langer Reihen kodierten Textes darin. Rufe ich den Entwurf wieder auf, wird das Logo dargestellt.
    Ich werde dir diese Mail zusenden.
    Darum fragte ich auch wie genau du dabei beim Einfügen vorgegangen bist.
    Könntest du mir das hier erklären?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,
    ich habe auch schon alles als Entwurf/Datei und Vorlage abgespeichert.
    Beim Erstellen sehe ich die eingebundene Grafik, beim Wiederaufruf nur noch den Platzhalter.
    Die Grafikdatei befindet sich im selben Verzeichnis, wie die abgespeicherte Datei.
    Und "Anhänge eingebunden anzeigen" ist auch aktiviert.
    Öffne ich einer dieser Dateien im Quelltext, steht ja jede Menge drin, unter anderem
    <img alt="" src="file:///D:/mailkopf.jpg".
    Das ist der Ort, wo alles steht.
    Diese Zeile steht sowohl beim 1.Erstellen so drin, wenn man die Grafki noch sieht, als auch beim 2.Aufruf -nach dem Abspeichern-, wenn mann die Grafik nicht mehr sieht, sondern nur noch einen Platzhalter.


    Momentan bin ich weiterhin ratlos


    Grüße aus Regensburg


    Detlev

  • Zitat

    Öffne ich einer dieser Dateien im Quelltext,


    Welche
    Datei meinst du genau, die *.html Datei?


    Ich habe mal 2 *.html Dateien verglichen, die eine von dir gesendete und die, die ich für die Signatur in Thunderbird erzeugt hatte.
    Die von mir erzeugte Datei enthält weder

    Code
    1. <img alt="" src="file:///D:/mailkopf.jpg"


    noch

    Code
    1. <img alt="" src="file:///C:/Users/User/Desktop/mailkopf.jpg"


    sondern die schon kodierte:

    Code
    1. src="cid:21F8C777C04D48FBB021EF96785FCDFF@UserPC"


    Die ursprüngliche *.png Datei ist also gar nicht mehr zu erkennen und ist trotzdem da.


    Und im Quelltext, der an dich gesendeten Mail steht noch etwas anderes:

    Code
    1. <img alt="" src="cid:part1.00010502.05090807@arcor.de"
    2. width="605" height="130">


    Und wenn bei dir dieser Code fehlt, wird das Logo nicht angezeigt.
    Ursache: offensichtlich kann TB keine externen *.html Datei korrekt verwerten.
    Warum aber bei mir deine Mail korrekt angekommen ist, kann ich nicht sagen.
    Aber da es keinen Standard für HTML in Mails gibt (anders als bei Websites und Browsern) wundert mich das Verhalten auch nicht besonders.
    Wie schaut es denn aus, wenn du meine Mail als Vorlage benutzt?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    wenn ich Deine Mail als Vorlage nehme, kommt folgendes Ergebnis raus.
    1. Dieser codierte Text der Grafik ist gar nicht mehr da, sondern es steht folgendes da:



    und in der Vorschau sieht es dann folgendermaßen aus:




    Ich habe an der Datei rein gar nichts verändert, sondern nur abgespeichert.


    Mmmmhhh,...... :aerger:
    Gracie und Grüße einstweilen


    Detlev



    EDIT: ich habe den dir vermutlich aus der PN bekannten echten Namen unseres Forenhelfers mrb oben gelöscht..
    rum,
    Moderator

  • Tut mir Leid, säße ich an deinem Computer, würde ich normalerweise schnell das Problem lösen.
    Eine "Ferntherapie" ist in diesem Fall nicht möglich.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke rum ,
    das war denn auch das letzte Mal , dass ich bei einem leider unvermeidlichen Mailkontakt meinen Vornamen genannt habe und auch nur, weil der User seinen nicht verschleiert hatte.
    Man überschätzt leider immer wieder das Misstrauen und die Vorsicht von Usern bei Gebrauch der Internets.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw