Netzwerkkalender, WebDAV und fehlende Updates/neue Termine

  • Hallo Leute,


    ich habe ebenfalls ein Problem mit Lightning:
    Lange Zeit lief alles problemlos, dann irgendann konnte ich die Kalender nicht mehr updaten: Einen Termin eintragen ist kein Problem, aber der Kalender wird nicht auf den Server geladen. Das Server-Log zeigt mir den Download-Zugriff des WebDav-Kalenders, aber keinen Upload. Neustarten des lighttpd bringt nichts.
    Thunderbird kann den Kalender dann auch nicht mehr synchronisieren. Nach einem Neustart ist der alte Kalender wieder aktiv, als hätte ich keinen neuen Termin eingetragen. Den Kalender exportieren geht ebenfalls nicht, es erscheint einfach kein 'Speichern unter'-Fenster.
    Die Konsole sagt:

    Code
    1. Timestamp: 18.12.2012 10:20:46
    2. Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.requestSucceeded]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: file:///<path to>/Thunderbird/Profiles/o7s2hmwg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js :: <TOP_LEVEL> :: line 423" data: no]
    3. Source File: file:///<path to>/Thunderbird/Profiles/o7s2hmwg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js
    4. Line: 423


    Das Problem zieht sich schon eine ganze Weile hin, bestand insbesondere auch schon bei alten Versionen.
    Teilweise bringt es was, wenn ich von Hand die Kalender editiere und Termine lösche, aber ich habe noch keine Regelmässigkeit gefunden.
    Löschen des lokalen Kalender-Caches bringt ebenfalls nichts. Irgendwie scheint der Kalender so kaputt zu sein, dass Lightning ihn nicht mehr lesen kann. Dabei wird er immer nur von Lightning selbst geschrieben. Andere Rechner fummeln da nicht rein.


    Kann mir jemand weiterhelfen? Gibts noch irgendetwas, das ich ausprobieren kann?
    Viele Grüße,
    Daniel


    Thunderbird-Version: 18
    Lightning-Version: 2.0b1

  • Zitat von "danielkr"

    Thunderbird-Version: 18
    Lightning-Version: 2.0b1


    Hallo danielkr,
    benutze die offizielle Version Thunderbird 17 und Lightning 1.9 oder schreibe ein BUG.
    Es ist natürlich möglich das die Beta Version einen Fehler hat und Dir die Kalender zerschossen hat.
    Aber das ist das Riskio wenn man nicht mit offiziellen Versionen arbeitet.
    Installiere Thunderbird 17 in einem neuen Programm-Ordner und benutze ein neues Profil.

  • Da gab es genau das gleiche Problem... schon seit Version 12? 13? eine längere Zeit jedenfalls...

  • Hallo Daniel,


    und willkommen im Forum!


    Zwei Bemerkungen dazu:
    1.)
    Ich lese: Thunderbird-Version: 18, Lightning-Version: 2.0b1
    Aktuell ist die Version 17.0.1
    Wer mit Vor- und Beta-Versionen experimentiert, sollte auch mit Fehlfunktionen und Problemen leben können. Auszuschließen sind diese keinesfalls.


    2.)
    Ich habe in meinem langjährigen Umgang mit Lightning und extern gehosteten Kalendern (nicht immer aber immer) öffters Probleme gehabt. Egal, ob ich die Kalender auf diveren ftp-Servern ("richtigen" und dem meiner Fritz-Box) oder in diversen Cloudanwendungen hatte. Ich habe wirklich viel experimentiert!
    Letztendlich habe ich mich zu einem sehr stabilen (!) "Mischbetrieb" entschlossen.
    Ich verwende als vertrauenswürdigen (!) Cloudanbieter Teamdrive. Bei der Installation des TD-Clients wird ein lokaler Ordner angelegt, dessen Inhalt sauber und im Hintergrund mit dem TD-Server synchronisiert wird. Und diese lokal vorliegenden (!) Kalender binde ich in Lightning ein. DAS ist für mich die sicherste und stabilste Variante.
    Und ein weiterer Vorteil: Sie funktioniert auch offline!


    HTH


    MfG Peter (zu spät, aber trotzdem ...)

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!