Im Offlinemodus aber IMAP Postfach merkt es nicht!

  • Hallo,
    ich habe ein IMAP Postfach, was aber nicht mehr existiert. Aber ich habe ja noch alle Mails. Jetzt will ich, die für mich wichtigen Mails in bestimmte lokale Ordner kopieren und kann es selbst im Offlinemodus nicht. Immer kommt der Fehler, dass ich das Postfach nicht mehr abrufen kann, und tut dann nichts. Ich bin aber doch offline, war rum zum Teufel fragt der nach statt die Mail zu kopieren, die ist doch komplett da?
    Viele Grüße


    Thunderbird-Version: 17
    Betriebssystem + Version: Debian 6
    Kontenart (POP / IMAP): IMAP / Lokal

  • Hallo,


    kopiere doch einfach die mboxen unterhalb .../ImapMail/ in das Verzeichnis für die lokalen E-Mails, also .../Mail/Local Folders. Den TB musst Du zuvor beenden und ggf. Dateien bei Namensgleichheit mit dort bereits bestehenden Dateien umbennen. Beim nächsten Start des TB sollten die Ordner/E-Mails dann unter "Local Folders" auftauchen.


    Gruß


    Susanne

  • Danke Dir für den Tip Susanne!


    Es hat allerdings nicht geklappt. Der Ordner erscheint, aber es sind keine Mails drin. Habe es schon mit und ohne msf Datei probiert. Wenn ich mir die Datei so ansehe, sehe ich die Mails aber.


    Viele Grüße

  • Hi nudgegoonies,


    welchen X-Mozilla-Status haben denn die zwar im Quelltext zu sehenden aber im TB nicht angezeigten Mails?
    Die Indexdatei solltest du aber nicht mit übernehmen. Sie wird beim ersten Start des TB automatisch neu angelegt.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,
    danke für den Versuch. Ich habe mir jetzt die Header anzeigen lassen und auch die Inbox Datei so angeschaut, aber von einem X-Mozilla keine Spur. Dafür lauter X-MS-Exchange Zeilen und x-spam-status und andere.


    Eine Frage wäre noch, ob das nicht ein Bug ist, dass bei einem IMAP Postfach der Offlinemodus ignoriert wird und man eine Mail, die komplett da ist, nicht verschieben kann.
    Viele Grüße

  • Hallo nudgegoonies,


    "nudgegoonies" schrieb:

    ... von einem X-Mozilla keine Spur.


    Bist Du sicher? Hast Du einmal die Suchfunktion des Editors benutzt? Ich habe mir gerade die E-Mails eines IMAP-Kontos offline verfügbar gemacht und mir die mbox per Editor angeschaut. Alle E-Mails haben einen X-Mozilla-Status, wie es sich gehört.


    "nudgegoonies" schrieb:

    Aber ich habe ja noch alle Mails.


    Wo genau befinden sich denn diese E-Mails bei Dir?


    Gruß


    Susanne

  • Hallo Susanne,
    vielen Dank für Dein Weiterforschen. Im Profilordner ist ja der Unterordner ImapMail, worin dann die Unterordner der ganzen IMAP Konten sind. Da habe ich dann die Dateien INBOX, sent-1, trash etc. Die INBOX und die sent-1 hatte ich mit einem Textbetrachter durchsucht und es ist definitiv kein "X-Mozilla" drin (auch nicht "x-mozilla" etc.).


    Google Mail läuft bei mir auch via IMAP und in dem Unterordner sieht es genauso aus und die INBOX Datei enthält auch kein "X-Mozilla".


    In den Eigenschaften des Posteingangs, also der Inbox, ist übrigens unter Synchronisation bei "Diesen Ordner zum Offline-Lesen auswählen" der Haken gesetzt. Von daher müsste alles synchronisiert sein.


    Viele Grüße,
    Andreas

  • Hallo Andreas,


    "nudgegoonies" schrieb:

    Google Mail läuft bei mir auch via IMAP und in dem Unterordner sieht es genauso aus und die INBOX Datei enthält auch kein "X-Mozilla".


    Das ist schon richtig so. Diese E-Mails liegen ja auch noch auf dem Server. Sobald Du sie aber lokal in eine mbox kopierts oder verschiebst, sollten sie einen entsprechenden Status bekommen. Das kannst Du gern mal mit einer beliebigen E-Mail aus dem IMAP-Posteingang versuchen, in dem Du sie in einen lokalen Ordner verschiebst und Dir danach den Quellcode anschaust.


    Warum die lokalen E-Mails in Deinem Fall keinen solchen Status haben, entzieht sich meiner Kenntnis. Ich habe im Moment auch keine weitere Idee, außer vielleicht, es einmla mit der Erweiterung ImportExportTools zu versuchen.


    Gruß


    Susanne

  • Hallo Susanne,
    danke Dir sehr für's Weiterversuchen. Das Verschieben und Kopieren klappt beim Google Mail Konto. Aber nicht bei dem Konto, was es nicht mehr gibt.


    Der Export mit dem Plugin hat schon mal geklappt. In dem Export ist aber auch kein "X-Mozilla" zu finden. An den Import traue ich mich aber erst nach einem Backup vom Profil, was ich am Wochenende mal machen werde.


    Vielleicht sollte ich mal erwähnen, wie lange dieses Profil schon auf dem Buckel hat. Ich erinnere mich noch dunkel an Netscape 3.5 Gold unter Slackware 3.5 und es hat nach dem Ende von Netscape erst Mozilla und dann Thunderbird (hier unter Debian heißt er Icedove) gesehen. Aber das ImapKonto ist vom letzten Jahr, von daher glaube ich nicht, dass es was damit zu tun hat.


    Viele Grüße und ein schönes Wochenende,
    Andreas