Von-Feld enthält nicht existierende E-Mail Adressen [erl.]

  • Thunderbird-Version: 17.0.2
    Betriebssystem + Version: Win7 Pro 64bit
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): Diverse


    Infos:
    2 separate Posteingänge für 2 verschiedene Personen (meine Frau und von mir)
    1 Posteingang mit 1 E-Mail Adresse verknüpft (Frau), 1x eigener Mailserver, alles ok
    1 Posteingang (der globale) mit 3 E-Mail Adressen verknüpft (meine), 1x GMX, 1x eigener Mailserver, 1x Exchange-POP3 (und hier eine gelöschte E-Mail Adresse, die rumzickt)



    Hallo Ihr Lieben!


    Erst einmal vielen Dank für Thunderbird und dieses hilfreiche Forum!


    Zu meinem Problem: ich nutze Thunderbird schon seit vielen Jahren seit der Version 3. Seit Anfang an nutze ich eine E-Mail Adresse (z.B. max@mustermann.de) als führende Adresse und 3-4 weitere Adressen (GMX, Web.de, eigener Mailserver, etc) als eigenständige POP3-Konten. Alles bestens bisher. Nun habe ich mich von der uralten E-Mail Adresse max@mustermann.de getrennt und nutze eine andere Adresse als führende Adresse (z.B. max@googlemail.com) und leite serverseitig die Mails der alten auf die neue Adresse weiter. Soweit auch gut.


    In Thunderbird habe ich die neue Adresse eingerichtet und alles läuft. Die alte Adresse habe ich komplett gelöscht (ist ja nur noch eine Weiterleitung) und auch SMTP entsprechend umgestellt und den alten Eintrag entfernt. Ich sehe nirgendwo in den Einstellungen mehr die alte E-Mail Adresse, wie ich es auch gewünscht habe.


    Wenn ich nun neue Nachrichten schreibe, schlägt er mir dennoch unter "Von" die alte Adresse als ersten und aktiven Eintrag vor, obwohl ich sie nirgendwo mehr gespeichert sehe. Dies passiert immer, sowohl bei neuen leeren Nachrichten als auch bei "Antworten" auf bestehende Mails etc.


    Die neue E-Mail Adresse steht in der Von-Liste immer unten, obwohl diese als Standard definiert ist und eigentlich oben stehen sollte. :cry:


    1. Wie bekomme ich die alte Adresse aus der "Von"-Liste?
    2. Wie stelle ich die neue E-Mail Adresse als führend ein, dass nur noch diese immer genommen werden soll, sei denn ich stelle das MANUELL im Von-Feld um?


    Wäre sehr schön, wenn Ihr hier einen oder mehrere Tipps für mich hättet. Wenn ich Infos unterschlagen habe, bitte hauen, ich liefere diese dann asap nach.


    Danke vorab und einen schönen Tag!

  • Hallo Russkowski,


    und willkommen im Forum!


    wie ich sehe, hast du bereits alles getan, was ich dir jetzt auch vorgeschlagen hätte.
    Vielleicht noch einmal in den "Weiteren Identitäten" suchen, denn das hast du nicht erwähnt. Die dort stehenden Absender werden ja in der Sende-Auswahl ebenfalls angezeigt.


    Auch wenn ich persönlich nicht weiß warum und wieso:
    Wir hatten in den letzten Wochen einen ähnlichen Fall. Dieser wurde gelöst, weil einer der Helfer vorgeschlagen hat, bei beendetem Thunderbird(!) den Ordner /Cache im TB-Userprofil zu löschen.


    Du kannst diesen Ordner auch per Einstellungen > Erweitert > Netzwerk & ... leeren. (Weiß aber nicht, ob das reicht!)
    Du kannst ihn auch einfach umbenennen (=> Cache_old). Es wird beim nächsten Start sofort wieder ein entsprechender Ordner angelegt.
    Ich selbst verzichte seit einigen Wochen generell auf den Cache und habe ihn vollständig deaktiviert. Nachteile habe ich bis jetzt nicht bemerkt. Du kannst das also ohne "Angst" wie vorgeschlagen tun.


    Würde mich über ein Feedback freuen.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter


    Danke für die Vorschläge! Die weiteren Identitäten hatte ich auch schon alle gecheckt, aber auch da nichts gefunden.


    Einen Cache-Ordner habe ich in meinem Profilordner gar nicht gefunden?! Es gibt nur eine Cache-Datei cache.sqlite - da geh ich nicht dran :rolleyes:


    Ich habe mir mal alles in eine virtuelle Umgebung geklont und rumexperimentiert, ohne was kaputt machen zu können :eek:


    In der Datei prefs.js habe ich dann die alte E-Mail Adresse unter einem der Konten in der Zeile


    user_pref("mail.identity.id4.useremail", "max@mustermann.de");


    gefunden. Die anderen Einträge zur id4 waren alle von der neuen E-Mail Adresse, seltsam. Also habe ich TB geschlossen, die prefs.js mit Notepad++ geöffnet, den Eintrag in der Zeile auf die neue führende E-Mail Adresse umgestellt, gespeichert und TB neu gestartet. Und siehe da - die Von-Adresse ist nun richtig, nur habe ich aber die neue E-Mail Adresse 2x drin stehen im Von-Feld, einmal oben als führende Adresse :D und ganz unten nochmal :gruebel:


    Also nochmal die prefs.js geprüft und erstaunlicherweise 2 ids gefunden, die nun komplett identisch sind (id 4 und 5). Nur traue ich mich jetzt nicht, die ID 5 einfach zu löschen. Kann ich irgendwo sehen, wo die ID noch mit verknüpft ist?


    Achso: BITTE NICHT EINFACH NACHMACHEN, ICH HABE DAS IN EINER TESTUMGEBUNG MIT DUPLIZIERTEN DATEN GETAN. Sonst könnte es wohl passieren, dass Ihr Euren TB abschießt. Oder, Peter?


    Viele Grüsse! Guido

  • Hi Guido,


    die prefs.js ist eine Datei, von welcher ich bis jetzt die Finger gelassen habe. Wirklich keine Ahnung ... .
    Aber es kann ja gar nichts passieren. Du machst eine Kopie deines kompletten TB-Userprofils (was ein sicherheitsbewusster User ja eh regelmäßig macht ...) und testest einfach. Falls es schief gehen sollte, löschst du das Profil und benutzt die Kopie weiter.


    Oder du wartest ein wenig.
    Ich weiß, dass es Helfer gibt, die sich da bestens auskennen ;-)


    BTW: Trotzdem würde mich das Ergebnis des Tests mit dem gelöschten Cache interessieren.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo,


    den Vorschlag mit der prefs.js wollte ich dir vorhin machen, musste aber weg...(ich weiß, das kann ja jeder sagen :rolleyes:


    Wenn du z.B. ein Konto einrichtest und später löschst, dann bleiben in der prefs.js und im Kontenordner ..\mail\.. bzw. ...\imapmail\... Einträge und das kann dann solche Fehler geben.
    Du kannst zu jedem Konto in Extras>Konten-Einstellungen>%Accountname%>Server-Einstellungen unter Lokaler Ordner nach sehen, welcher Ordner im Profil zugeordnet ist und darüber dann in der prefs.js raus finden, welcher Eintrag dazu gehört.
    Alte Einträge kannst du dann löschen.
    Dass man das mit den von dir genannten Bedingungen und/oder einer weiteren Kopie des gesamten Profilordners macht, setze ich voraus.

  • Hallo Peter


    Einen Cache-Ordner habe ich in meinem TB-Profilorder nicht gefunden, nur die Datei cache.sqlite.


    Unter Einstellungen > Erweitert > Netzwerk & Speicherplatz > Cache passiert NIX beim Klick auf Jetzt leeren. Ich glaube eher, dass hier der Cache schon deaktiviert sein könnte (oder defekt ist hahaha). Wo kann ich den Cache ein- und ausschalten?


    Und ja, das Profil sichere ich komplett regelmäßig per Synchredible auf meinen Homeserver - sicher ist sicher! Aber ich finde es toll, dass Du nochmal daran erinnerst.


    Viele Grüsse, Guido

  • Hallo rum!


    Danke für die Infos! Es freut mich, dass ich fast auf dem richtigen Weg war. Ich habe die Einträge soeben verglichen und id 4 war das alte gelöschte Postfach und 5 das neue - ich habs nun durch löschen von id4 hinbekommen, alles ist toll, es wird nur noch 1x die Von-Adresse angezeigt und alles läuft noch.


    Was für ein Forum! Danke für Eure Hilfe und viele Grüsse!


    Guido

  • Hi Guido,


    auch wenn du dein Problem schon lösen konntest:
    Im TB-Userprofil, also unter dem Profilordner mit den 8 Zufallszeichen.default gibt es (normalerweise) den Ordner /Cache. Darin sind wieder viele Untgerordner.
    Die Größe dieses Caches kannst du mit der dir jetzt bekannten Einstellung vorgeben.
    Ein vollständiges Deaktivieren kannst du unter Einstellungen > Erweitert > Allgemein > Konfiguration bearbeiten. Du suchst nach dem Eintrag "browser.cache.disk.enable" und setzt ihn auf "false".


    Und noch einmal: Ich spiele damit ggw. herum. Habe bis jetzt durch das Deaktivieren keinerlei Vorteile aber auch noch keinerlei Nachteile festgestellt. Ich weiß auch nicht was passiert, sollte ich eine Vorliebe für Klickibunti-Mails mit fetten Mailanhängen entdecken. (Bei mir gibt es nämlich nur Reintext-Mails und Anhänge mit max. 2-3 MB Größe. Alles andere hat bei mir über ftp zu laufen.)


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!