Signatur HTML Bilder Problem [erl.]

  • Hallo,


    habe eine portable Version in Benutzung und meine Signaturen basieren auf HTML und beinhalten Bilder. Da mein USB Stick hier und da mal einen anderen Laufwerkbuchstaben bekommt habe ich ein Problem mit den eingefügten Bildern.


    Thunderbird selber legt den Pfad wie folgt an: src="file:///D:/***.gif"
    Hat der Stick aber nun nicht D, kann das Bild nicht gefunden werden. Mit src="file:./***.gif" kann Tunderbird nichts anfangen, auch wenn meine Browser hier das Bild aus dem Stammverzeichnis finden. Auch mit src="./***.gif" funktioniert es bei Browsern, doch wieder mit Thunderbird nicht.


    Wieso ist das so und wie kann man das fixen?


    Viele Grüße


    aesis

  • Hallo,

    Zitat

    Da mein USB Stick hier und da mal einen anderen Laufwerkbuchstaben bekommt habe ich ein Problem mit den eingefügten Bildern.


    Das sollte nicht sein, da portable Versionen nicht mit absoluten sondern mit relativen Laufwerken arbeiten, die Laufwerksbezeichnung also keine Rolle spielen sollte.
    Will das ab er gerne noch mal testen.
    Wie hast du denn die Signatur erstellt, in einem TB-Verfassenfenster und dann als *.html gespeichert oder mit einem externen Programm?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Jup habs in Thunderbird gemacht und als HTML gespeichert. War die schnellste Möglichkeit ;).

  • OK, die Grafik-Dateien für die Signatur hattest du wo abgelegt auf dem Stick?


    Und die *.html Datei ebenfalls?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ist beides im gleichen Ordner. In Profile habe ich dafür einen Ordner Signaturen erstellt wo die Daten liegen.

  • Ich habe das gerade getestet:
    TB schreibt und erkennt nicht immer relative Pfade. In sehr alten Versionen ging das problemlos und irgendwann nicht mehr.
    Vermutlicher Grund: da Mozilla die portables selbst nicht entwickelt, sondern dies ein paar andere Firmen/Leute tun, von denen hat wohl einer mal einen Programmierfehler gemacht. Die Desktopversion braucht ja in Signaturfragen keine relativen Pfade, weil dort ja immer feste, absolute Pfade vorliegen.
    Den einzigen Tipp, den ich dir geben kann, je nach Laufwerksbuchstaben die HTML-Datei anzupassen.
    Beispiel:
    öffne die *.html Datei mit einem Texteditor(!) etwa WordPad - also kein Doppelklick darauf oder mit dem Browser öffnen.
    Dann änderst du diese Zeile:

    Code
    1. <img alt="" src="file:///S:/Passfoto.jpg" height="692"
    2. width="531">


    und passe den Laufwerksbuchstaben den Gegebenheiten an - hier S nach beispielsweise Z.
    Danach klappt es auch wieder der mit der Grafikanzeige.
    Die Änderung ist in wenigen Sekunden zu bewerkstelligen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    3 Mal editiert, zuletzt von mrb ()

  • Ist für mich nix neues. War ja schon ständig am abändern des Pfades, bis ich jetzt die Faxen dicke hatte und beschlossen hab hier nach zu haken. War mir schon zu 80% sicher, dass es ein Bug ist.

  • Ich hatte früher, als ich noch HTML-Mails versendet habe, die Grafik umgewandelt ins Base64-Format (z. B. mit http://webcodertools.com/imagetobase64converter oder aus dem Mail-Quelltext holen) und nur noch den data:image/png;base64-Code eingetragen, vielleicht kommst Du damit ja weiter. :)
    Kleines Beispiel ;)

    Code
    1. src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAADP0lEQVQ4jXWTe1ALABzHf67y1pydFvKotVZe5UqxusrNuIXVUcLV6jwTSTprNaaHGkvtGiZclO4QR8zarZrJY7XrdHK5ecRxODvvSvKaff3hvMLn7+/n+8/v9yXqByfzvICbqTMH59WnzS29Eu2XVRdOcbkD++f+ydiEat5UufFj1F4zQpVXMC3X6ODKGh0caX0fZ2vdBV+pLvC/smd6bcF0udEuM95FlrYd8YeuYqHmGkSHWzFH3YKZisvwkxvt7Eyd+i85uLAxw397w9ctp9pQUKuFaN9lTEg5Bo5YjbBCI5ZUdqDQcA8RpWbMKGjC+M3a4p+yUK13nZFv+jB7tQqLsk/iCM8XkyVnQGEKEFcCGrcSHuJqeKefQ3iREdlnrZgiv2h3W3uS/b1AYykO2XYebL4MoUl7IJAfQ4BAjNR0GeSKCsQs3ohxgWsQKNVBcvoWpmdoEapsBleiNxARUUjRpU7eOg28Qtaj4vgFLI+LhUpZiPudt/GdXizfooZ7tAqTkqoRKDdhh+4ufKX1vURE5JvT0OcpyENGzl6kpazB4f2lAD4Djk+A4zPsXz6grqEJQ/m7sKnqOsJyDVhS3gKfnPqvRETkI9G/G+qTgkaTBR3trag6qMLjB1bc7miD/lwNNCUFSE1eiiF8JSIVlxCQdgJRJSZwZY0OIiJyj8w/wOCmoP3GDdg/dqHT2obivCwocyU4VKZAs0kHi8UCprAEQVtr4Z1YhXk79Zi07OhDIiJycp0ldBq/CrXai3jfbcP7Lht6u2zo63mOvm4bel48xKsnVpgNZzEgTIEJC8rAjtaAJdin/XFJp4FuSZ0sTiLKy3bDoK1xvH35GL1dNvS8eYrXz+7h1aPrOFVZg5HsVLBCtsNjfilGBRXF/vokRmQQuSfaI3j818nxou4NybGOfGk6KstVjuYmPaw3W5Ag3gX3mdkYM3kdmNOkFqK4P/fh7DxyjouLTzURxTCGD48LDw7YGS8StK5NiOlJW7kUE3k5YPmlYgRTeGcwY4XXv+bgRESjiYhNRP5ExCci0Qg3/5LRnglfmBPFYIwVNhAR87+D+o0BRDTMedAoAcMjosKVFWV2cfVOJKJB/YPfAE2avIyIhDY1AAAAAElFTkSuQmCC">
  • Zitat

    War mir schon zu 80% sicher, dass es ein Bug ist.


    Das sehe ich auch so.



    @ FUX


    Den Trick kannte ich noch nicht, Danke!


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw