Lag beim scrollen

  • Hallo,


    seit einer der aktuellen Updates habe ich eine nervende Verzögerung beim Scrollen mit dem Mausrad in TB. Ist das ein bekanntes Problem, gibts eine Lösung?


    Die Einstellungen "sanfter Bildlauf" oder "automatischer Bildlauf" haben mit dem Problem nichts zu tun. Und ausserhalb von TB funktioniert es natürlich sofort und ohne Verzögerung.


    Scrolle ich mit der Tastatur gibt es diese Verzögerung nicht.

  • Weil ich gerade eine Stunde mit demselben Problem verbracht habe -- und damit die ermittelte Lösung auch von anderen gefunden werden kann, hier die Schilderung, woran es bei mir lag.


    Ich hatte in der Mail-Liste seit einiger Zeit (vermutlich seit dem Update auf v.31, bei dem wieder etwas an der Grafikbeschleunigung geändert wurde) ein hakeliges Scrollen festgestellt. Beim Start im Thunderbird-abgesicherten Modus (Menü "Hilfe" -> "mit deaktivierten Add-ons neu starten" -> "im abgesicherten Modus weiterarbeiten") war dies jedoch nicht festzustellen.


    Es lag aber weder an einem Theme, noch an einem Add-on, noch an irgendwelchen sonstigen Benutzereinstellungen, was sich durch komplettes Löschen des Profilordners zeigte, da das langsame Scrollen dann immer noch auftrat (außer eben im abgesicherten Modus).


    Nun war mir bekannt, dass im abgesicherten Modus von Thunderbird die Hardwarebeschleunigung durch die Grafikkarte deaktiviert ist.


    Ich also in die erweiterte Konfiguration (Menü "Einstellungen" -> "Erweitert" -> "Konfiguration bearbeiten"), "acceleration" oben eingegeben, und die Hardwarebeschleunigung deaktiviert:


    [IMG:http://i.imgur.com/ESlKvL3.png]


    Ergebnis: Scrollen immer noch schlecht (außer wieder im abgesicherten Modus).


    Bis ich dann nach längerem Suchen herausfand, dass es noch eine Einstellung für die Hardwarebeschleunigung gibt, die aber nicht den Begriff "acceleration" enthält, sondern "gfx.direct2d.disabled" lautet.


    Also wieder in die Konfiguration, und die entsprechende Einstellung deaktiviert:


    [IMG:http://i.imgur.com/Uss1fkf.png]


    Thunderbird-Neustart -- und: Scrollen geht 1a schnell und flüssig in der Mailliste, trotz aktivem Theme, trotz mehrerer Dutzend Add-ons, trotz zahlreicher Änderungen in der Userchrome.css, und trotz einiger aktiver Benutzerstile (mittels Stylish-Add-on).


    Wer also Probleme mit flüssigem Scrollen in der Mailliste hat, kann einmal versuchen, "gfx.direct2d.disabled" in der erweiterten Konfiguration auf "true" zu setzen. Die Einstellung "layers.acceleration.disabled" hingegen hatte wie oben beschrieben keine Auswirkungen, sollte also zunächst auf Standard ("false") bleiben.


    Das ganze gilt zumindest für Thunderbird 31.1.2 auf Windows 7 64bit und für eine AMD Radeon Grafikkarte.


    Grüße David.P

  • Hallo David,


    wobei die von Dir vorgenommenen Änderungen den Standardeinstellungen entsprechen, zumindest unter TB 24.8.1.
    Wurden unter TB 31 Änderungen vorgenommen? (von Mozilla)


    Gruß
    Herbert

  • Hallo,


    wir hatten hier erst kürzlich einen anderen User, der von einem flackernden Bildschirm berichtete. Ich nahm an, dass das Problem mit der HW-Beschleunigung zusammenhängen könnte.
    Ich fand dann diesen Artikel in der Mozilla KB. Der Artikel liest sich für mich etwas widersprüchlich. Er spricht einserseits davon, dass die 2D-Hardwarebeschleunigung ab Version 9 ausgeschaltet sei, andererseits wird erwähnt, dass jemand in der Version 31 ein Anzeige-Problem lösen konnte, indem er die Beschleunigung abschaltete.


    Zitat


    Thunderbird 5 through version 8 uses Direct2D hardware acceleration (disabled starting in version 9), which can be disabled by setting gfx.direct2d.disabled true and layers.acceleration.disabled true using the config editor. If you are using Linux or OS X try setting layers.prefer-opengl true instead, to see if you can use OpenGL for the hardware acceleration instead. Normally you would use Direct2D under Windows and OpenGL under OS X and Linux. [4] Several people have reported display performance problems even with these settings disabled, unless they disable Window's Aero theme. Using the NoGlass theme doesn't seem to help, but the SilverMel theme did. [5]. One person reported that after upgrading from 24.6.0 to 31.0 the main window's fonts weren't properly aliased/smoothed and some windows had unusual tints. This was worked around by setting gfx.direct2d.disabled true [6]


    Ich habe das nicht weiter recherchiert, weil es mich unter Linux nicht betrifft und weil ich im TB eh keine Grafik-Beschleunigung benötige.
    Die HW-Beschleunigung scheint aber nach wie vor etwas wackelig zu sein, wie man an dem KB-Artikel und auch in einigen Beiträgen im FF-Forum sieht. Offenbar spielen da einfach zu viele Abhängigkeiten eine Rolle: Das OS, die Graphikkarte, die Treiber, Aero, usw. .


    Gruß


    Susanne