Leerzeilen-Problem

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 31.5.0
    * Betriebssystem + Version: Windows 7 Prof, 64 Bit
    * Kontenart (POP / IMAP): POP
    * Postfachanbieter (z.B. GMX): Web.de, GMX


    Hallo,


    jüngst fiel mir auf, dass ein längst vergessenes Problem bei mir wohl immer noch vorherrscht: Wenn ich textbasierte E-Mails aus Thunderbird (früher auch Outlook) heraus verschicke, sehen sie beispielsweise so aus:


    Code
    1. Ich habe mich heute Morgen gleich in einem Internet-Forum erkundigt und
    2. Antwort erhalten: möglicherweise handelt es sich hierbei um ein
    3. "durchgeschlagenes Poti". So etwas kann wohl auch passieren, wenn das
    4. Gerät während des Transportes nicht ausreichend gepolstert wurde.


    Wenn diese Zeilen beantwortet zu mir zurückkommen, sehen sie so aus:


    Code
    1. > Regler für den Bassbereich hat keinen Anschlag. Normal ist es, dass bei
    2. >
    3. > etwa 5 Uhr und 7 Uhr jeweils das Ende des Regelbereiches wäre, aber
    4. >
    5. > diese beiden Anschläge gibt es nicht, man kann den Regler einfach


    Dort sind also überall ungewollte Leerzeilen dazwischen, die beim Versenden noch nicht dort war. Und vermutlich bekommt der Empfänger meine Nachrichten bereits in dieser Formatierung.


    Es ist einige Zeit her als ich diesen Computer mit Thunderbird eingerichtet habe - jedenfalls will ich E-Mails ausschließlich als Text senden und empfangen. (Eben habe ich die Einstellmöglichkeiten dafür aber nicht gefunden.) Auch bricht der Editor beim Verfassen von Nachrichten nach 7x Zeichen automatisch in die nächste Zeile um. Kann dort der Fehler liegen, muss man nach x Zeichen manuell mit [Enter] in die nächste Zeile umbrechen? Was könnte ich tun, damit meine Nachricht gescheit formatiert verschickt werden?


    Gruß

  • Hallo,
    die Nachricht kommt so an, wie sie im Quelltext bei dir vor dem Versenden angezeigt wird. Du kannst auch im Ordner "Gesendet" nach dieser Mails suchen und im Quelltext (Strg+U) öffnen.
    Outlook und Word sind bekannt dafür einen anderen Zeilenumbruch beim Drücken der Returntaste durchzuführen.
    Schau mal in den Quelltext (Strg+U) der Mail, ob es dort einen Eintrag "X-Mailer:" gibt.
    Auch "user-agent" ist möglich. Dahinter wird dir das Mailprogramm des Versenders angezeigt. Bei vielen Mails fehlen aber diese Einträge.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Du kannst auch im Ordner "Gesendet" nach dieser Mails suchen und im Quelltext (Strg+U) öffnen.


    Ich habe mir eben die verschickte Nachricht und auch deren Quellcode angesehen. Dabei ist mir ein Unterschied aufgefallen: Beim Quellcode sind die Zeilen nach x Zeichen (also vermutlich die maximalen 73 Zeichen) umgebrochen, und es gibt keine Leerzeilen (außer die von mir gewollten Absätze). Wenn ich die verschickte Nachricht aufrufe, wird die Zeilenlänge jedoch am Anzeigefenster angepasst, die Zeilen werden also nicht automatisch umgebrochen. Dort gibt es aber ebenfalls keine überflüssigen Leerzeilen.


    Zitat

    Schau mal in den Quelltext (Strg+U) der Mail, ob es dort einen Eintrag "X-Mailer:" gibt.


    In meiner verschickten Nachricht steht "User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.5.0".


    In der Antwort (aus der ich das obige Beispiel mit den Leerzeilen kopiert habe) steht: "X-Mailer: IncrediMail (6605288)".


    Kannst Du aus diesen beiden Angaben etwas ableiten?


    Wenn ich Dich richtig verstanden habe, werden meine Nachrichten zwar korrekt verschickt, aber beim Empfänger nicht korrekt geöffnet - kommen also deshalb mit den Leerzeilen wieder zu mir zurück? Kann man denn etwas dagegen machen? ...Ich habe eben noch mal ein paar andere (empfangene) Nachrichten angeschaut, und diese Leerzeilen tauchen nicht überall auf.

  • Zitat

    Kannst Du aus diesen beiden Angaben etwas ableiten?


    Ja kann ich.

    Zitat

    Wenn ich die verschickte Nachricht aufrufe, wird die Zeilenlänge jedoch am Anzeigefenster angepasst,


    Ja, das ist so aber nur bei HTML-Mails, bei Reintext wird die Mail so umgebrochen wie im Quelltext.
    Das geht auch nicht anders, weil mit der Größe der Schrift auch die Anzahl der Buchstaben pro Zeile variiert, unmöglich hier eine feste Darstellung zu haben.
    Im Quelltext kann man den Umbruch nach 72 Zeichen aber erkennen.
    Früher was es so, dass selbst in Reintext-Mails nur dann nach 72 Zeichen umgebrochen wurde, wenn eine Monospace-Schriftart (=nicht proportional) wie Courier verwendet wurde. Mit Arial (proportional) ging es also nicht. In der aktuellen Version geht aber trotzdem.

    Zitat

    "X-Mailer: IncrediMail (6605288)".


    Dieser Mailklient ist für seine umfangreichen HTML-Funktionen bekannt.
    Und leider gibt es für HTML in Mails keinerlei Standard. Du musst also bei HTML-Mails immer damit rechnen, dass der Empfänger sie ganz anders dargestellt bekommt, schlimmstenfalls unlesbar.

    Zitat

    Wenn ich Dich richtig verstanden habe, werden meine Nachrichten zwar korrekt verschickt, aber beim Empfänger nicht korrekt geöffnet


    Da musst du schon den Empfänger fragen, aber in Outlook z.B. werden die Mails, die in Thunderbird genau 72 Zeichen pro Zeile lang sind, bis zum Fensterrand angezeigt.
    Allerdings kann man dies mit einem Schalter rückgängig machen.
    Da ja durch das Antworten durch das Mailprogramm Änderungen in der Mail gemacht werden, sind solche Effekte keine Seltenheit.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Erstmal vielen Dank für Deine Unterstützung!



    Du musst also bei HTML-Mails immer damit rechnen, dass der Empfänger sie ganz anders dargestellt bekommt, schlimmstenfalls unlesbar.


    Hmm, das verstehe ich leider noch nicht. Meine E-Mails verfasse ich doch ausschließlich als Textnachrichten und genau so sollen sie angezeigt werden - als reiner Text, ohne Formatierungen. Inwiefern kommt dabei HTML ins Spiel?

  • Zitat

    Hmm, das verstehe ich leider noch nicht.

    Nein, ich auch nicht.


    Ich hatte vergessen, dass du in Reintext schreibst.
    Also noch einmal von vorne.

    Zitat

    Wenn ich die verschickte Nachricht aufrufe, wird die Zeilenlänge jedoch am Anzeigefenster angepasst, die Zeilen werden also nicht automatisch umgebrochen. Dort gibt es aber ebenfalls keine überflüssigen Leerzeilen.


    Woran erkennst du beim Verfassen, dass du in Reintext und nicht in HTML schreibst?
    Welche Schriftart benutzt du für Reintext?
    Das Verhalten bei dir tritt bei mir nicht auf, es muss also einen Grund dafür geben.
    Dazu brauche ich deine Vorgaben um das bei mir zu testen.
    Es handelt sich in deinem Screenshot um eine Antwort also ein Zitat.
    Und ich sagte ja schon, dass deine Mail bei der Antwort erheblich verändert wird.
    Mache die Gegenprobe: schreibe dir selbst eine Mail und antworte darauf. Ergebnis?


    Das ganze ist aus der Ferne etwas schwierig. Säße ich vor deinem PC, könnte ich das relativ schnell analysieren.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo divisi,


    wie sieht Dein Verfassen-Fenster aus?:



    oder



    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Woran erkennst du beim Verfassen, dass du in Reintext und nicht in HTML schreibst?


    Hmm, soweit ich erinnere, müsste man ja bei HTML diverse Formatierungsmöglichkeiten im Editor haben, die mir aber nicht zur Verfügung stehen. ...Mir fällt eigentlich ansonsten nicht ein woran ich das erkennen sollte.


    Welche Schriftart benutzt du für Reintext?


    Unter Einstellungen | Ansicht ist Tahoma eingestellt.


    [EDIT]
    Habe eben noch mal in den Konto-Eigenschaften nachgeschaut. Bei jedem Mail-Account ist die Option "Nachrichten im HTML-Format verfassen" abgewählt.
    [/EDIT]


    Mache die Gegenprobe: schreibe dir selbst eine Mail und antworte darauf. Ergebnis?


    O.k., das habe ich gemacht. Klappt zwischen Konten bei Web.de und GMX problemlos, d.h. ohne ungewollte Leerzeilen.


    wie sieht Dein Verfassen-Fenster aus?:


    Die zweite Grafik, also ohne Formatierungsmöglichkeiten, so wie es ja bei einem reinen Texteditor sein sollte, denke ich.

  • Ich habe das mit Tahoma getestet, der Umbruch erfolgt bei mir korrekt nach 72 Zeichen.
    Poste mal deine Einstellung in der erweiterten Konfiguration für diesen Eintrag:
    mailnews.wraplength


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Lege mal bitte ein neues Profil mit zunächst nur mit 1-2 Konten.
    Lege die Konten als IMAP dort an (das geht mit GMX und Web.de und zwar auch kostenlos).
    Überprüfe das Verhalten dort.
    4 Ein neues Profil erstellen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Oha, dazu muss ich mir wohl Mut antrinken.


    BTW. Habe vorhin noch mal etwas geprüft. Ein und die selbe Nachricht a) im Browser beim GMX-Postfach und b) beim Betrachten in Thunderbird. Dabei fiel bei Thunderbird auf, dass meine zitierten Zeilen in der Antwort die Leerschritte aufweisen. Im Browser/GMX-Account jedoch nicht. Aber: Als ich die Zeilen aus dem Browser kopierte und sie hier als Beispiel einfügen wollte, waren hier in der Vorschau plötzlich auch diese Leerzeilen. Wenn ich die kopierten Zeilen jedoch in den Windows-Editor einfüge, sind dort keine Leerzeilen. 8| ...Ich weiß nicht was es ist, aber es scheint nicht an Thunderbird zu liegen. :huh:

  • Auf die Schnelle drei Screenshots vom selben Text:


    GMX:


    [IMG:http://i60.tinypic.com/sd2ww7.gif]


    Hier im Editor:


    [IMG:http://i62.tinypic.com/inbtj8.gif]


    Und OpenOffice Writer:


    [IMG:http://i58.tinypic.com/1zyzns3.gif]


    Es deutet für mich nichts darauf hin, woher in manchen Anwendungen Leerzeilen entstehen könnten.


    [EDIT]
    Zumindest aber weiß ich durch die Ansicht in GMX eines: Meine Zeilen scheinen beim Empfängern korrekt formatiert einzutreffen. Und vom Empfänger wird mein Text auch korrekt weitergeleitet.


    ...Dumm sieht es erst dann aus, wenn ich meine Zeilen - die bei mir dann mit Leerzeilen angezeigt werden - dann ein weiteres Mal verschicke, beispielsweise um eine Diskussion fortzuführen.

  • Auch an dich meine Frage:
    verschlüsselst oder signierst du Mails?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw