Umlaute falsch dargestellt

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version:
    * Betriebssystem + Version:
    * Kontenart (POP / IMAP):
    * Postfachanbieter (z.B. GMX):
    * Eingesetzte Antivirensoftware:
    * Firewall (Betriebssystem-intern/Externe Software):
    Thunderbird 38.4.0, Windows 7, POP, t-online, Firewall Norton:
    Umlaute werden regelmäßig zuerst falsch dargestellt, wenn ich E-Mail schließe und erneut öffne, ist alles richtig. Trotzdem ist dies lästig, jedesmal 2xzu öffnen.
    Habe schon diverse Einstellungen geändert wie:
    1. Schriftart Lateinisch oder auch schon andere Schriftarten
    2. ausgehende und eingehende Nachrichten mit Unicode, UTF 8 oder ISO bzw. westlich etc.
    3. Auch steht unter: mailnews.force-charset .... richtig "false".
    Ich bin war ziemlicher Laie aber meine Söhne wissen auch keine Lösung.
    Mir bleibt halt nur, jede Mail immer 2x zu öffnen!
    Habt Ihr evtl. eine Lösung parat?? Danke.

  • Hallo,

    Zitat

    Umlaute werden regelmäßig zuerst falsch dargestellt, wenn ich E-Mail schließe und erneut öffne, ist alles richtig.

    .
    So eine Problembeschreibung habe ich noch nie gehört.

    1. Schriftart Lateinisch oder auch schon andere Schriftarten

    Schriftart Lateinisch: in welchem Menü steht das?

    2. ausgehende und eingehende Nachrichten mit Unicode, UTF 8 oder ISO bzw. westlich etc.

    Das ist eigentlich unwichtig, wenn Thunderbird nicht gehindert wird, die richtige Zeichenkodierung selbst zu finden.
    Un das geschieht zu 90% dann, wenn in den Ordnereigenschaften also Rechtsklick auf den Ordner --> Allgemein, das untere Kästchen angehakt ist. Ist das bei dir der Fall?
    Eine weitere Erklärung wäre die, dass diese Mails falsch deklariert sind. Die Deklaration findest du im Quelltext (Strg+U) einer Mail hinter dem "charset:"
    Also etwa:


    Code
    1. Content-Type: text/html; charset=windows-1252
    2. Content-Transfer-Encoding: 8bit

    Bei "charset" kann auch UTF-8 oder ein ISO-Wert u.a. stehen


    In der zweiten Zeile auch "quoted printable" u.a.


    Diese Deklarierung muss dann - wenn du die Mail wieder öffnest - mit der gerade angezeigten Zeichenkodierung übereinstimmen und zwar unter Ansicht --> Zeichenkodierung. Ist das nicht der Fall, ist die Mail falsch deklariert oder gar nicht.
    Eine weitere Ursache könnte ein altes Profil (älter als 2 Jahre)sein, welches du nie erneuert hast. Auch inkompatible Add-ons gehören dazu.
    Starte mal Thunderbird miot einem neuen Profil und testweise nur einem Konto am Besten IMAP und teste es dort.
    Ein neues Profil erstellen



    3. Auch steht unter: mailnews.force-charset .... richtig "false".

    Das sagt mir, du hast Expertenwissen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für Deine diversen Infos, die ich gestern mit meinem Sohn durchgegangen bin:
    Also 1. zur Schriftart: Die finde ich unter Extras/Einstellungen/Ansicht/Formatierung/Erweitert/ Schriftarten für ....: Und hier erscheinen 27 ausländische fremde Schriftarten darunter eben Lateinisch und noch zusätzliche andere Schriftarten. Da also kein "Deutsch" aufgeführt ist, habe ich eben Lateinisch genommen und habe auch schon andere Schriftarten ausprobiert. Keine Veränderung. Warum hier nicht deutsch oder westlich aufgeführt wird, ist mir ohnehin ein Rätsel.
    zu 2. Das beschriebene untere Kästchen ist bei mir nicht angehakt, d.h. Thunderbird sollte eigentlich die richtige Kodierung selbst finden.
    Das Eigenartige bei meinen Umlauten ist ja der Umstand, daß selbst die von mir versandten E-Mails, wenn ich diese nochmal herhole, mitunter beim 1. Mal auch falsch angezeigt werden. Und beim 2. Mal wird wieder alles richtig. D.h. meiner Meinung nach sollte er wenigstens meine versandte Mail wieder richtig erkennen?


    Da mein Profil älter als 2 Jahre ist, habe ich mal Deinen Tipp umgesetzt und einen neuen Benutzer angelegt und dann die Mail-Darstellung ausprobiert. Leider hat das auch nichts gebracht. Im Gegenteil: Manchmal erschien dann zu der eingegangen Mail zu Beginn ca. 20 unlesbare und undefinierbare Zeilen und erst im Anschluß dann die richtige Mail. Auch diese konnte ich wieder bereinigen, indem ich eben die Mail schloß und erneut öffnete - dann war alles klar und rein.


    Ich meinte zu meinem Sohn, ob es was brächte, wenn ich Thunderbird mal ganz deinstalliere und neu installiere? Er meint, das brächte nichts, ich hätte ja die aktuelle Version 38.4.0 drauf.
    Ich hoffe, das Ganze hat nichts mit einem Virus zu tun?


    Ansonsten mache ich halt weiterhin die Mails i.d.R. zweimal auf, dann funktioniert es ja - aber komisch und lästig ist es schon.
    Ich möchte Euch nicht weiter bemühen, aber wenn Ihr noch eine Idee hättet, wäre ich darür dankbar.
    Vielen Dank vorerst für Eure Bemühungen.
    19.12.2015

  • Also 1. zur Schriftart: Die finde ich unter Extras/Einstellungen/Ansicht/Formatierung/Erweitert/ Schriftarten für ....: Und hier erscheinen 27 ausländische fremde Schriftarten darunter eben Lateinisch und noch zusätzliche andere Schriftarten. Da also kein "Deutsch" aufgeführt ist, habe ich eben Lateinisch genommen und habe auch schon andere Schriftarten ausprobiert. Keine Veränderung. Warum hier nicht deutsch oder westlich aufgeführt wird, ist mir ohnehin ein Rätsel.

    Ja, du hast Recht, da ist tatsächlich Lateinisch aufgeführt, früher stand dort Western, ISO-8859-1 o.a. Die ändern das ständig.



    Da mein Profil älter als 2 Jahre ist, habe ich mal Deinen Tipp umgesetzt und einen neuen Benutzer angelegt und dann die Mail-Darstellung ausprobiert.

    Was meinst du mit Benutzer? Ein neues Profil?




    Ich meinte zu meinem Sohn, ob es was brächte, wenn ich Thunderbird mal ganz deinstalliere und neu installiere? Er meint, das brächte nichts, ich hätte ja die aktuelle Version 38.4.0 drauf.

    In der Regel hilft das auch fast nie, aber wenn ein neues Profil auch nicht hilft, würde ich es probieren, also deinstallieren und neuinstallieren. Die Profile werden nicht angerührt, so dass der Arbeitsaufwand nur wenige Minuten beträgt. Schaden kann das nie.
    Hast du deiner Sicherheitssoftware untersagt, das Thunderbird-Profil abzuscannen, solltest du besser tun.






    Ich hoffe, das Ganze hat nichts mit einem Virus zu tun?

    Höchst unwahrscheinlich, bei Firefox wäre das eher möglich.



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw