posteo und Thunderbird-Adressbuch sync - SOGo Connector nicht installierbar

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 38.5.1
    * Betriebssystem + Version: WIN 7
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX): posteo.de
    * Sync-Add-on für Online-Adressbuch?: offen


    Hallo,


    ich habe mich angemeldet, da ich heute morgen am syncen der Adressbücher vpn posteo und Thunderbird verzweifelt bin.


    Eigentlich liest es sich mit der Anleitung die beiden Adressebücher mit Hilfe von SOGo Connector zu synchronosieren. Ich habe das Problem, dass Thunderbird sich beschwert, wenn ich den SOGo Connector 31.0.2 installieren will. Die Installation wird abgebrochen, da er nicht kompatibel zu Firefox 38.0.5 sei. Außerdem benutze ich noch Lightning (4.0.5.2), was ja auch benötigt wird. Hat jemand eine Idee, was das Problem sein könnte.


    Ansonsten habe ich noch die cardbook-Erweiterung ausprobiert. Anscheinend habe ich bei der Einstellung des remote-Adressbuchs einen Fehler gemacht. Es tut sich nichts und alles Felder sind ausgegraut. Wenn ich das Add-on deinstalliere und wieder reinstalliere, sind alle vorher eingestellten Konten (das fehlerhafte posteo-remote-Konto) wieder da und cardbook hängt sich direkt wieder auf. Habt ihr einen Weg Add-ons vollständig zu deinstallieren, damit ich dafür die Einstellungen von null wieder anfangen kann?


    Über Hinweise wäre ich Euch echt dankbar.


    Grüße,
    Peter

  • Guten Tag peter, und willkommen im Forum!

    Die Installation wird abgebrochen, da er nicht kompatibel zu Firefox 38.0.5 sei. Außerdem benutze ich noch Lightning (4.0.5.2), was ja auch benötigt wird. Hat jemand eine Idee, was das Problem sein könnte.

    Was hältst du davon, wenn du mal den SOGo Connector im Thunderbird und nicht im Firefox installierst?
    Als Datei herunterladen (wie üblich mit dem Fx), lokal speichern, TB öffnen, Add-on-Manager, Aus Datei installieren ... .



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • peinlich, peinlich...aber danke.


    Die Installation hat jetzt wunderbar geklappt. Die Synchronisation aber nicht.


    Die URL, die ich eingegeben habe, ist die folgende: https://posteo.de:8843/addressbooks/max.muster/default


    max.muster ist natürlich mit meinem Accountnamen ersetzt. Beim Synchronisieren tut sich allerdings nichts. Weder eine Fehleranzeige noch irgendeine Anzeige, dass Thunderbird was synchronisiert, wenn ich syncen will. Gibt es eine Idee, woran das liegen könnte?

  • Hi peter,


    da ich meine Kalender und Adressbücher bei mir zu Hause auf einem kleinen RasPi hoste, kann ich dir nicht mit praktischen Erfahrungen kommen. Die entsprechende Anleitung von Posteo kennst du aber sicherlich: Wie richte ich Posteo in Thunderbird manuell ein?. Den richtigen Link hast du ja gehabt. jOb dein Kalender einfach "default" heißt, weißt nur du ... .


    Mal senen, ob sich noch ein posteo-Nutzer meldet.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,


    danke wieder für die Antwort. So richtig weiter bin ich leider nicht gekommen. Laut der Anleitung bei posteo heißt der Kalender "default". Ich habe jetzt noch ein wenig rumprobiert, aber so richtig bin ich nicht weiter gekommen. Ich hoffe, dann mal auf einen posteo-Nutzer hier...;)


    Grüße,
    Peter

  • Hallo peterlele,
    die von Dir genannte URL ist im Prinzip ok, sie muss aber mit https:// beginnen.

  • Hey...


    das "https://" siehst du nicht im geschriebenen Link. Es ist war aber mit eingefügt (siehst du auch, wenn du denn Link anschaust). Danke für den Tipp aber.


    Vielleicht hilft das ja noch bei der Fehlersuche. Wenn ich das genauso eingebe, wie posteo es empfiehlt (siehe oben), tut sich beim Snychronisieren einfach gar nichst. Keine Fehlermeldung, keine Anmerkung, dass eine Verbindung versucht wurde...


    Versuche mit einer leicht modifizierten URL (z.B. entferne ich die sichere Verbindung - http://..., oder ich versuche andere Namen für das Adressbuch) ergibt sich das Resultat, dass beim Synchronisationsversuch zumindest die Meldung kommt: "SOGO: Name des Adressbuchs; Keine Änderungen". Zumindest wird da anscheinend, ein wie auch immer geartete, Verbindung hergestellt...

  • Hallo Peter,


    mangels eines Kontos bei posteo kann ich die Verbindung nicht selbst überprüfen. Ich nehme aber an, dass die Leute bei Posteo ihre Anleitung sorgfältig erstellt haben. Der URL sollte also so stimmen, wie er in der Anleitung steht.


    Zitat

    Der Abgleich zwischen Thunderbird und Posteo funktioniert ab sofort automatisch. Wenn Sie Ihr Adressbuch mit der rechten Maustaste anklicken und “Synchronisieren” auswählen, wird er manuell durchgeführt. Beim ersten Abgleich werden Ihre Posteo-Adresse als Benutzername und Ihr Posteo-Kennwort abgefragt. Diese Daten können Sie speichern.

    Bist Du jemals so weit gekommen, dass Du nach dem Benutzername und dem Passwort gefragt wurdest?


    Gruß


    Susanne


    P.S.: Noch eine Frage. Hast Du auch eine Kalender bei Posteo, den Du über Lightning eingebunden hast?

  • ich bin verwirrt. sehr verwirrt. Es funktioniert. Zum wiederholten Male habe ich die Kontakte mit der bekannten URL verknüpft und alles von Grund auf neu aufgesetzt, weil ich die Passwörter gelöscht hatte...


    Danke für die Unterstützung. Für nachfolgende Fragende kann ich leider nicht nachvollziehen, woran es liegt, dass es jetzt funktioniert, vorher aber nicht.


    @Susanne
    Der Kalender hat von Anfang an ohne Probleme funktioniert.

  • ... und alles von Grund auf neu aufgesetzt, weil ich die Passwörter gelöscht hatte...

    Unter anderem deshalb hatte ich nach den Kalendern gefragt. Der SOGo-Connector benutzt ja Lightning. In den Anleitungen bei Posteo finden sich Hinweise, dass es unter Umständen notwendig sein kann, vorhandene Passwörter zu löschen. Möglicherweise war also eben dieses Löschen der Schlüssel zum Erfolg.

  • wenn das so ist. Vielen Dank. Aber gibt es einen Grund dafür?


    Ich meine, dass ich es vorher schon mal mit einer komplett neu aufgesetzten Verbindung zum
    Posteo-Adressbuch probiert hatte. Gut ist, dass es jetzt funktioniert


    Eine Frage aber noch.


    Thunderbird und Posteo vertauschen die Felder teilweise. Aus Telefon-mobil bei Posteo wird Telefon-dienstlich, etc. Kann man die Felder noch irgendwie anpassen oder passiert das automatisch.

  • Thunderbird und Posteo vertauschen die Felder teilweise. Aus Telefon-mobil bei Posteo wird Telefon-dienstlich, etc.

    Ja, das hatte ich auch schon beobachtet, unabhängig von Posteo. Ich kenne die Ursache nicht, vermute aber, dass sie im TB-Adressbuch begründet liegt, das noch vCard v 2.1 verwendet.
    Mit der Erweiterung Cardbook statt SOGo tritt dieses Problem bei mir nicht auf. Im Gegensatz so SOGo benutzt Cardbook nicht das TB-Adressbuch sondern verwendet sein eigenes im Format vCard v 3.x.
    Cardbook it derzeit noch unter rascher Entwicklung. Mit kleineren Bugs ist zu rechnen.