Mails automatisch im Reintext trotz aller Einstellungen auf HTML

  • Hallo zusammen,


    ich bin neu hier und bei Thunderbird und kriege trotz aller Rechercheanstrengungen mein Problem nicht gelöst. ?( Ich hoffe, ich habe keinen ähnlichen Thread übersehen. Vielleicht könnt ihr helfen? :)


    Mein Problem, an dem ich mir die Zähne ausbeiße:


    Jede E-Mail, die ich verfasse, wird standardmäßig als Reintext verschickt, obwohl ich automatisch und immer im HTML-Fenster mit Formatleiste verfasse (ohne Shift-Taste) und obwohl ich in den Kontoeinstellungen den Haken für HTML-Nachrichten bei Verfassen & Adressieren bei allen Konten gesetzt habe. Bei den Globalen Einstellungen ist für die Sendeoptionen Reintext UND HTML eingestellt. (Bei NUR HTML geht es auch nicht.) Domains sind keine eingetragen, weder für HTML noch Reintext. Im Adressbuch sind alle Einträge bzgl. des Formats auf unbekannt gesetzt. Addons sind nur Lightning 4.0.6, Inverse SOGo Connector 31.0.2, Manually Sort Folders 1.1 und MyPhoneExplorer 2.0.19 installiert. Das Problem tritt aber auch im abgesicherten Modus auf, also mit deaktivierten Addons. Bei verschickten Mails steht im Quelltext immer Content-Type: text/plain; charset=utf-8. Es ist also kein Anzeigeproblem
    bei mir.


    HTML-Mails kriege ich momentan nur auf Umwegen raus: Ich antworte auf eine in HTML empfangene Nachricht oder ich stelle in jeder einzelnen(!) Mail das E-Mail-Format von Automatisch auf nur HTML oder Reintext und HTML oder aber ich trage jede(!) Domain, an die ich senden möchte, in den Globalen Sendeeinstellungen ein. Das ist jedoch alles sehr umständlich und aufwändig! Die Automatik funktionert nicht ;(


    Hat jemand eine Idee, wie ich das Format für immer auf HTML stelle?
    Gibt's vielleicht eine Einstellungen in about:config?




    Gruß
    plinox





    * Thunderbird-Version: 38.6.0
    * Betriebssystem + Version: Windows 10 Home 64 bit
    * Kontenart (POP / IMAP): POP
    * Postfach-Anbieter (z.B. GMX): Posteo / GMX / Gmail
    * Eingesetzte Antiviren-Software: GDATA
    * Firewall (Betriebssystem-intern/Externe Software): GDATA

  • Hallo und willkommen im Forum!


    Du verwendest aber in den Mails auch die Formtierungsfunktionen?
    Hört sich sich nach einer Inkompatiblität, einem defekten Profil oder einen Eingriff von außen /Virenscanner) an.


    Starte Thunderbird im abgesicherten MOdus ohne Add-ons:
    In TB > Hilfe > "Mit deaktivierten Add-ons neu starten" und den Button "Im abgesicherten Modus weiterarbeiten" verwenden oder Start mit gedrückter Umschalt-Taste.
    Oder über Win+R --> thunderbird -safe-mode --> OK.


    Hast du dort das gleiche Problem?


    Hast du mal den Quelltext (Strg+U) dieser Mails untersucht, steht dort HTML-Code drin?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb und danke für deinen Tipp!


    Den abgesicherten Modus hatte ich schon versucht, nun noch einmal. Das bringt aber keine Abhilfe.


    Dagegen bin ich nun - dank dir :) - auf die Idee gekommen, die Textformatierung genauer zu untersuchen: Wenn ich nur Text schreibe oder nur den Textsatz formatiere (zentriert, rechtsbündig etc.), erhalte ich stets unformatierten Reintext. Die Formatierungen werden hier also verworfen. Ist die Formatierung dagegen eine andere Farbe, Größe, Fett etc., so kommt die E-Mail korrekt im HTML-Format an. Merkwürdig! :S


    Klingt für mich nach einer inhaltssensitiven Automatik, die "einfache" Formatierungen ignoriert. So sehen aber die meisten E-Mails von mir aus.


    Kann man diese Automatik irgendwo ausschalten?
    Kann man - quasi als work around - diese Automatik vielleicht überlisten, indem man standardmäßig eine Signatur anhängt, in der entsprechend "stark" genug formatierter Inhalt steckt?



    Gruß
    plinox

  • Welche Schriftart verwendest du?


    Ob ein Profilfehler vorliegt kann man ja schnell testen, indem man ein neues Profil anlegt
    4 Ein neues Profil erstellen
    ein Konto einrichtet und an sich entspr. Mails schickt. Das dauert bei mir max. 5 Minuten.


    In früheren Versionen war das Verhalten ähnlich dem, wie du es beschreibst, erst bei Verwendung der Formatierungsoptionen bzw. einen anderen als der default Schriftart sendete Thunderbird trotz gegenteiliger Einstellung in Reintext.
    Ich kann dieses Verhalten allerdings seit Jahren bei mir nicht mehr feststellen - möglicherweise, weil ich nicht die Standardschriftart verwende.
    Dieses Add-on
    QuoteAndComposeManager verfügt u.a über eine Funktion, die Thunderbird dazu zwingt immer in HTML zu senden.
    Wörtlich schreibt der Autor:

    Zitat

    10) option to send always mails in HTML format, when you compose with this format, also if the message have no element that requires HTML (by default Thunderbird in this case convert the message in plain text);

    .Weiterhin:
    öffne die erweiterte Konfiguration (Extras > Einstellungen > Erweitert > Allgemein > "Konfiguration bearbeiten") und überprüfe die EInträge dieser Art:
    mail.identity.id1.compose_html
    ob sie auf true stehen.
    Der Eintrag mail.default_html_action steht auf welcher Zahl?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    4 Mal editiert, zuletzt von mrb ()

  • Das hilft!
    Die Schriftart stand bei mir auf "variable Breite". Wenn ich eine konkrete Schriftart aussuche klappt die Formatierung als HTML-Mail.


    Eine frühere Version hatte ich, trotzdem ich erst neu bei TB bin, auch auf dem Rechner gehabt. Da der Umzug aus Outlook zur Zeit bei den meisten Versionen wegen Fehler abgeschaltet ist, hatte ich die einzig dafür taugliche / empfohlene Version TB 17 installiert. Nach erfolgreichem Import hatte ich auf die neueste Version aktualisiert.


    Im Übrigen:
    Das Profil war nicht fehlerhaft. Ein Test-Profil ergab denselben Fehler.
    Es stehen id1.compose_html auf true und default_html auf 2.
    Quellcode / Strg+U ergab text/plain; charset=utf-8. Siehe mein erster Post.
    Die Idee mit der Signatur hat auch funktionert. Ich hatte ein weißes, also idR "unsichtbares" Satzzeichen angefügt. Brauche ich nun nicht mehr.


    Vielen Dank! :thumbsup:


    Gruß
    plinox

    Einmal editiert, zuletzt von plinox ()

  • Das Profil war nicht fehlerhaft. Ein Test-Profil ergab denselben Fehler.

    Ich wollte damit nur eine Eventualität abdecken, nämlich die, dass, wenn ein Schalter sich immer wieder zurücksetzt, einen Fehler im Profil als Ursache hat. In deinem Fall natürlich wenig hilfreich, weil bei einem neuen Profil alles auf Default gestellt ist und die Schriftart stand bei dir ja auf default. Das kann man aber nicht im voraus wissen.
    Mit der Signatur beziehst du dich auf einen anderen Thread?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Kann man - quasi als work around - diese Automatik vielleicht überlisten, indem man standardmäßig eine Signatur anhängt, in der entsprechend "stark" genug formatierter Inhalt steckt?

    Die Idee war, durch eine "ausreichend stark" formatierte Signatur die HTML-Erkennung der Automatik auszulösen, um nicht für jede einzelne E-Mail händisch das Format umstellen zu müssen. Hatte funktioniert, ist nun aber nicht mehr notwendig.


    Gruß
    plinox