CardBook nicht zu bearbeiten

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 38.8.0
    * Betriebssystem + Version: Linux 4.4.0-24
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX): Strato
    * Sync-Add-on für Online-Adressbuch?:
    * Eingesetzte Antivirensoftware:
    * Firewall (Betriebssystem-intern/Externe Software):


    Hallo,


    ich habe, nach Problemen mit SOGo, CardBook installiert, um meine Kontakte mit ownCloud zu synchronisieren. Das klappt auch.
    Aber:
    ich kann in CardBook nichts bearbeiten. Alle Buttons sind ausgegraut, auch in den Kontextmenüs ist alles grau. Bei Doppelklick auf einen Kontakt öffnet sich immer das E-mail-Formular und "URL öffnen" ist auch der einzige Eintrag im Kontextmenü, der zugänglich ist. Wenn ich das Adressbuch nochmals aktiviere indem ich es anklicke, ist der "Kontakt hinzufügen"-Button für ein bis zwei Sekunden aktiv, und das war's. Wenn ich ganz schnell bin, kann ich dann auch das entsprechende Formular öffnen.
    Nur alle anderen Bearbeitungen sind überhaupt nicht möglich.
    Wo kann ich anfangen zu suchen?

  • Hallo reader, und willkommen im Forum!

    Wo kann ich anfangen zu suchen?

    Zuerst einmal im umfangreichen und auch recht aussagefähigen Log von CardBook. => einfach auf die letzte Meldung unten rechts in der Statuszeile klicken.
    Du kannst evtl. auch vorher den Debug-Modus in den Einstellungen von CardBook einschalten.


    Und dann natürlich auch in den Einstellungen deines OwnCloud-Servers.
    - Hast du wirklich dort den betreffenden Link angeklickt und via Zwischenablage übernommen und in den TB eingefügt?
    - Hast du als der betreffende Nutzer auch Schreibrechte auf diesem Kalender (es muss ja nicht dein eigener sein!)?


    Ich nutze zur Zeit selbst einen Account auf einem OC-Server. Kann deswegen mit Bestimmtheit sagen, dass CardBook ausgezeichnet mit OC zusammenarbeitet. Einzig und allein die Tatsache, dass OC alle Datensätze in die vCard-Version 3.0 umwandelt, ist (ggw. noch) etwas schade.
    Ich habe festgestellt, dass bei sehr umfangreichen Kalendern und langsamer Internetverbindung kurzzeitig ein Bearbeiten nicht möglich ist. Ein bis zwei Sekunden - bis die Sync abgeschlossen ist. Aber das wird im Log deutlich angezeigt.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Danke erstmal für die Antwort.
    Die Synchronisation mit der Cloud klappt ja. Es sind alle Kontakte der OC da. Es liegt also nicht an der Verbindung zum OC-Server. Ich kann sie nur nicht bearbeiten.
    In der Log-Datei gibt es keine Fehlermeldungen. Da steht, welche Kontakte gefunden und synchronisiert wurden und dass aufgrund des periodischen Syncs synchronisiert wurde.
    Ich denke also, es ist irgendwas in CardBook (oder in TB) selbst, dass mir die Bedienoberfläche verweigert.
    Ich habe mal einen Screenshot angehängt.

  • Ich denke also, es ist irgendwas in CardBook (oder in TB) selbst, dass mir die Bedienoberfläche verweigert.

    Hallo reader,
    bist Du auch sicher das Cardbook alle Daten herunter geladen hat?
    Steht unten in der Leiste Synchronisation beendet?
    Was hast Du außer Cardbook noch für Erweiterungen installiert?

    Gruß
    EDV-Oldi

  • Ich gehe ebenfalls davon aus, dass es nicht an CardBook liegt.
    - So viele User, die CardBook nutzen => dieses Problem wäre bekannt!
    - Keine Antwort zu meiner Frage, deine Nutzerrechte auf dem Server betreffend. Synchronisieren geht auch, wenn du nur Leserechte hast! Ich kann auch eigene Kalender "teilen" und nur lesenden Zugriff geben.


    Hast du mal aus CardBook heraus einen neuen Kalender Kontakt angelegt? Geht es da?



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

    2 Mal editiert, zuletzt von Peter_Lehmann () aus folgendem Grund: @edvoldi: DANKE! ;-)

  • Also, einen Kontakt anlegen geht nicht, weil der entsprechende Menüpunkt ausgegraut ist.
    Die Synchronisation ist offensichtlich nicht abgeschlossen. Unten rechts stand vorhin was von periodischem Sync und nach einem Neustart, dass er einen bestimmten Kontakt aus dem Cache gelesen hat. Aber der Fortschrittsbalken ist nicht durchgelaufen.


    Vlt. sollte ich dazusagen, dass ich ein Kubuntu-Upgrade gemacht habe. Bis dahin lief alles einwandfrei, sogar mit SOGo und dem Standardadressbuch. Auf der Cloud habe ich nichts verändert. Und die Kalender syncen auch einwandfrei.
    Also wo genau finde ich den Pfad zu den Kontakten? Das läuft doch über die remote.php. Ich kenne mich da nicht so aus.

  • Aber der Fortschrittsbalken ist nicht durchgelaufen.

    Dann kannst Du auch keine Kontakte bearbeiten, erst wenn alle Adressbücher synchronisiert wurden, ist eine Bearbeitung möglich.
    Das kann bei einer neu Anlage mit viele Kontakten schon etwas dauern.

    Gruß
    EDV-Oldi

  • Es wurden 189 Kontakte synchronisiert. Da können noch ein paar wenige fehlen. Aber es bleibt seit Stunden bei diesen 189 Kontakten.

  • Habe ich gemacht. Einstellungen kann ich nur direkt bei den Erweiterungen bearbeiten.
    Ich lasse das mal bis morgen laufen. Ich wundere mich nur, warum er die ersten 189 Kontakte innerhalb von Sekunden synchronisiert hat und jetzt seit Stunden nichts passiert.

  • Dann wird wohl der letzte Eintrag (der, bei dem es hängt), faul sein.
    Die einzelnen Einträge mal genau ansehen.

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Wie bekomme ich heraus, an welchem Eintrag es hängt? Jetzt steht wieder in der Statusleiste: "Synchronisiere aufgrund des periodischen Syncs". Das macht er lt. Log alle 10 min seit ca. 15:00 Uhr. Davor steht bei zig Kontakten "... bereits aus dem Cache gelesen.

  • Das Loggen im Debug-Modus eingeschaltet?
    Schau dir die zu importierende .vcf-Datei Zeile für Zeile an.

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Moin,


    ich habe jetzt den Debug-Modus eingeschaltet und das Log angehängt.
    Es trat zwischenzeitlich der Effekt auf, dass in der Statuszeile stand: "Alle Synchronisierungen abgeschlossen" und ich ganz normal arbeiten konnte. Die Kontaktanzahl ist bei 189 geblieben. Nach einem manuellen Sync sowie nach einem Neustart hänge ich wieder da, wo ich am Anfang war: er scheint synchronisieren zu wollen, wird aber ewig nicht fertig, und ich kann mit CardBook nicht arbeiten. Ich habe weder auf der Cloud noch lokal irgendetwas an den Kontakten geändert.

    Dateien

    • log.txt

      (28,2 kB, 83 Mal heruntergeladen, zuletzt: )
  • Hallo reader,
    wenn die Synchronisation hängt, klicke unten auf die Cardbookleiste.
    Jetzt erscheint das Protokoll, hier müsstest Du die Adresse sehen können die als letztes bearbeitet wurde.
    Jetzt schaue Dir einmal den letzten Kontakt genau in der Ansicht "vCard" an.
    Hast Du hier andere Einstellungen wie bei anderen Kontakten.
    Es sollte auch bei allen neben PRODID: "ContactSync" eingetragen sein.
    Ich hatte auch mit einigen Kontakten Probleme, die Eintragungen von "MoreFunktiosForAddressBook" hatten.
    Alle diese Adressen habe ich exportiert und bearbeitet, die Kontakte in Cardbook gelöst und dann die bearbeiteten Kontakte wieder in Cardbook importiert.

    Gruß
    EDV-Oldi

  • Manche Leute laden auch 5MB-Bilder als Kontaktfotos hoch ...


    Schau dir mal in der Web-GUI der Owncloud die einzelnen Datensätze an und vergleiche mit der Gesamtsumme.
    Irgendwo ist ein Problem drin. Das beginnt bei der Bildgröße und geht bis hin zu unzulässigen Einträgen, Zeichen usw.


    Ja, ich weiß aus eigener Erfahrung (bei der Erstbefüllung), dass die Fehlersuche langwierig sein kann.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • edvoldi :
    Wenn ich das Log aufrufe steht da in der letzten Zeile: "2016.06.29 11:17:54:379 : default : debug mode : cardbookRepository.cardbookServerSyncDone : (new Number(189))". Woher weiß ich jetzt, welcher Kontakt das ist? Und wo finde ich die Ansicht "vCard"?
    "MoreFunktiosForAddressBook" hatte ich nie installiert da die Synchronisation mit SOGo bis zum System-Upgrade funktioniert hat und mir das so gereicht hat.


    Peter :
    Bilder habe ich nur drei, und die haben normale Größe.
    Das heißt also, dass ich mir jetzt alle 189 Kontakte einzeln vornehmen muss?

  • Und wo finde ich die Ansicht "vCard"?

    Hast Du das wirklich noch nicht gesehen?

    Wenn ich das Log aufrufe steht da in der letzten Zeile: "2016.06.29 11:17:54:379 : default : debug mode :

    Bei mir werden die einzelnen Kontakte Mit Namen dargestellt, ist das bei Dir nicht der Fall?
    Z.B.: 2016.06.29 11:14:56:965 : Hotels & Restaurants: Kontakt Hellas Grill
    Schalte den Debug-Modus wieder einmal aus.

    Gruß
    EDV-Oldi

  • Das hatte ich ganz am Anfang mal. Jetzt habe ich nur eine Liste mit den Kontakten. Wie komme ich in diese Ansicht?
    Debug kann ich gerade nicht abschalten, weil wieder alles grau ist. Und ich kann jetzt auch über die Add-On-Einstellungen nicht ran, weil ich im Moment damit arbeiten muss. Wenn etwas Luft ist, starte ich TB neu.