Thunderbird hängt in Endlosschleife beim Mailabruf

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:* Thunderbird-Version: 45.8.0.-1
    * Betriebssystem + Version: Arch Linux
    * Kontenart (POP / IMAP): IMAP
    * Postfach-Anbieter (z.B. GMX): auf eigenem Server: exim4 als MDA
    * Eingesetzte Antiviren-Software:
    * Firewall (Betriebssystem-intern/Externe Software):
    * Router-Modellbezeichnung (bei Sende-Problemen):


    ----------------------------------------------------------------------------------------------------------------------------


    Wenn ich Thunderbird starte hole es nicht mehr die Emails ab. Statt dessen sieht man unentweg die "Sanduhr" (ist jetzt ja so ein rotierender Kreis)
    Habe deswegen parallel nun auch Seamonkey installiert. Die Kontoeinstellungen sind die selben wie bei Thunderbird. Bei Seamonkey funktioniert alles.


    (Was mir noch aufgefallen ist: Bei Thunderbird lassen sich Kalendereinträge nicht mehr löschen.)


    ==> Um der Sache näher zu kommen, muss es doch irgendwo ein Log-Datei von Thunderbird geben. Aber ich finde auf dem Rechner nichts.
    ==> Wie kann ich dem Problem näher kommen/analysieren.

  • Haben zwecks Log-Dateierzeugung die beiden Variablen wie im Link oben beschrieben gesetzt:



    export NSPR_LOG_MODULES=imap:5,timestamp
    export NSPR_LOG_FILE=/tmp/imap.log


    Dann habe ich Thunderbird gestartet, welches in der Endlosschleife verharrte und keine Emails abholte. Dann im /tmp nach einer Datei imap.log geschaut. Keine vorhanden. Thunderbird geschlossen, nochmals in /tmp nachgesehen. Aber immer noch keine Datei. Lese/Schreibrechte für /tmp sind vorhanden.

    (Seamonkey dagegen zeigt mir die aktuellsten Emails an, legt aber auch keine log-Datei an).

  • Bei mir funktioniert es. Entgegen der Aussage in dem Dokument wird die Log-Datei auch bereits erstellt, während der TB noch läuft. Es kann natürlich auch sein, dass der TB gar nicht bis zum Schreiben des Files kommt, weil er bereits vorher feststeckt.

    Versuche zunächst einmal, den TB im safe-mode zu starten. Vielleicht ist Dein Problem dann schon erledigt. Fall nicht, starte den TB über folgendes Script:

    Code
    1. #!/bin/sh
    2. export NSPR_LOG_MODULES=imap:5,timestamp
    3. export NSPR_LOG_FILE=/tmp/imap.log
    4. thunderbird

    ggf. auch hier im safe-mode probieren.

    Wird damit immer noch kein Log geschrieben, könntest Du es noch mit Hilfe des in dem Artikel erwähnten TBTracers versuchen. Den habe ich persönlich noch nicht benutzt und weiß daher nicht, ob er mit der aktuellen Version läuft. Vermutlich erzeugt er eine noch weitaus größere Datenflut als das Logging des TB. Die Suche darin könnte also etwas mühsamer werden. Aber wie einer meiner Kollegen aus dem Rheinland so schön sagt: Versuch macht kluch.

  • Mit dem Script konnte ich nun eine Log-Datei schreiben. Ganz unten in der Log-Datei steht etwas von "failed creating protocol to play queued url:imap..." Habe danach natürlich schon gegoogelt, aber leider keine Lösung gefunden. Hier mal die komplette Log-Datei (IPs habe ich mal durch xxx ersetzt):



  • Hier mal die komplette Log-Datei

    Ist das wirklich die komplette Log-Datei? Für mich sieht sie aus, als würde einiges fehlen. Zum Beispiel der komplette Block zur Passwort-Übermittlung und das "login succeeded".

    Btw, Dein Server scheint STRARTLS nicht zu unterstützen. Das würde ich ändern.


    Was der Log-Eintrag ""failed creating protocol to play queued url:imap..." genau besagt, weiß ich auch nicht. Eine Suchmaschine führt mich jedoch u.a. zu diesem bug, in dem Brian Kennelly in Comment # 12 schreibt:

    Zitat

    This log entry, or its absence, does not indicate an error.


    Da kann sich aber auf den konkreten Kontext des bugs beziehen und muss hier nichts sagen.


    Da es vom selben Rechner aus mit Seamonkey funktioniert, liegt der Fehler augenscheinlich in der Konfig des TB. Dazu hatte ich oben schon dazu geraten:


    Versuche zunächst einmal, den TB im safe-mode zu starten. Vielleicht ist Dein Problem dann schon erledigt.

    Der nächste Schritt wäre dann ein Test mit einem neuen Profil.

  • also ich habe das Problem nun wie folgt gelöst:

    Einfach in Thunderbird das Konto gelöscht und wieder neu eingerichtet. Dann ging auch gleich wieder alles.

    Vielleicht ist noch erwähnenswert: ich glauben einer meiner Versuche war auch Thunderbird zu de- und dann neu zu instsallieren. Ich bin mir nicht sicher, aber dabei glaube ich wurden die Kontoeinstellungen gar nicht mitgelöscht sondern in der Neuinstallation übernommen ... ist jetzt aber auch schon etwas länger her, kann mich auch irren ...

    (würde den Thread jetzt als gelöst markieren ... kann man das in diesem Forum?)

  • Hallo BigMan,

    Vielleicht ist noch erwähnenswert: ich glauben einer meiner Versuche war auch Thunderbird zu de- und dann neu zu instsallieren. Ich bin mir nicht sicher, aber dabei glaube ich wurden die Kontoeinstellungen gar nicht mitgelöscht sondern in der Neuinstallation übernommen

    ja, dem ist wohl so. TB trennt zwischen Programm und Daten. Das Programm kannst Du deinstallieren, die Profildaten bleiben (wobei ich nun nicht sicher bin, ob TB vielleicht fragt, die Daten zu löschen). D.h., dass eine Neuinstallation in den allermeisten Fällen völlig sinnfrei ist, da Fehler i.d.R. im Profil stecken und nicht im Programm selber (das ist natürlich auch nicht fehlerfrei, verändert sich aber nicht oder nur durch Updates). Und TB findet nach einer erneuten Installation den alten Profilordner mit allen Daten wieder.


    Gruß

    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Da habe ich mich zu früh gefreut. Denn nachdem ich das Konto neu angegeben hatte, begann TB auch gleich die IMAP-Strukur aufzubauen und zeigte auch gleich die neuen Emails, was bislang nicht der Fall war. Doch jetzt hängt wieder alles.


    Was schon verunderlich ist:

    - Auf dem selben Rechner läuft auch Seamonkey, und dort klappt alles;

    - Auf einem Laptop habe ich ebenfalls TB und dort klappt es auch;

    ... und Laptop/Seamonkey haben die selben Kontoeinstellungen wie das nicht funktionierende TB (alles IMAP auf das selbe Email-Konto).


    Ich würde jetzt gerne TB komplett runterschmeißen ... also inkl. aller Profildaten, Konfiguration etc. Weiß jmd. wie das unter Arch Linux geht? $ pacman -Rns thunderbird scheint beim letzten Mal ja nicht ausreichend gewesen zu sein.

  • - Auf einem Laptop habe ich ebenfalls TB und dort klappt es auch;

    Du kannst einfach das Profil kopieren und das funktionierende Profil auf dem anderen Rechner nutzen. Vorher den Profilorder löschen (oder vielleicht zur Sicherheit erst einmal verschieben).


    Profilordner - Sichern und aus Backup wiederherstellen


    Gruß

    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite