ERROR in IMAP command MYRIGHTS: ACLs disabled


  • Problem:

    "ERROR in IMAP command MYRIGHTS: ACLs disabled" ist die (Fehler-) Meldung des Servers eines neu eingerichteten IMAP Kontos.


    Der Betreiber eduport sagt lediglich "es handelt sich um eine Inkompatibilität von Thunderbird"



    Versuch:

    Nach einem Hilfe-Hinweis habe ich mit dem Add-on "IMAP-ACL" Rechte zu ändern.

    Ergebnis: "Sie haben keine Berechtigung die Rechte für diesen Ordner zu ändern!"


    Und: Auf der "Liste aller ACLs" erscheinen die betroffenen Ordner / der neue Server nicht.



    Kann man Thunderbird die "Veruche abgewöhnen" (?!) , dort Rechte zu setzen?


    System:

    • Thunderbird-Version: 52.3.0
    • Betriebssystem + Version: Win7 prof SP1
    • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX): eduport (Behördennetz Hamburg)
  • Hallo!


    Ich habe über die Jahre noch nie gehört, dass Thunderbird eigenständig versucht die Berechtigungen bei IMAP-Ordnern zu verändern. Thunderbird fragt allerdings vermutlich die Berechtigungen bei dem IMAP-Server ab. Ich kann nicht sicher sagen, wo der Fehler liegt, würde aber nicht unterschreiben, dass es bei Thunderbird liegt.


    Der Versuch mit dem Add-on "IMAP ACL" erscheint mir eher kontraproduktiv, da dieses Add-on doch vermutlich erst Recht dazu gedacht ist, um solche Rechte zu bearbeiten/ändern.

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Mal anders herum gefragt: Hat der Betreiber eduport die ACL Extension für den IMAP-Server installiert? Beim Login auf dem Server meldet der ja seine "Capabilities" zurück. Die meisten Server haben die ACL Capability nicht - vielleicht hört man deshalb auch so gut wie nie von Problemen damit. Wenn ich ein Log von der Kommunikation mit den IMAP-Servern erstelle, taucht davon in meinem Fall für verschiedenste IMAP-Server absolut nichts auf. Meine Anbieter bieten die ACL-Capability allerdings auch nicht an, wie man im Log letztlich sieht.


    Da ich keine Login-Daten für eduport habe, kann ich davon natürlich kein Log erstellen... Das solltest Du mal machen, und dann im Log nach "CAPABILITY" suchen. In der Zeile könnte dann vielleicht ACL auftauchen.


    Vermutlich unternimmt Thunderbird nur dann weitere Aktionen, wenn ACL bei den Capabilities auftaucht und nur dann könnte der Fehler auftreten.

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Gruß zurück (an Thunder) :thumbsup:, und danke soweit. Ich würde gerne ein Log erstellen, Dummies brauchen dafür Hilfe (habe die Hilfe lange duchsucht und keinen Hinweis gefunden).



    Was ich sehe/kann ist unter extras/aktivitäten der Hinweis


    Der aktuelle Vorgang in "Gesendet" ist fehlgeschlagen. Der Server des Kontos "StS-old" antwortet: ERROR in IMAP command MYRIGHTS: ACLs disabled.


    Wobei "Gesendet" ein Verzeichnis auf dem Server ist und "StS-old" meine Namensgebung für den Problemserver.


    Ich habe mit Thunderbird diverse IMAP-Server verbunden (auch auf eigenen Webservern) und soetwas nie gesehen.


    Bitte: Wie starten Dummies Logs? :lupe:

    Danke


    p.s.: Doch noch etwas gefunden: https://wiki.mozilla.org/MailNews:Logging

    Das ergibt zwar ein neues Logfile wie beschrieben, aber bei Start oder Stop von Thuderbird gibt es keine Einträge (eben nur die oben genannte Fehlermeldung unter "extras/aktivitäten"

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von kallibird ()

  • Dann hast Du etwas falsch gemacht, oder vielleicht fehlen notwendige Berechtigungen im Betriebssystem (Admin-Rechte sind aber glaube ich gar nicht notwendig).


    Hast Du alles "brav" in der Kommandozeile eingegeben - auch das Starten des Thunderbird?

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Dann hast Du etwas falsch gemacht, oder vielleicht fehlen notwendige Berechtigungen im Betriebssystem (Admin-Rechte sind aber glaube ich gar nicht notwendig).


    Hast Du alles "brav" in der Kommandozeile eingegeben - auch das Starten des Thunderbird?

    sogar brraaaaavvvv!!!!


    Aber (test, test ....) wenn ich das dafür angefertigte batch NICHT als admin ausführe klappt es.


    Nun finde ich jede Menge für mich unverständliches (auch MYRIGHTS und CAPABILITY). Capability nur bei Kommunikation mit t-online, nicht mit dem Problemserver. Ist's recht, wenn ich das Log sende (oder sind da kritische Logindaten enthalten?).

  • Du kannst mir das Log in einer Konversation an mich senden, dann kommt nichts entscheidendes an die Öffentlichkeit.


    Theoretisch könnten da Passwörter drin stehen, die im Klartext oder auch kodiert oder verschlüsselt sein könnten. Ich schaue mir das dann bis Morgen früh an.

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Du kannst mir das Log in einer Konversation an mich senden, dann kommt nichts entscheidendes an die Öffentlichkeit.


    Theoretisch könnten da Passwörter drin stehen, die im Klartext oder auch kodiert oder verschlüsselt sein könnten. Ich schaue mir das dann bis Morgen früh an."

    Dateianhang "hier", dann wär's doch öffentlich ?!? .........

    ... sorry, gefunden, gesendet.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von kallibird ()

  • Guten Morgen!


    1.) Du brauchst nicht immer alles im Forum zu zitieren ;-)


    2.) Ich habe mir das Log-File ziemlich lange angesehen. Was ich gesehen habe wird Dich nicht direkt weiter bringen:


    Es werden 3 IMAP-Server verwendet:

    • Einer der Server bietet von sich aus bei "Capability" gar nicht die Option ACL an (so wie bei den meisten Postfachanbietern). Hier gibt es dann auch keinen Fehler im Zusammenspiel mit Thunderbird.
    • Der ältere individuelle Server sts-old scheint ein Cyrus IMAP-Server zu sein und bietet ACL. Dort geht es ohne Probleme.
    • Der neuere individuelle Server von eduport ist ein Dovecot IMAP-Server und bietet auch ACL. Dort gibt es das "Problem". Warum das so ist kann ich als "Amateur" aber nicht erkennen.

    Ich kenne leider keinen anderen Dovecot-Server, der ACL unterstützt, mit dem ich testen könnte. Was mich wundert ist, dass es im Internet kaum Fehlermeldungen dazu gibt, mit denen man dem Problem auf die Spur kommen könnte.

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Beim Login auf den Servern, melden beide die allgemeinen Rechte zurück: ACL RIGHTS=kxte


    • Der "alte" Cyrus-Server meldet bei der Abfrage für einzelne IMAP-Ordner die Rechte zurück: MYRIGHTS INBOX lrswipkxtecda.
    • Der "neue" Dovecot-Server bringt an genau der Stelle jeweils den Fehler und meldet letztlich keine Rechte zurück. Könnte es sein, dass man am Dovecot-Server irgendwas anders konfigurieren muss oder zumindest könnte. Das sollte man den Admin des Servers mal fragen.


    Außerdem sind hier mal ein paar Einträge auf BugZilla, die damit zusamen hängen könnten:


    Ein vielleicht vergleichbares Problem, das man bei Roundcube mal behoben hat:


    Wäre schön, wenn man den Admin bei eduport auf dieses Thema / diesen Beitrag hier aufmerksam machen könnte. Vielleicht hilft es bei der Problemlösung.


    Ich bin dann mit meinem Latein am Ende ;-)

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Hallo THUNDER,


    GANZ GROßEN DANK für deine Hilfe. Ich veruche bei Eduport jetzt weiteren Support zu erhalten. Ich melde mich mit (hoffentlich positiven finalen Ergebnissen) zurück.


    Nette Grüße

    kallibird

  • Hallo THUNDER, noch'n Dank für deine Hilfe.


    Eduport hat den Widerstand aufgegeben, einen Fehler erkannt und beseitigt, jetzt klappts.


    Das war's

    :thumbsup: