Skriptprobleme wegen Provider für Google Kalender

  • Hallo zusammen,


    ich habe mein Wochenende mit einem Phänomen verbracht und habe es nicht lösen können.

    Ohne, dass sich erkennbar etwas geändert hat, bleibt der Thunderbird wegen Skriptfehlern stecken
    und verweigert die weitere Arbeit.

    Das Problem ist aber nicht auf einen Rechner beschränkt, sondern betrifft drei meiner sieben Rechner im Netzwerk.
    Und das gleichzeitig. Andere Rechner funktionieren noch.


    Es geht immer um Windows10-Rechner mit Thunderbird 52.4.0. Die Synchronisation mit den Google-Kalendern
    erfolgt über Provider für Google Kalender 3.3.


    Gibt es irgendein Problem zwischen diesen Versionen? Ich habe mir einen Rechner vorgenommen und
    Thunderbird neu installiert, Provider für Google Kalender neu installiert, anderes Windows-Profil versucht.
    Und nun weiß ich gerade nicht mehr, wo ich noch ansetzen soll.


    Hat noch jemand eine Idee oder gleiche Erfahrungen gemacht?


    Vielen Dank

    Jadokus

    Einmal editiert, zuletzt von Jadokus ()

  • Hallo Jadokus und Willkommen im Forum,

    Ich habe mir einen Rechner vorgenommen und
    Thunderbird neu installiert,

    das ist zu 99% unnötig.
    Wenn es ein Problem gibt, liegt diese fast immer im Thunderbird Profil.

    Die Synchronisation mit den Google-Kalendern
    erfolgt über Provider für Google Kalender 3.3.

    Wie kommst Du auf die Idee das es an dieser Erweiterung liegt?

    Es gibt sporadisch Probleme mit Script-Fehlern, die kommen aber meisten nach einer Fehlerhaften Installation einer Erweiterung.

    Versuch es bitte einmal im Abgesicherter Modus.
    Das dient nur zum testen, und ist keine Lösung des Problems!

    Über: Hilfe>Mit deaktivierten Add-ons neu starten ...


    Oder starte Thunderbird im abgesicherten Modus, indem du gleichzeitig auf die Umschalttaste drückst, während du TB startest.

    Im Safe-Mode ist mein Problem behoben. Was nun?

    Komisch ist auch das mehrere Rechner im Netzwerk betroffen sind, Virus?


    Gruß
    EDV-Oldi

  • Hallo EDV-Oldi,


    danke für die schnelle Rückmeldung und das freundliche willkommen.

    Ich habe TB im abgesicherten Modus gestartet und das Problem ist weg,
    wenn die Google-App deaktiviere. Dann läuft auch Lightning, aber synchronisiert nicht mehr.


    Ein Virus? Natürlich theoretisch immer möglich. Auf allen Rechnern laufen dauerhaft Virenscanner.
    Dann müsste was durchgeflutscht sein. Ich sehe aber keinen Grund, warum ein Virus im Netzwerk
    vor manchen Rechnern halt machen sollte, das Virenschutzprogramm ist überall gleich.


    Hast Du noch eine Idee?

  • Hallo Jadokus,

    mache eine Datensicherung des Thunderbird-Profils,

    lösche in Lightning alle Google Kalender, deinstalliere den Provider, beende Thunderbird.
    Lösche im Thunderbird-Unterordner "calendar-data", alle Daten außer die "local.sqlite".

    Starte Thunderbird und installiere wieder den Provider, starte Thunderbird einmal neu und richte dann alle Google-Kalender in Lightning wieder ein.


    Gruß
    EDV-Oldi

  • Hallo EDV-Oldi,


    das hat leider nicht geholfen. Aber ich bin trotzdem einen Schritt weiter: Es ist nicht das Google Add-on, sondern ein Kalender,
    der zum Skriptfehler führt, sobald er importiert ist.
    Hierbei handelt es sich um einen den einzigen Kalender, der auf den betroffenen Rechnern nur die Nichtverfügbarkeit anzeigt, aber keine Details. Das erklärt auch, warum mein Rechner nicht betroffen ist: ich darf alle Details sehen.

    Ist irgendwas bekannt, dass Thundebird bzw. das Google-Add-on neuerdings empfindlich auf Kalender reagiert, die keine Details zeigen?
    Das hat ja bis vor kurzem einwandfrei funktioniert...


    Danke!

    Jadokus

    Einmal editiert, zuletzt von Jadokus ()

  • Hallo Jadokus,

    Ist irgendwas bekannt, dass Thundebird bzw. das Google-Add-on neuerdings empfindlich auf Kalender reagiert, die keine Details zeigen?

    von diesem Problem höre ich das erste mal.

    Frage doch bitte einmal hier:

    https://groups.google.com/foru…vider-for-google-calendar

    nach, Hier liest der Entwickler vom Provider mit.


    Gruß
    EDV-Oldi

  • Beschreibe Dein Problem dort so genau wie möglich, am besten noch mit einer Anleitung wie bei Dir der Fehler auftritt.

    Je genauer Du den Fehler beschreibst, um so eher bekommst Du dort eine Antwort.
    Und wenn Du eine Lösung hast bitte das auch hier bekanntgeben.


    Gruß
    EDV-Oldi

  • Hallo EDV-Oldi,


    ich wollte Dir noch eine kurze Rückmeldung geben. Im Google-Forum habe ich keine leider Antwort bekommen.
    Als Versuch habe ich einen neuen privaten Kalender angelegt und freigegeben. Alles gut, kein Scriptfehler.

    Dann habe ich alle Termine aus dem alten Kalender exportiert und in den neuen Kalender importiert.
    Prompt war der Fehler wieder da. Also habe ich angefangen, Termine zu löschen. Nachdem ich nun einen Serientermin
    gelöscht habe, scheint es zu funktionieren.


    Vielen Dank für Deine Hilfe