Einfügen aus Zwischenablage löscht Spaces (Problem bei formatiertem Text)

  • Hallo,

    möchte einen, durch ein Programm erzeugten formatierten Text (ergibt Tabelle), der in der Zwischenablage liegt, in eine Mail mit STRG + V einfügen.

    Leider gehen dabei die Leerzeichen verloren.


    Statt

    | Rechnungsbetrag | ......................................| 25,44 EUR | (Punkte sollen blank sein. Blanks löscht dieser Editor hier im Forum auch raus.)


    wird folgendes in die Mail eingefügt:

    | Rechnungsbetrag | 25,44 EUR |


    Der einzufügende Text liegt in der Zwischenablage in einer nichtproportionalen Schriftart vor.

    Wenn ich den Text in z.B. Notepad kopiere dann ist alles in Ordnung.


    Vielen Dank für die Hilfe.

    ---------------------------------------------------------------------

    Windows 10 1903 / Thunderbird 60.9.0 (32-Bit) /

  • Es wäre mir neu, dass Thunderbird beim Einfügen die Leerzeichen löscht.


    In einem kurzen Test ergibt sich bei mir Folgendes:


    Beim Verfassen einer Reintext-Nachricht bleiben die Leerzeichen erhalten.

    Beim Verfassen einer HTML-Nachricht bleiben die Leerzeichen ebenfalls erhalten und das komplette HTML (in diesem Fall aus dem Quelltext-Editor "Visual Studio Code" wird ordentlich umgesetzt/erhalten.


    Blanks löscht dieser Editor hier im Forum auch raus.

    Ja, der Editor im Forum ist eine aktive Anwendung, die solche Dinge (leider) entfernt.

  • Hallo,

    vielen Dank für die Antwort.

    Arbeite schon seit etlichen Jahren mit Thunderbird, habe mich aber noch nie mit dem "Maschinenraum" von Thunderbird beschäftigt.

    Ich drücke "verfassen" und stelle dann über Optionen / E-Mail-Format "nur Reintext" ein und mache dann mein Strg+V. Trotzdem sind die Blanks weg. Was mich wundert, das die ganzen Einstellelement für Fettdruck, Unterstreichung usw. noch auswählbar sind. Das sollte bei Reintext doch nicht möglich sein, oder?


    Wie bereits geschrieben funktioniert die Sache in Notepad. Wenn ich dort den Asciicode der Zeile:


    | Rechnungsbetrag...……………………………………………. | 35,50 € | (punkte == blanks)


    anzeige, dann sieht das so aus:


    207C20526563686E756E677362657472

    61672020202020202020202020202020

    20202020202020202020202020202020

    202020202020202020202020207C2033

    352C353020E282AC207C


    Danke

  • Ich drücke "verfassen" und stelle dann über Optionen / E-Mail-Format "nur Reintext" ein

    In Deinem Fall ist damit das Verfassen-Fenster im HTML-Modus geöffnet und Du erstellst eine HTML-Nachricht, die anschließend aber nur als Reintext gesendet wird. Sie wird also quasi nachträglich für den Versand "vereinfacht", um den Ansprüchen des Empfängers gerecht zu werden. Deshalb gibt es dort in den Optionen auch die Möglichkeit "Automatisch bestimmen" (wählt die Einstellung dann aus dem Adressbuch für den jeweiligen Empfänger) und auch "Reintext und HTML" (sendet dann in beiden Formaten innerhalb der einen E-Mail).


    Bei Dir ist in den Konten-Einstellungen für das entsprechend Konto voreingestellt, dass als "HTML" verfasst werden soll. Das kann man in den Konten-Einstellungen für jedes Konto getrennt festlegen. Beim Aufrufen des Verfassen-Fensters per Klick auf den "Verfassen"-Button kann man die Umschalt-Taste zusätzlich drücken. Damit wechselt man zwischen HTML und Reintext (abhängig von der jeweiligen Einstellung des jeweiligen Kontos) schon für das Erstellen der neuen Nachricht.


    Das macht bei mir aber letztlich keinen Unterschied. In beiden Varianten (HTML-Modus und Reintext-Modus des Verfassen-Fensters) werden die Leerzeichen für diese "Pseudo-Tabelle" ordentlich mit eingefügt, sodass bei einer Schriftart mit fester Breite alles korrekt wie eine Tabelle angezeigt wird:



    Ich habe daher den Verdacht, dass bei Dir entweder schon das Ursprungs-Programm die Leerzeichen beim Kopieren entfernt (glaube ich nicht) oder Du verwendest ein Tool für die Zwischenablage, das dafür verantwortlich sein könnte.

  • Hallo,

    suuuper, funktioniert vielen Dank!!

    Frage: Ob ich in meiner Identität aber " "Nachrichten im HTML-Format verfassen" on oder off habe spielt keine Rolle. Wie kann das auch an der Identität hängen wenn man ja zuerst Verfassen (mit shift) drückt und dann erst die Indentität wählt? Also Reintext oder HTML weis ich nicht wie man das unterscheidet.

    Ein Handicap gibt es noch. Bei ca. 100 Zeichen bricht Thunderbird den Text um. Gibt es da noch etwas einzustellen? Vielleicht hat Reintext oder HTML da noch eine positive Auswirkung bzgl. dem Umbruch?

    Gruß

    Winni

  • Hintergrund meiner Aktivitäten: Ich möchte aus Libre Office heraus eine Auftragsbestätigung über Thunderbird verschicken. In einem ersten Schritt soll das mit einer nicht proportionalen Schriftart als Tabelle (Bestellpositionen) und Text (z.B. AGB) ausgegeben werden. Das klappt ja jetzt mit Strg+V. Der AB-Text wurde vorher per Makro in Libre-Office autom. erstellt und in die Zwischenablage kopiert.

    In einem weiteren Schritt soll die AB vielleicht schöner werden mit unterschiedlichen und schöneren Schriftarten….. aber schauen wir mal :-)

  • Was genau hat Dir denn jetzt bezüglich der Leerzeichen geholfen?


    Wenn man im schon offenen Verfassen-Fenster die Identität ändert oder sogar als Absender eine Adresse eines ganz anderen Kontos auswählt, dann ändert dies am Reintext-/HTML-Modus des Fensters nichts mehr. Im Prinzip müsste man schon davor links in der Konten-/Ordner-Liste einen passenden Ordner anwählen, der mit der gewünschten Absender-Adresse übereinstimmt. Womöglich würde es da auch helfen, wenn man eine absolut passende E-Mail in den Ordnern anwählt, die zu der gewünschten Absende-Identität passt (keine Ahnung, ob das funktioniert).


    Wenn ich nicht irre sind folgende 3 Einstellungen für den Zeilenumbruch (im Konfig-Editor) dafür verantwortlich:

    • Beim Verfassen / Senden schon umbrechen: plain_text.wrap_long_lines true oder false
    • Beim Lesen / bei der Anzeige empfangener Mails: mail.wrap_long_lines true oder false
    • Die resultierende Länge, nach der umbrochen wird (wenn ein Leerzeichen da ist): mailnews.wraplength Integer-Wert (also eine "glatte" Zahl)
  • In einem weiteren Schritt soll die AB vielleicht schöner werden mit unterschiedlichen und schöneren Schriftarten….. aber schauen wir mal

    Du weist schon, dass es dafür keinen Standard im E-Mail-Verkehr gibt? Jeder Empfänger kann Deine schön formatierte Mail zerschießen, wenn er bei sich andere Schriftarten oder auch einen zwangsweisen Zeilenumbruch eingestellt hat, der nicht Deiner Vorstellung entspricht. Verzichte zumindest auf großartig tabellarische Dinge in den Mails. Im Zweifelsfall erstelle lieber PDFs, die Du als Anhang mit den Mails sendest.

  • Quote

    Im Prinzip müsste man schon davor links in der Konten-/Ordner-Liste einen passenden Ordner anwählen, der mit der gewünschten Absender-Adresse übereinstimmt.

    Im Kontextmenü der jeweiligen Ablage fehlt die Option Mail verfassen, vielleicht funktioniert das aber nur bei lokalen Ordnern? Bei mir liegt alles auf dem Mailserver.

    Quote

    Beim Verfassen / Senden schon umbrechen: plain_text.wrap_long_lines true oder false

    wird doch nicht nötig sein, aber sehr interessant !

    Quote

    Verzichte zumindest auf großartig tabellarische Dinge in den Mails. Im Zweifelsfall erstelle lieber PDFs, die Du als Anhang mit den Mails sendest.

    Ja, natürlich, bin mir aber nicht sicher ob jeder Empfänger eine PDF auch öffnen kann. Besonders etwas ältere Mailempfänger sind da nicht so firm.

  • ob jeder Empfänger eine PDF auch öffnen kann. Besonders etwas ältere Mailempfänger sind da nicht so firm.

    Wenn es einen Standard für Dokumente quer über alle möglichen Geräte und Systeme hinweg gibt, dann PDF. Letztlich sollte das nicht Dein Problem sein, sondern das Deiner Kuden(?). Du musst eine rechtssichere Auftragsbestätigung versenden, denke ich. Du hättest ja auch die Möglichkeit einer einfachen Reintext-Mail (ohne großartige Tabellen) plus PDF im Anhang.


    wird doch nicht nötig sein, aber sehr interessant !

    Das steht standardmäßig auf auf true. Somit werden die Zeilen beim Senden umbrochen.


    Im Kontextmenü der jeweiligen Ablage fehlt die Option Mail verfassen

    Du sollst nicht im Kontextmenü auf "Verfassen" klicken, sondern dort in der Konten-/Ordner-Liste nur einen zur Identität passenden Ordner auswählen und dann in der Toolbar auf "Verfassen" klicken. Das funktioniert zumindest für den korrekten Absender zum passenden Konto (und vielleicht halt auch für die genaue Identität).

  • Quote

    Du sollst nicht im Kontextmenü auf "Verfassen" klicken, sondern dort in der Konten-/Ordner-Liste nur einen zur Identität passenden Ordner auswählen und dann in der Toolbar auf "Verfassen" klicken

    Ja gemacht aber da ändert sich bei mir mit HTML On und OFF nichts

  • Ich werde jetzt wahrscheinlich die Auftragsbestätigung ohne Tabelle aufbauen. Zu viele Kommentare, u.a. hier im Forum, warnen vor einer unkorrekten / verschobenen Darstellung beim Empfänger.

    Ggf. werde ich noch später ein PDF dazu hängen …. doppelt hält besser.


    Danke an alle Helfer - bin jetzt auch tiefer in Thunderbird eingestiegen und hoffe das ich auch mal helfen kann. Ist einfach ein tolles Programm :thumbsup: