Abgetrennte eMail-Anhänge werden seit 68.? bei Anzeige der eMail abgerufen - dauert ewig bei Netzwerkpfad und langsamer Internetverbindung

Wenn Sie plötzlich keine E-Mails mehr empfangen können

Bitte lesen Sie die Hinweise zu den beiden derzeit häufigsten Problemursachen!

Hier bitte klicken!

Diese rote Box verschwindet, wenn Sie in der rechten oberen Ecke auf das X klicken.

    • Thunderbird-Version (konkrete Versionsnummer): 68.10.0
    • Betriebssystem + Version: Ubuntu 18.04.5 LTS 64bit
    • Kontenart (POP / IMAP): IMAP
    • Postfachanbieter (z.B. GMX): greensta.de
    • Speicherdienst (z.B. Dropbox): –
    • Eingesetzte Antivirensoftware: keine
    • Firewall (Betriebssystem-intern/Externe Software): keine


    Hallo,


    ich trenne eMail-Anhänge in einen Ordner ab, der mit SSHFS übers Internet eingebunden ist (Thunderbird weiß also nicht, dass es ein "Netzwerkpfad" ist.) Seit einem Update vor einiger Zeit werden beim Aufrufen einer eMail die abgetrennten Anhänge komplett geladen (um die Dateigröße anzuzeigen?). Bei langsamer Internetverbindung & großen Anhängen braucht das ewig und blockiert Thunderbird. Vor besagtem Update bestand das Problem nicht.


    Wer kann helfen:

    Mit welcher Änderung entstand dieses Verhalten?

    Ist das konfigurierbar?



    Vielen Dank & Grüße,

    Johannes

  • Ich kann mir eigentlich nicht vorstellen, dass dies wirklich so sein soll. Mit Thunderbird 68 hatte ich mich ja noch ziemlich tiefgreifend mit dem Abtrennen von Anhängen beschäftigt, um das Add-on "AttachmentExtractor Continued" anzupassen. Der 68er hat sich gegenüber dem 60er so geändert, dass abgetrennte Anhänge mit einem Direktlink in den Mails referenziert werden, um den Speicherort per Klick öffnen zu können. Der Code war/ist aber meines Erachtens so, dass da nichts automatisch geladen wird. Ich lasse mich aber gerne eines Besseren belehren, falls es doch so sein sollte.

  • Hallo thunder,
    doch, da muss sich was geändert haben. Dieses Verhalten gab es früher nicht. Hier mal ein Bildschirmfoto während der Anhang geladen wird

    und danach:

    Ich habe als Landwirt "im Sommer" viel zu tun gehabt und deshalb nicht gleich recherchiert, deswegen weiß ich leider nicht, mit welcher Version diese Änderung gekommen ist.

    Vielen Dank & Grüße,

    Johannes

  • Du meinst den rotierenden Pfeil, der in dem einen Screenshot gezeigt wird? Das habe ich noch nie gesehen, allerdings lagen die Attachments bei mir auch immer auf der lokalen Festplatte.


    Prinzipiell hast Du aber Recht. Thunderbird greift tatsächlich auch auf abgetrennte Anhänge zu, wenn er diese am referenzierten Ort findet, um deren Größe weiterhin in der Benutzeroberfläche anzeigen zu können. Das war mir gar nicht mehr bewusst. Ich habe dies jetzt aber mal mit Version 60, 68 und 78 getestet. Alle 3 haben dieses Verhalten. Eine ältere Testinstallation habe ich nicht mehr. Auf BugZilla kann ich auch gerade keinen passenden Bug finden, in dem dies diskutiert und eingebaut wurde.


    Ich wüsste jetzt leider auch keine Pref, mit der man das Verhalten abschalten könnte, werde dazu aber mal einen Bug erstellen:

    https://bugzilla.mozilla.org/show_bug.cgi?id=1669712

  • Hallo Thunder,

    ja genau, den rotierenden Pfeil meinte ich. Herzlichen Dank für das Erstellen des Bugs! Hoffentlich gibt es dann bald eine Lösung.


    Viele Grüße,

    Johannes

  • Nachtrag:

    Noch ein nerviges Fehlverhalten:

    Nach dem Klick auf eine andere eMail wird, solange der Anhang nicht geladen ist, noch der alte Link mit dem Anhang der vorherigen eMail angezeigt. Beispiel siehe Bild:

    Dafür sollte sicher besser ein eigener Bugreport erstellt werden, oder?


    Besten Dank & Gruß,

    Johannes