OpenPGP: TB 78.3.2 - Ungültige digitale Unterschrift doch gültig!

  • Hallo zusammen,


    ich habe mal wieder einen vermeindlichen "Fehler" in TB 78 und bin mir unsicher, ob es wirklich ein Fehler ist. Evtl. könnte ihr das ja mal gegenprüfen.


    Also ich nutze seit Jahren Enigmail mit TB. Seit der Umstellung auf Version 78 (jetzt natürlich ohne Enigmail) habe ich ein Problem mit verschlüsselten und unterschriebenen Mails.


    Sehe ich mir die Mail im Posteingang via "Nachrichtenbereich" an, also der Cursor steht auf der ungeöffneten Nachricht und ich drücke F8, dann sehe ich, dass die Unterschrift ungültig ist. Klicke ich auf das entsprechende Icon, erscheint folgendes Bild:



    Nun öffne ich die Mail mit einem Doppelklick in einen eigenständigen Tab, so erscheint folgendes Bild:



    Oh Wunder, aus einer "ungültigen digitalen Unterschrift" wird durch einen Doppelklick bei der selben Mail plötzlich eine "Gute digitale Unterschrift".


    Gegenprobe mit Enigmail unter TB 68, zeigt natürlich auch, dass die Unterschrift gültig ist.


    Schließe ich den Tab wieder, zeigt auch das Vorschaufenster / Nachrichtenbereich, dass die Unterschrift gültig ist.


    Hat jemand eine Idee dazu?

  • Ich meine, das ist ein Bug. Er tritt bei mir zunächst mit jeder neuen signierten E-Mail auf. Es genügt dann, einfach eine andere E-Mail anzuklicken und dann wieder auf die signierte zurückzugehen. Danach wird die Signatur als gültig erkannt und bleibt es auch bei weiteren Aufrufen.

    Das ist nicht tragisch, aber unschön, weil doch gerade sie Signatur sicheres Vertrauen geben soll. So hat es etwas von Voodoo und wird dann vielleicht manchen doch etwas verunsichern.

  • Es genügt dann, einfach eine andere E-Mail anzuklicken und dann wieder auf die signierte zurückzugehen.

    ....oder so. :)


    Danke für die Rückmeldung. Dachte mir schon, dass das kein Bedienfehler war.

  • Moin,

    nun, bei mir brach auch nach dem Update auf 78.3.2 (64-Bit Linux) das Chaos aus.



    Dann mußte ich alle Schlüssel nochmal bearbeiten, den Konten zuordnen, usw., und der oben beschriebene Effekt trat noch verschärfter auf, denn die Anzeige wechselt immer wieder zwischen Signatur o.k. und, beim nächsten Anklicken, Signatur kaputt.

    Das hat schon mal besser funktioniert.


    Grüße,

    muzel

  • Oh, das klingt nicht gut. Da bin ich mal wieder froh ob meiner konservativen Upgrade-Strategie auf meinem produktiven Linux-Systemen. Dort bin ich immer noch auf der 68 und GnuPG. Ich kann es deshalb nicht reproduzieren.

    Die Fehlermeldung lässt vermuten, dass es sich um Problem handelt, das nur die Linuxversion und den Import aus dem secring betrifft. Die 78.3.1 hat gegenüber der 78.3.0 meines Wissens nur diesen Update-Bug gefixt. Der sollte hier keine Rolle spielen. Es würde mich nicht wundern, wenn hier die Besonderheit des agents wieder zugeschlagen hat. Hast du es denn lösen können?

  • Ist natürlich nur ein Testprofil - "produktiv" ist nach wie vor die 68, etwas neueres gibt ja die Paktetverwaltung von Mint/Ubuntu auch nicht her. Die gerade "drübergebügelte" 7.3.3 verhält sich ähnlich, aber irgendwie auch "zufällig" - meistens ist die Signatur gültig, manchmal aber auch nicht...

    "Agentenprobleme" hatte ich in letzter Zeit keine.

  • "Agentenprobleme" hatte ich in letzter Zeit keine.

    Na dann ist die CIA entweder besser geworden oder sie hat dich nicht mehr auf dem Radar. ;)


    Heute gab es hier Meldungen über Probleme mit den Sprachpaketen unter SuSE. Hast du wahrscheinlich gelesen. Ich würde sagen, unter Linux ist noch Zurückhaltung angesagt.

  • Der Fehler scheint unter Windows 10 - TB 78.3.3 - also der neuen aktuellen Version - weg zu sein.


    Unter kubuntu [ubuntu-snap-build 1.0] - TB 78.3.2 (!!) war er übrigens nicht vorhanden.


    Also alles wieder gut.