verweigert der Server den Zugang (mit dem Zeitablauf)
Gibt es eine Fehlermeldung, und falls ja, welche?
obwohl das Passwort unter Gespeicherte Passwörter richtig eingetragen wurde.
Diese Aussage kann unterschiedlich interpretiert werden.
Entweder willst du ausdrücken, dass das PW für den SMTP-Server jetzt im PW-Manager gespeichert ist, oder du hast nur das (gültige) PW für den Posteingang-Server gesehen und meinst, das würde ausreichen.
Auch wenn das PW für deinen Posteingang-Server das selbe ist wie das für den Postausgang-Server, es muss für jeden Server extra gespeichert werden.
Ein fehlerhaftes PW kann übrigens im PW-Manager bearbeitet werden
Bitte schaue auch in den Konten-Einstellungen > Kontenname (ganz unten) nach, ob der richtige SMTP Server ausgewählt ist, falls mehrere SMTP Server existieren.