automatisches Backup 7Zip

  • Quote from "rst"

    Hallo Gerhard,


    die Meldung besagt, dass der Taskplanerdienst nicht gestartet ist. Guck mal in der Systemsteuerung unter Verwaltung -> Dienste ob der Dienst "Taskplaner" gestartet ist. Wenn nicht, dann starte ihn mal und versuche dann noch mal in dem Task etwas zu ändern.


    Gruß,
    Robert


    Hallo Robert,


    laut Systemsteuerung ist der Taskplaner deaktiviert. Unter dem Reiter "Anmelden" erhalte ich den folgenden Screenshot


    Lieben Gruß
    Gerhard


  • Quote from "rst"

    Okay. Kannst du in dem Reiter (in dem Fenster oben) Allgemein, in der Mitte auf aktivieren klicken? Zur Verdeutlichung ein Screenshot:


    Ich meine dort, wo der Mauszeiger zu sehen ist (bei mir ausgegraut, weil der Deinst bei mir läuft).


    Gruß,
    Robert


    Hallo Robert,


    beim erneuten Hochfahren meines Rechners war es überraschenderweise möglich, den Task entsprechend Deinen Vorgaben zu berichtigen.


    Aber so langsam weiß ich nicht mehr weiter, weil jedes Mal ein neues Problem auftaucht. Zuletzt konnte ich den Unterordner Backups noch öffnen und Dir den entsprechenden Screenshot schicken. Mittlerweile geht auch das nicht mehr:


    Wenn ich den Unterordner Backups doppelklicke, erscheint "-2006-06.7z". Darauf gehe ich mit Rechtsklick und es erscheint "Öffnen mit...". In der Auswahl befindet sich nicht das Programm 7-Zip. Beim "Durchsuchen" erhalte ich unter Programme zwar 7-Zip, aber mit den dortigen Dateien kann ich den Unterordner auch nicht öffnen.


    Wo "stolper" ich?


    Gruß und Dank
    Gerhard

  • Nabend Gerhard,


    wenn in dem Ordner nur die Datei "-2006-06.7z" ist, dann ist schon etwas schief gelaufen. Das Backup hat nur das Datum als Namen und das ist nicht richtig. Davor müsste noch etwas stehen, z.B. TB-BACKUP-2006-06.7z". Das heißt in der Ausführen-Zeile des Tasks stimmt irgendwas nicht. Was hast du dort eingegeben?


    Screenshot: Ich meine die Zeile, wo die Maus hinter steht.
    7z_backup_ausfuehrenzeile.png


    Gruß,
    Robert


  • Dann von mir jetzt einen schönen guten Morgen, Robert,


    In meiner Ausführen-Zeile steht: "D:\Dokumente und Einstellungen\uu\Desktop\TB-Backup.bat" TB-BACKUP "D:\Dokumente und Einstellungen\uu\Andwendungsdaten\Thunderbird"


    Wenn es korrekt geklappt hat, sind das die Code-Zeilen aus Deinem Beitrag vom 30.06. (13.25 Uhr). Ich habe sie kopiert und in meiner Ausführen-Zeile eingefügt. Liegt der Fehler möglicherweise an dem d in "Anwendungsdaten"?


    Erübrigt sich bei korrekter Eingabe der Ausführen-Zeile mein geschildertes Problem mit dem Öffnen dieses Unterordners?


    Dank und Gruß
    Gerhard

  • Quote from "Naturfreund"


    Dann von mir jetzt einen schönen guten Morgen, Robert,


    In meiner Ausführen-Zeile steht: "D:\Dokumente und Einstellungen\uu\Desktop\TB-Backup.bat" TB-BACKUP "D:\Dokumente und Einstellungen\uu\Andwendungsdaten\Thunderbird"


    Wenn es korrekt geklappt hat, sind das die Code-Zeilen aus Deinem Beitrag vom 30.06. (13.25 Uhr). Ich habe sie kopiert und in meiner Ausführen-Zeile eingefügt. Liegt der Fehler möglicherweise an dem d in "Anwendungsdaten"?


    Ich habe gerade versucht, die Ausführen-Zeile entsprechend zu berichtigen, komme mit dem Cursor aber nicht weiter als bis "...\uu\Desktop\TB-Backup.bat".


    Erübrigt sich bei korrekter Eingabe der Ausführen-Zeile mein geschildertes Problem mit dem Öffnen dieses Unterordners?


    Dank und Gruß
    Gerhard

  • Moin Moin Gerhard,


    das d ist zuviel. Das muss raus. Sorry!
    Versuch dann noch mal den Task auszuführen.


    Gruß,
    Robert

  • Quote from "rst"

    Moin Moin Gerhard,


    das d ist zuviel. Das muss raus. Sorry!
    Versuch dann noch mal den Task auszuführen.


    Gruß,
    Robert


    Hallo Robert,


    ich habe jetzt den Code nochmals wie folgt eingegeben:


    "D:\Dokumente und Einstellungen\uu\Desktop\TB-Backup.bat" TB-BACKUP" D:\Dokumente und Einstellungen\uu\Anwendungsdaten\Thunderbird"


    anschließend auf "Übernehmen" geklickt und die Aufforderung, ein Kennwort festzulegen, mit OK übersprungen, dann den Fehlerhinweis erhalten "0x80070005: Zugriff verweigert. Sie haben nicht die nötigen Rechte, um diesen Task auszuführen".


    Als nächstes habe ich im Ordner D den Unterordner Backups geöffnet und erhalte erneut die Datei "-2006-06.7z", für die ich dann kein Programm zum Öffnen finde. Aber hier fehlt ja immer noch vorangestellt TB-BACKUP.


    Kann ich Dir mit diesen Angaben helfen, mir zu helfen? Oder fehlen Dir noch bestimmte Angaben?


    Dank und Gruß
    Gerhard

  • Nabend Gerhard,


    Quote from "Naturfreund"

    anschließend auf "Übernehmen" geklickt und die Aufforderung, ein Kennwort festzulegen, mit OK übersprungen, dann den Fehlerhinweis erhalten "0x80070005: Zugriff verweigert. Sie haben nicht die nötigen Rechte, um diesen Task auszuführen".

    Du musst hier das Kennwort eingeben, dass du auch eingibst, wenn du dich unter Windows anmeldest. Sonst werden die Änderungen nicht übernommen.


    Gruß,
    Robert

  • Quote from "rst"

    Nabend Gerhard,


    Du musst hier das Kennwort eingeben, dass du auch eingibst, wenn du dich unter Windows anmeldest. Sonst werden die Änderungen nicht übernommen.


    Gruß,
    Robert


    Grüß Dich Robert,


    da mir ein Kennwort für die Windows-Anmeldung nicht bekannt ist, habe ich es mit dem Kennwort versucht, mit dem ich meine Internet-Verbindung herstelle. Aber das ist wohl falsch, weil ich wieder den obigen Hinweis auf meine Zugriffverweigerung erhalte.


    Lieben Gruß
    Gerhard

  • Oh je, ein Grund mehr, WindowsXP zu hassen wie die Pest. Nutzer, die ihr eigenes Kennwort nicht kennen. Danke Microsoft, danke Billy, du sorgst dafür, das unsere Nutzer schön verdummen!.

  • Hallo Gerhard,


    wie meldest du dich denn unter Windows an, wenn du das Kennwort nicht kennst?
    Du kannst in dem Geplanten Task unten "Nur ausführen, wenn angemeldet" anhaken, dann brauchst du das Kennwort nicht eingeben.


    Gruß,
    Robert

  • Quote from "rst"

    Hallo Gerhard,


    wie meldest du dich denn unter Windows an, wenn du das Kennwort nicht kennst?
    Du kannst in dem Geplanten Task unten "Nur ausführen, wenn angemeldet" anhaken, dann brauchst du das Kennwort nicht eingeben.


    Gruß,
    Robert


    Hallo Robert,


    ich habe Deinen Vorschlag umgesetzt, erhalte im Unterordner Backups jedoch nach wie vor die schon bekannte falsche Datei "-2006-06.7z"


    Ich habe den Geplanten Task als Screenshot beigefügt - vielleicht hilft er weiter.


    Dank und Gruß
    Gerhard


  • Quote from "Heiggo"

    Oh je, ein Grund mehr, WindowsXP zu hassen wie die Pest. Nutzer, die ihr eigenes Kennwort nicht kennen. Danke Microsoft, danke Billy, du sorgst dafür, das unsere Nutzer schön verdummen!.


    Hallo Heiggo,


    ich kann ja verstehen, wenn Du Deinen Ärger über WindowsXP hier äußerst. Aber nur ärgern bringt nichts. Zu dem Ärger sollte eine Alternative genannt werden oder in diesem (meinen) Fall eine Antwort darauf, wie ich an das Kennwort komme.


    Netten Gruß
    Gerhard

  • Quote from "rst"

    Okay. Kannst du in dem Reiter (in dem Fenster oben) Allgemein, in der Mitte auf aktivieren klicken? Zur Verdeutlichung ein Screenshot:


    Ich meine dort, wo der Mauszeiger zu sehen ist (bei mir ausgegraut, weil der Deinst bei mir läuft).


    Gruß,
    Robert


    Hallo Robert,


    ergänzend zu meinem Beitrag vom 02.07. (02.58 Uhr) noch folgende Information:


    Ich habe Deinen Screenshot mal mit meinen entsprechenden Einstellungen im Dienst "Taskplaner" verglichen - sie sind identisch. Unter "Autostarttyp" steht bei mir "Automatisch".


    Netten Gruß
    Gerhard

  • Hallo Gerhard,


    ich weiß im Moment leider nicht wo bei dir der Fehler steckt.
    Ich würde dir raten einen neuen Task anzulegen und alle Eingaben noch mal zu machen. Irgendwo muss bei dir ein Fehler drin stecken, vielleicht ein Tippfehler. Überprüf noch mal alle Pfade.


    Gruß,
    Robert

  • Quote from "rst"

    Hallo Gerhard,


    ich weiß im Moment leider nicht wo bei dir der Fehler steckt.
    Ich würde dir raten einen neuen Task anzulegen und alle Eingaben noch mal zu machen. Irgendwo muss bei dir ein Fehler drin stecken, vielleicht ein Tippfehler. Überprüf noch mal alle Pfade.


    Gruß,
    Robert


    Hallo Robert,


    ich habe den Task nochmals neu angelegt, aber leider wieder ohne Erfolg:


    Offensichtlich ist es so, dass vor der Datei "-2006.06.7" ein bestimmter Text fehlt. Aus welchen Elementen setzt sich dieser Text zusammen?


    Vielleicht helfen mir diese Angaben weiter.


    Gruß und Dank
    Gerhard


    Nachtrag:


    In der Ausführen-Zeilen steht jetzt folgender Code:


    "D:\Dokumente und Einstellungen\uu\Desktop\TB-Backup.bat" TB-BACKUP "D:\Dokumente und Einstellungen\uu\Anwendungsdaten\Thunderbird"
    >>> Sind beide Laufwerke richtig angegeben?
    >>> Stehen alle Anführungszeichen an der richtigen Stelle?
    >>> Ist die Leertaste vor und nach TB-BACKUP richtig?


    Wenn ich die Datei "-2006-06.7z" mit 7-zip öffne und dann im 7-Zip Dateimanager die Datei "logs" öffne, erscheint der beigefügte Screenshot. Hilft er bei der Lösung meines Problems weiter?


    Herzlichen Dank für Deine Geduld
    Gerhard


  • Guten Abend Gerhard,


    die Leerzeichen vor und nach TB-BACKUP in der Ausführenzeile sind richtig.
    Der Name des Backup setzt sich aus der zweiten Angabe der Ausführen Zeile, also TB-BACKUP und dem Datum in Form von -JJJJ-MM zusammen.


    Du kannst mal in dem Ordner logs (nicht in dem Archiv, sondern dort wo auch die TB-Backup.ini Datei liegt) dir die letzte/neuste Datei angucken. Steht da etwas drin, dass dir weiter hilft?


    Gruß,
    Robert


  • Hallo Robert,


    die letzte Datei in dem Ordner logs sieht wiefolgt aus:


    7-Zip (A) 4.23 Copyright (c) 1999-2005 Igor Pavlov 2005-06-29


    Scanning


    Updating archive .\backups\-2006-06.7z


    Compressing backups\-2006-06.7z
    Compressing logs\-2006-06-29_22h21m29s.log


    Everything is Ok


    Ich habe den Eindruck, wir sind an dem Punkt, den ich befürchtet hatte, dass unsere Kommunikation aneinandervorbeiläuft: Du gehst nicht mehr konkret auf meine Fragen ein und mir fehlt offensichtlich das nötige Verständnis.
    Damit will ich Dir keineswegs zu nahe treten. Ich finde es einfach ärgerlich, dass ich nach so vielen Mühen jetzt vor dem Punkt stehe, aufgeben zu müssen.


    Das Adressbuch könnte ich notfalls noch regelmäßig mit Extras > Exportieren sichern, aber für die Sicherung meiner Einstellungen habe ich nichts Entsprechendes gefunden und die Nachrichten lassen sich leider nur einzeln speichern und als Ordner gesamt.


    Ich will mich sehr gerne bemühen, auch weiterhin nach der Lösung für mich zu suchen, falls Deine Bereitschaft auch nach vorhanden ist. Und sorry, falls ich Dich fehlinterpretiert habe.


    Dank und Gruß
    Gerhard

  • Guten Abend Gerhard,


    wie du schon erkannt hast, sind wir an einem Punkt, an dem ich nicht mehr weiter weiß. Irgendwo steckt ein - womöglich ganz kleiner - Fehler. Und von hier aus, kann ich dir kaum weiterhelfen.


    Das Backup-Skript sichert bei dir nicht das Profil-Verzeichnis von Thunderbird, sondern den eigenen Ordner, in dem das Backup-Skript liegt. Zusammen mit der Tatsache, dass das Backup bei dir nicht den gewünschten Namen (TB-BACKUP) bekommt, können wir schließen, dass die Parameter nicht von dem Backup-Skript übernommen/angenommen werden. Allerdings weiß ich nicht, warum das so sein sollte.


    Ein letzter Versuch in diese Richtung wäre ein kompletter neuer Versuch.
    Als erstes lädst du dir das Backup-Skript von hier nochmal herunter. Installiere es diesmal so, dass der Pfad keine Leerzeichen enthält. Zum Beispiel nach D:\TB-Backup.
    Dann legst du wieder einen neuen Task an und wählst mit Durchsuchen die Datei TB-Backup.bat aus, die du vorher nach D:\TB-Backup installiert hast.
    Dann hängst du hinten in der Ausführenzeile den Rest wieder dran. Also zuerst ein Leerzeichen, dann TB-BACKUP und dann wieder ein Leerzeichen. Dann kommt der Pfad zum Profil-Verzeichnis von Thunderbird. Das müsste bei dir "D:\Dokumente und Einstellungen\uu\Anwendungsdaten\Thunderbird" sein. Gib aber sicherheitshalber diesen Pfad mal unter Start -> Ausführen ein und gucke, ob sich das Profil-Verzeichnis öffnet (denk an die " Zeichen).


    Wenn uns das immernoch nicht weiterbringt, gucken wir uns nach anderen Möglichkeiten zum Sichern des Profil-Verzeichnis um.


    Gruß,
    Robert