Totalverlust nach Systemabsturz

  • Hallo,
    nach einem Absturz des Betrübssystems (Windows 2000) heute morgen leidet TB unter umfassender Amnesie - beim Programmstart werde ich zur Einrichtung eines neuen Kontos aufgefordert.


    Die Daten an sich sind offensichtlich noch vorhanden, die entsprechenden Dateien habe ich gesichert. Nur scheint TB keinen Zugang mehr dazu zu finden.


    Habe mir die Neueinrichtung mal verkniffen, weil ich vermute, daß das mehr schadet als nutzt.


    Die wesentliche Frage ist trotzdem: wie kriege ich meinen Kram zurück?


    System ist win2k, TB-Version ist 1.5.0.2. Der Absturz begann mit einer Fehlermeldung wg. nicht genügend virtuellem Speicher, beim Reboot meckerte Scandisk inkorrekte Größen bei diversen Dateien an (auf der Partition, wo auch meine Mails liegen), welche das allerdings genau waren, kann ich nicht sagen, dazu war die Meldung zu schnell wieder weg. Und mitgeloggt hab' ich Idiot natürlich nicht. *grmpf*


    Für Hilfe wäre ich unendlich dankbar - bin grad echt ratlos und traue mich nicht, irgendwas zu machen, aus Angst, noch mehr zu zerstören.


    Kurze Ergänzung: ist das normal, daß in jedem extensions-Ordner auch noch eine prefs.js liegt? Gehört die dahin?
    Die im Profil-Ordner sieht auf den ersten Blick ganz vernünftig aus, eine zweite existiert auch nicht. Dafür fehlen im Profil-Ordner folgende Dateien, die laut Doku dort liegen sollten: components.ini, defaults.ini, training.dat und panacea.ini. Der chrome-Ordner ist komplett leer, da ist gar nix drin.
    Vielleicht helfen diese Infos ja irgendwie weiter...

  • Vorneweg, ich gehe mal davon aus das du nur ein Profil nutzt.


    Sofern die Dateien in Profil-Ordner alle ok sind, kannst du ja in TB unter Extras/Konten und dann bei Server-Einstellungen den Pfad bei "Verzeichnis wählen" entsprechend ändern (bitte vorher deinen ganzen Ordner "Thunderbird" sichern, falls irgendwas nicht klappt, dann hast du die Dateien immer noch).
    Dasselbe machst du dann bei "Lokale Ordner".


    Danach TB schließen und wieder öffnen.


    Viele Grüße


    Thomas Mc Kie

  • > Vorneweg, ich gehe mal davon aus das du nur ein Profil nutzt.


    Jepp, das stimmt.


    > Sofern die Dateien in Profil-Ordner alle ok sind,


    Gute Frage, das kann ich ja nicht 100% sagen. "Sieht für mich okay aus" heißt ja nicht zwingend, daß dem auch tatsächlich so ist. ;-)


    > kannst du ja in TB unter Extras/Konten und dann bei
    > Server-Einstellungen den Pfad bei "Verzeichnis wählen" entsprechend
    > ändern (bitte vorher deinen ganzen Ordner "Thunderbird" sichern, falls
    > irgendwas nicht klappt, dann hast du die Dateien immer noch).
    > Dasselbe machst du dann bei "Lokale Ordner".
    >
    > Danach TB schließen und wieder öffnen.


    Das hat leider nicht zum gewünschten Erfolg geführt. *snief*


    Bevor wir uns mißverstanden haben - folgendes habe ich jetzt gemacht:
    - Thunderbird gestartet
    - neue Mailadresse angelegt
    - in den Server-Einstellungen den Pfad auf das alte (gleichnamige) Mail-Profilverzeichnis geändert (und dabei festgestellt, daß er das im alten Profilordner gespeichert hat, den hat er also offensichtlich gefunden!)
    - Pfad bei "Lokale Ordner" von den (neu angelegten) Local Folders -1 auf Local Folders verändert
    - Thunderbird neu gestartet
    - Ergebnis: _ein_ Mailkonto vorhanden, und zwar das gerade neu angelegte mit Pfad auf das alte Verzeichnis. Aber aus dem alten Verzeichnis genau Null geladen, keine einzige Mail. Adressbuch scheint seltsamerweise vollständig da zu sein, aber sonst nix, keine Filter, keine Mails, njet. Da scheint also irgendwas so richtig gründlich zerschossen zu sein... :-(((

  • > lagen denn Deine Mails im jeweiligen Posteingang oder in
    > Unterordnern?


    Ich hatte nur einen (globalen) Posteingang, und natürlich eine ganze Menge Unterordner.

  • Als erstes einfach mal das Adresbuch exportieren, was man hat, hat man :-)


    Ich hatte selber ein so ähnliches Problem, habe dann TB deinstalliert (aber vorher das Verzeichnis, in dem die Profile sind, gespeichert), neu installiert und dann aber kein neues Konto erstellt, sondern nach der Installation mein altes Profil in das frische Profilverzeichnis hineinkopiert. Dann hatte ich (soweit ich weiß) alles wieder da, wobei die Ordnerstruktur zwar verloren war, aber die habe ich ruck zuck wieder hergestellt.


    Einen Versuch ist es wert.


    Grüße


    Thomas Mc Kie

  • "inga" schrieb:

    > lagen denn Deine Mails im jeweiligen Posteingang oder in
    > Unterordnern?


    Ich hatte nur einen (globalen) Posteingang, und natürlich eine ganze Menge Unterordner.


    die Frage war, wo Deine Mails waren. In den Unterordnern?
    Welche Dateien sind denn im Profilverzeichnis vorhanden
    zum Vergleich [IMG:http://img269.imageshack.us/img269/4505/10312006120314te9.th.jpg]


    Wenn die Mails in Unterordnern waren, muss für den Unterordner eine gleichnamige Datei ohne Endung und ein gleichnamiger Ordner mit der Endung .sbd vorhanden sein, und in diesem dann die endunglosen Dateien des Unterordners. D.h., in meinem Local Folders gibt es eine Datei Namens Lager und die dazugeh. Lager.sbd
    Alle Index-Dateien (mit der Endung *.msf) kannst Du löschen. Daraufhin durchsucht TB die endunglosen Dateien nach Mails und erstellt neue Indexdateien

  • > die Frage war, wo Deine Mails waren. In den Unterordnern?


    Sowohl im Posteingang als auch in den Unterordnern.


    > Wenn die Mails in Unterordnern waren, muss für den Unterordner eine
    > gleichnamige Datei ohne Endung und ein gleichnamiger Ordner mit der
    > Endung .sbd vorhanden sein, und in diesem dann die endunglosen Dateien
    > des Unterordners. D.h., in meinem Local Folders gibt es eine Datei Namens
    > Lager und die dazugeh. Lager.sbd


    Habe ich. Das sieht okay aus, nichts fehlt.


    > Alle Index-Dateien (mit der Endung *.msf) kannst Du löschen. Daraufhin
    > durchsucht TB die endunglosen Dateien nach Mails und erstellt neue
    > Indexdateien


    Ich weiß ehrlich gesagt nicht, ob das jetzt so sinnvoll ist. Bin obigem Rat gefolgt und habe neu installiert, aber zurückkopieren bringt genau Null!
    Und das schlimmste an der Sache ist: ich verstehe nicht, warum! Selbst so ein Drecksding wie Outlook Express schafft es, innerhalb von fünf Minuten ein Backup zu importieren oder ihm untergeschobene Ordner vorbehaltlos zu fressen. Wieso kann Thunderbird, das doch an anderen Stellen viel leistungsfähiger ist, sowas banales nicht? Wieso ist der Donnervogel nicht einmal in der Lage, seine eigenen Dateien wieder zu importieren? Das kann doch nicht so schwer sein.
    Wo also steckt der Fehler?
    Ich kann einfach nicht glauben, daß TB das nicht können soll. Irgendwo muß ein Fehler stecken, muß einfach... Nur wo?


    Ich krieg' hier jedenfalls langsam echt die Krise... Menno! *schmoll*

  • "inga" schrieb:


    Und das schlimmste an der Sache ist: ich verstehe nicht, warum! Selbst so ein Drecksding wie Outlook Express schafft es, innerhalb von fünf Minuten ein Backup zu importieren...


    wenn ein Backup vorhanden wäre, könntest Du das ja auch einfach an die Stelle des neuen Profiles, also ab /thunderbird/ kopieren und alles wäre gut.
    Aber wenn Du nur korrupte Dateistruktren hast...
    Deinem TB fehlt derzeit vermutlich die Ordnerstruktur in der prefs.js
    Du kannst folgendes versuchen: (ich gehe davon aus, dass Du den Profilordner unter anderm Namen gesichert hast) erstelle in TB innerhalb eines neuen Profiles (Profilmanager) genau die vorherige Ordnerstruktur und kopiere dann bei beendetem TB die Maildateien in diese Ordner. Ohne die *.msf

  • > wenn ein Backup vorhanden wäre, könntest Du das ja auch einfach an die
    > Stelle des neuen Profiles, also ab /thunderbird/ kopieren und alles wäre
    > gut.
    > Aber wenn Du nur korrupte Dateistruktren hast...


    Das ist es ja: das kann ich weder verifzieren noch fasifizieren. Es sieht alles in Ordnung aus, wird aber nicht gefressen.
    Übrigens dasselbe Ergebnis mit einem ältern Backup, wie ich inzwischen ausprobiert habe.
    Ist ja nicht so, als hätte ich hier die letzten fünf Stunden herumgesessen und Däumchen gedreht... ;-))


    > Deinem TB fehlt derzeit vermutlich die Ordnerstruktur in der prefs.js


    Ist das logisch, daß damit dann sämtliche Konteneinstellungen weg sind? Mir erschließt sich der Zusammenhang nicht so ganz...


    > Du kannst folgendes versuchen: (ich gehe davon aus, dass Du den
    > Profilordner unter anderm Namen gesichert hast)


    Jepp.


    > erstelle in TB innerhalb eines neuen Profiles (Profilmanager) genau die
    > vorherige Ordnerstruktur und kopiere dann bei beendetem TB die
    > Maildateien in diese Ordner. Ohne die *.msf


    Okay, probieren wir das auch noch aus. Mal schauen, was diesmal schiefgeht... *eg*

  • "inga" schrieb:


    > Deinem TB fehlt derzeit vermutlich die Ordnerstruktur in der prefs.js


    Ist das logisch, daß damit dann sämtliche Konteneinstellungen weg sind? Mir erschließt sich der Zusammenhang nicht so ganz...
     


    Sieh mal da rein: http://www.thunderbird-mail.de…ion1.5/profil_dateien.php
    Schau Dir halt mal Deine prefs.js mit einem Editor an...


    Zitat

    Okay, probieren wir das auch noch aus. Mal schauen, was diesmal schiefgeht...


    ??


    Zitat

    Übrigens dasselbe Ergebnis mit einem ältern Backup, wie ich inzwischen ausprobiert habe.

    Ergebnis?


    Hast Du wirklich das alte Profil gegen das neue getauscht (also ab /Thunderbird komplett reinkopiert)? Wenn Du den neuen Inhalt dieses Verzeichnisses mit dem Alten ersetzt, muss das funktionieren.

  • > Sieh mal da rein:
    > http://www.thunderbird-mail.de…ion1.5/profil_dateien.php
    > Schau Dir halt mal Deine prefs.js mit einem Editor an...


    Längst geschehen, mit o.g. Seite hatte ich schon abgeglichen, bevor ich mich hier gemeldet habe. Siehe erstes Posting.


    > > Okay, probieren wir das auch noch aus. Mal schauen, was diesmal
    > > schiefgeht...
    > ??


    Galgenhumor!


    > > Übrigens dasselbe Ergebnis mit einem ältern Backup, wie ich
    > > inzwischen ausprobiert habe.
    > Ergebnis?


    Keins halt. Er schluckt es nicht.


    > Hast Du wirklich das alte Profil gegen das neue getauscht (also ab
    > /Thunderbird komplett reinkopiert)?


    Ja, habe ich.


    > Wenn Du den neuen Inhalt dieses Verzeichnisses mit dem Alten ersetzt,
    > muss das funktionieren.


    Offensichtlich muß es nicht müssen. Es tut es jedenfalls schlicht und einfach nicht.

  • > erstelle in TB innerhalb eines neuen Profiles (Profilmanager) genau die
    > vorherige Ordnerstruktur und kopiere dann bei beendetem TB die
    > Maildateien in diese Ordner. Ohne die *.msf


    So, wenigstens ein Erfolgserlebnis: das hat funktioniert. Die Mails sind also wieder da. Puh! *erleichtert_bin*


    Für weitere Experimente fehlt mir jetzt der Nerv. Ich denke, ich richte die Mailaccounts einfach alle von Hand wieder ein. Und dann werde ich wohl den Rest des Abends mit dem Kopieren der Filterregeln verbringen... :-((


    Dank an Euch für die Hilfe.

  • Edit: rum hatte genau das folgende vorgeschlagen, was zum Erfolg geführt hat. :oops:


    Hallo inga;


    und sorry, wenn ich mich hier mit einklincke....
    Es hat den anschein, als ob Du neben den Vorschlägen von rum noch andere Sachen probierst. Das ist lobenswert, macht aber die Hilfe schwieriger, denn rum weis was er vorschlägt und baut mit jedem Tipp auf dem vorherigen auf.


    Lass uns mal was anderes probieren:
    - schließe den TB und starte ihn mit dem Profilmanager neu und lege dort ein neues an.
    - nun richtest Du 1 Konto hier komplett ein (wichtig dabei ist, keine Filter zu definieren und bei POP die Mails auf dem Server zu belassen.)


    Geht das?


    Wenn ja, schließe den TB und gehe in den Ordner Local Folders (defektes Profil). Nimm eine Datei-ohne-Endung von dort und kopiere sie in den Ordner Local Folders vom heilen Profil. Wenn du jetzt den TB startest sollte er den Ordner erkennen und die Mails anzeigen.


    Tut er das?


    Gruß