Link erstellt mit Thunderbird wird verändert

  • Hi,
    Wenn ich einen Link mit Thunderbird erstelle wird er verändert, also statt auf
    file://///SERVER/FILENAME.html verweist er auf eine Datei in den Anwendungsdaten. Sieht dann etwa so aus:
    mailbox:///C|/Dokumente%20und%20Einstellungen/.../.../.../Inbox?number=xxxx&part=1.2&filename=FILENAME.html
    Derjenige der die Mail empfängt kann damit natürlich nichts anfangen.
    Beim Schreiben der Nachricht wird der Link immer richtig angezeigt.
    Kann man das Verhalten irgendwie einstellen?
    Ich will die Datei auch nicht anhängen, denn sie soll genau dort bleiben um weiter daran arbeiten zu können.


    Danke

  • Hallo und [IMG:http://bestsmileys.com/welcome/17.gif] im Forum.


    Ich bin kein HTML Experte.
    Bitte beschreibe genau wie du beim Setzen des Link vorgehst. Soll auf eine Datei auf deinem Computer oder im Netz gelinkt werden?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "Kamiro"

    Hi,
    Wenn ich einen Link mit Thunderbird erstelle wird er verändert, also statt auf
    file://///SERVER/FILENAME.html verweist er auf eine Datei in den Anwendungsdaten. Sieht dann etwa so aus:
    mailbox:///C|/Dokumente%20und%20Einstellungen/.../.../.../Inbox?number=xxxx&part=1.2&filename=FILENAME.html
    Derjenige der die Mail empfängt kann damit natürlich nichts anfangen.


    Nachfrage: Du willst einen Link zu einer lokalen Datei auf deinem Rechner setzen? Das wird nicht klappen, dein Empfänger hat keinen Zugriff auf deinen Rechner. (mal abgesehen von Netzwerken)

  • Hi,
    Danke schon mal für die Antworten.
    Es handelt sich um eine Datei im lokalen (intra-) Netzwerk, auf die die Empfänger Zugang haben.
    Das passiert nur wenn ich html verschicke. So mache ich es:
    Schreibe im TB eine Mail. Markiere ein Wort z.B. Wichtige_Datei und gehe über den Befehl Link erstellen. Dort gebe ich den UNC-Pfad (ist dann für alle Empfänger gleich) ein. Wenn ich die Link-Einstellungen hinterher kontrolliere stimmt auch alles noch.
    Nur wenn ich die Mail wegschicke und dann den Link in der gesendeten Mail anschaue ist der völlig verändert. Wie oben beschrieben zeigt er auf meine lokalen Einstellungen. Die Empfänger können damit nichts anfangen.

  • Schade,:cry:
    es scheint sich hier keiner damit auszukennen. Oder es interressiert keinen?
    Habe zu dem Thema nirgens was hilfreiches gefunden. Dachte es gäbe irgend einen Trick mit about:config oder so.
    Muß jetzt immer einen Anhang mitschicken, das ist Arbeiten wie Vorgestern!
    Für mich bedeutet das, dass man mit Thunderbird keine Links schicken kann! :!:

  • Ich schicke täglich Links. Und Anhänge. Ist doch weder von Vorgestern noch kompliziert. Man muss halt auch ein bisschen flexibel sein.


    Es gibt eben nicht alles in allen Programmen, speziell nicht, wenn sie nichts kosten (dürfen). Und ich finde, TB ist bereits sackstark, auch wenn das eine oder andere fehlt.

  • Hallo Kamiro,


    die Mozilla-Produkte haben an sich einen etwas merkwürdiges Verhalten, was UNC-Pfade angeht. Schick doch einfach eine kleine Batch in der nur


    explorer \\%servername%\%freigabe%\Verzeichnis oder
    \\%servername%\%freigabe%\Verzeichnis\datei (wenn datei mit einem auf dem Ziel assoziierten Programm verknüpft ist) drin steht.



    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hi Arran,
    wollte hier niemanden auf die Füße treten!
    Thunderbird ist meiner Meinung nach ein super Programm!
    Ich finde nur das Verhalten an dieser Stelle etwas eigenartig. Ich schätze mal es ist ein Bug oder ein als Feature getarner Bug 8)
    Mich wundert es nur, dass es scheinbar noch niemanden aufgefallen ist.

    Zitat von "Arran"

    Ich schicke täglich Links. Und Anhänge. Ist doch weder von Vorgestern noch kompliziert. Man muss halt auch ein bisschen flexibel sein.


    Es gibt eben nicht alles in allen Programmen, speziell nicht, wenn sie nichts kosten (dürfen). Und ich finde, TB ist bereits sackstark, auch wenn das eine oder andere fehlt.


  • Danke!
    Werde es mal ausprobieren. Als Umgehung bestimmt ein guter Ansatz.
    Will nicht unbedingt nerven, aber vielleicht hat ja jemand eine Erklärung für das Verhalten....
    Kann mir auch vorerst damit behelfen, indem ich kein html benutze, darf dann allerdings keine Sonderzeichen im Dateinamen und Pfad haben.
    Das unsägliche Programm von m$ zeigt dann einen Link an, wenn ich den kompletten Pfad mit angebe: \\servername\pfad\dateiname.
    Formatierungen sind dann allerdings nicht möglich, klar!


    schöne Grüße zurück


    Kamiro

  • Hallo Kamiro,


    also ich habe es gestern mal getestet und den Link händisch in eine neue Mail eingetragen... verändert wurde er nicht - nur aufgerufen wurde auch nichts. So richtig funktionieren File-Links aber auch nur, wenn der IE der Standard-Browser ist. Dann erkennt das System den File-Link und aus dem IE wird ein Explorer-Fenster. Ich hatte schon mal vor geraumer Zeit das gleiche Problem - und nach einigem Suchen im Internet (ja, es soll irgendwie doch mit Firefox gehen...) habe ich das anders gelöst. Ich erstelle mit vbscript oder Kix kleine Scripte die das Programm und die Datei aufrufen. Java-Script ginge theoretisch auch - müsstest du dann aber in TB aktivieren (was der Sicherheit bestimmt nicht besonders gut tun würde).


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hi,
    wie hast du den händisch eingetragen?
    Ich habe ein Wort markiert und dann mit Link erstellen gemacht?

    Zitat von "Toolman"

    ...
    also ich habe es gestern mal getestet und den Link händisch in eine neue Mail eingetragen... verändert wurde er nicht - nur aufgerufen wurde auch nichts. ....
    Toolman


    Der Link war allerdings schon in meinem gesendet Ordner vermurkst. (TB zeigt in der Statuszeile den Link an)
    Stimmt, ich benutze Firefox, aber die Empfänger benutzten meistens den IE :evil:


    Zitat von "Toolman"


    So richtig funktionieren File-Links aber auch nur, wenn der IE der Standard-Browser ist. Dann erkennt das System den File-Link und aus dem IE wird ein Explorer-Fenster. ...
    Ich erstelle mit vbscript oder Kix kleine Scripte die das Programm und die Datei aufrufen. Java-Script ginge theoretisch auch - müsstest du dann aber in TB aktivieren (was der Sicherheit bestimmt nicht besonders gut tun würde).


    Läuft darauf raus den Teufel mit dem Beelzebub auszutreiben :twisted:


    Habe mit File-Links normal keine Probleme, TB macht sie "richtig" wenn es plain text ist, d.h. den ganzen sermon in die mail schreibe file://---/---/---/myfile.html