xcopy kopiert zuviel TB-Dateien

  • Hallo,


    Ich habe mir eine Batchdatei mit xcopy gemacht und sichere damit auf einen Stick. Unter anderem sichere ich auch die TB-Daten und zwar so:


    Code
    1. xcopy "c:\Dokumente und Einstellungen\Maus\Anwendungsdaten\Thunderbird" "G:\sicherung\Thunderbird" /c /r /d /y /e /i /h


    Normalerweise dürften nur Dateien gesichert werden, die sich seit der letzten Sicherung verändert haben. Das klappt bei allen anderen Daten prima, nur nicht bei TB. Da sieht es aus, als würden immer sämtliche Dateien gesichert. Ich sehe da Dateinamen durchrauschen, die ich schon seit Monaten nicht mehr angerührt hatte.


    Weiss jemand, warum und wie ich das ändern kann?


    Gruss Filou

  • Nun, das liegt sicher daran, dass TB unter Windows jedes File mit dem geheimen Attribut "Muck_about_with_xcopy" versieht. Siehe dazu die PC Computer Weltbild, Ausgabe 54/2005. ;-)


    Ernsthaft, falls da tatsächlich etwas schiefgeht, dann liegt das ganz sicher nicht am TB. Das Filesystem steht schließlich unter der Kontrolle Windows bzw. dessen Treibern.
    Dass der xcopy-Befehl nicht richtig arbeiten würde, halte ich für eher unwahrscheinlich. Vielleicht täuscht Ihr Eindruck?. Kopieren Sie doch mal Ihre Sicherung, führen den batch erneut aus und vergleichen dann file für file.


    Btw, sollten Sie statt der Option /e nicht besser /s /e verwenden?