Bei Klicken von "Anhang" Programmabsturz

  • ich weiss nicht leute, vielleicht sollte man den nutzern vor dem herunterladen von tb erstmal eine einjährige it-ausbildung machen lassen. ich, als laie, bin jedenfalls mit der sache überfordert. das gebe ich ganz offen zu. ich komme keinen schritt weiter, weil ich vieles, was ihr mir als tips gebt, gar nicht verstehe und deshalb möglicherweise auch fehler mache, die ich nichtmal bemerke. okay, wenn ihr mir noch beibringt, wie ich tb wirklich komplett löschen und noch einmal jungfräulich installieren kann, dann mach ich´s auch noch ein mal. ansonsten lebt wohl und ich warte auf die version x, die dann vielleicht funktioniert...
    euer stivi

  • Quote from "mrb"

    Halo,
    meine Antwort bezog sich auf TB selbst. Wenn das Betriebssystem die Ursache ist, hättest du Recht.


    Hallo mrb,


    es wäre auf jeden Fall angenehm, wenn "offiziell" nach Lösungen gesucht wird - vielleicht liest da ja gerade einer von den Programmierern. Denn hier in diesem deutschsprachigen Post sind wir schon 3-4 mit dem Problem. Bis heute wusste ich nicht, dass es nur die e-mails mit den Anlagen sind, da ich kaum selbst welche verschicke. Ich hatte nur gesehen, dass mir TB bei einigen empfangenen abschmierte. Da draussen ist also noch eine Dunkelziffer mit Leuten, die die Regel hinter dem Absturz noch nicht verstanden haben und deswegen nicht in Erscheinung treten.


    Ehrlich gesagt: Ich werde demnächst mal in Ruhe die Methode von f2air ausprobieren (die TB-Jungfrau, wie stivi so schön meinte) und wenn das nicht hilft, werde ich wohl wieder zurück zu Office - oder zum neuen Windows Mail von Vista, sieht auch nicht so schlecht aus. Dabei gefällt mir TB sehr gut, nutze es schon seit 2 Jahren enthusiastisch.
    Da das Prog bei mir sogar in den Anhangsoptionen bei "Aktionen anzeigen und bearbeiten" abstürzt, scheint mir der Code nicht kompatibel mit irgendwas von Windows zu sein. Was hast du für ein Betriebssystem, stivi?

  • ICH HABE GERADE MEIN PROBLEM GELOEST:


    In meinem Profilordner befand sich eine Datei names mimeTypes.rdf, die schon über ein GB angeschwollen war. Sie speichert Infos über Dateitypen und Anwendungszuordnungen (http://kb.mozillazine.org/MimeTypes.rdf). Jetzt ist mein Profil ein GB schlanker und mein TB läuft wieder ohne mucken.


    Ich hoffe es hilft jemandem. War wohl Zufall, dass das erst seit Vista so ist, oder halt wegen der Reinstalls der ganzen Programme wurde die Datei überladen.

  • Hallo und guten Morgen @all,



    erst mal danke an McWalt für die Lösung, evtl. ist das ja auch für die anderen Beteiligten ursächlich.
    EDIT: Die von dir

    Quote

    ICH HABE GERADE MEIN PROBLEM GELOEST:

    gepriesene Lösung wurde von mrb bereits am 4.10. gepostet! :schlaumeier:
    Btw:

    Quote from "McWalt"


    es wäre auf jeden Fall angenehm, wenn "offiziell" nach Lösungen gesucht wird - vielleicht liest da ja gerade einer von den Programmierern

    das ist nicht anzunehmen, dies ist ja ein reines User_helfen_Usern-Forum, da lesen die Entwickler afaik nicht mit. Man kann aber bei bugzilla entsprechende Meldungen in englisch abgeben oder dort nachsehen, ob ein Bug vorliegt. Aber in diesem Fall glaube ich nicht an einen Bug von TB.


    @Jürgen

    Quote

    Auf dem einen Rechner hatte ich zwar alles mögliche, was e-mail betrifft im Scanner deaktiviert (ich frage mich jetzt, ob ich überhaupt noch gegen irgendwas geschützt bin)

    wenn du gemäß der Anleitung das Profilverzeichnis von TB aus dem Prüfvorgang ausgeschlossen und den Haken in den Einstellungen gesetzt hast, dann verhinderst du damit, dass der Scanner die bereits abgelegten Mails in den Mbox-Dateien scannt. Und das ist auch gut so, denn alle Mails stehen dort "am Stück", das Entfernen eines (scheinbaren) Virus würde also alle Mails komplett betreffen=löschen.
    Dein Scanner scannt vermutlich den eingehenden Web-Datenverkehr und on_demand jede Datei, die du öffnest/anklickst. Ein Virus in einer Mail kann aber erst durch das Öffnen des Anhanges gefährlich werden und da greift ja wieder der Scanner. Unabhängig davon sollte man nie, nie, nie einen Anhang direkt aus der Mail öffnen. Ich trenne alle Anhänge per Rechtsklick ab und speichere sie außerhalb des Profilverzeichnisses, TB merkt sich sogar den Speicherort. Klicke ich dann, ist der Anhang nie im gefährlichen Maildatenbereich.


    stivi

    Quote

    . wenn mir einer erklären könnte, wie ich tb komplett, also wirklich komplett von meinem laptop kriege,

    versuche zuerst mal den Tipp von McWalt Gehe also in das Profilverzeichnis und benenne dort die Datei mimeTypes.rdf um oder lösche sie. Starte dann TB und teste.
    Wenn das nichts nutzt, dann beende TB, benenne das Profilverzeichnis um z.B. in ...\thunderbird-alt\...
    Dann deinstalliere Thunderbird Start>Systemsteuerung>Software und lösche auch den versteckten Ordner C:\Dokumente und Einstellungen\%Benutzername%\Lokale Einstellungen\Anwendungsdaten\Thunderbird
    Installiere TB neu, lade ihn dazu mit dem Button "Herunterladen" hier auf dieser Site ganz oben oder links.
    Wenn du alles neu eingerichtet hast und alles funktioniert, kannst du die Mails aus dem umbenannten Profil mit ImportExportTools (Mboximport) wieder importieren.

  • macwalt,
    so etwas macht mich richtig wütend.
    Du hättest gar nicht nach der Lösung und Datei mimetypes.rdf suchen müssen.
    Ich hatte in diesem Thread schon längst diesbezüglich Stivi einen Tipp gegeben:
    Beitrag
    und zwar:

    Quote

    Beende TB und lösche die Datei mimetypes.rdf.


    Reaktion von Stivi: keine.


    Also den ganzen Thread vorher durchlesen und nicht einfach sich dranhängen und kritisieren.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • :redface: sorry mrb, da habe ich dann auch noch ungeprüft McWalt als Lösungsfinder bestätigt :evil:
    Ich habe es per Edit korrigiert und gelobe reuig Besserung! :flehan: :flehan:

  • lieber mrb,
    ich habe immer deine anweisungen befolgt (soweit ich sie verstanden habe) und das auch geschrieben:
    von stivi am 6. Okt 2008, 07:43
    "...ich frage mich nur immer wieder, wo kommen die ganzen profile wieder her, wenn ich alle ordner lösche - sogar mit dem tune up schredder - und das set up aus dem internet neu runter lade. und schwups, alle daten, konten und ordner sind wieder da wie vorher - woher?!..."
    alles gelöscht, auch die mimetypes datei, aber es hat sich nichts getan. nun versuche ich noch einmal alles zu löschen und neu zu installieren
    stivi

  • rum,
    du warst ja nicht gemeint. Man kann von den helfenden Usern nicht immer verlangen, dass sie alles detailliert lesen - das mache ich ja auch nicht - besonders bei einem so langen Thread, beim Überfliegen bleibt aber eben schon etwas auf der Strecke. Es geht ja darum, vielen Usern im möglichst kurzer Zeit zu helfen.
    Von jemandem, der aber sich an einen Thread dranhängt und auch noch kritisiert, da setze ich doch andere Maßstäbe.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi stivi,


    Quote

    ich habe immer deine anweisungen befolgt

    hmm, auch

    Quote from "mrb"

    Vorher gleiche dein System nach dieser Anleitung ab:
    http://freenet-homepage.de/rene-gad/invisible.html

    und

    Quote

    Darum gebe ich dir mal etwas zum Lesen:
    11 Profile

    :?:


    Dann kann dies

    Quote from "stivi"

    ...wenn ich alle ordner lösche - sogar mit dem tune up schredder - und das set up aus dem internet neu runter lade. und schwups, alle daten, konten und ordner sind wieder da

    nicht passieren.


    Das Profil ist nun mal versteckt und nur sichtbar, wenn man es gemäß der obigen Anleitung freigibt oder den Pfad wie in der Anleitung beschrieben z.B. mit %appdata%\thunderbird aufruft. Und wenn es nicht gelöscht wird, nutzt der neu installierte TB das auch ganz brav. Genau so soll es sein. Programm und Daten getrennt, damit beim Update/Neuinstall... nichts passiert.


    Deshalb lies auch noch mal den Beitrag von mir am Do 09.10.2008 09:47:06, beachte mrbs Hilfen (oben von mir zitiert) und versuch es noch mal.


    mrb: mich ärgert es aber, dass ich mich bei McWalt für die von dir genannte Lösung bedanke :evil::wall:

  • hallo rum,
    1.: ja, 2.: ja und 3. ebenfalls ja - soweit es mir, als laie, jedenfalls möglich war. ich habe vorhin alle ordner und versteckte ordner suchen lassen und jeden ordner einzeln mit dem tuneup schredder 2x gelöscht. dann habe ich tb von der webseite herunter geladen und neu installiert, habe auf versenden und anhänge geklickt und der tb ist abgestürzt. basta.
    kannst du nicht mal hier urlaub machen und vorbei kommen und das in ordnung bringen? ich geb dir auch ´ne leckere pina colada aus... :cool:
    oder kannst du dich irgendwie mit meinem laptop per internet verbinden und nachsehen? ich kriege das jedenfalls nicht hin und muss es wohl dabei belassen.
    danke für deine mühen!
    stivi

  • Quote


    kannst du nicht mal hier urlaub machen und vorbei kommen und das in ordnung bringen? ich geb dir auch ´ne leckere pina colada aus... :cool:

    ok, schicke das Flugticket und die Hotelreservierung an flgd. Adresse: :mrgreen:


    Ich weiß nicht, ob es bereits gefragt wurde: hast du einen Virenscanner am Laufen?

  • ja, avast, aber ich habe nach mrb´s anleitung alle relevanten punkte deaktiviert, und sogar zeitweise avast gelöscht - ohne erfolg.
    gibt es nicht so etwas wie eine ferndiagnose und -reparatur via internetverbindungen?
    p.s. für das geld eines tickets und die hotelübernachtung könnte ich mir wahrscheinlich gleich einen neuen pc kaufen, was?! :lol:

  • Quote from "mrb"

    rum,
    du warst ja nicht gemeint. Man kann von den helfenden Usern nicht immer verlangen, dass sie alles detailliert lesen - das mache ich ja auch nicht - besonders bei einem so langen Thread, beim Überfliegen bleibt aber eben schon etwas auf der Strecke. Es geht ja darum, vielen Usern im möglichst kurzer Zeit zu helfen.
    Von jemandem, der aber sich an einen Thread dranhängt und auch noch kritisiert, da setze ich doch andere Maßstäbe.
    Gruß


    ich habe doch gar nichts kritisiert - komm mal bitte klar! Ich habe mir sogar die 3 Seiten Newbie-Talk durchgelesen. Aber das mit der mimetypes.rdf war so nebensächlich erwähnt, das konnte ja nicht als DIE HAUPTURSACHE für unser ALLER PROBLEME ins Auge fallen.


    Sorry. Wenn du willst, bedanke ich mich bei dir, aber der Dank gebührt eigentlich Treesize, denn ohne das Prog hätte ich nie diesen riesigen Parasiten im Profilordner entdeckt.

  • tja, liebe freunde, da ich ein paar tage nichts neues von euch gehört habe, gehe ich davon aus, dass ihr ebenfalls mit eurem latain am ende seid. ich danke euch noch einmal für eure mühen und vorschläge und hoffe, dass die macher des programms irgendwann eine lösung finden oder eine weniger anfällige version entwickeln werden. es wäre nett, wenn man mich benachrichtigen würde - meine email habt ihr ja...
    so lange wechsle ich halt zu outlook.
    macht´s gut
    euer stivi

  • Hallo zusammen,


    habe dasselbe Problem, wie es hier mehrmals beschrieben ist, allerdings habe ich alles befolgt was so in diesem Thread steht, u.a. die Profile gelöscht und neu angelegt, diese rdf Datei gelöscht etc. Trotzdem bleibt das Problem nach wie vor bestehen, dass, sobald ich auf "Anhang hinzufügen" klicke, TB abschmiert.


    Weiß noch jemand Rat?
    Danke

  • Hallo hubseb


    und willkommen im Thunderbird-Forum!


    Ich habe jetzt nicht diesen Thread noch mal gelesen, was also hast du bisher versucht?
    Hast du Schutzsoftware (Virenscanner etc.) am Laufen?
    Was genau geschieht wann, also z.B. bei welchen Typen von Anhängen?

  • Hallo zusammen,
    da muss ich diesen alten Thread noch einmal ausgraben.
    Ich hatte mit meinem pop Konto auch dieses Problem. Hin und wieder hatte ich die "mimetypes.rdf" gelöscht und dann lief alles wieder.
    Nun habe auf imap umgestellt und folgendes "Anhang Problem". Ich kann gesendete mails mit Anhängen nicht mehr herunterladen, und zwar speziell "pdf-Anhänge". Andere gehen. Habe Thunderbird schon neu installert und auch ein neues Profil angelegt. Hat alles nichts geholfen. Mails mit pdf-Anhängen kann ich empfangen, herunterladen und den Anhang auch öffnen. Nur gesendete gehen nicht.
    Weiss jemand weiter?
    Schöne Grüsse
    Jürgen

  • Ich hatte dasselbe Problem mit TB 2.0.0.23 unter XP.
    Ich verwende mehrere Computer, die vernetzt und nicht alle ständig eingeschaltet sind.
    Wenn man einen Anhang sendet, wird die Herkunft des Anhangs unter mail.compose.attach.dir gespeichert. Ist der Anhang auf einem anderen Computer im Netzwerk, kann das zu den beschriebenen Problemen führen.


    Lösung:
    - Gehe zu Extras - Einstellungen - Erweitert - Konfiguration bearbeiten
    - Lösche den Wert für den Einstellungsnamen "mail.compose.attach.dir", der auf einen ausgeschalteten Computer zeigt.


    Da die Lösung nur temporär ist, sollte im TB ein entsprechender Fix eingebaut werden.

  • Hallo Thundfan


    und willkommen im Thunderbird-Forum! <wir begrüßen uns hier


    Danke für deine Info, wenngleich ich sie nicht testen kann.

    Quote

    Ich verwende mehrere Computer, die vernetzt...
    Da die Lösung nur temporär ist, sollte im TB ein entsprechender Fix eingebaut werden.

    nun, TB ist nicht für Netzwerke ausgelegt und deshalb gehe ich da nicht von aus.
    Wenn das schon entsprechend "verbogen" wird, hilft es dann nicht, wenn die Anhänge im Netzwerk verfügbar bleiben?

  • Hallo rum,


    es ist nichts Außergewöhnliches, wenn in einer Familie mehrere Computer am gleichen Router hängen und auf deren Dateien zugegriffen wird. TB sollte zumindest einen Abbruch verhindern. Es ist sehr ärgerlich und schadet dem Image von TB, wenn man eine lange Email geschrieben hat, etwas anzuhängen versucht und dann nur noch mit dem Affengriff weiterkommt.


    Klickt man auf die Büroklammer, dann poppt ein Menu mit dem Directory des zuletzt gewählten Anhangs auf. Eine einfache Abfrage im TB könnte verhindern, dass der Name eines remote Directory in mail.compose.attach.dir abgespeichert wird. Viele Nutzer von TB hatten das Problem schon, man kann es googeln.