Ordner beim Verschieben verschwunden (erledigt!)

  • Moin,


    ich benutze den TB 1.5.0.9.
    Ich wollte gestern etwas in meinem Posteingang aufräumen... Dabei habe ich einen neuen Ordner erstellt und wollte dann zwei bereits existierende Ordner per click&drop als Unterordner in diesen verschieben. Leider kann ich mich nicht genau erinnern, ob das tatsächlich durchgeführt wurde. Ich hab die Ordner einfach verschoben und dann weiter gearbeitet. Als ich heute dann auf die Ordner zugreifen wollte, war der gestern neu erstellte Ordner vorhanden, die Unterordner und sämtliche in ihnen enthaltene Mails aber nicht da und auch sonst nicht aufzufinden.
    Ich hoffe sehr, daß mir jemand helfen kann, da die Ordner nicht ganz unwichtig sind (Korrespondenz mit meinem Prof zu meiner DA...)


    Danke für Hilfe im voraus!
    Roebuk

    Einmal editiert, zuletzt von Roebuk ()

  • Hallo Roebuk, willkommen im Forum !


    Keine Bange, vermutlich ist alles noch da :wink:
    Du machst aber doch wohl regelmässige Datensicherung, oder? Aber dann wenigstens ab sofort...
    Beende mal TB und gehe in das Profilverzeichnis Der Profilordner?

    Zitat

    sieh mal hier: http://www.thunderbird-mail.de…tion1.5/profil_ordner.php


    oder gib mal %appdata%/thunderbird entweder in Start/Ausführen oder im Windows Explorer (nicht Internet Explorer :wink: ) in die Adresszeile ein


    Achtung: bei direkter Suche dran denken, das der Anwendungsordner ein versteckter Ordner ist.
    Klar: erst TB beenden und immer bei Arbeiten im Profil: erst den Profilordner durch kopieren sichern...


    Du hast leider nicht verraten, ob Du mit POP Konten und wenn ja mit lokalem Ordner oder mit IMAP-Konten arbeitest.
    Bei Pop: im Unterordner C:\Dokumente und Einstellungen\%Name%\Anwendungsdaten\Thunderbird\Profiles\swfd8bbg.default\Mail (wobei die krypt. Zahlen/Buchstaben vor default variieren) findest Du im Ordner local folders oder pop* Deine Unterordner als Dateien ohne Endung , das sind Deine Mails. Diese Dateien wieder direkt unterhalb von local folders bzw. pop* einfügen
    Bei imap: wie oben, aber im Ordner imapmail suchen

  • Hallo Rum!


    Also erstmal jepp, POP-Konten und local folders trifft zu. Ich habe meine Unterordner dann dort im Inbox.sbd-Ordner gefunden. Alles noch da, die Sache mit der Datensicherung wird mal eines Tages noch mein früher Herztod sein, ich weiß...
    Ich hab die Dateien jetzt kopiert und wieder direkt unterhalb des pop-Ordners eingefügt. Wenn ich jetzt den TB wieder starte, ist alles wieder gut?!
    Ich hoffe mal!


    Super vielen Dank für die schnelle Hilfe!!!!!


    P.S.: Könnte der ganze Mist passiert sein, weil ich Trottel beim Ordnernamen Punkte verwendet habe?!

  • Zitat von "Roebuk"

    P.S.: Könnte der ganze Mist passiert sein, weil ich Trottel beim Ordnernamen Punkte verwendet habe?!


    Sei nicht so hart zu Dir. Aber in der Sache hast Du Recht. Die (Windows-)Konventionen für Dateinamen gelten auch in TB, leider weist TB einen nicht darauf hin :roll:
    Du kannst die Ordner ruhig wieder in den Inbox.sbd-Ordner kopieren, aber entferne die Punkte! TB betrachtet alle (!) Dateien ohne Endung automatisch als Maildateien

    Zitat

    die Sache mit der Datensicherung wird mal eines Tages noch mein früher Herztod sein, ich weiß...

    na ja, da ist aber doch eine wirkungsvolle Prophylaxe auch im Rahmen der Gesundheitsreform und sogar für Kassenpatienten durchaus mach- und bezahlbar.
    Ein USB-Stick im M...- oder Sat...- Markt für um die 20 Euronen...

  • Punkte sind unter Windows in Verzeichnis- und Dateinamen doch erlaubt, oder? Das dürfte also nicht die Fehlerursache sein.


    Gruß, Sünndogskind_2

  • Zitat von "Sünndogskind_2"

    Punkte sind unter Windows in Verzeichnis- und Dateinamen doch erlaubt, oder? Das dürfte also nicht die Fehlerursache sein.


    Gruß, Sünndogskind_2


    ähm, stimmt :oops:
    habe es gerade getestet: Punkt stört nicht. Die Fehlerursache ist das also nicht.

  • Also der Ordner hiess "Diplom u.a.." Ich denke, das war der Fehler, durch meine Wurstfinger standen da zwei Punkte hintereinander und das hat den Schlamassel wohl ausgelöst. Hab den Ordner jetzt optimistisch "Diplom07" genannt und alles ist gut, alles da!


    Thx nochmals!

  • Schön, freut mich. Danke für die Rückmeldung!
    Alles Gute für das Diplom 07 !!!


    PS: Schön wäre es, wenn Du als Threadersteller im Deinem ersten Beitrag per "Edit"-Button dem Titel ein "(erledigt)" anfügst, denn dann wissen Forensucher dass es für dieses Frage eine Lösung gab

  • Problem erkannt. Die Punkte am Ende sind die Übeltäter. Die werden nämlich von Windows entfernt, wenn keine Typendung folgt, und das merkt der dumme Thunderbird nicht. Er stellt sie in der laufenden Session sogar noch dar. :shock:


    Tückisch wird es aber nur, wenn Unterordner im Spiel sind. Aus der Profildatei "Diplom u.a.." (2 Punkte) wird "Diplom u.a" (keine Punkte), die Dateien der Unterordner stecken aber in einem Verzeichnis namens "Diplom u.a...sbd" (2 Punkte und 1 Punkt für die Typendung). Da eine Maildatei "Diplom u.a.." (2 Punkte) fehlt, können die Unterordner in TB nicht dargestellt werden. Dass in diesem Zusammenhang auch noch eine überflüssige Indexdatei "Diplom u.a...msf" (2 Punkte und 1 Punkt für die Typendung) erstellt worden ist, zu der es keine Maildatei gibt, ist schon nebensächlich.


    Gruß, Sünndogskind_2

  • hi Sünndogskind,


    perfekt recherchiert! Danke!!
    Das mit dem .. der durch Windows entfernt wird, habe ich auch per Test rausbekommen, die Problematik mit dem Unterordner hat meine graue Masse im Oberstübchen aber nicht erfasst :evil: