Thunderbird holt keine Mails automatisch ab, nur manuell

  • Hallo,


    folgendes Problem habe ich erst, seit ich einen neuen Hoster habe und meine Konten gelöscht und neu eingerichtet habe (meines Wissens habe ich außer dem Server und dem Benutzernamen nichts an den Einstellungen verändert):


    Manchmal tut Thunderbird, als hole er Mails ab, das Briefchen wird angezeigt, aber die Mails kommen erst, wenn ich sie manuell abhole, meist aber holt er sie GAR nicht automatisch ab.
    Ich hab’s bei allen Konten mit allen Einstellungen versucht, die ihn veranlassen sollen, sie abzuholen: Neue Nachrichten automatisch herunterladen, Alle 3 Minuten (auch mal mit alle 10 Minuten), Beim Start abholen und Kombinationen aus denen.


    Ideen? (Mein neuer Hoster, Hostloco, meinte, es seien vielleicht zu viele Verbindungen offen, was meint er denn damit? Alle anderen Bedingungen sind nämlich gleichgeblieben...)


    Dankeeeee!

  • Hallo oil-on-canvas,


    hast Du denn POP- oder IMAP-Konten? Bei Imap Konten mit Unterordnern auf dem Server wird je nach Anzahl der abonnierten Ordner die Verbindungszahl erhöht.
    Deine Beschreibung der Einstellungen lässt aber eher auf POP-Konten schliessen.
    Du hast den Hoster gewechselt und dazu die Konten neu eingerichtet. Die Mails verblieben aber in der Ordnerstruktur?
    Dann komprimiere mal alle Ordner jeweils per Rechtsklick/Diesen Ordner komp. und geh dann mal in den Profilordner und lösche die *.msf
    Da Du bereits seit über 2 Jahren dabei ist, findest Du den Profilordner ja wohl?

  • Danke. Ich hab die Ordner einzeln komprimiert (kam mir aber schnell vor! Was ist, wenn ein einziger aus Versehen vergessen habe, funktioniert es dann nicht?), dann sogar, wie in einem älteren Tipp empfohlen, nicht nur die msf- sondern auch die popstat-Dateien gelöscht, und es funktioniert immer noch nicht... Bin am Ausprobieren, denn was ich auch komisch fand, ist, dass die Ordner weiterhin den Popnamen des alten Hosters tragen. Grüßli u. bis später vielleicht.

  • Hallo,
    na ja, das vergessen eines Ordners wäre nicht dramatisch. Beim komprimieren werden ja nur überflüssige Mails entfernt, also z.B. die als gelöscht markierten, es wird nichts gezippt oder gepackt. Durch das Entfernen der *.msf muss TB danach die "gesäuberte" Dateien durchsehen, um einen aktuellen Index zu haben. Die Popstate ist wiederum der Index, welche Dateien bereits vom Server geladen wurden, war also ok die auch zu entfernen.
    Das die Ordner den alten Namen behalten ist normal, es gäbe sonst zu viel Kuddelmuddel, da in der pref.js, aber evtl auch in Dateien von Erweiterungen, sonst die Beziehungen nicht stimmen würden.


    Starte doch mal den TB einmal Testweise mit dem Profilmanager und lege ein neues Profil an und richte ein Konto ein. Start/Programme/Mozilla Thunderbird/Profiles Manager

  • Mittlerweile hab ich das Update auf Version 1.5.0.10 gemacht, keine Änderung, es kommt nur das Briefchen, aber nicht die Mails.


    Nun fiel mir aber auf, dass die Ordnernamen, in denen die Konteneinstellungen liegen, immer noch auf den alten Server lauten, nämlich


    mail.domainnameohnedotde.de
    mail.domainnameohnedotde.de
    mail.domainnameohnedotde.de


    Ich habe sie jetzt mal umbenannt und Nummern vergeben, bis sie alle 3 so hießen:


    pop.mail.domainnameohnedotde.de
    pop.mail.domainnameohnedotde.de-1
    pop.mail.domainnameohnedotde.de-2


    Da es immer noch nicht ging, Mails auch dann im Posteingang zu haben, wenn das Briefchen angezeigt wurde, habe ich es damit versucht:


    pop.mail.domainnamemitdotde
    pop.mail.domainnamemitdotde-1
    pop.mail.domainnamemitdotde-2


    Immer noch keine Mails zu sehen.


    Nochmal komprimiert, keine Änderung.


    Tja, und beim Starten von Thunderbird holt der Kerl auch nicht ab, das ging früher immer.

  • Sorry, ich hab deine Antwort erst wahrgenommen, nachdem ich mir schon die ganze Umbenenn-Arbeit gemacht hatte - jetzt hab ich wohl noch mehr kaputt gemacht, wenn das die Bezüge in der pref.js außer Kraft setzt. Auch kann ich mich nicht mehr genau erinnern, welches Konto ursprünglich wo vermerkt war. Aber wenn ich mir jetzt ein neues Profil anlege und auf diesem Weg funktioniert es, komme ich ja nicht mehr an meine Ordnerstruktur und Mails, oder?


    Schönes WE für alle Fälle schon mal,
    oilili

  • doch, Du kannst ein neues Profil anlegen und Deine Konten neu einrichten und dann die Mails aus dem alten Profil rüberkopieren. Dabei kann man auch die Ordnerstruktur kopieren :wink:
    Ist halt ein bisschen Arbeit

  • Wir tröstlich. Dann wirds schon werden. Wechsel bloß nicht den Hoster, da zieht sich immer ein Rattenschwanz von Arbeit hinterher.

  • Das mit dem neuen Profil ging tatsächlich - danke - ich möchte nun alle von der Problemlösung profitieren lassen:


    Da mit der Anleitung aus der Thunderbird-Hilfe „Wie übernehme ich Nachrichten und Einstellungen aus einem anderen Thunderbird-, Netscape6/7 oder Mozilla-Profil“ dummerweise alle (korrupten) Konten mitkamen, ich sie aber doch neu anlegen wollte, um besagten Abholfehler auszumerzen, hier mein Erfolgsrezept, das einfach umzusetzen war, obwohl ich das Thunderbird-Profil dabei gleichzeitig auf eine andere Partition geschoben habe: [andernfalls, wenn die Konten mitkommen dürfen, doch die vielleicht der ausgedruckten Thunderbird-Hilfe folgen!]


    1. Nur den alten Ordner „Local Folders“ (nicht der Konten-Ordner, in denen nur Einstellungen sind, die man leicht durch Neuanlegen nachholen kann) kopiert und vorübergehend in einen Ordner „Backup alte Local Folders“ neben den zukünftigen Speicherort des neuen Profils gestellt.
    Daraus per Suchen alle *.msf-Dateien gelöscht sowie die panacea.dat, xpti.dat, localstore.rdf und compreg. dat und alle *.ini und die extensions.rdf im Ordner extensions.
    (Falls das jemand nachvollziehen will, in der Thunderbird-Hilfe unter „Wie übernehme ich Nachrichten und Einstellungen aus einem anderen Thunderbird-, Netscape6/7 oder Mozilla-Profil“ stehen noch andere Dateien, auf die man achten muss, die bei mir aber nicht vorhanden waren)


    2. Start\Mozilla Thunderbird\Profile Manager gestartet und neues Profil angelegt, gleich mal auf der ersten Karte des Assistenten unter einem neuen Speicherort auf meiner Datenpartition im Ordner "Sonstige Anwendungsdateien“ statt auf C abgelegt (= später besser zu sichern). Bevor ich auf das neue Konto klickte, um Thunderbird zu öffnen, habe ich erst mal „Jetzt offline arbeiten“ angeklickt, damit neue Mails nicht direkt in diesem landen, bis alles stabil läuft (das andere Profil erst im Profil Manager gelöscht – niemals einfach die Ordner löschen!- , als alles lief, inklusive Adressbuchimport). „Beim Starten nicht nachfragen“ erstmal weggehakt, um per Klick auf das Thunderbird-Symbol vorübergehend komfortabel zwischen den Profilen wechseln zu können.


    3. Erst nur mal 1 Konto angelegt und überprüft, wie sich der Konten-Ordner nennt, der sich daraufhin unter „Speicherort des Profils\Mail\“ bildet. Er wurde eben nicht, wie es in der Thunderbird-Hilfe heißt, pop.Servername genannt, sondern nur Servername. (Alle folgenden Konten-Ordner bekamen einen Bindestrich und eine Nummer angehängt , die aber nicht hinter die Landesabkürzung der Domain, sondern vor sie kam, z. B.: Servernameminusde-1.de)


    4. Im neuen Ordner Mail\Local Folders alle Dateien gelöscht und da hinein die alten Mails (= mit Ordnerstruktur) aus dem Ordner „Backup alte Local Folders“ rüberkopiert.


    5. Weitere Konten angelegt und überprüft, dass auch die entsprechenden Ordner gebildet wurden.


    6. Thunderbird geschlossen, altes Profil aufgerufen, Adressbücher unter Adressbuch\Extras alle einzeln nacheinander exportiert (*.ldif) - ihnen genau den Namen gegeben, den sie im Adressbuch hatten -, geschlossen, neues Profil aufgerufen (immer noch offline), alle einzeln importiert.
    Die ursprünglich schon vorhandenen Adressbücher „Persönliches Adressbuch“ und "Gesammelte Adressen“ lassen sich nicht löschen. Da zwei meiner Bücher genauso so hießen, musste ich tricksen und alle Adressen im jeweiligen Buch markieren und in die alten Ordner rüberziehen. Bei einer Mailingliste ging das nicht, da musste ich unter "Gesammelte Adressen“ eine neue Liste anlegen, ihr 1 Adresse von Hand eingeben, damit sie sich überhaupt eröffnen ließ, und dann ließen sich die anderen reinziehen (die löschbaren Ordner gleichen Namens dann am Ende gelöscht).


    Das war's, nun wird das Briefchen angezeigt UND die Mails landen wieder im Posteingang!