HyperLink - Problem beim Aufruf aus HTML-formatierter Mail

  • Hallo Leute,


    wenn ich eine Mail schreibe und sie als HTML-Text verschicke, dann funktionieren unter Thunderbird eingefügte HyperLinks nicht.


    Beispiel:


    <a href="https://curriculum-online.de/confirm_i6g1lo18udm/lieferID_123.html">Bestätigungs-Link</a>


    Das wird optisch und im Quellcode richtig dargestellt. Im Aufruf wird aber alles um einen Buchstaben nach rechts verschoben:


    ttps://curriculum-online.de/confirm_i6g1lo18udm/lieferID_123.html"


    Also es fehlt das 'h' und es ist ein " zuviel am Ende. Dann startet natürlich kein Browser mehr.


    Kennt jemand das Problem? Ist es ein interner Bug? Kann man es abstellen?


    Viele Grüße


    Joachim Eberhardt

  • Hallo Joachim, willkommen im Forum.


    "JEberhardt" schrieb:

    Das wird optisch und im Quellcode richtig dargestellt.


    Dann kann das Problem doch eigentlich gar nicht bei Thunderbird liegen, wenn ein Link nicht richtig angezeigt wird dann liegt das meist an fehlerhaften Einstellungen des Betriebssystems.


    Tritt der Fehler auf deinem eigenen Rechner auf oder beim Empfänger der Mail?


    Gruß
    Werner

  • Hallo Werner,


    das Problem tritt bei verschiedenen Empfängern auf. Andere Mail-Programme wie Eudora oder Outlook stellen den Link richtig dar. Dort ist der Link anklickbar und es startet automatisch ein Browser-Programm.


    In diesem Forum gab es bereits ähnlich Beiträge, die ein Hyperlink-Problem schildern. Ich habe den Eindruck, dass auch dort dies Problem nicht wirklich gelöst wurde.


    Viele Grüße


    Joachim

  • JEberhardt ,
    habe das bei mir getestet mit deinem Link. Funktioniert einwandfrei.
    Probiere mal Folgendes:
    Schicke dir selbst eine ähnliche Mail anstatt auf Senden wählst du "später senden" aus. Die Mails liegt dann im lokalen Postausgang und du kannst den Quelltext lesen und den Hyperlink im Nachrichtenfenster direkt ausführen.
    Ich würde das ganze mal in einem neuen Profil versuchen, um auszuschließen, das dort eine Datei defekt ist.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    das ist leider nicht die Lösung. Die Mail wird als HTML-Mail aus einem Shop-System generiert.
    Der Link an sich funktioniert, allerdings nicht wenn er als HTML-Mail in Thunderbird geöffnet wird.


    Gruß


    Joachim[/url]

  • "JEberhardt" schrieb:


    Der Link an sich funktioniert, allerdings nicht wenn er als HTML-Mail in Thunderbird geöffnet wird.
    [/url]


    Bei mir aber schon. Allerdings habe ich auch kein Shop-System.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi Leute;


    ich bin da leider nicht der Experte, aber es muss an der Erstellung der Mail liegen.
    Wenn mrb den Link manuell erstellt ist alles OK, wird er hingegen vom Shop System erstellt, geht es nicht.
    Vielleicht kannst Du JEberhardt, mal einen Quelltext posten, damit das vergleichbar wird.


    Gruß

  • Hallo Leute,


    das Problem ist gelöst. Uff!


    Danke für Eure Hilfe!!


    In der Header der HTML-formatierten Mail darf folgende Zeile nicht stehen:
    Content-Transfer-Encoding: quoted-printable;


    Einige Mail-Programme tolerieren es - Thunderbird nicht.
    Wieder was dazu gelernt.


    Gruß
    Joachim

  • Hallo,
    mich hätte ja dann noch gerne interessiert ob in den Einstellungen, unter Verfassen, Allgemein dort "Quoted Printable" angehakt war oder nicht.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    die Mail wird nicht in Thunderbird verfasst. Die Mail wird automatisch generiert in einem barrierefreien Shopsystem einer Buchhandlung (http://www.curriculum-online.de).
    Ich habe den Shop als CMS in php entwicklt. Wird ein Buch gekauft so erhält der Kunde eine Mail, in der über den besagten Link die Bestellung durch den Kunden bestätigt wird (double-opt-in). Also, die Mail inklusive aller notwendigen Header-Zeilen wird von dem CMS geschrieben und gesendet. Bisher funktioniert der Link in allen Mail-Programmen ausser eben Thunderbird. Und nach der Änderung im Header funktioniert das jetzt auch.


    Gruß
    Joachim