neue Aktion für Attachment erstellen

  • TB 2.0.0.4 Linux/IceWM


    Moin,


    einige Bilder (jpg, bmp) im Anhang sind bei mir mit xv verknüpft und werden auch geöfnet. Andere, die nicht in der Liste der Aktionen stehen (tif), werden mit xnview geöffnet. Das möchte ich auch auf xv ändern - kann es aber nicht, weil sie eben nicht in der Liste stehen. Es fehlt also so eine Option wie "öffnen mit..." oder "neu erstellen".


    *Die* Standardverknüpfung für bestimmte Endungen wie unter Windows gibt es in Linux nicht, sie sind immer Anwendungs- oder Windowmanager-bezogen. Bei IceWM gibt es das so nicht. Also müßten die Verknüpfungen irgendwo in den Thunderbird (unter ~/.thunderbird) stehen, tun sie aber nicht, jedenfalls finde ich es nicht.


    Gibt es Abhilfe? Kann ich das irgendwo zu Fuß editieren, die nötigen und vorhandenen Kenntnisse vorausgesetzt :-).


    Ralph

  • Falls ich dich nicht falsch verstehe: Unter SuSE findet man die Standard-Verknüpfung unter "Persönliche Einstellungen/KDE-Komponenten/Dateizuordnungen"


    Joke

  • Nix KDE! Ich nutze IceWM, wie ich erwähnte :-), und da gibt's das nicht.


    Ralph

  • Und dabei wär's sonst so einfach gewesen! Ich dachte, ich kenne die gängigen Linux-Distributionen - IceWM war mir als solche nicht bekannt.


    Joke

  • Wieder falsch gelegen: IceWM ist keine Distri, sondern ein Windowmanager wie KDE oder Gnome. Aber das wird jetzt OffTopic :-).


    Ralph

  • "Joke" schrieb:

    ... und wieder was gelernt!


    Jeden Tag :D . Danke, Joke.


    Nun bin ich nur gespannt, ob einer ne Antwort auf mein eigentliches Problem hat... :roll:


    Ralph

  • Eine Notlösung ist gefunden: in ~/.thunderbird/xxxxx.default/mimeTypes.rdf stehen die ganzen Verknüpfungen (xxxxx ist Nutzerabhängig, bei mir gibts nur 1 solches Verzeichnis). Ich habe die Datei einfach mal umbenannt, TB neu gestartet (dabei wird die mimeTypes.rdf neu angelegt) und einen Anhang angeklickt - es erscheint der Dialog, mit dem man die passende Anwendung öffnen kann. Weil es eben keine Verknüpfungen mehr gibt. Die kann ich damit jetzt neu zuweisen.


    Die Datei ist normal editierbar, aber es ist mühsam zu finden, wo man drehen muß. Kann man also tun, aber die Notlösung ist einfacher :-).


    Schlecht ist, daß TB keine Option zum Neu-Anlegen solcher Verknüpfungen anbietet! Da sollten sich die Entwickler des ansonsten tolen Programms was einfallen lassen, finde ich.


    Ralph

  • Hallo Ralph,


    "Bearbeiten/Einstellungen/Anhänge/Standard-Aktionen/Aktionen anzeigen & bearbeiten" hilft auch nicht weiter?


    Micha :-D

  • Nein, hilft nicht weiter: "bearbeiten" ist nicht "neu anlegen". Die beschriebene Notlösung ist die einzige gefundene. Die Thunderbid-Entwickler haben nicht bedacht, daß es schon vom System (hier Linux) her Voreinstellungen für MIMI-Typen gibt, die aber von der aktuellen Umgebung abhängig und damit irgendwo im System verstreut (= schwer zu finden und zu ändern) sind. Daher wird ein so definierter Dateityp nicht zum Bearbeiten angeboten. Bei Windoof ist das einfacher, da stehen alle Typen zusammen in der Registry und lassen sich (ebenfalls Sachkenntnis vorausgesetzt) dort überschreiben.


    Ralph

  • Hallo Ralph,


    ich habe es gerade noch mal getestet. Bei mir funktioniert es. Ich kann die Einstellungen sowohl ändern als auch löschen. Beim Ändern kann ich auch das jeweilige Programm, mit welchem die Datei/der Dateityp geöffnet werden soll aussuchen (vorausgesetz ich weiß, wo im System das Programm liegt ;-) )


    Micha :-D

  • Lieber Micha, ich möchte etwas HINZUFÜGEN, was noch nicht da ist, und das geht nicht! Also zum mitmeiseln: ich klicke auf en Bild im Anahang, dessen Format (z.B. TIF) nicht in der Liste ist. Aufgrund der Sytemeinstellungen (!) wird mir das ohne Rückfrage angezeigt. Wenn ich das öffnende Programm ändern will, habe ich keine Chance, weil es eben nicht in der Liste ist. Und jetzt kann ich es auch nicht hinzufügen, weil eben das nicht geht. Claro? Es müßte ändern, löschen UND zufügen geben. Es gibt aber nur ändern und löschen.


    Ralph

  • Danke Ralph.


    Die Tatsache, daß es bei Dir eine Standardregel gibt, welche nicht aufgeführt wird, ist mir so nicht bewußt geworden. Bei mir werden entweder eine Standardregel ausgeführt bzw. bei Nichtvorhandensein das Auswahlfenster gezeigt. Dort ist dann das Programm, welches aufgrund von Systemeinstellungen ausgesucht wird, voreingestellt. Mir bleiben aber immer noch weitere Auswahlmöglichkeiten (Speichern, anderes Programm und Hinzufügen als Standardregel).


    Gibt es dies Phänomen bei Dir nur für einen Dateityp (*.tif) oder auch für andere? Gibt es Dateitypen, bei denen das Problem nicht auftritt?


    Micha :-D


    P.S. Bitte Schrei nicht so. Ich liege mit Grippe im Bett und meine Ohren sind empfindlich.[/i]

  • Sorry, Micha, ih wollte nicht schreien, ist mir so rausgerutscht :-). Gute Besserung für Deine Ohren!


    Also: irgendwelche Standardregeln für Dateitypen gibt es vermutlich in jedem System. Bei Windoof an bekannter Stelle in der Registry, dort ist es überschaubar. Bei Linux ist das ggf. sehr verstreut, je nach System (Distri) und verwendetem Windowmanager. Irgendwo sind MIM-Typen festgelegt, und die Zuordnung zu bestimmten Programmen ist mir nicht unbedingt klar (eigentlich gar nicht). Zum Bleistift kann ich beim Midnight Commander (bekannt? NortonCommander-Clone) in einer Datei explizit festlegen, daß beim Doppelklick auf ein .tif ein bestimmter Angucker aufgeht. Beim Thunderbird ist das so ähnlich (siehe oben mimeTypes.rdf ). Nur werden eben auch dort nicht aufgeführte Typen ggf. mit irgendwas geöffnet, wenn sie woanders verknüpft sind (und diese Stelle kenne ich nicht). Es kann also - Deine Frage - bei allen möglichen Typen der Effekt auftreten, daß sie automatisch geöffnet werden, obwohl sie nicht in der Thunderbird-eigenen Definitionsdatei stehen.


    Und *das* (ich schreie nicht :-) ) ist der Fehler: TB sollte sich ausschließlich auf die eigene Def.-Datei beziehen und Typen, die dort nicht eingestellt sind, zur Auswahl des öffnenden Programms anbieten! Wenn das so wäre, bräuchte ich keine extra Option "hinzufügen" und ich müßte auch nicht die TB-Datei bearbeiten (was ein nur-User nicht kann). TB ist ein Programm, das auf vielen Systemen zur Verfügung steht, die er unmöglich alle kennen kann, und damit kann er auch unmöglich alle Verknüpfungsmöglichkeiten kennen - also sollte er nur seine eigenen benutzen!


    Ich hoffe, das erklärt's nun hinreichend. Schönen Gruß ebenfalls nach Leipzig!
    Ralph

  • Und eben diesen von Dir beschriebenen Effekt kann ich bei mir nicht nachvollziehen. Mein TB hat seine eigenen Regeln bzw. fragt mich. Ungefragt übernimmt er aber bei mir keine systemweiten Einstellungen - er schlägt sie mir nur vor.


    Nachdem Du den Eintrag in der mimeTypes.rdf gelöscht hast, bekommst Du dann das Auswahlfenster angezeigt? Gibt es überhaupt Dateitypen, bei denen Du dieses siehst, bzw. für welche es Standardregeln (TB) gibt, welche im Bearbeitungsfenster angezeigt werden? (die oben von Dir benannten *.bmp, *.jpg?)


    Kannst Du vielleicht Deine mimeTypes.rdf mal posten?


    Micha :-D


    P.S. Ja ich weiß, was der ms ist. Und ja ich habe auch schon mit dem NortonCommander gearbeitet ;-)

  • Tja, ich müßte mir mal ne Mail schicken mit was außergewöhnlichem dran, andererseits wird es für die wenigsten exotischen Typen ne Standardeinstellung geben. Ich habs nur für .tif gemerkt, daß da irgend so ein Gnome-Viewer benutzt wurde (obwohl ich nicht mit Gnome arbeite, das aber mal tat). Wie auch immer... Hier ist die Datei nach dem Wegwerfen und neu erzeugen (lassen)::


    <?xml version="1.0"?>
    <RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#"
    xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
    <RDF:Seq RDF:about="urn:mimetypes:root">
    <RDF:li RDF:resource="urn:mimetype:application/tif"/>
    <RDF:li RDF:resource="urn:mimetype:image/gif"/>
    <RDF:li RDF:resource="urn:mimetype:image/jpeg"/>
    </RDF:Seq>
    <RDF:Description RDF:about="urn:mimetype:handler:image/jpeg"
    NC:alwaysAsk="false"
    NC:saveToDisk="false"
    NC:useSystemDefault="false"
    NC:handleInternal="false">
    <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:image/jpeg"/>
    </RDF:Description>
    <RDF:Description RDF:about="urn:mimetypes">
    <NC:MIME-types RDF:resource="urn:mimetypes:root"/>
    </RDF:Description>
    <RDF:Description RDF:about="urn:mimetype:handler:image/gif"
    NC:alwaysAsk="false"
    NC:saveToDisk="false"
    NC:useSystemDefault="false"
    NC:handleInternal="false">
    <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:image/gif"/>
    </RDF:Description>
    <RDF:Description RDF:about="urn:mimetype:externalApplication:image/jpeg"
    NC:path="/usr/X11R6/bin/xv"
    NC:prettyName="xv" />
    <RDF:Description RDF:about="urn:mimetype:image/gif"
    NC:value="image/gif"
    NC:editable="true"
    NC:fileExtensions="gif"
    NC:description="GIF-Bild">
    <NC:handlerProp RDF:resource="urn:mimetype:handler:image/gif"/>
    </RDF:Description>
    <RDF:Description RDF:about="urn:mimetype:externalApplication:application/tif"
    NC:path="/usr/X11R6/bin/xv"
    NC:prettyName="xv" />
    <RDF:Description RDF:about="urn:mimetype:image/jpeg"
    NC:value="image/jpeg"
    NC:editable="true"
    NC:description="JPEG-Bild">
    <NC:fileExtensions>jpg</NC:fileExtensions>
    <NC:fileExtensions>jpeg</NC:fileExtensions>
    <NC:fileExtensions>jpe</NC:fileExtensions>
    <NC:handlerProp RDF:resource="urn:mimetype:handler:image/jpeg"/>
    </RDF:Description>
    <RDF:Description RDF:about="urn:mimetype:externalApplication:image/gif"
    NC:path="/usr/X11R6/bin/xv"
    NC:prettyName="xv" />
    <RDF:Description RDF:about="urn:mimetype:application/tif"
    NC:value="application/tif"
    NC:editable="true"
    NC:description="TIFF-Bild">
    <NC:handlerProp RDF:resource="urn:mimetype:handler:application/tif"/>
    </RDF:Description>
    <RDF:Description RDF:about="urn:mimetype:handler:application/tif"
    NC:alwaysAsk="false"
    NC:saveToDisk="false"
    NC:useSystemDefault="false"
    NC:handleInternal="false">
    <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/tif"/>
    </RDF:Description>
    </RDF:RDF>


    Ist für mich nicht wirklich übersichtlich, obwohl ich mit xml durchaus umgehen kann. Deine Frage noch: wenn ich enen Typ lösche, bekomme ich nächstes mal die Frage, ja. Und nein, ich habe keinen Typ parat, bei dem es nun nicht mehr funktioniert (tif ist ja erledigt).


    Ralph


    PS in den Raum gestellt: wo überall könnten denn Standard-Vverknüpfungen bei Suse 10 mit (früher mal) KDE und (früher mal) Gnome und (jetzt) IceWM stehen?