MagicSLR ???

  • Hallo!


    wir hatten das schon mal, mit einer älteren Version, von MagicSLR:
    wenn man diese Erweiterung installierte, dann verschwanden oben aus dem Menu die Punkte "Datei" und "Bearbeiten".
    Damals habe ich das voller Hoffnung hier im Forum gemeldet;
    als Antwort habe ich eine schnippische Bemerkung vom Herrn "Thunder", alias Herrn Ihrig, geerntet.
    Jetzt, mit der neusten Version von MagicSLR, taucht dieses Problem erneut auf. Thunderbird 1.5.0.12 ist installiert.
    Ich werde diese Erweiterung jetzt deinstallieren, somit ist dieses Thema für mich erledigt ..


    Danke. :?

  • Hallo aljurisch,


    ich wollte das gerade in einem Testprofil nachvollziehen und habe dann erst mal gesucht.
    Lese Dir doch noch mal den alten Thread durch> http://www.thunderbird-mail.de…topic.php?p=123171#123171
    Nachdem Dein Problem behoben war

    "aljurisch" schrieb:

    Hallo, Thunder!


    also, ich bin Deiner Empfehlung gefolgt, und habe einen völlig neuen Benutzer angelegt, und mit dessen eingeschränkten Rechten den TB gestartet, so daß er für diesen Benutzer ein ganz neues Profil angelegt hat.
    Darin habe ich dann MagicSlr installiert, die neue Version 1.2


    Nach dem obligatorischen Neustart war die Leiste oben einwandfrei - wie es sein soll. Kein Problem also!...
    ...- aber man soll doch Internetanwendungen mit eingeschränkten Rechten betreiben, der Sicherheit wegen - deswegen habe ich es so bei mir organisiert ...

    hat Thunder noch eine abschliessende Frage gestellt

    "Thunder alias Alexander Ihrig" schrieb:

    Klar sollte, man mit eingeschränkten Rechten surfen - ich mache das auch. Ich kann momentan nicht ganz nachvollziehen, warum Du mit "runas" den Thunderbird laufen lässt,denn da liegt doch der Hund begraben. Vermutlich gibt es da Probleme mit der Aktualisierung des XUL-Caches.

    deren Beantwortung bis Heute offen geblieben ist.

    "alljurisch" schrieb:

    Damals habe ich das voller Hoffnung hier im Forum gemeldet;
    als Antwort habe ich eine schnippische Bemerkung vom Herrn "Thunder", alias Herrn Ihrig, geerntet.

    mal ehrlich, nachvollziehen kann ich diese Aussage nicht. Was war da schnippisch?
    :roll:

  • danke, rum.



    Man kann das natürlich auffassen, wie man will.
    Man kann mir selbstverständlich auch vorwerfen, daß ich überspitzt reagiere.


    wie auch immer, das Problem ist für mich nun beseitigt.
    Die Titelleiste im TB ist jetzt wieder ok.
    8)

  • Sorry, ich wollte Keinem etwas vorwerfen, nur zum nachlesen und überdenken anregen :wink:
    (Es ist nicht immer leicht, das was man denkt statt im Gespräch, unter zur Hilfenahme von Mimik und Gestik, rein schriftlich rüber zu bringen. )

    "aljurisch" schrieb:

    Ich werde diese Erweiterung jetzt deinstallieren, somit ist dieses Thema für mich erledigt ..

    und

    Zitat

    wie auch immer, das Problem ist für mich nun beseitigt.
    Die Titelleiste im TB ist jetzt wieder ok.

    Würde mich freuen, wenn mein Posting und das dadurch verursachte "in Erinnerung rufen" mitgeholfen haben.
    Aber wie dem auch sei, ich freue mich, dass Du Dein Problem gelöst hast, hoffe das die Lösung nicht in der Deinstallation bestand und Du so ein hoffentlich zumindest in dieser Hinsicht entspanntes Wochenende verbringen kannst

  • Danke, Rum!


    [XP;TB 1.5.12]


    Dass bei solchen Diskussionen die Mimik fehlt, da hast Du voll und ganz recht.


    Nun, ich will mal das Ganze näher darlegen - eventuell wird es etwas zu lang,
    und ein paar Punkte könnten nicht ins Forum gehören, dann bitte ich um Entschuldigung ...


    Es war so:
    meist, zu etwa 75%, habe ich Windows XP gestartet;
    da habe ich recht schnell heraus gefunden, daß man eigentlich nur mit Administratorrechten so richtig glücklich wird; denn mit Benutzerrechten sind einem einfach zu viele Funktionen und Einstellungen verwehrt; ach ja - ich habe das XP nur einmal installiert, und seither läuft es sogar, ohne Neuinstallation. Das war früher mal anders. Aber wem sage ich das!
    So, aber wenn man sich das Internet anschaut, wie es da heute nun mal leider zugeht, dann ist man aber gezwungen, alle Anwendungen, die aufs Internet zugreifen, mit Benutzerrechten zu betreiben;
    ich kann das beweisen; ich habe vor dem Intranet hier einen Slackware (Linux)- Server, der mit Dienste,
    wie Routing, DNS, und DHCP und einen Firewall zur Verfügung stellt.
    Und noch vieles mehr ....
    Wenn ich jetzt den Firewall auf volles Logging stelle, dann schwillt innerhalb einer Woche die Logdatei
    auf mehrere Megabyte an: fragmentierte Pakete - Portscans, beinahe stündlich - klar, manches mag Zufall sein, aber irgendwann denkt man sich doch Böses dabei. Vor 10 Jahren ist es auf jeden Fall nicht so zugegangen. Das ist mal ganz sicher.
    So, also stand ich bei XP (um zum Thema zurück zu kommen) vor der Wahl:
    entweder ich darf alles im System, und habe das hohe Risiko, denn auch der Firewall liefert mir stets,
    was ich im www eventuell ohne Absicht anklicke. Da ist ja mittlerweile auch auf guten Websites bösartiger Code zu finden, weil er denen untergeschoben wurde.
    Tja - oder ich fahre ein Profil mit Benutzerrechten, das ist sicher, beim www, weil sich die Schadsoftware nicht installieren darf.
    Und dafür müßte ich jedes Mal zwischen den Profilen hin- und her wechseln, was mir aber zu umstaendlich war.
    Der Ausweg war für mich, alles Internetanwendungen über den Befehl "runas" mit Benutzerrechten zu starten, von einem Profil aus, das ansonsten Admin - Rechte hat.
    So, und nun endlich zu TB:
    auch den habe ich mittels "runas" mit Benutzerrechten gestartet.
    Ich habe 9 Erweiterungen integriert, und alle liessen sich anstandslos immer updaten,
    wenn eine neue Version erschien. Nur "MagigSLR" eben ab einer bestimmetn Version nicht mehr,
    das heisst: die Installation gelang, aber das Menu oben war weg.
    So, ich meinte es nun gut, und habe das hier gemeldet;
    ich dachte, ich tue etwas Gutes, wenn ich meine Erfahrungen beitrage -
    dabei hat mich die Antwort von "Thunder" dann eben etwas verstimmt, dass der Hund da begraben sei,
    wenn man den TB mittels "runas" startet.
    Das habe ich so nicht ganz eingesehen, weil restlos alle anderen Erweiterungen keine Probleme machten.
    Das war dann auch der Grund, warum ich keine Antwort mehr gegeben habe.
    Und interessanterweise kam kurz danach ein Update, von MagicSLR, das ich wieder im
    TB unter Benutzerrechten installierte, und die Titelleiste war wieder da!


    So, und heute ist es doch so, daß die Herrschaften aus Redmond wieder mal ein neues Betriebssystem
    verkaufen wollen, für viel Geld, das für mich unverständlicherweise unheimlich viele Ressourcen
    frißt, und damit den Stromverbrauch einer Rechners in die Höhe jagt;
    und das in einer Zeit, wo alle vom Klimaschutz, und vom Energiesparen reden.
    Ich bin kein Grüner, aber trotzdem ist dies für mich das falsche Produkt zur jetzigen Zeit.


    Gut, ich habe also ein neues OS installiert - allerdings eines, das kein Geld kostet: FreeBSD !
    Das kommt meinen Anforderungen mehr entgegen. Das schont die Ressourcen. Und meinen Rechner. Und laeuft traumhaft.
    Und wie die Sache aussieht, werde ich künftig Windows immer weniger starten.
    Ich habe mich in BSD sofort wohl gefühlt, nachdem ich schon über 11 Jahre jetzt Linux
    nebenher auf dem Rechner habe. Vieles ist sehr ähnlich, nur die Devices heißen anders ...
    Und man kann mithilfe der Ports - Sammlung beinahe alles selber compilieren, ganz problemlos.


    Und unter BSD habe ich auch den neusten TB am Laufen, sogar die 2er Version.
    Da ist dann auch neben allen anderen Erweiterungen "MagicSLR" installiert,
    und funktioniert da unter X11 mit Benutzerrechten ganz prächtig!


    => es muß also niemand traurig sein, wenn ich jetzt unter XP beim TB "MagicSLR"
    deinstalliert habe, denn irgendwann wird XP bei mir ganz verwaisen, weil ich es ab einem gewissen Zeitpunkt gar nicht mehr starten werde, und wenn ich mal Speicherplatz brauche, na ja ...
    ich denke, der Rest ist klar!


    ach ja:
    sogar bei der Firma Microsoft in Redmond laufen die Firewall- Server mit dem Betriebssytem
    FreeBSD - warum wohl?
    - da mag sich jetzt jeder selber seinen Reim drauf machen .....


    :lol:

  • Ich kann nur sagen: meine Antwort damals war nicht schnippich gemeint. Ich reagiere manchmal auch "eingeschnappt", obwohl Aussagen anderer Personen vielleicht gar nicht "böse" gemeint waren - von daher kann ich alljurisch verstehen. Leider führt sowas dann immer dazu, dass Probleme nicht gelöst werden.


    Soweit ich mich zurück entsinne, habe ich in MagicSLR bezüglich des hier genannten Problems nichts geändert. Ich denke daher weiterhin, dass es ein spezielles Problem im Rahmen des "runas" Befehls war. MagicSLR hat noch nie Adminrechte gebraucht, um upgedated zu werden - genauso wenig wie andere Erweiterungen. Aus technischer Sicht kann da auch (theoretisch) gar kein Unterschied sein, da MagicSLR nur ganz rudimentären XUL-/JS-Code enthält, der sich nicht von anderen Erweiterungen unterscheidet.


    Da es wohl nur extrem wenige Anwender gibt, die Ihr System mit Admin-Rechten und dann einzelne Anwendungen mit eingeschränkten Rechten nutzen, kann man wohl leider keine repräsentative Aussage machen, ob das aufgetretene Problem letztlich an "runas" lag/liegt.


    Über den Sinn, das System als Admin und einzelne Anwendungen als eingeschränkter Nutzer zu betreiben, sollte hier nun aber bitte nicht diskutiert werden.


    Gruß
    Thunder

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Hallo!


    [XP;TB 1.5.12]



    ja, danke!


    aber letztlich wird mir das keine Rolle mehr spielen, wenn es ein Problem
    von Windows sein sollte ...
    denn ich werde mich von diesem System über kurz oder lang ja eh
    ganz verabschieden, und ich finde es jetzt im Nachhinein müßig,
    über die Probleme dieses Betriebssystems nachzudenken.
    Wir ändern daran eh nichts. Die wissen es ja doch besser.
    -
    was mich in dem Zusammenhang aber wirklich interessieren würde:
    kann ich den XUL - Cache vom TB auch manuell irgendwie aktualisieren?


    :?: