Thunderbird findet Daten nicht mehr

  • Während ich im Urlaub war und mit meinem Laptop nicht online gegangen bin, hat Thunderbird (2.0.0.0) plötzlich alle Daten verloren, d. h., er kennt mein Profil nicht mehr, alle Mails etc. sind weg. Wenn ich es öffne, kommt die Meldung, ich müsse erst ein Konto anlegen, bevor ich damit arbeiten könne.


    In Wirklichkeit habe ich aber gut 10 Konten in Thunderbird angelegt, und in den Anwendungsdaten ist auch alles da. Aber Thunderbird findet es nicht mehr. Ich habe schon versucht, das Programm zu deinstallieren und neu zu installieren (mit der exe, die auf der FP liegt) - alles ohne Erfolg. Ich bekomme weiterhin die Meldung, dass ich Thunderbird erst einrichten muss. Normalerweise ist es ja so, wenn man Thunderbird neu installiert, dass es direkt auf die vorhandenen Daten zugreift und die gesamte Struktur übernimmt und anzeigt. Aber es klappt einfach nicht mehr - das Programm denkt, es ist leer - ist es aber nicht.


    Meine Frage nun - wie kriege ich Thunderbird dazu, sich die Daten aus den Anwendungsdaten wieder zu holen? Wie kann ich dem Programm sagen, wo die Dinge liegen?


    Ein Versuch über die Systemwiederherstellung hat leider nicht funktioniert, danach hat sich Thunderbird nicht mal mehr öffnen lassen,sondern öffnete eine Fehlermeldung, die ich direkt wietersenden sollte (neben der üblichen Windows-Fehlermeldung "... hat einen Fehler verursacht und muss beendet werden ... blablabla ..." auch eine weitere direkte Meldung von Thunderbird). Nachdem ich das wieder rückgängig gemacht habe, bin ich nun immerhin wieder bei dem "alten" Problem - Thunderbird öffnet sich und will ein neues Konto einrichten.


    Bisher war ich mit dem Laptop noch nicht wieder online, es kann also auch nicht über ein Update oder irgendetwas aus dem Netz passiert sein.


    Das einzige, was ich zwischendurch mal gemacht hatte, war eine Datenträgerbereinigung und ein Defrag bzw. eine Aufräumaktion mit TuneUp-Utilities. Aber all das habe ich ja nicht zum ersten Mal gemacht ...


    Da ich nicht nur privat, sondern auch beruflich mit Thunderbird arbeite und wirklich alle wichtigen Mails darüber laufen, wäre ich über konstruktive Tipps sehr dankbar.


    Interessanterweise ist das Adressbuch übrigens verfügbar.

  • Hallo Werner,


    danke für die Antwort und den Tipp zum Weiterlesen. Dies hier habe ich ausprobiert:


    In einigen Fällen findet sich bei solchen Problemen im Profilordner eine Datei die so ähnlich heißt wie die "prefs.js", z. B. "prefs-1.js" die Konfigurationsdatei kann dann durch Umbenennen dieser Datei wiederhergestellt werden. Es wäre auch möglich die "prefs.js" durch die gleichnamige Datei einer aktuellen Datensicherung zu ersetzen, wenn beides nicht verfügbar ist wird es ein klein wenig komplizierter, aber das können wir bei Bedarf klären.


    Ich habe nachgeschaut und finde in meinem Profil sowohl die Datei prefs (2 kb) als auch die Datei prefs-1 (86 kb). Beide haben keine Endung .js - aber auch das Umbenennen in prefs.js bzw. prefs-1.js hat nichts gebracht. Thunderbird öffnet weiterhin als erstes den Kontoeinrichter ...


    Ich bin noch nicht zu Hause, dort habe ich auf einer externen FP alle meine Daten und auch Anwendungsdaten aktuell gesichert. Reicht es evtl., diese Sicherung einfach in den Profilordner zu übernehmen, damit die Daten wieder verfügbar sind?


    Ansonsten - woran könnte es noch liegen - oder habe ich mit den pref-Dateien vielleicht etwas falsch verstanden?


    Danke und Grüße,


    Holtzwurm

  • Zitat von "holtzwurm"

    Ich habe nachgeschaut und finde in meinem Profil sowohl die Datei prefs (2 kb) als auch die Datei prefs-1 (86 kb).


    Das sieht sehr gut aus, mit der prefs-1 kann dein Profil wahrscheinlich wieder aktiviert werden.


    Zitat von "holtzwurm"

    Beide haben keine Endung .js


    Die Endung ist ganz bestimmt vorhanden, aber du hast wahrscheinlich Windows so eingestellt dass bekannte Endungen nicht dargestellt werden. :wink:


    Zitat von "holtzwurm"

    ... auch das Umbenennen in prefs.js bzw. prefs-1.js hat nichts gebracht.


    So kann es auch nicht funktionieren, durch das Anhängen von "js" hast du eine Datei namens "prefs.js.js" erzeugt. Ändere einfach die Datei "prefs" in "prefs-leer" und "prefs-1" in "prefs" dann sollte es funktionieren.


    Gruß
    Werner

  • Hey, danke für die schnelle Antwort!


    Das hat jetzt tatsächlich geklappt! Eigentlich zeigt mir Windows alle Endungen an, denn ich habe "Details anzeigen" eingestellt, aber trotzdem hat es geklappt. Allerdings habe ich interessanterweise festgestellt, dass es dann noch eine Datei prefs gab, die nur 1 KB hat. Diese habe ich erstmal in prefs11 umbenannt, weil ich sonst die prefs-1 nicht in prefs umbenennen konnte. Kann ich die evtl. rauswerfen??


    Und - ich habe ja auf der ext. FP die aktuelle Datensicherung - die hat ja sicherlich andere Bezeichnungen für die jetzt umbenannten Dateien. Ist das letztlich egal (beim nächsten Backup würde ja dann die jetzt neue Bezeichnung gesichert werden) - oder sollte ich besser die Datei durch die gesicherte Version ersetzen?


    Danke für deine Hilfe!


    Grüße,


    Holtzwurm

  • Version 1.5.0.12 (20070509)


    habe im profilverzeichnis zwei "prefs" dateien gefunden und die eine in "prefs1" die andere in "prefs0" umbenannt. beide dateien sind 2KB groß. nichts hilft ich werde aufgefordert ein neues profil mit neuen konten etc. einzurichten, wenn ich thunderbird öffne. vor ein paar stunden hat alles noch funktioniert. erst nach neuerlichem hochfahren gab es das problem. habe nun ein neues profil erstellt, um wenigsten neue mails abrufen zu können (die daten hatte ich zum glück im kopf). aber die alten mails und kontakte sind nicht mehr da. was soll ich machen?


    danke für jede hilfe!