Empfaenger kann Anhaenge nicht oeffnen..

  • Hallo Forum,


    folgendes Problem:
    Verschickte Anhaenge - egal welches Format - lassen sich bei den Empfaengern nicht automatisch oeffnen. Erst wenn man den Anhang lokal abspeichert kann danach die entsprechende Datei geoeffnet werden. Verschickt werden die Mails meines Wissens mit einem TBird 1.5x, Empfaenger haben sowohl TBird 1.5x als auch 2.x.
    Irgendjemand eine Idee???
    Danke und Gruss


    Perennator

  • Hallo,
    das könnte an den MIME-Einstellungen des Empfängers liegen oder an dessen Programmen für das Öffnen des jeweiligen Typs.
    Suche mal im Forum nach Beiträgen zum Thema: anhänge nicht öffnen mime bzw. mimetypes
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Erstmal Danke fuer die schnelle Antwort, allerdings glaube ich nicht, dass es daran liegt. Jeder dieser Empfaenger kann von anderen Versendern die Attachments oeffnen, eben nur nicht von diesem einen. Kann also IMHO kein Empfaengerproblem sein.


    P.

  • Hallo,
    könntest du mir mal ein derartige Mail zukommen lassen?
    Ich schicke dir eine PN mit meiner Mailadresse.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    wie hängst du den Anhang an die Mail?
    Erzeugst du die Mail etwa mit Word?


    Deine an mich gesendete Mail ist so deklariert, dass sie TB nicht richtig darstellen kann.
    Ich kann den Anhang auch nicht öffnen.
    Speichere ich ihn aber ab und versende ihn noch mal, dann geht es und die Deklarierung fällt anders aus.


    Deklarierung der an mich gesendeten Mail:


    --------------040705000905000400080908
    Content-Type: *.msword;
    name="Protokoll 20080124.doc"
    Content-Transfer-Encoding: base64
    Content-Disposition: inline;
    filename="Protokoll 20080124.doc"



    Deklarierung der von mir versandten Mail:


    --------------060108030207090201060001
    Content-Type: application/msword;
    name="Protokoll 20080124.doc"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
    filename="Protokoll 20080124.doc"


    Siehst du den Unterschied?


    Wenn du möchtest, schicke ich dir beide Mails (deine als Weiterleitung) wieder zu.


    Erstelle also die MAil in TB und hänge die Datei normal an.


    U.U. musst du in about:config noch folgende Änderung machen:


    Stelle diesen Eintrag auf 1:


    mail.content_disposition_type


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke - werde ich prüfen. Da es sich bei dem Fehler nicht immer nur um Word Dokumente handelt, sondern Formatunabhaengig ist, werde ich bei dem entsprechenden Rechner meiner Chefin mal in der about:config gucken. Danke schonmal.
    Gruss
    P.

  • Ah das ist gar nicht dein Rechner?
    Läuft das im Büro über einem Mailserver?
    Außerdem: 1.5 ist nicht die aktuelle Version. Ein Update ist zu empfehlen.


    Alle von mir gemachten Angaben beziehen sich immer auf die aktuelle Version.


    Tipp: man kann schon vor dem Versenden den Quelltext und die Deklarierung anschauen, wenn du die Mails nicht mit "Senden" wegschickst, sondern mit "später senden". Dann landen sie im Postausgangsordner und dort kann man den Quelltext (strg+U) aufrufen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Nein, nein - nicht mein Rechner. Deswegen kann ich ja auch nicht immer gleich auf die Tipps reagieren. So auch jetzt, komme erst Montag testen. Ein schönes Wochenende.
    P.

  • Zitat von "mrb"

    Ah das ist gar nicht dein Rechner?


    Grundsätzlich erhält man diese Erkenntnis schon aus dem Topic des Autors :-)


    Es geht um einen Empfänger. Meines Erachtens sollte sich der Empfänger also, egal worum es geht, erstmal an einen eigenen Zuständigen Administrator wenden, da sich offensichtlich auch nur um einen Empfänger und nicht global um alle Empfänger von E-Mails vom Absender handelt.


    Derartige Problematiken habe ich zum Beispiel nicht selten bei Nutzern, die mit irgendwelchen Anwendungen (z.B. Datei Öffnen oder über den Explorer mit zerschossenen Anwendungsverknüpfungen) versuchen, Dateien zu öffnen, die nicht zur Applikation gehören. Dabei ist es natürlich egal, ob man Thunderbird, Lotus Notes oder sionstwas nutzt. Für die korrekte Öffnung von Dateien mit dem richtigen Programm ist in erster Linie das Betriebssystem verantwortlich, auch wenn Thunderbird da gewisse Umwege und Abweichungen zulässt.


    Gruß aus Stuttgart


    Heiggo

  • Leider ist ist nicht ganz so...
    Es ist nicht EIN Empfaenger, sondern ALLE Empfaenger des EINEN Absenders... :(


    Gruss
    P.

  • Noch ein Nachtrag zur verwendeten Version des Problem-Firefoxes...
    Es wird die Version 2.0.0.9 verwendet und der Versand (wie gemutmasst wurde) erfolgt nicht direkt aus WORD heraus, sondern es wird 'ganz normal' die Word Datei gespeichert und DANN angehaengt.


    Eventuell noch irgendjemand eine Idee???


    Danke
    P.

  • Hallo,
    ich sagte doch bereits, dass TB einen Word Anhang nicht als
    Content-Type: *.msword;
    deklariert.
    Darum wollte ich noch genau wissen, wie der Anhang verschickt wurde, bzw. wie er in das Verfassenfenster gelangt, da es dafür mehrere Möglichkeiten gibt.
    Fügt man eine *.doc im Verfassenfenster an, also über den Button "Anhang" , deklariert TB den Anhang als application/msword;
    Probiere es doch selbst aus!
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Also nochmal zur Vorgehensweise:


    Dokument wird mit WORD geschrieben und gespeichert - TBird gestartet - Mail geschrieben - *.doc als Attachment per Button ausgewählt , angehängt und abgeschickt.
    Trotzdem können bei dem(n) Empfänger(n) die Anhänge nicht aus der empfangenen Mail heraus geöffnet werden. Man muss sie erst lokal speichern und dann geht es.


    Hatte ich mich da unklar ausgedrueckt???


    P.

  • Hallo,
    jetzt wird es interessant.
    Versende mal die gleiche Mail an dich selbst, indem du "Später senden" benutzt. Dann liest du im Postausgang den Quelltext aus und kontrollierst, wie TB die Mail deklariert hat.
    Das hat den Vorteil, dass man kontrollieren kann, ob evtl. der Mailserver Änderungen macht.
    Danach vergleichst du die empfangene Mail.
    Nochmal: "*msword" kann TB nicht darstellen.
    Outlook express kann das, leitet man aber die Mail weiter, wandelt er die Deklaration in application/msword;
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo, wie der Quellcode der versendeten Mails aussieht, hatten wir doch schon, oder? Dass der Mailserver nur bei diesem einen von etwa 70 Gesamt....hmmm - kann ich mir nicht so recht vorstellen. Ausserdem sind Word-Dokumente nur ein Beispiel von vielen. Genauso passiert es meines Wissens mit allen anderen Anhängen - egal was es ist. Dumm ist leider noch immer, dass es nicht mein Rechner ist, der dieses Problem hat, so dass ich nicht imme sofort alles testen kann.


    Gruss

  • Hallo, Problem scheint gelöst zu sein...


    Beim sendenden TBird war scheinbar die mimeTypes.rdf defekt.
    Danke an mrb


    P.

  • Hallo,
    danke für die Rückmeldung. Wie bist du darauf gekommen?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    hätte noch eine Erklärung:
    schaue mal bitte in die Registry nach diesem Eintrag:
    Was steht unter "HKCR\.doc\Content Type"
    Sollte "application/msword" sein.
    TB übernimmt also die Einstellung des Systems.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw