Zeichensalat durch angehängte doc-Datei [vorläufig gelöst]

  • Hallo,
    wenn ich eine beliebige doc-Datei an eine Mail zum Versand anhänge, gelangt der Inhalt der Datei in die Mail hinein. Das heißt: Es erscheint nach meinem Mail-Text Zeichensalat (Steuerelemente) und dann der textliche Inhalt der doc-Datei.
    Dies geschieht, sobald ich die Mail abgeschickt habe. Der Empfänger erhält die Mail in dieser Weise, aber auch in meinem TB-Ausgangsordner (lokal wie IMAP-Ordner) erscheint die Mail so.
    Dieses Problem ist plötzlich und ohne erkennbaren Einfluß aufgetreten. Veränderungen an den Einstellungen habe ich vorher nicht vorgenommen. Die letzten Addons habe ich einige Tage vorher eingebunden. Auch nachdem ich sie wieder entfernt hatte, löste sich das Problem nicht auf.


    Ich nutze W2000 (SP4) und TB 2.0.


    Kann mir jemand helfen?


    Danke
    _kg_

    3 Mal editiert, zuletzt von _kg_ ()

  • Hallo,

    Zitat

    wenn ich eine beliebige doc-Datei an eine Mail zum Versand anhänge, gelangt der Inhalt der Datei in die Mail hinein.


    Das hast du selbst ausprobiert, indem du eine Mail an dich geschickt hast (das habe ich nämlich bei *doc Dateien noch nie gesehen) oder meldet es dir der Empfänger ? Falls Letzteres, welchen Mailklienten hat er?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"

    Hallo,


    Das hast du selbst ausprobiert, indem du eine Mail an dich geschickt hast (das habe ich nämlich bei *doc Dateien noch nie gesehen) oder meldet es dir der Empfänger ? Falls Letzteres, welchen Mailklienten hat er?
    Gruß


    Hallo Rothaut,
    hallo mrb,


    vielen Dank für Eure Antwort.
    Tatsächlich ist das Problem nicht mehr existent, wenn ich die von Rothaut empfohlene Funktion deaktiviere, Anhänge einzubinden. Aber: Diese Funktion brauche ich. Dennoch danke, kurzzeitig kann ich so wenigstens arbeiten.
    Zur Frage von mrb: Das Problem besteht sowohl bei Mails, die ich an mich, als auch bei solchen, die ich an andere schicke. Die Empfänger, bei denen ich das bislang ausprobiert habe, nutzen TB und das AOL-Programm (andere habe ich noch nicht ausprobiert).
    Ist das eine Spur? Oder soll ich Empfänger mit anderem Mailprogramm ausprobieren?


    Beste Grüße
    _kg_

  • Hallo,
    bei mir tritt das Problem nicht auf, ich habe noch nie eine *.doc im Nachrichtentext gesehen, auch nicht bei "Anhänge eingebunden anzeigen".
    Probiere mal, ob du nach Änderung in der Konfiguration, das Problem noch hast.
    Öffne die Konfiguration und suche mit dem Filter den Eintrag
    mail.content_disposition_type und setze den Wert auf 1.
    Dieser Wert verhindert die Deklaration "inline" in TB beim Versenden . Damit kommen andere Mailklienten oft nicht klar.
    Hat der Empfänger TB, dürfte das Problem eigentlich nicht auftreten.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"

    Öffne die Konfiguration und suche mit dem Filter den Eintrag
    mail.content_disposition_type und setze den Wert auf 1.


    Hallo,
    leider keine Änderung.
    Hast Du noch eine Idee?


    Danke und Gruß
    _kg_

  • Hallo,
    ja, weiter nach dem Fehler suchen.
    Überprüfe das Verhalten im safe-mode.
    Bringt das keine Änderung, erstelle mit dem Profilmanager ein neues Profil richte dort testweise ein Konto ein und überprüfe das Verhalten.
    Ergebnis?
    edit: könntest du mal von einer solchen Mail den kompletten Header (bis zum Beginn des kodierten Anhangs). aus dem Quelltext (strg+U) posten? Mache dabei Privates unkenntlich.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    mir ist noch eingefallen: Bei rtf- und pdf-Dateien taucht das Problem nicht auf.
    Der Zeichensalat ist im übrigen unabhänging von dem Konto, das ich bei TB verwende (insgesamt drei).
    Hilft diese Einengung in der Problembeschreibung weiter, um eine These zu bilden, woran es liegen könnte?
    (Die anderen Hinweise unternehme ich später.)


    Grüße
    _kg_

  • Hallo,
    wie wurden denn die *.doc- Dateien erstellt? In Word?
    Wurde evtl. die ganze Mail in Wort erstellt?
    Oft ist bei solchen Problemen im Header eine falsche Deklarierung zu erkennen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"

    Wurde evtl. die ganze Mail in Wort erstellt?


    Hallo mrb,
    nein, Mailtext und doc-Anhang werden unterschiedlich erstellt. Mail mit TB. Ich kann eine beliebige doc-Datei aus meinem Archiv nehmen, und das Problem erscheint erneut.
    Hast Du eine Ahnung, woran das liegt?


    Gruß
    _kg_

  • Hallo,
    meiner Ansicht nach kann das nur an der speziellen Form der *.doc Datei liegen, so dass TB sie als Text-Datei (die kann ich nämlich auch "eingebunden anzeigen" lassen) erkennt, und sie falsch in der Mail deklariert. Aber ohne den Header zu kennen, kann ich dazu nichts sagen.
    Da war mal ein Thread darüber im Forum, vielleicht kannst ihn über die Suche finden.
    Ach ja, enthält der Namen des Anhangs Umlaute, Sonderzeichen?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"

    Aber ohne den Header zu kennen, kann ich dazu nichts sagen.
    Da war mal ein Thread darüber im Forum, vielleicht kannst ihn über die Suche finden.
    Ach ja, enthält der Namen des Anhangs Umlaute, Sonderzeichen?


    Hallo,
    die Art der Zeichen im Dateinamen spielt keine Rolle.
    Was an Text in die Mail "geschoben" wird, da sind die deutschen Umlaute zu sehen, nicht aber Sonderzeichen wie langer Gedankenstrich oder Anführungsstriche.
    Kannst Du genauer sagen, was Du mit dem Hinweis auf den Header genauer meinst (damit ich weiß, wonach ich suchen soll.)


    Danke und Gruß
    _kg_

  • Ich meine die Deklarierungen im Header.


    Etwa so:
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.17) Gecko/20080914 Thunderbird/2.0.0.17 Mnenhy/0.7.5.0
    MIME-Version: 1.0


    Subject: test
    Content-Type: multipart/mixed;
    boundary="------------000105070808060709010600"


    This is a multi-part message in MIME format.
    --------------000105070808060709010600
    Content-Type: text/plain; charset=ISO-8859-15
    Content-Transfer-Encoding: 7bit


    test


    --------------000105070808060709010600
    Content-Type: application/msword;
    name="Ciao.doc"
    Content-Transfer-Encoding: base64
    Content-Disposition: inline;
    filename="Ciao.doc"



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    ja ich dachte es mir:
    Content-Type: text/richtext;
    name="Stehsatz.doc"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
    filename="Stehsatz.doc"


    Siehst du, dass meine Deklarierung trotz gleicher *.doc Datei anders ist?
    Bei mir steht:
    Content-Type: application/msword;


    Mögliche Ursache wird dein veraltetes Betriebssystem sein. Denn TB entnimmt die Deklaration aus Windows.
    Gehe mal in die Registry und suche dort nach application/msword; du wirst es vermutlich nicht finden. Dagegen wirst du text/richtext sehr wohl finden.
    Ich weiß auch nicht, ob es etwas hilft, die Einträge unter HKEY_CLASSES_ROOT\.doc umzuändern, denn es wären noch eine Reihe weiterer Einträge zu ändern.
    Da müsstest du dich evtl. an ein Win2000 Forum wenden.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    mir fällt gerade Lösungsmöglichkeit ein, dich aber nicht testen kann.
    Du müsstest folgendermaßen vorgehen.
    Besorge dir das Add-on TB Header Tools Extension
    Schreibe die Mail mit Anhang wie gewohnt und gehe auf "Später senden". Damit gelangt die Mail ind en Postausgang. Dort machst du einen Rechtsklick auf die Mails und wendest das Add-on an.
    Dort gehst du auf "full source" und änderst den Header ähnlich wie in der Mail, die ich dir zuschicken werde. Bei dieser Mail öffnest du den Quelltext (strg+U) und überprüfst dort die Deklaration.
    Wenn du an diesem Punkt aber nicht weiter mach willst, weil es dir zu zeitraubend ist, akzeptiere ich das natürlich.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    ich kann dein Problem nachvollziehen, wenn ich den Header so ändere, wie es in deinem steht.
    Voraussetzung ist aber, dass unter Ansicht "Nachrichten eingebunden anzeigen" angehakt ist.
    Dann verschwindet der kodierte Anhang aus dem Nachrichtentext. Das müsste dann evtl. Empfängern gesagt werden.
    In Outlook Express tritt übrigens der Fehler erwartungsgemäß nicht auf, weil OE diese Deklarierung kennt.
    Wie aber schon gesagt, kann man die Mails so modifizieren, dass sie richtig ankommen.
    Zeitaufwand bei etwas Übung 15-20 Sekunden.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"


    Du müsstest folgendermaßen vorgehen.
    Besorge dir das Add-on TB Header Tools Extension
    Schreibe die Mail mit Anhang wie gewohnt und gehe auf "Später senden". Damit gelangt die Mail ind en Postausgang. Dort machst du einen Rechtsklick auf die Mails und wendest das Add-on an.
    Dort gehst du auf "full source" und änderst den Header ähnlich wie in der Mail, die ich dir zuschicken werde. Bei dieser Mail öffnest du den Quelltext (strg+U) und überprüfst dort die Deklaration.


    Hallo,


    sorry nochmals für die späte Antwort.
    Also: Ich habe das von Dir empfohlenen Add-on installiert und gemäß Deiner Mail den Header in der Zeile "content-type" auf "application/msword" geändert. Und voilà: Es funktioniert (habe zur Sicherheit auch den Mailtext formatiert - kein Problem), die Mail mit doc-Anhang geht normal und ohne Zeichensalat hinaus und kommt auch so an.
    Das ist ja aber keine dauerhafte Einstellung. Als ich danach eine weitere Mail mit doc-Anhang abgeschickte, ist das Problem wieder aufgetaucht.
    Kannst Du mir nun verraten, wie ich diese Einstellung dauerhaft verändern kann?


    Herzlichen Dank!
    _kg_

  • Hallo,
    diese Deklaration ist in deinem Betriebssystem so verankert. Ich sehe keine Möglichkeit, einer dauerhaften Veränderung. Dafür bin ich aber auch keine Spezialist. Ich persönlich würde zwar versuchen, den Contentype in der Registry zu ändern, bzw. den richtigen hinzufügen, da ich das hier aber nicht simulieren kann, kann ich auch nicht sagen, ob es Erfolg haben wird.
    In deinem Fall wäre es tatsächlich das beste, Outlook Express zu benutzen oder das Betriebssystem zu wechseln. DU kannst auch versuchen Foren für W2000 nach einer Lösung zu fragen.
    Oder du verzichtest auf das Einbinden der Anhänge. Übrigens kann ich auf meinem System Anhänge vom Typ *.doc gar nicht mehr einbinden. Das geht nur noch bei *.txt DAteien. Ich vermute, dass dein Problem dafür der Anlass war.
    Wozu brauchst du eigentlich die Funktion "Anhänge eingebunden anzeigen".


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    schade, dann versuche ich es mal ohne die Funktion.
    Danke für die Bemühungen
    _kg_

  • Hallo, mrb, noch mal,


    doc-Dateien wurden auch nie richtig eingebunden gezeigt. Insofern hast Du recht, daß es damit zusammenhängt. Wüßtest Du wie man das abstellt. Oder: wenn ich in einem Windows-Forum anfrage, kannst Du mir dafür einige Hinweise geben, wonach ich mich genau erkundigen sollte. Mir scheint, daß Du eine Spur weißt.


    Danke und Gruß
    _kg_