Thunderbird Fehlermeldung - e-mails weg [erledigt]

Am 24.09.2018, werden in der Zeit zwischen 21:00 Uhr und 09:00 Uhr des folgenden Tages Wartungsarbeiten am Server durchgeführt. Daher wird die Webseite in dieser Zeit nur eingeschränkt erreichbar sein.
  • hi,


    ich habe folgendes Problem: ich hatte mir thunderbird neu eingerichtet und mein konto angelegt (seperater posteingang für das konto) und dann alle meine e-mails von server runtergeladen. soweit lief alles gut. als ich allerdings danach auf den ordner Posteingang oder eine mail klicken wollte, bekam ich von Thunderbird eine Fehlermeldung, dass der angegebene pfad nicht gültig sei (oder so ähnlich. ich hab mir die meldung nicht notiert...) ich konnte meine e-mails zwar sehen, aber nichts damit machen. ich also das programm geschlossen und nochmal neu gestartet. leider waren danach sämtliche e-mails und ordner, die ich unter dem konto hatte weg (komplett leer.... nix mehr da.... :pale: ) blöderweise hatte ich die "Nachrichten auf dem Server belassen"-Funktion noch nicht aktiviert.... die e-mails befinden sich also auch nicht mehr auf meinem gmx-konto....
    gibt es eine möglichkeit, dass man die noch irgendwie retten kann????? da waren doch einige wichtige bei.....


    ich hoffe, mir kann jemand helfen.... ;-(

  • Hi Ariii, willkommen im Thunderbird-Forum!


    "Ariii" schrieb:

    bekam ich von Thunderbird eine Fehlermeldung, ... (oder so ähnlich...)


    Der ist gut! :lol:


    Bitte versuche mal "Rechtsklick auf den Posteingangsordner > Eigenschaften > Index wiederherstellen". Wahrscheinlich hilft das schon.


    Gruß, Sünndogskind_2

  • Guten Morgen allerseits!
    Und wenn die von Synndogskind_2 vorgeschlagene Lösung den Vogel noch nicht zur Raison bringen kann, dann gibts noch radikalere Methoden, den Vogel schließen und im Explorer im Profilverzeichnis die inbox.msf vom GMX-Konto löschen, damit sind die Mails noch immer da, die MSF ist nur die Indexdatei, und wenn Du die manuell löscht, zwingst Du den Vogel, sie neu zu erstellen, was ihn hoffentlich zur Vernunft bringen sollte.
    Dein Profilverzeichnis wohnt unter Vista, wenn nicht von Dir anders erstellt, in c:\users\username\appdata\roaming\thunderbird\profiles\langezahlenbuchstabenkombination. Da drin wohnt dann ein Verzeichnis namens Mail, und da sicher eins, das den Namen trägt, dem Du Deinem GMX-Konto beim Erstellen verpasst hast.
    Wenn Du das alles aber im Explorer sehen willst, muss unter Extras Ordneroptionen, Registerkarte Ansicht, Erweiterte Einstellungen, die Anzeige von versteckten und Systemdateien eingeschaltet sein.
    Sollte das noch immer kein positives Ergebnis bringen, ist dennoch nichts wirklich verloren, dazu aber erst in der nächsten Folge unserer Serie, wie hole ich meine Mails wieder her :-)

  • Danke für die Antworten. :xmas:


    "Index wiederherstellen" hat leider nichts gebracht.... (hatte ich glaub ich auch shcon versucht gehabt)


    Rothaut:
    um... ich denke mal, ich hab die richtige inbox.msf gefunden und gelöscht. hat leider auch nichts gebracht... ich denke mal, dort sind keine mails.... die paar dateien, die dort drin snd, sind zw. 0 und 2 KB klein. wenn ich dagegen als vergleich mein anderes konto sehe, dort ist das ganze doch wesentlich größer und umfangreicher.
    vielleicht hätte ich noch erwänen sollen, dass ich Win XP SP3 nutze und ich für meine konten eigene verzeichnisse angelegt habe. (mir ist das nichts, wenn die unter C: liegen, mein Windows dann nen totalschaden hat und ich wieder rnicht an meine dateien rankomme ^^)
    um, falls es relevant ist. ich hab thunderbird 2.0.0.19 installiert.

  • Hallo Ariii


    Öhem, ich habe nie behauptet, dass die MSF-Dateien Mails enthalten.
    Ich schrieb doch oben:

    Zitat

    im Profilverzeichnis die inbox.msf vom GMX-Konto löschen, damit sind die Mails noch
    immer da, die MSF ist nur die Indexdatei, und wenn Du die manuell löscht, zwingst
    Du den Vogel, sie neu zu erstellen, was ihn hoffentlich zur Vernunft bringen sollte.


    Stimmen Deine Verzeichnispfade mit denen in der Profile.ini überein?
    Ich muss Dein Betriebssystem mit einem Beitrag verwechselt haben, den ich vorher bearbeitet habe, sorry, ich wollte Dir nicht Vista aufdichten :-)

  • ach so, ich meinte auch nicht, dass in der mfs-datei drin sind, sondern in dem ordner, in dem die datei liegt. hab mich falsch ausgedrückt. ^^"


    also ich hab bisher nur eine profiles.ini gefunden, im verzeichnis von thunderbird, wo der lokale ordner liegt. dort steht drin:


    [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=1
    Path=Profiles/jkt0op3p.default


    seltsamerweise sind die mails, die ich seit der fehlermeldung bekommen bzw. die ordner, die ich danach angelegt habe noch da. obwohl ich nichts an den einstellungen geändert habe. (außer halt, dass die nachrichten auf dem server nicht gelöscht werden sollen)

  • Hallo und guten Morgen,


    kurze noch mal eine Zwischenfrage, die Rothaut ja eigentlich auch schon gestellt hat,du sagst

    "Ariii" schrieb:


    und ich für meine konten eigene verzeichnisse angelegt habe.


    Heißt das, das du in den Konten-Einstellungen die Pfade der lokalen Verzeichnisse geändert hast?
    Dann solltest du dort noch mal suchen, denn scheinbar greift TB wieder auf die Pfade im Profiverzeichnis zu. Deshalb sollte man, wenn man das

    "Ariii" schrieb:


    (mir ist das nichts, wenn die unter C: liegen, mein Windows dann nen totalschaden hat und ich wieder rnicht an meine dateien rankomme ^^)

    möchte, was ja auch sinnvoll ist, das Profil mit dem Profilmanager verschieben. Siehe Punkt 11 der Anleitung.


    Ach ja: hast du einen Virenscanner am Laufen?

  • Hallo rum :)


    also, ich hab 2 insgesamt mailadressen von gmx in thunderbird. bei beiden habe ich das lokale verzeichnis unter den server-einstellungen geändert und bei "seperatem posteingang für dieses Konto" ein häkchen gemacht.
    beim ersten konto hat auch alles wurderbar geklappt, nur das zweite konto macht halt die probleme....


    wenn TB auf die pfade im profilverzeichnis zugreift, müssten doch die mails noch irgendwo sein. (?) ich seh die im programm selber nicht... nur halt die, die jetzt neu dazukommen. die werden auch so wie es sein soll im von mir ausgewähltem verzeichnis gespeichert.


    ja, bei mir läuft antivir. hat bisher aber eigentlich nie gestört.


    das mit dem profilmanager les ich mir mal durch. danke.

  • Genau das

    Zitat


    bei beiden habe ich das lokale verzeichnis unter den server-einstellungen geänder

    habe ich befürchtet. Schau mal in den Konten-Einstellungen nach, welcher Pfad da jetzt drin steht.
    Deine alten Mails findest du wahrscheinlich an dem von dir geänderten Ort und kannst sie dann wieder importieren mit ImportExportTools (Mboximport)


    "Ariii" schrieb:


    ja, bei mir läuft antivir. hat bisher aber eigentlich nie gestört.

    bisher, mag sein. Das aber ist kein Garant, siehe Beitrag zum Virenscanning


    Fehlalarm durch neue Virendefinition

  • Hallo nochmal!


    Ich glaube, die Mails kommen ja auch, nur der Vogel findet den Weg zu ihnen nicht. Und sind Deine Mailordner denn auch wirklich im Defaultprofil? Ich frag deshalb so dämlich, weil Du ja vorhin schriebst, es wäre nicht sinnvoll, sie auf c: abzulegen, was ja durchaus seine Berechtigung hat. Wo liegen also Deine Mailordner wirklich?
    Liegen die in c:\dokumente und Einstellungen\username\anwendungsdaten\thunderbird\profiles\langezahlenbuchstabenkombination\mail (und diesmal hab ich den wirklichen XP-Pfad des Defaultprofiles angegeben :-)), oder liegen die etwa woanders?

  • rum:


    um... ich weiß leider nicht mehr, welcher pfad da vorher stand.... wenn ich ihm das lokale verzeichnis geben will, meckert er, weil das schon vergeben ist.



    Rothaut:


    so als überblick:
    TB unter auf F:\Programme installiert
    den lokalen ordner hat er standartmäßig auf C:\Dokumente und Einstellungen\Admin\Anwendungsdaten\Thunderbird\Profiles\jkt0op3p.default\Mail\Local Folders
    für meine beiden mail-adressen hab ich je ein eigenes verzeichnis unter E:\eigene dateien\mails angelegt. in beiden verzeichnissen sind die inbox, inbox.ini usw. dateien drin bzw. im ersten verzeichnis (zur mail-adresse, wo alles funktioniert) auch meine unterordner, die ich angelegt habe.


    die e-mails von mail-adresse 1 sind sowohl im lokalen ordner also auch unter F: zu finden bzw. in TB selbst sieht man die halt in beiden posteingängen. hatte erst die mails runtergeladen und danach den seperaten posteingang angelegt und die dann erst in den posteingang vom mail-konto 1 rüberkopiert.
    bei mail-adresse 2 hatte ich erst das verzeichnis geändert und dann die mails runtergeladen. waren auch alle da.... wollte dann den posteingang in verschiedene unterordner einordnen und beim anklicken der ersten mail kam auch schon die fehlermeldung... nu sind die nirgens zu sehen... ;-(

  • Schönen Nachmittag!


    Also eine inbox.inihabe ich noch nie beim Vogel gesehen, weder unter Vista noch unter XP.
    Ja, rum hat wieder mal recht, da dürfte wirklich die totale Verzeichniskonfusion ausgebrochen sein.
    Ich würde auch mit
    ImportExportTools (Mboximport enhanced)
    meine Mails wieder importieren und dann mit dem Profilmanager arbeiten bzw. die Pfade neu vergeben.

  • uuuhhh. ich hab sie gefunden. im ordner pop.gmx.net im default-profil ordner war eine inbox-datei. dort sind die mails alle drin. :freude:
    bei rums-beitrag zum virenscanner stand drin, man könne sich die inbox-dateien im editor ansehen. also hab ich daraufhin mal alle durchgeschaut, die ich finden konnte. ^^
    nu hab ich mir die datei in mein eigenes verzeichnis rüberkopiert und siehe da, sie sind alle wieder in TB zu sehen. jetzt werd ich mir die mails schnell wieder auf den server laden, bevor wieder was passiert.


    den profilmanager und das add-on schau ich mir mal genauer an. ich will nie wieder verzweifelt nach meinen mails suchen müssen....


    Danke für die Hilfe! :D
    und noch eine schöne restwoche!

  • also Chaos pur ;)
    Ich würde TB mit dem Profilmanager starten, neues Profil erstellen, bel. Namen, z.B. Ariii, eingeben und dann den Pfad z.B. zu E:\eigene dateien\Mailordner angeben, dann Ordner erstellen anhaken und fertigstellen lassen.
    Dann kannst du die Konten neu eingeben und die Mails und Adressen aus dem alten Profil in C: und den Mailordnern auf E: importieren.
    Alles andere Vorgehen gibt wahrscheinlich nur weiteres Chaos, so hast du einmal Arbeit und gut ist.


    Btw: da

    "Ariii" schrieb:

    (mir ist das nichts, wenn die unter C: liegen, mein Windows dann nen totalschaden hat und ich wieder rnicht an meine dateien rankomme ^^)

    bist du sicherheitsorientiert, aber der PC wird als

    Zitat

    C:\Dokumente und Einstellungen\Admin\Anwendungsdaten...

    statt mit eingeschränkten Benutzerkonten betrieben?



    Edit: ich habe zu langsam getippt und zwischenzeitlich kam deine Erfolgsmeldung, trotzdem ist die saubere Neuanlage sinnvoll!


    btw:

    Zitat

    ich will nie wieder verzweifelt nach meinen mails suchen müssen...

    da hilft eine regelmäßige Datensicherung ungemein! Einfach das gesamte Profilverzeichnis ..\thunderbird\.. bzw hier jetzt E:\eigene dateien\Mailordner komplett kopieren.

  • okay. das werd ich am besten so machen. bevor das hier noch ein größeres chaos gibt (zB wenn ich noch andere mail-adressen hinzufüge)


    "rum" schrieb:

    also Chaos pur ;)
    Btw: da

    bist du sicherheitsorientiert, aber der PC wird als

    statt mit eingeschränkten Benutzerkonten betrieben?


    ähm... ja... da muss ich auch noch was dran ändern. irgendwie hab ich da damals nicht ganz dran gedacht. muss C: eh mal formatieren und windows neu raufziehen. (macht nur probleme...)


    Danke! ;)