Sonderzeichen Hotmail [gelöst]

  • LÖSUNG
    Du kannst den Fehler umgehen, wenn du in den Einstellungen, Verfassen, einen Haken bei quoted printable" machst. mrb
    _________________________________________________________________________________


    Bei eingehenden Emails bei den Hotmailkonten in meinem TB werden keine äöü angezeigt, sondern immer nur als Fragezeichen. Wenn ich über den Browser gehe werden alle Nachrichten korrekt angezeigt, nur über TB nicht. Meine Zeichenkodierung ist:
    Automatisch bestimmten = universell & westlich ISO 8859 15
    Die beiden Hacken unter Einstellungen/Ansicht/Zeichenkodierung sind nicht gesetzt.
    Bei dem Web.de und alice-dsl.de Account gibt es diese Probleme nicht. Wenn ich Nachrichten von den hotmail Accounts verschicke an den web.de Account werden alle Zeichen korrekt dargestellt.
    Im Betreff der Hotmailkonten werden die Umlaute jedoch korrekt dargestellt. Ich versende Nachrichten nur im Reintextformat.


    Habe jetzt alles so eingestellt wie hier geschrieben:
    Zitat
    mrb
    Hallo und willkommen im Forum.
    grundeinstellung:
    Unter Extras, Einstellungen, Ansicht, Schriftarten und Kodierung wird kein Haken gesetzt bei den unteren beiden Kästchen.
    "Nachrichten erlauben andere Schriftarten zu erlauben", sollte angehakt sein.
    Außerdem sollte unter Ansicht, Zeichenkodierung, "Automatisch bestimmen" auf "universell" stehen.


    Bei Zeichenkodierung wählst du bei ausgehenden Mails UTF-8 aus.
    Leider schreibt du nicht, welcher Zeichensatz dort bei dir eingetragen ist. Normalerweise trägt man hier in Deutschland ISO-8955-15 ein.
    Welche Sonderzeichen verwendest du denn zusätzlich zu den Umlauten und ß?


    Gruß
    Zitat Ende


    Trotzdem das gleiche Problem.

    4 Mal editiert, zuletzt von seven7en ()

  • Hallo,
    da du ja schon die korrekten Einstellungen durchgeführt hast, ein paar andere Fragen.
    Die an deinen Hotmail-Konto versendeten Mails wurden von wo versendet?
    Einem Mailklienten oder von einer Webseite?
    Poste die Deklarierung dieser Mails.
    Bei dem empfangenden Ordner für die Hotmail-Mails ist im Kontextmenü dieses Ordner, Eigenschaften ein Haken gesetzt? Was steht dort für eine Standardkodierung?
    Leider verstehe ich jetzt nicht ganz, wer wo und von wo etwas empfängt bzw. versendet. Könntest du das noch einmal detailliert erklären?
    Außerdem interessiert mich die Deklarierung dieser Mails. Webserver halten sich oft nicht an die Standards.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,

    Zitat

    Poste die Deklarierung dieser Mails.
    Wie geht das?


    Dazu rufst du den Quelltext (strg+U) auf und suchst nach Einträgen wie diesen:


    Content-Type: text/plain;
    charset="iso-8859-1"
    Content-Transfer-Encoding: 7bit


    Content-Type: text/html;
    charset="iso-8859-1"
    Content-Transfer-Encoding: quoted-printable


    Zitat

    Versand von Web.de
    Empfang bei Hotmail.de


    Beides in TB?

    Zitat

    Wenn ich über den Browser gehe werden alle Nachrichten korrekt angezeigt,


    Bei beiden Konten? Also Versand und Empfang auch dort?


    Wenn du dir selbst Mails zusendest (also Versand und Empfang in TB) das gleiche Problem?


    Unter Extras, Einstellungen,Verfassen, Allgemein, ist das zweite Kästchen bei dir angehakt?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    die Deklarierung ist OK.
    Aber:
    User-Agent: Thunderbird 2.0.0.19 (Windows/20081209)


    Welches Betriebssystem hast du?


    Du versendest die Hotmail-Mails über die beiden Web-Add-ons oder über POP?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich sende über POP. Habe das Webmail Addon bereits deinstalliert.
    Betriebssystem ist XP SP2

  • Hallo,
    über POP sendest du sicher nicht, sondern höchstens über SMTP.
    Wenn du jetzt die Web-Add-ons installiert, würdest du sicher TB durcheinander bringen. Das würde ich wieder rückgängig machen und sie entfernen.
    Wenn du die gesendeten Mails im Ordner gesendet im Quelltext (strg+U) anschaust,
    sind dort die Umlaute noch OK?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    ich habe jetzt von meinem web.de Konto eine Mail an ein live.de Konto gesendet.
    Nach dem Versenden sah die Deklararion noch so aus:


    Content-Type: text/plain; charset=ISO-8859-15; format=flowed
    Content-Transfer-Encoding: 8bit


    Ümläüöteßs (im Nachrichtentext)


    Nach dem Empfang im live.de Konto sah sie so aus:
    Content-Type: text/plain; charset=ISO-8859-15; format=flowed
    Content-Transfer-Encoding: 8bit


    ?ml???te?s


    Deklarierung richtig, Darstellung falsch.
    Das ist ein eindeutiger Serverfehler von live.de ich habe es mit mehreren anderen Konten getestet, niemals war die Darstellung falsch.


    Du kannst den Fehler umgehen, wenn du in den Einstellungen, Verfassen, einen Haken bei quoted printable" machst.
    Dann siehst die Deklarierung so aus:


    Content-Type: text/plain; charset=ISO-8859-15
    Content-Transfer-Encoding: quoted-printable


    =DCml=E4=FC=F6te=DF


    Man erkennt an den = , dass hier in quoted printable kodiert wurde.
    Der empfangende Mailkliente dekodiert dann wieder und stellt die Umlaute im Nachrichtenfenster korrekt da.


    Folgerung:
    der Mailserver von live.de erkennt den richtigen Zeichensatz nur dann, wenn in quoted printable gesendet wurde.


    Ich hatte das gleiche Problem mit Googlemail. Allerdings nur anfänglich. Später wurde korrekt dargestellt.
    Da die hotmail/live Server relativ neu sind ( 2 Monate), solltest du noch ein bisschen warten.


    Grruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hast recht, jetzt geht es. Hat das irgendwelche Nachteile in quoted printable zu senden,
    ich meine kann es da Probleme mit anderen Mail Programmen geben?


    Was heisst denn dieses "zitiert Druckbar" (quoted printable) eigentlich ?

  • Aber ich laufe nicht Gefahr das es beim Empfänger so ankommt
    H=E4tten H=FCte ein =DF im Namen, w=E4ren sie m=F6glicherweise keine H=FCte=
    mehr,
    sondern H=FC=DFe.
    oder ?

  • Hallo,
    solange die Mail richtig deklariert und kodiert wurde, ist das Problem gering.
    Lies:
    http://www.wschmidhuber.de/oeprob/
    dort unter quoted printable.


    Probleme gibt es nur mit dem Zeilenumbruch und damit beim Zitieren in Outlook Express.
    Das macht es in Newsgroups recht unbeliebt.


    Ach übrigens: In Outlook Express werden die Umlaute falsch dargestellt, aber nicht in Windows Live Mail, was ja neu entwickelt wurde aber auf OE aufbaut.
    Bei WLM wurde also das Serververhalten mit dem Mailklienten genau abgestimmt.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw