jpgs im Anhang öffnen

  • Hallo,


    wenn ich versuche eine Bilddatei im Anhang einer Mail zu öffnen, dann bekommen ich folgende Fehlermeldung:

    Code
    1. Fehler: Datei nicht gefunden
    2. Die Datei /res/[xpconnect wrapped nsIURI] konnte nicht gefunden werden. Bitte überprüfen Sie den Namen und versuchen Sie es nochmals.
    3. * Könnte die Datei umbenannt, gelöscht oder verschoben worden sein?
    4. * Enthält die Adresse einen Rechtschreib-, Groß-/Kleinschreibungs- oder andere Fehler?
    5. * Haben Sie ausreichende Zugriffsrechte für die aufgerufene Datei?


    Wenn ich die Mail öffne, werden die Bilder aber ohne Probleme angezeigt und auch wenn ich sie speichere, kann ich sie öffnen. Aber einfach auf die Datei in der Mail klicken funktioniert eben nicht (mehr).
    TB-Version: 2.0.0.19.


    Danke,
    null.plan

  • Hallo,
    um welche Dateitypen, handelt es sich und welches Programm soll die Datei öffnen?
    Enthält die Datei Umlaute, Sonderzeichen?
    Poste die Deklarierung der Mail durch Öffnen des Quelltextes (strg+U).
    Poste alle vorhandenen content-type. Z.B.


    Content-Type: image/jpeg;
    name="crystal_ball_1.jpg"
    Content-Transfer-Encoding: base64


    Content-Disposition: attachment;
    filename="crystal_ball_1.jpg"


    Beende TB und verschiebe die Datei mimetypes.rdf .
    Nach Neustart das gleiche Problem?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo!


    Ich habe die mimetypes-Datei umbenannt und es hatte keinen Effekt.
    Und hier der Code:

    Code
    1. Content-Type: image/jpeg;
    2. name="Rangitoto.jpg"
    3. Content-Transfer-Encoding: base64
    4. Content-Description: Rangitoto.jpg
    5. Content-Disposition: attachment;
    6. filename="Rangitoto.jpg"


    Danke!
    null.plan

  • Hallo,
    sorry für den Mist, den ich geschrieben hatte und eben editiert habe. Ich habe ein Programm, welches mir bei bestimmten Wörtern ganze Sätze einfügt und das ist bei "Dateitypen" passiert.
    Bitte beantworte mir jetzt die Fragen noch einmal.
    Die Deklarierung ist OK.
    Nur was mich stutzig macht ist:
    Content-Description: Rangitoto.jpg


    Das könnte die Ursache sein. Sicher bin ich mir aber nicht.
    TB selbst schreibt so eine Deklarierung nicht.Habe ich noch nie gesehen. OE auch nicht.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo mrb,


    Zitat

    um welche Dateitypen, handelt es sich


    jpg

    Zitat

    und welches Programm soll die Datei öffnen?


    Es ist egal, ob ich gar nichts einstelle, den Windows Bildbetrachter oder z.B. Irfan View nehme.

    Zitat

    Enthält die Datei Umlaute, Sonderzeichen?


    Das ist vollkommen egal - "Rangitoto.jpg" hat keine Umlaute...


    null.plan

  • Hallo,

    Zitat


    Ich habe die mimetypes-Datei umbenannt und es hatte keinen Effekt.


    Na j es hätte zumindest den Effekt haben müssen, dass nach dem Neustart von TB die Datei neu erstellt wurde. Ist das der Fall?
    Außerdem müsstest du danach bei Öffnen der Anhänge eine neue Abfrage von TB bekommen, mit welchem Programm abgespeichert werden soll.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich hab sowohl die mimetypes-Datei unter C:\Program Files\defaults\profile umbenannt als auch die unter C:\Program Files\Mozilla Firefox\defaults\profile, aber die Datei wurde weder neu angelegt noch überschrieben, noch wurde ich nach einem Programm gefragt... Eine andere mimetypes findet der Explorer nicht.
    Auch im abgesicherten Modus passiert das gleiche...


    Viele Grüße,
    null.plan

  • Hallo,

    Zitat

    Ich hab sowohl die mimetypes-Datei unter C:\Program Files\defaults\profile umbenannt


    Nur diese solltest du umbenennen, mache das bei der anderen wieder rückgängig.

    Zitat

    aber die Datei wurde weder neu angelegt noch überschrieben,


    Sehr merkwürdig. Du hattest TB zuvor beendet? Sonst klappt das alles nicht.
    Du hast auch im richtigen Profil das geändert?
    Welches Betriebssystem hast du?
    Der o.a. Pfad kommt mir recht ungewöhnlich vor.
    Eigentlich müsste der Pfad so heißen:
    C:\Dokumente und Einstellungen\[Benutzername]\Anwendungsdaten\Thunderbird\Profiles\...


    Ich bin eigentlich fast sicher (nach deiner Beschreibung), dass du die richtige Datei noch nicht gefunden hast.
    Gleiche mal deine Systemeinstellungen nach dieser Anleitung an: http://freenet-homepage.de/rene-gad/invisible.html
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Okay, jetzt habe ich die richtige gefunden.
    Ich habe TB geschlossen, die Datei umbenannt, TB wieder geöffnet und versucht ein Bild zu öffnen.
    Ergebnis: Die gleiche Fehlermeldung wie immer, die alte mimetypes hat das heutige Datum als Änderungsdatum und die neue hat den 31.10.2007 als Änderungsdatum...


    Viele Grüße,
    null.plan

  • Hallo,
    wenn die Datei gelöscht wurde, muss TB die Dateizuordnungen neu schreiben und fragt dich, welchem Programm du den Dateityp zuordnen möchtest. Was hast du geantwortet?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo,
    aber die gelöschte mimetypes.rdf wurde neu erzeugt mit einer anderen Größe?
    Die mimetypes.rdf im Programmordner hattest du aber wieder zurückkopiert?


    Und dieses Fenster öffnete sich nicht?:



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich hab jetzt beide mimetypes in dem Ordner.
    Die alte _mimetypes.rdf mit Änderungsdatum gestern und 8 KB und
    die neue mimetypes.rdf mit Änderungsdatum 31.10.2007 und 3 KB.
    Und das Fenster kommt nicht hoch - keine Ahnung warum nicht....
    Wenn ich auf eine *.doc klicke, dann kommt das Fenster hoch.
    Ich hab jetzt außerdem mal die neue wieder gelöscht und die alte wieder umbenannt. Die *.doc öffnet sich wie vorher im Word, aber bei den *.jpg kommt immer noch die Fehlermeldung.

  • Hallo,


    ich habe jetzt auch mal die Erweiterung MIME Edit ausprobiert - keine Chance. Es ändert sich nichts...


    Gruß
    null.plann

  • Hallo,
    2 Fragen:
    du hast deine Ordneroptionen ähnlich wie bei dieser Anleitung eingestellt?
    http://freenet-homepage.de/rene-gad/invisible.html

    Zitat

    Ich hab jetzt beide mimetypes in dem Ordner.
    Die alte _mimetypes.rdf mit Änderungsdatum gestern und 8 KB und
    die neue mimetypes.rdf mit Änderungsdatum 31.10.2007 und 3 KB.


    Wie kommt das Änderungsdatum 2007 dort hinein?
    Ich habe immer noch das Gefühl, dass du die falsche Datei im falschen Pfad genommen hast.
    Poste noch mal den Pfad.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich habe die Einstellungen schon immer so...
    Die Datei, von der ich sprach, liegt im Ordner: C:\Users\***\AppData\Roaming\Thunderbird\Profiles\y63k8hfm.default
    Wie das 2007er Datum zustande kommt, hat mich auch sehr gewundert - ich kann es mir nicht erklären... Aber immerhin wurde nach dem Umbenennen eine neue Datei erstellt!


    Liebe Grüße,
    null.plan

  • Guten Morgen,


    Zitat


    Wie das 2007er Datum zustande kommt, hat mich auch sehr gewundert - ich kann es mir nicht erklären...

    das ist das Datum der Default-Originaldatei, die beim Erststart oder zum Ersetzen von TB aus C:\Programme\Mozilla Thunderbird\defaults\profile geholt wird ;)

  • Sofas ähnliches hab ich mir dann auch gedacht... Es hatte mich nur gewundert, weil sowohl Rechner als auch TB-Version jünger sind... aber ist ja auch egal - tut ja nichts wirklich zur Sache... Wird schon seinen Grund haben.
    Jedenfalls funktioniert die Sache mit den Fotos immer noch nicht.
    Was mich sehr irritiert ist, dass es schon mal ging - aber ich weiß nicht mehr, ab wann es nicht mehr funktioniert hat. Und eigentlich kann es auch nicht an den Erweiterungen o.ä. liegen, da es im abgesicherten Modus ja auch nicht geht... :nixweiss:

  • Hallo,
    Virenscanner/Firewall vorhanden, die den TB-Profilordner abscannen?


    Außerdem sagte ich ja bereits, dass die Deklarierung
    Content-Description: Rangitoto.jpg
    ungewöhnlich ist. Es könnte ein Feature von Vista sein.


    Da ich Vista nicht gut genug kenne, könnte es auch ein Rechte-Problem sein?
    In Vista ist unter Standardprogramme, Dateizuordnungen welches zur Auswahl von jpg festgelegt ist.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw