X-Spam-Flag Filter funktioniert nicht

  • Hallo Leute,


    wenn ich den Filter X-Spam-Flag -> ist -> YES anlege, funktioniert dieser nicht.
    Natürlich ist das Kriterium im Nachrichtenkopf enthalten.


    Andere Filter (Absenderadresse, Betreff etc.) funktionieren problemlos.


    Es handelt sich um ein IMAP-Konto.
    Die Thunderbird-Version ist 2.0.0.21
    OS ist XP


    Hat jemand eine Ahnung wie ich das Problem lösen kann?

  • Hallo,


    von wem kommt die Kopfzeile, von einem externen Dienst/Server?


    Wenn es die Zeile gibt, dein Filter nicht funktioniert, ist normalerweise ein Fehler in deiner Filterkonfiguration die Ursache. Manchmal übersieht man Sachen und sieht den Wald vor Bäumen nicht.


    Das kann man "von hier" aber nur mit genauen Infos/Screenshots beurteilen.


    Tipp ins Blaue:


    Versuche "enthält" statt "ist".
    Überprüfe auf Leerzeichen in der Bedingung.

  • Danke für die schnelle Antwort. Ich hab's jetzt mal an einem anderen Rechner getestet und da funktioniert zumindest die automatische Filterung nachdem der Filter eingerichtet wurde.
    Die manuelle Anwendung funktioniert leider nicht.


    Morgen teste ich dann nochmal den Ursprungsrechnner.


    Der X-Spam-Flag Eintrag wird übrigens durch den Filter des Uni-Rechenzentrums gesetzt.


    Morgen berichte ich dann, ob das Problem rechnerspezifisch ist.



    Danke schon mal

  • So, das Problem besteht weiterhin. Ich habe gerade ein "frisches" Vista-System genommen und direkt die aktuelle Version von Thunderbird installiert, um Versionsprobleme bzw. Probleme mit älteren Dateien auszuschließen.


    Ich würde gern zwei Screenshot hochladen. Wie mache ich das bzw. geht das hier im Forum oder muss ich auf eine externe Seite für die Bilder zurückgreifen?

  • Hallo,

    "Moros" schrieb:


    Ich würde gern zwei Screenshot hochladen. Wie mache ich das bzw. geht das hier im Forum oder muss ich auf eine externe Seite für die Bilder zurückgreifen?


    Screenshot?
    --> http://www.wintotal.de/Tipps/tipp865,rubrik5.html
    Anleitung zum Erstellen von Screenshots
    Bitte vor dem Posten die Abbildung mittels "Vorschau" überprüfen!

  • Screenshots gesehen, danke.


    Leider bist du bisher auf keinen meiner zwei Tipps von damals eingegangen.


    Zudem ist sichtbar: Die Mail wurde als Junk von Thunderbird eingestuft - automatisch? Wenn ja, wo ist das Problem? (Übrigens gut möglich, dass auf erkannte Junkmails kein weiterer Filter mehr angewendet wird - braucht man ja auch eigentluch nicht)


    Dann noch mit der Erweiterung Delete Junk Context Menu ab und an den Inhalt des Ordners löschen - auf Wunsch unter Umgehung des Papiekorbes.


    Einfacher geht es doch nicht, oder?

  • Die Screenshots sollten lediglich einen beispielhaften Header und die Einstellungen zeigen. Viele der E-Mails mit dem Merkmal X-Spam-Flag: YES landen trotz des Filters im Posteingang und werden NICHT als Junk erkannt.


    Die Nachricht im Screenshot wurde manuell als Junk markiert und manuell in den Ordner verschoben.

  • Unabhängig von deinem Problem sollte der Junkfilter von Thunderbird diese Spammails aber "lernen" können. Im Gesamtblick habe ich den Eindruck, dass es einen hohen Aufwand bedeutet, Junk zunächst serverseitig filtern (offenbar nicht löschen) zu lassen und sie dann noch per manuellem Filter lokal zusätzlich zu sortieren. (Diese Bemerkung löst die technische Seite seines Problems jedoch nicht)


    Unklar ist mir, wieso du - auch nach erneutem Hinweis - keine Rückmeldung zu meinen beiden o.g. Tipps gibst. :nixweiss:


    Nach erneuter Ansicht deines Beispielquelltextes fällt auf, dass die Zeile X-Spam-Flag wie auch einige andere nach rechts eingerückt sind bzw auf den Doppelpunkt hin ausgerichtet ist. Das ist nicht normal, könnte die Ursache ein.


    Woher kommt das? Macht das der Server womöglich?

  • Welche Tipps meinst du, hab ich da was überlesen?


    Die doppelte Filterung ist sicherlich nicht effizient. Die Markierung mit X-Spam-Flag wird durch das Rechenzentrum der Uni vorgenommen. Dabei dürfen aber keine E-Mails direkt gelöscht werden, da ja eine dabei sein könnte, die kein Spam ist.


    Den SPAM-Filter habe ich jetzt seit November sehr konsequent trainiert, trotzdem landen unzählige SPAM-Mails, die ja auch vom Uni-Rechenzentrum als solche gekennzeichnet werden, im Posteingang.


    Erfolgt das "Einrücken" bzw. Alignment nicht durch Thunderbird? Ich dachte, dass es sich dabei um das normale Layout von Thunderbird handelt. Gibt es vielleicht eine Möglichkeit nur nach "X-Spam-Flag" oder "YES" in der gesamten Kopfzeile zu suchen bzw. dafür einen Filter zu erstellen?


    Mit Outlook funktioniert die Filterung übrigens problemlos.

  • "Moros" schrieb:

    Welche Tipps meinst du, hab ich da was überlesen?


    In meiner ersten Antwort hier im Thread, letzte 2 Zeilen.

    Zitat

    Erfolgt das "Einrücken" bzw. Alignment nicht durch Thunderbird?


    Nein (soweit ich weiß, auch nie so gesehen). Evtl. eine Erweiterung hier am Werk?


    Überprüfe mal andere Mails, die über andere Server hereingekommen sind oder mal von dir gesendete Mails.


    Es ist auch nur eine Vermutung von mir, dass es daran liegen könnte. Lösung weiß ich so erst mal keine, wenn es so sein sollte.

  • Ich hab schon sämtliche Kombinationen mit "ist", "enthält", verschiedensten Bedingungen etc. ausprobiert.


    Die E-Mails kommen alle über den Uni-Server, da es sich um einen E-Mail-Adresse der Uni handelt. Unabhängig von der Herkunft, sehen alle Header gleich aus.

  • Ich hatte auch nach von dir "gesendeten" Mails gefragt ...


    Und nach Erweiterungen.

  • Als Erweiterungen sind minimizetotray und lightning installiert.


    Gesendete E-Mails haben in Thunderbird das gleiche Alignment.


    @edit
    Gibt es keine Möglichkeit einen Filter zu erstellen der ungefähr so funktioniert:


    wenn "text" vorhanden im header,
    dann...


    @edit2
    Ich hab mir nochmal Anleitungen von diversen Universitäten angesehen und da steht es genau so beschrieben wie ich es gemacht habe. Das Filtern nach "Betreff", "An" oder "Von" funktioniert problemlos. Es scheinen nur die "X-..." Teile des Headers ignoriert zu werden.
    Könnte es sein, dass Thunderbird diese ignoriert? Wenn ja, warum bzw. wie kann ich das ändern?


    Das hier scheint sich mit meinem Problem zu decken:
    http://forums.mozillazine.org/viewtopic.php?f=39&t=505263


    @edit3
    Scheint ja ein bekannter Bug zu sein. Ich hab' nur noch keine Lösung gefunen.
    "Some users have reported that the trust SpamAssassin option sometimes ignores the junk mail headers in Thunderbird 2.x. Its not clear whether you can workaround this bug by disabling the option and adding the appropriate message filter."
    http://kb.mozillazine.org/Junk…_SpamAssassin_and_SpamPal

  • "Moros" schrieb:

    Gesendete E-Mails haben in Thunderbird das gleiche Alignment.


    Habe gerade festgestellt, dass das themeabhängig ist. Alles ok bei dir.

    Zitat

    Das hier scheint sich mit meinem Problem zu decken:
    http://forums.mozillazine.org/viewtopic.php?f=39&t=505263


    @edit3
    Scheint ja ein bekannter Bug zu sein. Ich hab' nur noch keine Lösung gefunen.
    "Some users have reported that the trust SpamAssassin option sometimes ignores the junk mail headers in Thunderbird 2.x. Its not clear whether you can workaround this bug by disabling the option and adding the appropriate message filter."
    http://kb.mozillazine.org/Junk…_SpamAssassin_and_SpamPal


    All das hat nichts mit deinem Problem zu tun, da du bzw. die Uni ja gar nicht SpamAssassin oder SpamPal benutzt.


    Du hast hoffentlich auch in den Einstellungen deines Kontos bei "Junk" diesbezüglich nichts aktiviert. Oder doch?

    Zitat

    Es scheinen nur die "X-..." Teile des Headers ignoriert zu werden.
    Könnte es sein, dass Thunderbird diese ignoriert?


    Nein, das klappt normal ohne Probleme.

  • So, jetzt hab ich's wohl. Es scheint mit Thunderbird zwei Probleme zu geben, wovon ich eines als Bug einstufen würde.


    1) Der Thunderbird-Spam-Filter führt in Kombination mit "SpamAssassin vertrauen" zu Problemen. Jedenfalls wird dann nicht mehr korrekt gefiltert. Ich vermute mal, dass entweder Thunderbird oder die Einstellungen dafür verantwortlich sind, dass die Filter nicht korrekt hintereinander abgearbeitet werden. Gibt es diese Einstellung überhaupt irgendwo?


    2) Das manuelle Filtern nach "X-..." Einträgen funktioniert bei einem IMAP-Konto definitiv nicht! Ich habe jetzt den TB-Junk-Filter deaktiviert und die Einstellung "SpamAssassin vertrauen" aktiviert. Dadurch werden alle E-Mails mit dem Merkmal "X-Spam-Flag: YES" korrekt und automatisch aus dem Posteingang gefiltert. Die manuelle Filterung nach diesen Merkmalen funktioniert wie gesagt überhaupt nicht, egal welche Einstellungen gesetzt werden.


    Man muss also auf die manuelle Filterung verzichten und entweder mit Hilfe der Spam-Flags, die durch das Uni-Rechenzentrum gesetzt werden, filtern oder den integrierten Filter nutzen. Beides funktioniert nicht.

  • "Moros" schrieb:

    1) Der Thunderbird-Spam-Filter führt in Kombination mit "SpamAssassin vertrauen" zu Problemen.


    Wieso hast du das denn überhaupt aktiviert? In den Headerzeilen deines Screenshots wird ein anderer Dienst genannt. Womöglich sind die Zeilen ähnlich und verursachen so Probleme.


    Wenn kein SpamAssassin genutzt wird -> Option deaktivieren.

    Zitat

    2) Das manuelle Filtern nach "X-..." Einträgen funktioniert bei einem IMAP-Konto definitiv nicht!


    Das klappt bei mir prima, das Wort "definitiv" ist falscg und verunsichert andere.


    Zitat

    Ich habe jetzt den TB-Junk-Filter deaktiviert und die Einstellung "SpamAssassin vertrauen" aktiviert.


    Das scheint meinen Satz oben zu bestätigen. Nochmals: EInstellung "SpamAssassin" deaktivieren, damit DEIN Filter funktionieren kann.

    Zitat

    Man muss also auf die manuelle Filterung verzichten und entweder mit Hilfe der Spam-Flags, die durch das Uni-Rechenzentrum gesetzt werden, filtern oder den integrierten Filter nutzen. Beides funktioniert nicht.


    Natürlich ist es am besten, eine Spammail nur einmalig zu filtern.


    Trotzdem vermute ich, dass es klappen müsste, wenn du die fälschlicherweise angehakte Option oben deaktivierst.