SMTP-Server ist nicht einzustellen

  • Hallo,


    ich verwende Thunderbird 2.0.0.21 und Windows XP SP2 und habe ein Problem mit der Erstellung einer neuen Identität in einem meiner Mailkonten.


    Und zwar lässt sich der SMTP-Server nicht einstellen. Das drop-down-menue zeigt Standard-Server und sonst nichts. Da ich 6 SMTP-Server definiert habe (eigentlich zwei, 5x mgate.chello.at mit unterschiedlichen Zugangsdaten und einmal gmx) verwundert mich das doch etwas.


    GMX ist der Standard-Server und auch bei den anderen Identitäten lässt sich der SMTP-Server nicht einstellen, diese, früher erstellten Identitäten, verwenden aber den im Konto eingestellten Server (chello) während die neue Identität darauf besteht, die mails über GMX zu senden. Was GMX aber ablehnt. Wechsle ich den Standard-Server auf den im Konto angegebenen Server, wird die mail korrekt versendet. Nur will ich nicht dauernd den Standard-Server wechseln.


    Hat vielleicht jemand eine Ahnung, woran es liegen könnte?


    TIA!


    Roman

  • Hallo,

    Zitat

    GMX ist der Standard-Server und auch bei den anderen Identitäten lässt sich der SMTP-Server nicht einstellen,


    Ich würde dir empfehlen, das GMX-Konto samt SMTP zu entfernen und neu anzulegen.

    Zitat

    diese, früher erstellten Identitäten, verwenden aber den im Konto eingestellten Server (chello)


    Du möchtest also bei einigen Identitäten des GMX-Kontos einen anderen SMTP-Server für das GMX-Konto einrichten?
    Damit wirst du dann aber nicht mehr senden können, weil GMX es strikt ablehnt, offenes Mailrelaying zu betreiben. Heißt auf Deutsch: es lässt keine anderen SMTP-Server zu als den eigenen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    "mrb" schrieb:

    Du möchtest also bei einigen Identitäten des GMX-Kontos einen anderen SMTP-Server für das GMX-Konto einrichten?


    Nein, ich habe Konten für GMX-Identitäten und für Chello-Identitäten. Das hat auch über Jahre gut funktioniert. Jetzt habe ich einem Chello-Konto eine Chello-Identität hinzugefügt, aber diese Identität verwendet den SMTP-Server von GMX anstatt den dem Konto zugeordneten Chello-SMTP-Server. Zumindest wenn der als Standard eingetragen ist.


    Das Problem liegt, IMHO, darin, das ich bei dieser neuen Identität keinen SMTP-Server einstellen kann. Es wird "Standard-Server verwenden" angezeigt und das lässt sich nicht ändern. Bei der Hauptidentität dieses Kontos ist der Chello-Server eingetragen und alle anderen Identitäten dieses Kontos verwenden ihn auch problemlos.


    Ich weiß nicht, ob ich mich verständlich ausgedrückt habe, ich möchte, dass eine Identität in einem Chello-Konto mit Chello-Adresse den Chello SMTP-Server für ausgehende mails benutzt, der auch für dieses Konto eingetragen ist und den die anderen Identitäten dieses Kontos benutzen. Ich habe einiges probiert, wie die Identität neu anlegen, wenn chello der Standard-Server ist, nur verwendet er ihn nur so lange, wie dieser Server Standard-Server ist. Ich weiß nicht, wieso ich bei den "Weitere Identitäten..." keinen SMTP-Server mehr eintragen kann.


    Roman

  • Hallo Roman,

    "Roman" schrieb:

    Ich weiß nicht, wieso ich bei den "Weitere Identitäten..." keinen SMTP-Server mehr eintragen kann.


    bei "Weitere Identitäten" werden die Alias-Adressen eingetragen, die ja üblicherweise den gleichen SMTP-Server wie die Hauptadresse verwenden.

  • Hallo graba,


    "graba" schrieb:

    bei "Weitere Identitäten" werden die Alias-Adressen eingetragen, die ja üblicherweise den gleichen SMTP-Server wie die Hauptadresse verwenden.


    Stimmt, nur tut es diese "Weitere Identität" nicht. Naja, jetzt schon, weil ich in der about::config den Eintrag mail.identity.id45.smtpServer von leer, was wohl Standard-Server bedeutet, auf smtp2 gesetzt habe. Das kann aber nicht im Sinne des Erfinders sein wenn ich solche Einstellungen manuell erledigen muss.


    Wenn mir die Adresse nicht sehr wichtig gewesen wäre, hätte ich es mir nicht angetan, zu suchen, welche identity.id diese neue Identität hat und so weiter. Gut, beim nächsten mal geht es schneller, weil ich weiß, wo ich nachsehe, aber optimal ist das nicht und ich würde den Fehler, so er an meinen Einstellungen, etc. liegt, gerne beheben.


    Roman

  • Hallo,
    diese Fehler später nachzuvollziehen ist kaum möglich. Oft sind Änderungen in den Kontoeinstellungen wie Portnummer, Servername, Benutzernamen usw. Auch die Übernahme der Konten aus alten Profilen ist manchmal kritisch, und ebenfalls das Löschen eines Kontos kann ursächlich sein, entweder man entfernt die betr. Konten und erstellt sie samt Identitäten neu oder noch besser ist es manchmal, ein neues Profil aufzubauen. Kostet etwas Zeit, stimmt schon.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    "mrb" schrieb:

    diese Fehler später nachzuvollziehen ist kaum möglich.


    Naja, er ist nach wie vor existent. Aber das er auf einem anderen Rechner nicht willentlich reproduzierbar ist, war mir schon klar. Ich dachte, vielleicht ist so was schon einmal bei jemanden aufgetreten und er kann mir etwas raten, a la "Dieses und jenes passt nicht und diese oder jene Extension macht das".


    Zitat

    Oft sind Änderungen in den Kontoeinstellungen wie Portnummer, Servername, Benutzernamen usw.


    Der eingestellte SMTP-Server wird einfach nicht in die Konfiguration geschrieben. Nachdem ich das händisch erledigt habe funktioniert es gewohnt problemlos. Ich weiß nicht, hat Thunderbird ein Limit für verwaltete Adressen/ Kontos?


    Zitat

    entfernt die betr. Konten und erstellt sie samt Identitäten neu oder noch besser ist es manchmal, ein neues Profil aufzubauen. Kostet etwas Zeit, stimmt schon.


    Darauf wird es wohl hinaus laufen, auch wenn mir davor graut ;)


    Jedenfalls vielen Dank an alle, die sich über mein Problem Gedanken gemacht haben!


    Viele Grüße,


    Roman

  • Hallo,


    "rum" schrieb:

    mal eine Frage dazu: hast du evtl. ein Add-on laufen, welches Änderungen vornimmt. (wie z.B. Correct Identity, Virtual Identity)


    Ich hatte Correct Identity installiert, habe es aber deinstalliert, als dieses Problem auftrat (bevor ich hier gepostet habe ;) ). Allerdings bin ich nicht sicher, ob es sich wirklich komplett deinstalliert hat, da es in der about:config nach wie vor Einträge wie "CorrectIdentity.settings_id10" gibt.


    Ich habe Correct Identity dann nochmals installiert und da die Einträge wieder vorhanden waren, alle ausgeschaltet und nochmals deinstalliert. Die Einträge sind immer noch da, stehen aber hauptsächlich auf 'false'.


    Wäre es ratsam diese Einträge manuell zu löschen oder habe ich dann einen GAU zu erwerten?


    Roman

  • nun, du hast scheinbar einen Fehler in der Konfig und wirst auf Dauer gesehen sowieso agieren müssen.
    Ich würde erst mal TB beenden, eine Kopie des kompletten Porfilverzeichnisses ab ..\thunderbrid\.. machen und dann zusätzlich die Datei prefs.js (>about:config) als Kopie ablegen, dann die prefs.js mit einem Editor öffnen und alle das Add-on betreffenden Zeilen löschen. Dann testen. Im Notfall einfach die Kopie nehmen. So kann nichts passieren.


    Auf Dauer gesehen würde ich aber mit dem Profilmanager ein neues Profil parallel zum Alten erstellen* und peu a peu neu einrichten und dann die Adressen/Mails rüberziehen, aber das sagte ja mrb bereits. *So kann man sich etwas damit Zeit lassen.

  • "rum" schrieb:

    Ich würde erst mal TB beenden, eine Kopie des kompletten Porfilverzeichnisses ab ..\thunderbrid\.. machen und dann zusätzlich die Datei prefs.js (>about:config) als Kopie ablegen, dann die prefs.js mit einem Editor öffnen und alle das Add-on betreffenden Zeilen löschen.


    Hat leider nicht das gewünschte Ergebnis gebracht. Ich habe einen neuen alias angelegt, aber der für das Konto eingestellte SMTP-Server wird nicht in die Konfiguration geschrieben. Es wird kein Wert geschrieben. Es sollte aber smtp2 dort stehen.


    Zitat

    Auf Dauer gesehen würde ich aber mit dem Profilmanager ein neues Profil parallel zum Alten erstellen*


    Ich werde nicht darum herum kommen, wie ich sehe. Danke für die Erklärung bezüglich pref.js, so kann ich da etwas herum probieren.


    Roman