FTP Links öffnen

  • Hallo !


    Folgende Frage / Problem :


    Ich erstelle ein Link auf ein FTP Server (ftp://blabla.com/hallo.zip).
    Diesen Link integriere ich ins Mail welches ich auch sofort an mich sende.


    Wenn ich das angekommene Mail öffne und den FTP Link wähle,
    wird mir der Standardbrowser geöffnet (Firefox oder IE (beides probiert...)), soweit so gut....


    Nun wird anstatt die FTP Adresse z.B (ftp://blabla.com/hallo.zip) folgender Link aufgerufen file:///C:/Users/Diräkt/AppData/Local/Microsoft/Windows/Temporary Internet Files/Content.IE5/P1JXJQQ2/hallo.zip
    Und das Archiv wird dann als "beschädigt" gemolden, da es gar nicht runtergeladen wurde.......


    Wähle ich unter TB aber LINK ZIEL SPEICHERN UNTER, funktioniert es...



    Kann mir jemand eine Lösung vorschlagen ?


    Besten Dank !!



    OS: Windows 7
    TB: 2.0.0.23 (20090812)

  • Hallo,
    leider habe ich keinen korrekten FTP-Link hier zu Verfügung, aber bei Klick auf deinen Links, öffnet sich bei mir der IE. Genauso sollte es ja auch sein.
    Meiner Ansicht nach kein TB-Problem sondern eins deines BS.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo


    Danke für deine Antwort.



    Der Link der für den (OS abhängigen Browser) generiert wird ist Falsch wollte ich sagen.


    Ich klicke auf ftp://.............. und im Browser steht dann C:\..... (Firefox und IE)



    Kann man irgendwas einstellen ?


    Grüsse

  • Hi, habe es auch nochmal ausprobiert, sogar mit zip-Datei. Alles ok bei mir. Windows/Internet-Explorer öffnet sich - auch wenn Firefox Standardbrowser ist.


    Drei Ideen:


    - Die Zuordnung zum standardmäßigen Umgang mit FTP-Protokoll in Windows stimmt nicht bei dir
    - der IE hat die Datei bereits einmal heruntergeladen und sie liegt nun im Cache (evtl. aus irgendeinem Grund beschädigt). Mal einfach die Adresse öffnen ohne Datei ftp://blabla.com
    - Du hast den Link einfach falsch eingefügt in eine HTML-Mail

  • Hallo

    Zitat


    Windows/Internet-Explorer öffnet sich - auch wenn Firefox Standardbrowser ist.


    Das kannst du einstellen, (FTP Standard) wenn du da Firefox definierst, öffnet sich der Firefox.


    Zitat

    Drei Ideen:


    - Die Zuordnung zum standardmäßigen Umgang mit FTP-Protokoll in Windows stimmt nicht bei dir
    - der IE hat die Datei bereits einmal heruntergeladen und sie liegt nun im Cache (evtl. aus irgendeinem Grund beschädigt). Mal einfach die Adresse öffnen ohne Datei ftp://blabla.com
    - Du hast den Link einfach falsch eingefügt in eine HTML-Mail


    1. Keine ahnung was du mir damit sagen willst.
    2. Die grösse ist IMMER 0 KB, egal was ich hochlade
    3. Nein. (Rechtsklick Ziel Speichern funktioniert ja)


    Hab es nun an nem neu aufgesetzen Win 7 PC mit TB versucht => Selbes Phänomen...


    Danke für Antworten !

  • Ja, ich weiß, ist ein alter Thread, aber ich habe das gleiche Problem...


    Hat sich da schon eine Lösung ergeben?


    Ergänzend kann ich noch beitragen:


    1. Bei mir öffnet sich korrekterweise der Firefox und nicht der IE, aber trotzdem ist in der Adresszeile der Verweis auf "file:///C:/.../Windows/Temporary Internet Files/Content.IE5/.../". Also doppelt falsch: Erstens müsste hier ja ftp://undsoweiter.irgendwas stehen und andererseits: Warum Temp Internet Files, wenn doch der Feuerfuchs zuständig ist.


    2. Nicht nur das mit "rechts Klick -> Speichern" klappt, sondern es klappt auch, "rechts Klick -> Link Adresse kopieren" und dann im Firefox einfügen. Dann steht es nicht nur so da, wie auf Doppelklick erhofft, sondern es klappt auch.


    Auf meinem alten Windows 2000 klappte das übrigens problemlos. Nur nicht mehr unter XP und auch nicht unter Win7. :-(


    Danke & Grüße

  • Hallo,
    für mich hat das Problem nichts mit Thunderbird zu tun, da es hier nur die Einstellungen des Betriebssystems übernimmt.
    Du solltest also mal in die Dateitypen schauen, was für URL:FTP (file transfer protocol) dort unter "Erweitert" und "Open" eingetragen ist.
    Auch mal im Firefox-Forum fragen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • mrb : Danke für die Antwort und ja, es mag sein, daß es kein direktes Thunderbird-Problem ist.


    Ich kann auch Deiner Idee Folgen bzgl. "Erweitert"->"Optionen", aber leider diese nicht praktisch umsetzten, da Windows 7 das so nicht mehr bietet. Da kann ich nur ein Standardprogramm für ein bestimmtes Protokoll aus denen wählen, die er für tauglich hält. Von Optionen ist schon erst gar keine Rede... leider... schöne neue Welt...

  • Dann musst du mal in einem Win7-Forum fragen.
    Ich glaube kaum, dass diese Funktionen auch in der Registry gestrichen wurden.
    In XP steht das in diesem Pfad:
    HKEY_CLASSES_ROOT\ftp\shell\open\command
    Hierbei müsste im Schlüssel HKEY_CLASSES_ROOT\ftp\DefaultIcon der Pfad : C:\Programme\Mozilla Firefox\firefox.exe,1 stehen,
    in "command": "C:\Programme\Mozilla Firefox\firefox.exe" -requestPending -osint -url "%1"
    und unter "Application": "Firefox" stehen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw