Umlaute werden teilweise durch ? ersetzt

  • Hallo zusammen,


    einige Schwierigkeiten mit Thunderbird konnte ich bereits durch suchen im Forum finden und beseitigen. Seit dem Update auf die Version 3 habe ich jedoch bei vielen eMails die ich bekomme anstatt der Umlaute ? bsp. regelm��ig.


    Ich hab keine Ahnung, wie man das ändern kann. Habt ihr da ne Idee?


    Nur zur Info ich hab den Thunderbird 3.0.1, mit dem Addon Deutsches Wörterbuch 1.0.2 (hab das auch mal deinstalliert, hat aber auch nichts gebracht) auf einem Win 7 64 Bit System.


    Grüße
    tdrauhut

  • Hallo,
    dieses Problem habe ich auch. Obwohl ich mehrere Codierungssprachen eingegeben habe, erscheinen bei einigen Mails immer noch dieses ? anstatt Umlaute. Wie kann ich das ändern?


    Gruß Elke :?:

  • Hallo und willkommen im Forum!


    Kontrolliert in der erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, Konfiguration bearbeiten), welcher Wert (true, false) der Eintrag mailnews.force_charset_override  
    hat und postet ihn.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    bei mir steht mailnews.force_charset_override Status: Standard; Typ: boolean; Wert false


    Grüße
    tdarauhut

  • Hallo,
    tja, wenn TB den Zeichensatz (=Zeichenkodierung in TB) korrekt darstellen soll, darf er nicht gezwungen werden, den Standardzeichensatz nehmen, sondern muss ihn gemäß der Deklarierung in der Mail behandeln.
    Das geht nur, wenn der Wert auf false steht.
    Allerdings hat TB noch eine Option in den Ordnereigenschaften eines jeden Ordners. Dazu den Ordner links auswählen, Rechtsklick, Eigenschaften, Allgemein. Und in diesem Menü darf ebenfalls kein Haken gesetzt sein. Dieses sollte bei allen Ordnern geschehen.
    Obwohl bei mir die Konfiguration richtig war, waren nach dem Update alle Ordner mit dem falschen Haken versehen.


    Nun können aber immer noch Fehler auftreten, nämlich dann wenn eine Mail falsch oder gar nicht deklariert ist. Dann kann TB nur noch raten. In so einem Fall sollte man unter Ansicht, Zeichenkodierung versuchen, einen anderen als dort aktivierten Zeichensatz einzustellen etwa UTF-8, IS0-8955-15 u.a. Diese Einstellung ist aber nur temporär, bei der nächsten Mail wird sie wieder umgestellt, gemäß der Deklarierung dieser Mails.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi,
    danke für die Antwort. Bei mir ist es das 2. Problem. Nirgendwo waren Häckchen gesetzt.


    Hab mir jetzt mal alle Mails mit den Fehlern durchgeschaut (waren nur ca. 20). Bei allen war bei Ansicht Zeichenkodierung nichts ausgewählt und bei wahl von IS0-8955-1 passt alles.


    Hab jetzt gesehen, dass bis auf 2 alle Mails mit Sendblaster verschickt wurden. Hat einer ne Ahnung, ob es da ne Möglichkeit gibt, dass man da einstellen kann, dass eine Zeichenkodierung mit übermittelt werden soll?


    Gruß
    tdarauhut


  • und wie kann ich den Wert auf false stellen bzw. was muss ich jetzt richtig einstellen?


    Gruß Elke

  • "Bollywoodfan" schrieb:


    und wie kann ich den Wert auf false stellen bzw. was muss ich jetzt richtig einstellen?


    Hallo Elke :)


    Extras - Optionen - Erweitert - Konfiguration bearbeiten. Filter auf "mailnews.force_charset_override" (ohne die Anführungszeichen) und Doppelklick auf den Eintrag.


    Gruß Ingo

  • Hallo zusammen,


    das Problem mit den Umlauten ist bei mir immer noch. Wann wird da mal etwas getan? Da ich nebenbei auch noch mit dem Mailprogramm IncrediMail arbeite, muss ich manche Mails, die wichtig sind, dort ausdrucken, da dieses Mailprogramm keine Probleme mit den Umlauten hat. Alle Nachrichten werden dort korrekt dargestellt, auch die Mails, die bei Thunderbird anstelle von Umlauten eine Fragezeichen enthalten. Irgendwie müssen die Entwickler doch was einstellen können!!! Wäre nicht schlecht.


    Gruß Elke :help:

  • Hallo,
    wenn TB korrekt eingestellt ist - siehe die oberen Antworten - und jeder in Frage kommende Ordner mit Rechtsklick im Menü "Allgemein "überprüft wurde, dass dort kein Haken steht, wird TB - ganz egal welcher Standardzeichensatz ausgewählt wurde - den richtigen auswählen.
    Ich versichere dir, dass TB in diesem Punkt keinen Bug hat. Wäre es bei jedem so, wäre der Fehler längst auch bei den Entwicklern bekannt.
    Allerdings ist die Voraussetzung, dass die Mails richtig deklariert sind. Sie sie es nicht, kann man noch versuchen, unter Ansicht, Zeichenkodierung die korrekte zu finden. Sie wird dann richtig dargestellt, bis du eine andere Mail anklickst.
    Ich könnte anhand des Quelltext (strg+U) der Mail, erkennen, ob die Deklarierung OK ist. Das kann ich aber nicht im Forum machen. Du müsstest mir eine solche Mail als *.eml Datei zusenden. Schicke mir einfach eine PN und ich sende dir meine Mailadresse.


    Du kannst aber gerne auf BugZilla dort danach suchen oder einen Bug melden. Aber man sollte gut Englisch können und manchmal kann man sich auch ganz schön dort blamieren.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw