Umlaut und ß Darstellung = Fragezeichen [erl.]

  • Mein Thunderbird 3.1 unter Windows 7 verwaltet mehrere e-mail Konten.
    Nun habe ich ein neues Konto hinzugefügt, ein IMAP drei.at Konto.
    Wenn ich von diesem neuen IMAP Konto (drei.at) Umlaute und ß sende, finde ich im "gesendet" Ordner sowie beim Empfänger (egal ob thunderbird oder andere e-mail Programme)diese Zeichen als Fragezeichen angezeigt.
    Das tritt bei den anderen Konten aber nicht auf und läuft korrekt.
    Im Quelltext des Empfängers findet man:
    --------------------------------------------------------------------------------------------------
    Content-Type: text/plain; charset=ISO-8859-15; format=flowed
    Content-Transfer-Encoding: 8bit
    test????????????
    ------------------------------------------------------------------------------------------------------
    Also schon hier die Fragezeichen drin.
    Wenn man den gleichen mail content von windows live mail, auch drei.at IMAP Konto absendet, kommt er korrekt an, nämlich
    mit dem Quellcode:
    --------------------------------------------
    Content-Type: text/plain;
    charset="iso-8859-1"
    Content-Transfer-Encoding: quoted-printable


    test live mail =F6=E4=FC=F6=E4=FC=F6=E4=FC
    --------------------------------------------------------------------------
    Wenn ich die gleiche mail im Thunderbird durch meine anderen e-mail Konten (POP) sende, tritt der Fehler auch nicht auf.
    Wenn ich das drei.at Konto von IMAP auf POP umstelle, dann habe ich die Darstellung im "gesendet" Ordner richtig, also mit den Sonderzeichen, jedoch beim Empfänger wieder mit den Fragezeichen und gleichem Quelltext wie oben.
    Ich habe in den Foren schon gesucht, die Einstellungen
    mailnews.force_charset_override ist auf "false"
    -----------------------------------------------------------------------------
    Die Provider-drei.at Hotline sagt es muss an den Thunderbird mail sende Einstellungen liegen,
    vor allem wegen dem Fakt dass es in WIndowsl life mail ja funktioniert.
    Aber an welchen soll ich da drehen?
    Der gleiche Fehler tritt auf einem anderen PC unter Vista, TB 3.1 anderes drei.at IMAP Konto auch auf.
    Bitte um Hilfe

  • Hallo,
    der Fehler ist klar, einmal wurde unkodiert gesendet (8-Bit) und das andere Mal mit "quoted printable" kodiert.
    Bei welchem Mailprovider hast du die Mails gesendet?
    Als Googlemail in Deutschland IMAP einführte gab es monatelang das gleiche Problem, weil der Googlemail-Server nicht mit unkodiertem Text klarkam und quoted printable benötigte. Wenn man es weiß, kein Problem, denn man konnte in den alten TB-Versionen dieses in einem Menü ändern.
    Ab 3.0 geht das leider nur noch über die erweiterte Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten").
    Hierzu den Eintrag mail.strictly_mime auf "true" setzen.
    Meiner Ansicht nach ist dieses ein Problem des Mailservers.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Volltreffer
    Die mail.strictly_mime auf true gesetzt und es hat funktioniert.
    Der Internetprovider mit dem Problem heißt
    http://www.drei.at
    und glaubt nicht dass er ein Problem hat- laut seiner Hotline.
    Aber vielleicht habt Ihr zu denen einen besseren Zugang.
    SUPER
    Vielen Dank !!!!! Ihr habt mir sehr geholfen.
    (Ich dachte schon ich muss auf windows live mail zurück steigen.. nein danke)
    Reinhard Klein

  • Ich habe das gleiche Problem, ebenfalls mit dem IMAP-Server von drei.at.
    Selbstverständlich habe ich gleich nachgesehen - leider ist aber bei meinem Thunderbird (8.0) der "mail.strictly_mime"-Eintrag bereits auf "true" gesetzt gewesen.
    Trotzdem werden in meinen Mails ß und Umlaute durch ?? ersetzt - dieses Problem erkenne ich vor allem, wenn jemand auf ein Mail von mir antwortet.
    Da kommt sowohl jeder Umlaut (und ß) vom Antwortmail, als auch von der History durch ?? ersetzt bei mir an. Irgend welche Einstellungen sind also offensichtlich zu der Arbeitsweise der Drei-Mailserver nicht kompatibel. Aber welche?
    Hat jemand einen Tipp? Wäre dafür sehr dankbar!
    LG, Gerhard Altena

  • Eine Ergänzung zu meinem Problem:
    Ich habe den Quelltext einer von mir versandten Mail angesehen - auch der ist bereits verstümmelt, z.B.:


    "Subject: Hauszustellung =?ISO-8859-15?Q?f=FCr_K=E4rnten" oder: "Wir bedanken uns herzlich f=FCr Ihre Bem=FChungen!"


    Darunter findet man:


    Content-Type: multipart/alternative;
    boundary="------------030906050802030707010409" bzw.


    This is a multi-part message in MIME format.
    --------------030906050802030707010409
    Content-Type: text/plain; charset=ISO-8859-15; format=flowed
    Content-Transfer-Encoding: quoted-printable


    Vielleicht hilft diese Info weiter!


    MfG. Gerhard Altena

  • Hallo und willkommen im Forum!

    Zitat

    dieses Problem erkenne ich vor allem, wenn jemand auf ein Mail von mir antwortet.


    Dann hast du die TB-Originaleinstellungen geändert und damit falsch eingestellt.
    Poste uns die Einstellungen unter Extras, Einstellungen, Ansicht, Erweitert und dort im unteren Bereich "Zeichenkodierungen".


    Zitat

    Trotzdem werden in meinen Mails ß und Umlaute durch ?? ersetzt


    Bei den eingehenden Mails?
    Falls ja, musst du die betr. Ordner überprüfen, ob dort bei Rechtsklick darauf, Eigenschaften, Allgemein, beim unteren Kästchen ein Haken gesetzt ist, das sollte er auf keinen Fall.


    Zitat

    Subject: Hauszustellung =?ISO-8859-15?Q?f=FCr_K=E4rnten" oder: "Wir bedanken uns herzlich f=FCr Ihre Bem=FChungen!"


    Das ist im subject des Quelltextes absolut normal. Entscheidend ist, ob es im Nachrichten- und Headerfenster richtig angezeigt wird.


    Wenn du die Mail, deren Quelltext du geöffnet hast im rechten oberen Fenster markierst und dann auf Ansicht, Zeichenkodierung gehst, bei welchen Zeichensatz siehst du den Punkt?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Danke für die rasche Antwort!


    zu 1) hier habe ich jeweils ISO-8859-15 eingestellt und unten (wenn möglich, Standardcodierung...) kein Häkchen gesetzt
    zu 2) bei allen Ordnern ist das untere Kästchen NICHT angehakt, also OK
    zu 3) bei den Mails mit ?? statt Umlauten ist der Punkt bei "Unicode UTF-8" und "Automatisch bestimmen" auf "Universell"


    Ich habe auch den Kundendienst von Drei kontaktiert und mit Hinweis auf diese Site das Problem erklärt. Die Anfrage wurde noch gestern an die Technik weiter gegeben und seit heute kann ich Mails zwischen meinen verschiedenen Postfächern (gmx, drei, Outlook Web-Exchange) hin und her schicken, ohne dass das Problem nochmals aufgetaucht wäre. Das war bisher jedenfalls nicht möglich.
    Ein neuerliches Durchforsten meiner Mails hat aber gezeigt, dass es vor allem auftritt, wenn ein Antwort-Mail von einem Empfänger kommt, der in seinen Grundeinstellungen UTF-8 verwendet. Ob diese Mails auch inzwischen OK sind, weiß ich mangels Testmöglichkeit nicht.


    Ich werde mich wieder melden, falls das Problem mit "UTF-8"-Antworten weiter besteht - oder ist das ein bekanntes Problem, zu dem du Abhilfe weißt?


    LG, Gerhard Altena

  • Zitat

    zu 1) hier habe ich jeweils ISO-8859-15 eingestellt und unten (wenn möglich, Standardcodierung...) kein Häkchen gesetzt


    Und die Option für das Antworten???

    Zitat

    zu 3) bei den Mails mit ?? statt Umlauten ist der Punkt bei "Unicode UTF-8" und "Automatisch bestimmen" auf "Universell"


    Und im Quelltext unter "charset" steht der gleiche?



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für die Antwort!


    Zitat: "zu 1) hier habe ich jeweils ISO-8859-15 eingestellt und unten (wenn möglich, Standardcodierung...) kein Häkchen gesetzt"


    Ergänzung: Mit "jeweils" meinte ich: Sowohl ein- als auch ausgehende Nachrichten sind auf "ISO-8859-15" eingestellt, darunter die Option "wenn möglich, Standard-Zeichencodierung für Antworten verwenden" ist nicht angehakt.


    Zitat: "zu 3) bei den Mails mit ?? statt Umlauten ist der Punkt bei "Unicode UTF-8" und "Automatisch bestimmen" auf "Universell" "


    Ergänzung: Im Quelltext dieser Mail steht es auch:


    --Boundary_(ID_me2DI0ok3BvJHkhkeXE5TQ)
    Content-type: text/plain; charset=UTF-8
    Content-transfer-encoding: 8BIT


    LG, Gerhard Altena

  • Das scheint alles OK.

    Zitat

    Content-type: text/plain; charset=UTF-8


    Wenn du jetzt noch einmal auf Ansicht, Zeichenkodierungen gehst, ist dann ebenfalls dort "UTF-8" markiert (hat einen Punkt)?
    Nur zur Info: dieses ist eine Anzeige, die von der jeweiligen Deklarierung (in diesem Fall der charset) abhängig ist und kann u.U. ständig wechseln.


    Außerdem passiert es gelegentlich, dass eine Mail zwar in UTF-8 deklariert, aber nicht in UTF-8 geschrieben wurde sondern in z.B. ISO-8859-1. Dann werden Umlaute und bestimmte Zeichen immer falsch sein und man kann nur durch Ändern der o.g. Ansichtoption temporär den richtige Zeichensatz durch Ausprobieren einstellen.
    Bei jedem neuen Aufruf muss man das dann immer wieder tun.


    Vergessen:
    gehe in die erweiterte Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten") und überprüfe, ob dort der Eintrag
    mailnews.force_charset_override auf false steht (das muss er).
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"

    Wenn du jetzt noch einmal auf Ansicht, Zeichenkodierungen gehst, ist dann ebenfalls dort "UTF-8" markiert (hat einen Punkt)?


    Ja, der Punkt ist bei "Unicode (UTF-8)"


    Zitat von "mrb"

    gehe in die erweiterte Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten") und überprüfe, ob dort der Eintragmailnews.force_charset_override auf false steht (das muss er).


    Ja, auch hier steht bei mir die korrekte Einstellung "false".


    Ich glaube immer mehr, dass es sich bei dem Problem um ein IMAP-Problem von drei.at handelt, da auch ein Outlook-User (auch drei.at-Kunde) mich gestern auf das Umlaut-Problem angesprochen hat. Es tritt bei ihm ebenfalls immer auf, wenn UTF-8-codierte Mails einlangen oder auf seine Mails via UTF-8-eingestelltem PC geantwortet wird...


    Trotz allem: herzlichen Dank für die Mühe!


    LG, Gerhard Altena

  • Hi Alle,


    Habe eben dasselbe Problem behoben! hooray


    Extras -> Einstellungen -> Erweitert / Allgemein -> Konfiguration bearbeiten (vorsichtig sein ;-) -> Filter: mime -> mail.strictly_mime Wert auf true setzen


    LG, b

  • g.altena ,


    ich hatte von dir keine Rückmeldung über die Änderung in der erweiterten Konfiguration.
    Hattest du das überhaupt geändert?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw