Junk wird verschoben, aber nicht markiert [gelöst]

  • Hallo :)


    heute habe ich auch mal ein Problem(chen) ;) In den Konten-Einstellungen habe ich eingestellt, dass Junkmails in den (System-)Ordner "Junk" verschoben werden. Das funktioniert auch wunderbar, nahezu alles wird erkannt. In letzter Zeit fällt mir aber auf, dass im Ordner "Junk" von den verschobenen Mails nur ganz wenige die Markierung "Junk" bekommen. Ein System kann ich nicht erkennen. Ich muss also alle Mails manuell als Junk markieren.


    Ab und zu gibt es natürlich mal False Positives (insbesondere Newsletter, obwohl ich dafür Regeln habe). Die fälschlich erkannten Mails markiere ich als "kein Junk", und diese werden in den Ordner "Posteingang" zurück verschoben. So weit wunderbar. Jetzt habe ich aber eine Reihe von Regeln, die Mails aus dem Posteingang in Unterordner verschieben. Ich markiere dazu in der Ordnerliste den Posteingang und rufe aus dem Menü Extras - Filter auf Ordner anwenden auf. Leider passiert darauf überhaupt nichts. Ich muss also auf Extras - Filter, alle Filter markieren - Ausgewählte Filter anwenden auf: Posteingang - Jetzt ausführen. Das funktioniert zwar einwandfrei, ist aber etwas [tm] umständlich.


    Hat jemand Ideen? TIA für alle sachdienlichem Hinweise.
    Gruß Ingo


    XP SP3, TB 3.0.8, POP von meinem Hamster

    Einmal editiert, zuletzt von schlingo ()

  • "graba" schrieb:


    die übliche Frage: Hast du auch im Abgesicherten Modus das Problem?


    Hallo :)


    ähm ja, sehr gute und berechtigte Frage. Das hätte ich natürlich schon vorher ausprobieren können. Ich habe das jetzt mal getan: ja, auch im abgesicherten Modus funktioniert der genannte Menüpunkt nicht. Das Markieren der Junkmails konnte ich jetzt nicht testen (gerade keine - neuen - vorhanden).


    Gruß Ingo

  • "graba" schrieb:


    Versuch: Wechsle mal die Einstellungen - siehe Screenshot
    [IMG:http://img3.imagebanana.com/img/3vkpn9df/thumb/JunkEinstellungen.png]


    Hallo :)


    kleine Klarstellung meinerseits: es war die zweite Option ("Anderer Ordner") aktiviert. Ich habe das jetzt auf die erste Option ("Ordner Junk in Lokale Ordner") geändert. Zusätzlich war die Option, Spam-Assassin zu vertrauen, aktiviert. Das habe ich deaktiviert. Ergebnis: von 21 Junk-Mails wurden alle korrekt verschoben. Die ersten 13 (sortiert aufsteigend nach Eingangsreihenfolge) bekamen keinen Junk-Status, bei den restlichen 8 wurde er (so wie ich das erwarten würde) gesetzt.


    Btw, interessanterweise scheine ich nicht der einzige zu sein. Ohne dass ich es zum Zeitpunkt meines OP bereits gelesen hatte, hat Harald Miller in der NG genau dasselbe Problem beschrieben (TB 3.1 - Probleme mit Filter auf Ordner anwenden). Dem haben sich inzwischen weitere Leidensgenossen angeschlossen. Bisher leider ohne Lösung.


    Gruß Ingo

  • Hallo :)


    JFTR: das erste Problem aus dem Betreff ist gelöst. Ich nutze den Dienst eleven (für privat kostenlos). Die Mails werden gefiltert und mit speziellen (teilweise konfigurierbaren) X-Headern versehen, z.B.


    Code
    1. X-purgate-ID: expurgator30/1285108814-00006AB4-F4C63928/0-5388074388/0-10
    2. X-purgate-type: spam
    3. X-purgate-size: 2174
    4. X-purgate-Ad: Categorized by eleven eXpurgate (R) http://www.eleven.de
    5. X-purgate: This mail is identified as spam (visit http://www.eleven.de for further information)
    6. X-purgate: spam


    Ich habe mir einen Filter eingerichtet, der Mails mit X-purgate-type "spam", "bulk" oder "dangerous" (wobei ich letztere von eleven gleich löschen lasse und deshalb nur die Benachrichtigung sehe) in den Junk-Ordner verschiebt. In diese Regel musste ich als zusätzliche Aktion "Setze Junk-Status auf Junk" hinzufügen.


    JFTR2, inzwischen bin ich mit dem aktuellen TB 3.1.4 unterwegs. Beides löst leider nicht das zweite, auch im Usenet berichtete Problem mit Extras - Filter auf Ordner anwenden.


    Gruß Ingo

  • Hallo :)


    ich denke, ich habe die Lösung. Unter TB2 wurden mir per Extras - Filter zunächst die Filter für mein Mailkonto (hier der Hamster) angezeigt. Dort habe ich die allermeisten meiner Filter definiert.


    Unter TB3 werden mir per Extras - Filter jedoch zunächst die Filter für "Lokale Ordner" angezeigt. Um die Filter nicht manuell neu einrichten zu müssen (kopieren geht ja leider nicht), habe ich jetzt ganz frech aus der msgFilterRules.dat meines Hamsters in die msgFilterRules.dat der Local Folders (%appdata%\Thunderbird\Profiles\{Profilname}\Mail\Local Folders) kopiert (vorher TB natürlich beendet). Und siehe da: schon funktioniert Extras - Filter auf Ordner anwenden genauso wie Filter auf Nachricht anwenden.


    Gruß Ingo